1 (edited by nbd 2009-02-19 21:22:59)

Topic: Kamikaze 8.09

The long awaited 8.09 release is finally done. We took some extra
time to give it a lot of testing, to make sure that it's stable.

You can find it here: http://downloads.openwrt.org/kamikaze/8.09/

The source code repository URL is https://svn.openwrt.org/openwrt/tags/8.09
If necessary, updates will be committed at https://svn.openwrt.org/openwrt/branches/8.09
Packages were built from https://svn.openwrt.org/openwrt/branches/packages_8.09
with SVN revision r14365


List of supported platforms:
   * AMCC Taishan
   * AMD Alchemy (MeshCube)
   * Atheros AR531x/231x based routers
   * Atmel AVR32
   * Broadcom 47xx based routers (Linux 2.4 and 2.6)
   * Infineon/ADMtek ADM5120
   * IXP42x/43x
   * MagicBox
   * MikroTik RouterBoard 532
   * RDC SoC
   * Texas Instruments AR7
   * User-Mode Linux (source only)
   * x86 based boards

Changes from RC2 to 8.09:
   * Fixes for LuCI
   * More toolchain fixes for PowerPC
   * A small madwifi bugfix
   * Tx power handling fixes for multiple 802.11 drivers
   * Firewall fixes

Changes from RC1 to RC2:
   * Stability fixes for MadWiFi
   * Firewall fixes
   * Lots of package updates
   * PPPoE hotplug fixes
   * Atheros AR231x ethernet driver fixes
   * PowerPC fixes
   * ADM5120 support for both little and big endian
   * AVR32 compiler upgrade
   * Fixes for Broadcom 2.4 (stability, support for fixed bssid in ad-hoc mode)
   * Improved ethernet driver performance for Broadcom 47xx (Linux 2.4 and 2.6)

List of major changes from 7.09 to 8.09:
    * Busybox upgraded to 1.11.2
    * Kernel upgrades for all targets
    * uClibc upgraded to 0.9.29
    * Firewall rewrite, fully modular netfilter/iptables support
        - Syntax of /etc/config/firewall converted to UCI
    * ipkg package manager replaced with opkg
        - package lists moved to ramdisk, lists are not retained between reboots.
        - `opkg update' must be run after each reboot before new packages are installed
    * Broadcom 47xx running reliably with the new Kernel, including b43 wireless driver
        - WEP, WDS and multi-SSID not yet supported
    - AP mode and STA mode are supported with WPA, WPA2, or no encryption
    * IMQ and Traffic shaping fixed with newer kernels (2.6.25+)
    * Sysupgrade for x86, broadcom and adm5120
    * New web interface (LuCI, Lua Configuration Interface)
    * New HAL and driver for Atheros based WiFi cards
    * Attention towards the integration of security updates
    * Build system cleanup
    * Package maintaining and updates between releases

List of known issues:
    * The b43 driver included in 8.09 is still not fully stable,
      so it's not suitable for production use yet.

Re: Kamikaze 8.09

That is some great news! Thank you very much.  "Changes from RC1 to RC2" and "List of major changes from 7.09 to 8.09" are the same lists, is that intentional?

Yet if I understand it correctly, if one wishes to have stable broadcom wifi, she should use 2.4 kernel?

Re: Kamikaze 8.09

sup wrote:

That is some great news! Thank you very much.  "Changes from RC1 to RC2" and "List of major changes from 7.09 to 8.09" are the same lists, is that intentional?

Nope, and it's fixed now, thanks.

sup wrote:

Yet if I understand it correctly, if one wishes to have stable broadcom wifi, she should use 2.4 kernel?

Yes

Re: Kamikaze 8.09

Excellent and thank you.

Mazi

Re: Kamikaze 8.09

nbd wrote:

[

sup wrote:

Yet if I understand it correctly, if one wishes to have stable broadcom wifi, she should use 2.4 kernel?

Yes

I tried 2.6 in the end and so far it is stable, let see how it goes:-), I hafe put a backup router online just for sure.

I have not tried any of the RCs and I must say I am  rather impressed with LuCI: I was able to configure everything I need through my browser (even passwordless SSH logins:-)). You guys have great some quite nice distribution!

The only thing that confused me was a little that I needed to reboot after I installed some additional packages - I searched all over before I tried rebooting. I do not mind rebooting, but a hint that it is needed to get to just installed functionality would be helpful, especially to new users. I do not know how to make it inobtrusive though.

Re: Kamikaze 8.09

I am using the broadcom 2.4 image on an Asus Wl-500g deluxe. What I am now experiencing is that the ping of my wifi-connection has a very high latency (~4000ms) when I am downloading something. After the download finished the ping is down to 3ms. I think the download could be faster, too.
I just pinged my router.

Is there anyone who can confirm this? With OpenWrt 8.09rc2 this didn't happen.

Re: Kamikaze 8.09

Thank you very much for your great work.

I looked at the download 8.09 folders and found that unlike the 7.09 and 7.07 they did not have any ImageBuilder files. Are they still to come?
And if not, how are images built these days? I trust the big and unwieldy build-system is not the answer.

Cheers

chillifire

Re: Kamikaze 8.09

Great work, THANK YOU VERY MUCH.

1, Where is SDK for 8.09? Just like 7.09 did.
2, It's a pity to hear that BRCM driver is still unstable.
3, 8.09 should be 9.02 or sth. LoL

Re: Kamikaze 8.09

The IB and SDK may be still broken. Use the build-system instead.

10

Re: Kamikaze 8.09

SDK, Image Builder are compiling at the moment ...
About b43: If you want to help testing, compile a current trunk. It uses Linux 2.6.28 and a recent version of b43, which is reported to be much more stable than the old 2.6.25 based version.

Re: Kamikaze 8.09

Hi... i might do something wrong, but after flashing the image openwrt-brcm47xx-squashfs.trx on my WL500GP and performing opkg update+opkg upgrade... after reboot i'm left with 2.6.28.x modules installed but a 2.6.25.x kernel running (see below... the kernel package provides no files??? Doh indeed)... so the modules won't load. Doh again. I also see that the downloadable date to 15th Feb... is it possible they weren't updated and are still the RC2 images up there? Is it possible, the kernel ackage provides no files? Did I already say Doo-oh?
B]

[Grumbles and goes back to compile the image for himself....]

root@OpenWrt:~# opkg files kernel
Package kernel (2.6.28.5-brcm47xx-1) is installed on root and has the following files:

root@OpenWrt:~# uname -a
Linux OpenWrt 2.6.25.17 #16 Sun Feb 15 00:19:46 CET 2009 mips unknown

Re: Kamikaze 8.09

Hi again... don't get me wrong... I'm happy that Kamikaze is in a release state. I waited for it a long time.
B[

13

Re: Kamikaze 8.09

Hi.

The kernel package is just a metapackage. Never use opkg upgrade to update your system, it will just fill up the flash. The kernel image is _not_ stored on the filesystem, an opkg upgrade will _not_ update the kernel. The _only_ solution to update a running OpenWrt installation is a _reflash_.

~ JoW

14

Re: Kamikaze 8.09

Where did you get your packages from? Snapshots? 8.09 does not use any 2.6.28 stuff, not in the image, not in the repositories.

Re: Kamikaze 8.09

Yay! Thanks.... that was the obviously-shamefuly-selfpresentingly-simply-simple cause of my problem. I was compiling for myself from snapshots, before the release came out... and when the stable was flashed my opkg.conf was left with the snapshot settings. Lesson learned. Waste no more words on it.
[Fixes opkg.conf and goes back to cheerfuly celebrate the Release]
Cheers. B]

16 (edited by napierzaza 2009-02-21 01:34:55)

Re: Kamikaze 8.09

Thought it was cute until I tried to use the new firewall. So port ranges don't work? Hmmmm, well it will be a while before I use that feature than. BTW if it DOES work, using something other than a ":" it might be useful to use it in the config so we can actually see it.

17

Re: Kamikaze 8.09

Here's how I do it:

config redirect
        option src               wan
        option src_dport     8500-8600
        option dest             lan
        option dest_ip        192.168.42.238
        option proto           tcp

18 (edited by Yanira 2009-02-21 10:55:27)

Re: Kamikaze 8.09

nbd wrote:

Here's how I do it:

config redirect
        option src               wan
        option src_dport     8500-8600
        option dest             lan
        option dest_ip        192.168.42.238
        option proto           tcp

And for UCI CLI:

root@OpenWrt:~# uci add firewall redirect
root@OpenWrt:~# uci set firewall.@redirect[-1].src=wan
root@OpenWrt:~# uci set firewall.@redirect[-1].src_dport=8500-8600
root@OpenWrt:~# uci set firewall.@redirect[-1].dest=lan
root@OpenWrt:~# uci set firewall.@redirect[-1].dest_ip=192.168.42.238
root@OpenWrt:~# uci set firewall.@redirect[-1].proto=tcp
root@OpenWrt:~# uci commit firewall
root@OpenWrt:~# /etc/init.d/firewall restart

Re: Kamikaze 8.09

hi to all

I installed the 8.09 final version in my dir-300.

root@OpenWrt:~# cat /proc/cpuinfo

system type             : Atheros AR2317
processor               : 0
cpu model               : MIPS 4KEc V6.4
BogoMIPS                : 183.50
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : no
ASEs implemented        :
shadow register sets    : 1
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

I have configured my router in client mode.
I am having problems after changing the WAN MAC address, add the command 'option macaddr=00:19:E0:0F:4A:90', and dir-300 configuration:

root@OpenWrt:~# cat /etc/config/network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '172.16.0.1'
        option 'netmask' '255.255.0.0'
        option 'defaultroute' '0'
        option 'peerdns' '0'

config 'interface' 'wan'
        option 'proto' 'static'
        option 'type' 'bridge'
        option 'ifname' 'ath0'
        option 'ipaddr' '192.168.25.192'
        option 'netmask' '255.255.255.0'
        option 'gateway' '192.168.25.200'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'dns' '192.168.25.200'
        option 'macaddr' '00:19:E0:0F:4A:90'
root@OpenWrt:~# cat /etc/config/wireless

config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'channel' 'auto'
        option 'disabled' '0'
        option 'diversity' '0'
        option 'txpower' '20'

config 'wifi-iface'
        option 'device' 'wifi0'
        option 'ssid' 'SHARENET'
        option 'network' 'wan'
        option 'mode' 'sta'
        option 'encryption' 'wep'
        option 'key' '012345678901234567'
root@OpenWrt:~# ifconfig

ath0      Link encap:Ethernet  HWaddr 00:1E:58:C0:9D:45
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10 errors:0 dropped:4 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:594 (594.0 B)  TX bytes:0 (0.0 B)

br-lan    Link encap:Ethernet  HWaddr 00:1E:58:C0:9D:46
          inet addr:172.16.0.1  Bcast:172.16.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:964 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1145 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:93078 (90.8 KiB)  TX bytes:924202 (902.5 KiB)

br-wan    Link encap:Ethernet  HWaddr 00:19:E0:0F:4A:90
          inet addr:192.168.25.192  Bcast:192.168.25.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:103 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:208 (208.0 B)  TX bytes:4686 (4.5 KiB)

eth0      Link encap:Ethernet  HWaddr 00:1E:58:C0:9D:46
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:965 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1146 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:106916 (104.4 KiB)  TX bytes:925245 (903.5 KiB)
          Interrupt:4 Base address:0x1000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-1E-58-C0-9D-45-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35287 errors:0 dropped:15247 overruns:0 frame:20271
          TX packets:3975 errors:9 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:195
          RX bytes:8437274 (8.0 MiB)  TX bytes:214960 (209.9 KiB)
          Interrupt:3 Memory:b0000000-b00ffffc
root@OpenWrt:~# iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

br-lan    no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"SHARENET"  Nickname:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Bit Rate:1 Mb/s   Tx-Power:17 dBm   Sensitivity=1/1
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:0123-4567-8901-2345-67   Security mode:restricted
          Power Management:off
          Link Quality=26/70  Signal level=-70 dBm  Noise level=-96 dBm
          Rx invalid nwid:9800  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

br-wan    no wireless extensions.

also try using the command ifconfig ath0 hw ether, and can not connect to internet.

Please hope responses

20 (edited by napierzaza 2009-02-21 15:07:01)

Re: Kamikaze 8.09

Thanks for the firewall instructions ndb.

Is anyone else having trouble with pppoe? I tried my exact old config for pppoe from 7.09 and it didn't work. I then tried it through LUCI and selected some of the newer options (like using a new route once I got a connect etc) but it still didn't work.

Looking at the code LUCI inserted didn't seem to help either, except that it seems to confuse keep alive and disconnect while inactive.

config interface wan
    option ifname    "eth0.1"
    option proto    'pppoe'
    option username 'blahblah'
    option password    'password'
    option keepalive    '5'
    option mtu    '1492'

21 (edited by knox 2009-02-23 09:36:00)

Re: Kamikaze 8.09

bestlem wrote:

also try using the command ifconfig ath0 hw ether

As far as i can tell changing the mac address of an atheros based device requires the use of macchanger or iproute2 utils. See the madwifi user docs and this ticket about this. Maybe you can add a commet there that it does not work as expected.

Re: Kamikaze 8.09

Thanks for this new release!

luigi smile

Re: Kamikaze 8.09

Congratulations for the release !

And only one known issue ! wink

Is there a forum topic or some other place, where the status of the b43 driver is tracked ?
With information like:
- current status
- expected future changes
- how to test instructions
- how to contribute
- etc

(yes, you guessed right, I have a BCM wifi)

Re: Kamikaze 8.09

hello! I just begin to use Openwrt on a wireless router (linksys) and I want to know if it is possible to modify the transmission power of my device using kamikaze 7.09. Please help me

Re: Kamikaze 8.09

nbd wrote:

SDK, Image Builder are compiling at the moment ...
About b43: If you want to help testing, compile a current trunk. It uses Linux 2.6.28 and a recent version of b43, which is reported to be much more stable than the old 2.6.25 based version.

Hi,

Is there a location I can download the 8.09 SDK

7.09 SDK is here.. http://downloads.openwrt.org/kamikaze/7.09/brcm47xx-2.6/

8.09 SDK is NOT here ?? http://downloads.openwrt.org/kamikaze/8.09/brcm47xx/

Thanks