1 (edited by josephus 2009-02-01 18:24:29)

Topic: WDS problems with Kamikaze 8.09 RC2

I'm trying to establish a wds link between a wrt54g v2.2 and an asus wl500g with no luck.

Router1

root@galvangw:~# ifconfig wds0.1
wds0.1    Link encap:Ethernet  HWaddr 00:14:BF:15:F9:1C
          inet6 addr: fe80::214:bfff:fe15:f91c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@galvangw:~# ls
root@galvangw:~# wlc wds
00:11:d8:24:69:74
root@galvangw:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth0.0    no wireless extensions.

eth0.1    no wireless extensions.

sit0      no wireless extensions.

br-lan    no wireless extensions.

wl0       IEEE 802.11-DS  ESSID:"szar"
          Mode:Master  Frequency:2.437 GHz  Access Point: 00:14:BF:15:F9:1C
          Bit Rate=18 Mb/s   Tx-Power:32 dBm
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Link Quality:5  Signal level:0  Noise level:161
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:9  Invalid misc:0   Missed beacon:0

wds0.1    no wireless extensions.

root@galvangw:~# cat /etc/config/wireless

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'disabled' '0'
        option 'channel' '6'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'szar'
        option 'encryption' 'psk'
        option 'key' 'szarwpa-pskpass'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'ssid' 'szarwds'
        option 'network' 'lan'
        option 'mode' 'wds'
        option 'key' 'wdspass'
        option 'bssid' '00:11:d8:24:69:74'
        option 'encryption' 'psk'

root@galvangw:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.0014bf15f91a       no              eth0.0
                                                        wl0
                                                        wds0.1

Router 2

root@OpenWrt:~# ifconfig wds0.1
wds0.1    Link encap:Ethernet  HWaddr 00:11:D8:24:69:74
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@OpenWrt:~# wlc wds
00:14:bf:15:f9:1c
root@OpenWrt:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

br-lan    no wireless extensions.

wl0       IEEE 802.11-DS  ESSID:"szar"
          Mode:Master  Frequency:2.437 GHz  Access Point: 00:11:D8:24:69:74
          Bit Rate=36 Mb/s   Tx-Power:32 dBm
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Link Quality:5  Signal level:0  Noise level:159
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wds0.1    no wireless extensions.

root@OpenWrt:~# cat /etc/config/wireless

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'disabled' '0'
        option 'channel' '6'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'szar'
        option 'encryption' 'psk'
        option 'key' 'szarwpa-pskpass'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'ssid' 'szarwds'
        option 'network' 'lan'
        option 'mode' 'wds'
        option 'key' 'wdspass'
        option 'bssid' '00:14:bf:15:f9:1c'
        option 'encryption' 'psk'

root@OpenWrt:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.0011d8246974       no              eth0
                                                        wl0
                                                        wds0.1

I've tried with STP on, still no packets on the WDS interface.
Is there any way to see some more debug here?

Edit: NAS is working on both sides, clients can connect. Tried to run nas4not manually, it doesn't really print anything

Josephus

Re: WDS problems with Kamikaze 8.09 RC2

try something like this:

Node1

config 'wifi-iface'            
        option 'network' 'lan'           
        option 'device' 'wifi1'           
        option 'mode' 'sta'               
        option 'wds' '1'

Node2

config 'wifi-iface'
        option 'network' 'lan'
        option 'device' 'wifi0'
        option 'mode' 'ap'     
        option 'wds' '1'

so you will have a normal master-client (wlan-scanable!) with layer2-WDS...


regards
tetzlav

Re: WDS problems with Kamikaze 8.09 RC2

option wds does not work with brcm, there is only mode "wds"

4 (edited by josephus 2009-02-16 02:16:31)

Re: WDS problems with Kamikaze 8.09 RC2

Additional info: after reboot i have to trigger nas4not manually to get to the AUTHORIZED state

root@OpenWrt:~# wl sta_info 00:14:bf:15:f9:1c
 STA 00:14:bf:15:f9:1c:
         rateset [ 1 2 5.5 6 9 11 12 18 24 36 48 54 ]
         idle 109 seconds
         in network 0 seconds
         state:
         flags 0x41: BRCM
root@OpenWrt:~# wl wds none; wifi
root@OpenWrt:~# wl sta_info 00:14:bf:15:f9:1c
 STA 00:14:bf:15:f9:1c:
         rateset [ 1 2 5.5 6 9 11 12 18 24 36 48 54 ]
         idle 0 seconds
         in network 0 seconds
         state: AUTHORIZED
         flags 0x61: BRCM

SOLUTION In /etc/hotplug.d/net/20-broadcom_wds increase sleep 1 as it launches nas4not too early.

Josephus

5 (edited by jow 2009-02-16 05:18:50)

Re: WDS problems with Kamikaze 8.09 RC2

Hi.

Looks like a viable solution to me. Can you please suggest some value? Three seconds, five seconds?

~ JoW