Topic: WL-500GPV2 (brcm47xx) with kernel 2.6.27

I there smile

I don't know if it is the right place to post it but I don't see any other place with that kind of inoformation....

Ok, I'm trying to compile kamikase kernel 2.6.24 to the target brcm47xx but it is not going so well :S
I changed the target/linux/brcm47xx/Makefile to 2.6.27, made a copy of the target/linux/brcm47xx/patches-2.6.25 directory as patches-2.6.27 and made a copy of target/linux/brcm47xx/config-2.6.25 as target/linux/brcm47xx/config-2.6.27. That new config-2.6.27 needs to be updated because when I make "make V=99" the configuration restarts and ask me to configure the new settings.
After the reconfiguration, I have an error in crypt.c, the function kill_proc is no defined. I think it is defined in include/linux/sched.h as kill_proc_info, so I changed kill_proc to Kill_proc_info. I don't know if it the same thing but it passed to the next step. Now I have that error:
drivers/net/imq.c: In function 'imq_nf_queue':
drivers/net/imq.c:222: error: 'struct net_device' has no member named 'queue_lock'
drivers/net/imq.c:223: error: 'struct net_device' has no member named 'qdisc'
drivers/net/imq.c:234: error: 'struct net_device' has no member named 'queue_lock'
drivers/net/imq.c: In function 'qdisc_run_tasklet':
drivers/net/imq.c:252: error: 'struct net_device' has no member named 'queue_lock'
drivers/net/imq.c:253: warning: passing argument 1 of 'qdisc_run' from incompatible pointer type
drivers/net/imq.c:255: error: 'struct net_device' has no member named 'queue_lock'
they are making reference to elements of a structure that doesn't have the referenced elements... Now i don't know what to do :S

Can you help me? please :S

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

Why don't you disable CONFIG_PACKAGE_kmod-ipt-imq and PACKAGE_iptables-mod-imq in your OpenWRT menuconfig interface?

By the way, it will not be an only problem you will encounter compiling 2.6.27 for brcm47xx. I'm also trying to do it, but still no success.

3 (edited by umiki 2008-10-17 00:10:08)

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38 wrote:

Why don't you disable CONFIG_PACKAGE_kmod-ipt-imq and PACKAGE_iptables-mod-imq in your OpenWRT menuconfig interface?

By the way, it will not be an only problem you will encounter compiling 2.6.27 for brcm47xx. I'm also trying to do it, but still no success.

That is quite right, because if you only do that, most of the platform specific patches will not be applied. (take a look at the output of make V=99 after make clean). I have tried to correct most of these patches so they are applied (some of them are already integrated in 2.6.27), but after that I have found that the B43 package won't compile (I don't really know, why there are three different sources for that piece (B43 package, compat-wireless and kernel). I have changed the makefile of B43 to just simply copy the source of B43 from compat-wireless (I had no better idea; compat-wireless and kernel source are almost the same anyway), and removed the backport patch. This way the whole thing builds, the router boots nicely, but the B43 module will give unknown symbol errrors (PIO and PCMCIA). If I have disabled them in the config.mk of compat-wireless, than B43 will load nicely (load the firmware, hostapd starts), but I cannot connect to the router, and it does not return any scan results either.

To be honest, I have no experience with linux, I have no idea how this should be done. Hope somebody can give us some clues.

EDIT: iwlist scan returns scan results. (just wlan0 is shut down, when hostapd is run).

EDIT: I have succeeded to make it work (had to put disable_drivers and allow-ap-vlan-modes patches back to mac80211 and apply hostap-fix to hostapd).

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

It is nice that you got it working umiki.

I have stared to do that, but I haven't finished it.
Could you please send me your changes to kamikaze to get brcm47xx running with kernel 2.6.27.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

I am sorry, I have posted in the wrong thread (I meant to post to the more general thread brcm47xx and 2.6.27). I have a WL-500gP v1 (with the original wireless card)

It is working, and seems to be stable (not tested throughly). I can't tell if the wireless part has improved with the latest kernel and newer compat-wireless. With 2.6.25 speed was ok (~2000 kB/sec), but it was unstable (dropped connection after a larger amount of data was transferred), with 2.6.27 I don't know, because wireless transfer speed is somwhere near 100 kB/sec, so large amount of data has not been transfered...

If you are still interested, I can send you my files, but because I am not an expert, I don't think that the correction and selection of platform specific patches is properly done. I am even less sure of the B43 related stuff.

6 (edited by advance38 2008-11-19 11:46:06)

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

I've succeeded to build OpenWRT for kernel 2.6.27, and to load it on ASUS WL-500W(brcm47xx), starting from OpenWRT r13088. My work is based on the sn9's patch and inspired by umiki. Thanks!

My patch is available on http://dongsupark.de/openwrt/kamikaze-r13088-b43ssb-2.6.27.diff. You can see more details on my wiki, http://dongsupark.de/wiki/doku.php?id=linux:openwrt.

After loading the image onto ASUS WL-500W, I can see that wireless device is detected as wlan0, and it works as ap mode. However, the device actually doesn't work, as b43-phy0 complains that its hardware state is changed to DISABLED. Maybe I need to upgrade compat-wireless from 2008-10-08 to a newer one.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38 wrote:

I've succeeded to build OpenWRT for kernel 2.6.27, and to load it on ASUS WL-500W(brcm47xx), starting from OpenWRT r13088. My work is based on the sn9's patch and inspired by umiki. Thanks!

My patch is available on http://dongsupark.de/openwrt/kamikaze-r13088-b43ssb-2.6.27.diff. You can see more details on my wiki, http://dongsupark.de/wiki/doku.php?id=linux:openwrt.

After loading the image onto ASUS WL-500W, I can see that wireless device is detected as wlan0, and it works as ap mode. However, the device actually doesn't work, as b43-phy0 complains that its hardware state is changed to DISABLED. Maybe I need to upgrade compat-wireless from 2008-10-08 to a newer one.

Hey Mr Advance38, did you get able to go through the PHY problems ?

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

gramulhaozin wrote:
advance38 wrote:

I've succeeded to build OpenWRT for kernel 2.6.27, and to load it on ASUS WL-500W(brcm47xx), starting from OpenWRT r13088. My work is based on the sn9's patch and inspired by umiki. Thanks!

My patch is available on http://dongsupark.de/openwrt/kamikaze-r13088-b43ssb-2.6.27.diff. You can see more details on my wiki, http://dongsupark.de/wiki/doku.php?id=linux:openwrt.

After loading the image onto ASUS WL-500W, I can see that wireless device is detected as wlan0, and it works as ap mode. However, the device actually doesn't work, as b43-phy0 complains that its hardware state is changed to DISABLED. Maybe I need to upgrade compat-wireless from 2008-10-08 to a newer one.

Hey Mr Advance38, did you get able to go through the PHY problems ?

No, not yet. Please let me know too, if you hear a good news. :-)

9 (edited by rpress 2008-12-04 02:41:56)

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38 wrote:
gramulhaozin wrote:
advance38 wrote:

I've succeeded to build OpenWRT for kernel 2.6.27, and to load it on ASUS WL-500W(brcm47xx), starting from OpenWRT r13088. My work is based on the sn9's patch and inspired by umiki. Thanks!

My patch is available on http://dongsupark.de/openwrt/kamikaze-r13088-b43ssb-2.6.27.diff. You can see more details on my wiki, http://dongsupark.de/wiki/doku.php?id=linux:openwrt.

After loading the image onto ASUS WL-500W, I can see that wireless device is detected as wlan0, and it works as ap mode. However, the device actually doesn't work, as b43-phy0 complains that its hardware state is changed to DISABLED. Maybe I need to upgrade compat-wireless from 2008-10-08 to a newer one.

Hey Mr Advance38, did you get able to go through the PHY problems ?

No, not yet. Please let me know too, if you hear a good news. :-)

Did you also install wpa-supplicant?  I had this same DISABLED issue until I did that.  This is with 2.6.25.20.

I would like to download your patch but your web site doesn't work for me.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

I would also love to get my hands on that patch...

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

The site works for me. Here is the advance38's patch for r13287 http://openwrt.pastebin.com/m577e14fe

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

I just tried to apply it.

~/kamikaze $ patch --dry-run -p1 < kamikaze-r13088-b43ssb-2.6.27.diff
<lots of patching...>
(Stripping trailing CRs from patch.)
patching file target/linux/generic-2.6/patches-2.6.27/200-sched_esfq.patch
patch unexpectedly ends in middle of line
patch: **** malformed patch at line 6847: 

Could the patch be bad?

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

Actually, the pastebin copy is just no good. I can get to the site now, and that patch is valid.

However, I'd recommend the newer http://dongsupark.de/openwrt/kamikaze-r13287-b43ssb-2.6.27.diff patch - it applies almost cleanly to the latest svn (some patches in it have already been applied by openwrt). I'll try running this tomorrow.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

I modified the patch to work with r13514:
http://openwrt.pastebin.com/f4218e262

The b43 works fine in AP mode; I could browse the net from my laptop no problem.  I also installed hostapd-mini and wpa-supplicant.

Unfortunately the new kernel didn't fix my segfault problems with the mmc card.  sad

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

Shall we ask openwrt to apply this patch then? See https://dev.openwrt.org/ticket/4169

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

rpress wrote:

I modified the patch to work with r13514:
http://openwrt.pastebin.com/f4218e262

The b43 works fine in AP mode; I could browse the net from my laptop no problem.  I also installed hostapd-mini and wpa-supplicant.

Unfortunately the new kernel didn't fix my segfault problems with the mmc card.  sad

2.6.27 seems to work well for a while (I have a WL-500gPv1), but there is a problem I can not get rid of.

SSH and SAMBA connections to the router through wireless are not stable. It seem to be related to problems around package retransmission (wireshark capture is available)

Connections to any devices other than the router are fine, curiously if I ssh into my desktop computer first (through wireless and the router) and then ssh to the router from there (so it is going through wlan, the router and one extra computer) everything is fine.

I would appreciate any ideas to solve this...

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

rpress wrote:

I modified the patch to work with r13514:
http://openwrt.pastebin.com/f4218e262

The b43 works fine in AP mode; I could browse the net from my laptop no problem.  I also installed hostapd-mini and wpa-supplicant.

Unfortunately the new kernel didn't fix my segfault problems with the mmc card.  sad

Thanks. Based on your patch, I made a new patch for r13514, http://dongsupark.de/openwrt/kamikaze-r13514-b43ssb-2.6.27.diff. Maybe you can compile OpenWRT brcm47xx with kernel 2.6.27.4. But I'm not sure yet if wlan works with this patch. Posted also on https://dev.openwrt.org/ticket/4169

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38, I just applied your patch and compilation failed. Here's the output:

make[4]: Entering directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06'
./scripts/gen-compat-autoconf.sh config.mk > include/linux/compat_autoconf.h
make -C /home/candrews/kamikaze/build_dir/linux-brcm47xx/linux-2.6.27.4 M=/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06 modules
make[5]: Entering directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/linux-2.6.27.4'
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/config.mk:49: "WARNING: You are running a kernel >= 2.6.23, you should enable in it CONFIG_NETDEVICES_MULTIQUEUE for 802.11[ne] support"
  CC [M]  /home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/misc/eeprom_93cx6.o
  CC [M]  /home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/mac80211_hwsim.o
  CC [M]  /home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.o
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c: In function 'ath5k_rxbuf_setup':
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1169: warning: passing argument 1 of 'pci_dma_mapping_error' makes pointer from integer without a cast
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1169: error: too few arguments to function 'pci_dma_mapping_error'
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c: In function 'ath5k_beacon_setup':
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1921: warning: passing argument 1 of 'pci_dma_mapping_error' makes pointer from integer without a cast
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1921: error: too few arguments to function 'pci_dma_mapping_error'
make[8]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.o] Error 1
make[7]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k] Error 2
make[6]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless] Error 2
make[5]: *** [_module_/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06] Error 2
make[5]: Leaving directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/linux-2.6.27.4'
make[4]: *** [modules] Error 2
make[4]: Leaving directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06'
make[3]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/.built] Error 2
make[3]: Leaving directory `/home/candrews/kamikaze/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2
make[2]: Leaving directory `/home/candrews/kamikaze'
make[1]: *** [/home/candrews/kamikaze/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/candrews/kamikaze'
make: *** [world] Error 2

19 (edited by advance38 2008-12-08 12:11:25)

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

candrews wrote:

advance38, I just applied your patch and compilation failed. Here's the output:

make[4]: Entering directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06'
./scripts/gen-compat-autoconf.sh config.mk > include/linux/compat_autoconf.h
make -C /home/candrews/kamikaze/build_dir/linux-brcm47xx/linux-2.6.27.4 M=/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06 modules
make[5]: Entering directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/linux-2.6.27.4'
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/config.mk:49: "WARNING: You are running a kernel >= 2.6.23, you should enable in it CONFIG_NETDEVICES_MULTIQUEUE for 802.11[ne] support"
  CC [M]  /home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/misc/eeprom_93cx6.o
  CC [M]  /home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/mac80211_hwsim.o
  CC [M]  /home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.o
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c: In function 'ath5k_rxbuf_setup':
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1169: warning: passing argument 1 of 'pci_dma_mapping_error' makes pointer from integer without a cast
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1169: error: too few arguments to function 'pci_dma_mapping_error'
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c: In function 'ath5k_beacon_setup':
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1921: warning: passing argument 1 of 'pci_dma_mapping_error' makes pointer from integer without a cast
/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.c:1921: error: too few arguments to function 'pci_dma_mapping_error'
make[8]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k/base.o] Error 1
make[7]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless/ath5k] Error 2
make[6]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/drivers/net/wireless] Error 2
make[5]: *** [_module_/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06] Error 2
make[5]: Leaving directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/linux-2.6.27.4'
make[4]: *** [modules] Error 2
make[4]: Leaving directory `/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06'
make[3]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-08-06/.built] Error 2
make[3]: Leaving directory `/home/candrews/kamikaze/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2
make[2]: Leaving directory `/home/candrews/kamikaze'
make[1]: *** [/home/candrews/kamikaze/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/candrews/kamikaze'
make: *** [world] Error 2

Your .config file appears not to have CONFIG_LINUX_2_6_27 option set as 'y'. Did you choose the right Target System and Target Profile in your menuconfig interface? Try to set them correctly and try building kamikaze again.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38 wrote:
rpress wrote:

I modified the patch to work with r13514:
http://openwrt.pastebin.com/f4218e262

The b43 works fine in AP mode; I could browse the net from my laptop no problem.  I also installed hostapd-mini and wpa-supplicant.

Unfortunately the new kernel didn't fix my segfault problems with the mmc card.  sad

Thanks. Based on your patch, I made a new patch for r13514, http://dongsupark.de/openwrt/kamikaze-r13514-b43ssb-2.6.27.diff. Maybe you can compile OpenWRT brcm47xx with kernel 2.6.27.4. But I'm not sure yet if wlan works with this patch. Posted also on https://dev.openwrt.org/ticket/4169

Sorry, I should have been more specific.  I used r13514 with kernel 2.6.27.4 and the patch I posted was all that was required to get the two working together.  Perhaps there is something wrong with my system, I am just using "svn diff", but your patch seems to have things in it that are already part of the trunk.  Recently I used 2.6.27.8 and it compiled with one minor change vs compiling with 2.6.27.4, but I haven't tested 2.6.27.8 yet.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38

I did a "make clean" then "make V=99" again, and it picked up that CONFIG_LINUX_2_6_27=y this time (I checked .config again). However.. I got a patch application failure while making:

Applying ./patches/330-ath9k_buildfix.patch using plaintext: 
patching file drivers/net/wireless/ath9k/main.c
Hunk #1 succeeded at 609 with fuzz 2 (offset 572 lines).
Hunk #2 FAILED at 1388.
1 out of 2 hunks FAILED -- saving rejects to file drivers/net/wireless/ath9k/main.c.rej
Patch failed!  Please fix ./patches/330-ath9k_buildfix.patch!
make[3]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-11-29/.prepared_3dd5c60dd0c9805164d500514bee2c0d] Error 1
make[3]: Leaving directory `/home/candrews/kamikaze/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2
make[2]: Leaving directory `/home/candrews/kamikaze'
make[1]: *** [/home/candrews/kamikaze/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/candrews/kamikaze'
make: *** [world] Error 2

here are the contents of ./build_dir/linux-brcm47xx/compat-wireless-2008-11-29/drivers/net/wireless/ath9k/main.c.rej

***************
*** 1386,1392 ****
                        pci_iounmap(sc->pdev, sc->mem);
                        pci_release_region(sc->pdev, 0);
                        pci_disable_device(sc->pdev);
-                       ieee80211_free_hw(hw);
                        return -EIO;
                } else {
                        sc->sc_flags |= SC_OP_RFKILL_REGISTERED;
--- 1388,1394 ----
                        pci_iounmap(sc->pdev, sc->mem);
                        pci_release_region(sc->pdev, 0);
                        pci_disable_device(sc->pdev);
+                       ieee80211_free_hw(sc->hw);
                        return -EIO;
                } else {
                        sc->sc_flags |= SC_OP_RFKILL_REGISTERED;

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

candrews wrote:

advance38

I did a "make clean" then "make V=99" again, and it picked up that CONFIG_LINUX_2_6_27=y this time (I checked .config again). However.. I got a patch application failure while making:

Applying ./patches/330-ath9k_buildfix.patch using plaintext: 
patching file drivers/net/wireless/ath9k/main.c
Hunk #1 succeeded at 609 with fuzz 2 (offset 572 lines).
Hunk #2 FAILED at 1388.
1 out of 2 hunks FAILED -- saving rejects to file drivers/net/wireless/ath9k/main.c.rej
Patch failed!  Please fix ./patches/330-ath9k_buildfix.patch!
make[3]: *** [/home/candrews/kamikaze/build_dir/linux-brcm47xx/compat-wireless-2008-11-29/.prepared_3dd5c60dd0c9805164d500514bee2c0d] Error 1
make[3]: Leaving directory `/home/candrews/kamikaze/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2
make[2]: Leaving directory `/home/candrews/kamikaze'
make[1]: *** [/home/candrews/kamikaze/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/candrews/kamikaze'
make: *** [world] Error 2

here are the contents of ./build_dir/linux-brcm47xx/compat-wireless-2008-11-29/drivers/net/wireless/ath9k/main.c.rej

***************
*** 1386,1392 ****
                        pci_iounmap(sc->pdev, sc->mem);
                        pci_release_region(sc->pdev, 0);
                        pci_disable_device(sc->pdev);
-                       ieee80211_free_hw(hw);
                        return -EIO;
                } else {
                        sc->sc_flags |= SC_OP_RFKILL_REGISTERED;
--- 1388,1394 ----
                        pci_iounmap(sc->pdev, sc->mem);
                        pci_release_region(sc->pdev, 0);
                        pci_disable_device(sc->pdev);
+                       ieee80211_free_hw(sc->hw);
                        return -EIO;
                } else {
                        sc->sc_flags |= SC_OP_RFKILL_REGISTERED;

Sorry, my fault. As I uploaded the modified one on my website, please download and patch it again. http://dongsupark.de/openwrt/kamikaze-r13514-b43ssb-2.6.27.diff

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

Sweet! That patch worked! I just started up my router with the new image a few minutes ago, and the wifi is up and working well. I'll report back tomorrow with if it's still working. This is excellent :-)

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

rpress wrote:
advance38 wrote:
gramulhaozin wrote:

Hey Mr Advance38, did you get able to go through the PHY problems ?

No, not yet. Please let me know too, if you hear a good news. :-)

Did you also install wpa-supplicant?  I had this same DISABLED issue until I did that.  This is with 2.6.25.20.

On my router ASUS WL-500W, OpenWRT kamikaze r13514 with kernel 2.6.27.4, Wi-Fi interface does not work for ap mode, even after wpa-supplicant is installed. I'm getting always the error message:

b43-phy0: Radio turned on by software
br-lan: topology change detected, propagating
br-lan: port 2(wlan0) entering forwarding state
Mode: IEEE 802.11g  Channel: 6  Frequency: 2437 MHz
Using interface wlan0 with hwaddr 00:22:15:26:ac:af and ssid 'myssid'
b43-phy0: Radio hardware status changed to DISABLED

But the station mode seems to work fine. I think I need to look into b43 driver by myself, to get it working with ap mode.

Re: WL-500GPV2 (brcm47xx) with kernel 2.6.27

advance38 wrote:

On my router ASUS WL-500W, OpenWRT kamikaze r13514 with kernel 2.6.27.4, Wi-Fi interface does not work for ap mode, even after wpa-supplicant is installed. I'm getting always the error message:

b43-phy0: Radio turned on by software
br-lan: topology change detected, propagating
br-lan: port 2(wlan0) entering forwarding state
Mode: IEEE 802.11g  Channel: 6  Frequency: 2437 MHz
Using interface wlan0 with hwaddr 00:22:15:26:ac:af and ssid 'myssid'
b43-phy0: Radio hardware status changed to DISABLED

But the station mode seems to work fine. I think I need to look into b43 driver by myself, to get it working with ap mode.

How about hostapd or hostapd-mini?  Do you have that installed?

Kernel 2.6.27.8 is working for me with the wireless as well.