OpenWrt Forum Archive

Topic: Kamikaze Wireless Bridge Problem

The content of this topic has been archived on 5 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I am having a few problems getting a client bridge setup between a WRT54GL and a WRT54GC. The rough network diagram is below:

--- - Wireless Connections
| - Wired Connections

              Internet             
                 |
                 |
              Modem     
                       \             
                         \           
     Wireless  ----  WRT54GL    ------- Wireless Bridge ---------  WRT54GC
       Client             |                                                                |
                            |                                                                |
                            |                                                                |
                          PC1                                                            PC2

The WRT54GL is running Kamikaze 7.06 2.4 Kernel and the WRT54GC is running the standard linksys firmware (if only OpenWRT would go on here!). There is a working (well it seems to be) wireless bridge between the GL and the GC with the SSID of BRIDGE. There is a second Wlan interface on the GL with SSID of WIRELESS that the wireless clients connect to. No wireless clients are connecting to the GC. Basically the problem I am having is that all PC's connected to the GL (wired or wireless) can access all other PC's including PC2 as well as the internet. PC2 can access all other pc's on the GL and GC, but CAN'T access the internet.

All PC's, wired and wireless are on the same 192.168.0.0/24 subnet. There is a subnet between the GL and the modem of 192.168.1.0/24. PC2 recieves IP information, including gateway, from the DHCP server on the GL.
               
Can anyone suggest some changes I would need to make to be able to get PC2 to connect to the internet? I'm also having problems getting WPA PSK working on the bridge. Any suggestions would be greatly appreciated.

Config files are:

root@OpenWrt:/etc/config# cat network
#### VLAN configuration
config switch eth0
        option vlan0    "0 1 2 3 5*"
        option vlan1    "4 5"


#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   192.168.0.1
        option netmask  255.255.255.0


#### WAN configuration
config interface        wan
        option ifname   "eth0.1"
        option proto    static
        option ipaddr   192.168.1.2
        option netmask  255.255.255.0
        option gateway  192.168.1.1
        option dns      ....
root@OpenWrt:/etc/config# cat wireless
config wifi-device  wl0
        option type     broadcom
        option channel  11
# disable radio to prevent an open ap after reflashing:
        option disabled 0

config wifi-iface
        option device   wl0
        option network  lan
        option mode     ap
        option ssid     WIRELESS
        option hidden   0
        option encryption psk2
        option key      key

config wifi-iface
       option device   wl0
       option network  lan
       option mode     sta
       option ssid     BRIDGE
       option hidden   0
       option encryption none
#       option key      key

(Last edited by rwo on 14 Jul 2007, 07:07)

Updated to the 7.07 Experimental which fixed the WPA2-PSK on the bridge, but PC2 still can't get out to the internet.

Anyone have some suggestions of things to try, i'm out of idea's?

Are you sure your this is working. I want to try this.

I have a doubt because how wl0 can have 2 SSID's
"WIRELESS" & "BRIDGE".

If this working for you, why don't you try interchanging your router.

just to confirm WRT54GC is running a linksys firmware and pc2 can't access the internet but can access pc1.

If memory serves correctly the WRT54GC  has a default route out its wan port, you will need to add a static route in it to WRT54GL   

-----------
ignore above the how segment is one ethernet segment.

1) check the default route on pc2 is it pointing to WRT54GL (check the routing setup)
2) tcpdump on WRT54GL looking for a ping from pc2 to google.
   you should see an arp request for the ip address and then an ip packet
3) if the above doesn't produce any thing, try a tcpdump on pc2 (if its windows you can get wireshark for it) and look at it, I would guess that WRT54GC is hijacking the packets.

The discussion might have continued from here.