OpenWrt Forum Archive

Topic: Extremely slow WLAN performance on WRTSL54GS

The content of this topic has been archived on 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

[SOLVED] The distance setting was causing the low speeds, Thanks to Weedy's suggestions from IRC, I removed this option and the speed returned to the "normal" wifi speed!
The reason for the wireless extensions not being enabled when i display iwconfig, was because i had not installed the 'kmod-wlcompat' package (ipkg install kmod-wlcompat).

I recently got kamikaze up and running, wifi configured with WPA2 (psk2), and all that fancy stuff. Wired LAN works flawlessly. ~5-9MByte/s transfer speeds between a linux file server and windows PC using samba or http. however, when I test the speed (copying a large movie from my file server to my laptop via http and samba), the speed is very low. ~450KByte/s. When i do this test using my old D-Link router, I get speeds in the area of ~3MByte/s. Nothing changed on the client, the only change is this linksys.

my /etc/config/network:

root@OpenWrt:/etc/rc.d# cat /etc/config/network
#### VLAN configuration
config switch eth0
 option vlan0 "0 1 2 3 4 5u"


#### Loopback configuration
config interface loopback
 option ifname "lo"
 option proto static
 option ipaddr 127.0.0.1
 option netmask 255.0.0.0


#### LAN configuration
config interface lan
 option type  bridge
 option ifname "eth0"
 option macaddr "00:1A:70:44:84:75"
 option proto static
 option ipaddr 192.168.1.1
 option netmask 255.255.255.0


#### WAN configuration
config interface wan
 option ifname "eth1"
 option macaddr "00:0F:B0:FE:9D:F1"
 option proto dhcp

#### WIFI configuration
config interface  wifi
 option ifname "eth0"

my /etc/config/wireless:

root@OpenWrt:/etc/rc.d# cat /etc/config/wireless
config wifi-device  wl0
 option type  broadcom
 option maxassoc  128
 option distance  30
 option channel   11
 option disabled  0

config wifi-iface
 option network  lan
 option device   wl0
 option mode   ap
 option ssid  #######
 option hidden  0
 option isolate  0
 option encryption psk2
 option key  #################

CPU usage is roughly .5% when testing the wifi connection. and .3% of this comes from top.

the laptop (Windows) reports Good signal with 54mbit speed. a bandwidth meter running on the computer is what is giving me the speed readout. it is steady at roughly 450KB/s.

On a (possibly) related note. iwconfig shows no wireless extensions for my wl0 interface. Even though wireless is clearly working.

root@OpenWrt:/mnt# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

br-lan    no wireless extensions.

wl0       no wireless extensions.

imq0      no wireless extensions.

imq1      no wireless extensions.

sit0      no wireless extensions.

sixxs     no wireless extensions.

(Last edited by Cisien on 22 May 2007, 09:40)

Can someone tell me if this is a known problem with the Broadcom driver? I have experienced similar slowlessness (1 MBps max, where other firmwares get me 2.3-2.6 MBps).

Thanks for any pointers.

I've also stumbled onto this.
I'm using a Asus WL-500gP and i'm getting transfers with 400kb/s instead of 2mb/s
I got 100-200kb/s but then i tried the solution above here. And now atleast i get twice the speed.
But still not close to what i should get.

Commenting out the 'Distance' option worked for me. I even get up to 2.8 MBps now smile.

The discussion might have continued from here.