There are many postings related dhcp with relayd problems in this forum, but not specific my problem.

My desired config:

propriatary Cable-Router(BlackBox) as IAD and DNS/DHCP-Server -> OpenWrt17.0.1-Router/Repeater with wlan-sta/wlan-ap/lan -> wired/wireless-clients

Networks:
lan = bridged eth* and (optional) wlan-ap
wwan = wlan-sta
relayd-bridge between lan wlan

without dhcp and static-client-ips everything works like a charm, with the wlan-ap down also even with dhcp, but with the wlan-ap up dhcp-requests are not forwarded, independent of the configuation of tha wlan-ap network, if it is in a seperate subnet, or if it is ip-configured at all


Model    o2 Box 6431
Firmware Version    OpenWrt SNAPSHOT r6190-1188f35a98 / LuCI Master (git-18.109.36013-172155e)
Kernel Version    4.9.82

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddb:78d9:37ea::/48'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.1'
        option dns '8.8.8.8'
        option type 'bridge'
        option ifname 'eth0.1'

config interface 'wwan'
        option proto 'static'
        option ipaddr '192.168.0.8'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '8.8.8.8'

config interface 'wifi'
        option proto 'static'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'
        option netmask '255.255.255.128'
        option ipaddr '192.168.0.129'
        option auto '0'
        option disabled '1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'stabridge'
        option ipaddr '192.168.0.8'
        option proto 'relay'
        option forward_bcast '1'
        option forward_dhcp '1'
        list network 'lan'
        list network 'wwan'
        option delegate 0
        option gateway '192.168.0.1'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:0e.0'
        option htmode 'HT20'
        option country 'DE'
        option legacy_rates '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'wlan-sta'
        option encryption 'psk2'
        option key 'xxxx'
        option powersave '1'
        option disabled '0'
        option ipaddr '192.168.0.8'
        option dns '8.8.8.8'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option start_disabled '1'
        option ssid 'wlan-ap'
        option encryption 'psk2+aes'
        option key 'xxxx'
#        option wds '1'
        option channel '4'
        option network 'lan'
        option disabled '0'

remarks: the wifi-section in networks is only for testing purposes to set up the wlan-ap as a discrete/nonbridged-network, but that makes no difference

tried it also with dhcp-fwd and dnsmasq -dchp-relay-option, but no success
with AP off, everythings perfekt AP-on, no dhcp

firewall is off

I'm really wondering what has the AP to do with dhcp, even if it's not tied to any related network or bridge

(Last edited by rolli1 on 22 Apr 2018, 09:24)