Topic: VLAN tagging on my r7800 fiber connection

i want to vlan tag on my r7800 netgear so i dont use the modem that isp gave me 


tried change the number but it didnt work for me

the vlan is 10

anyone can help me?

Re: VLAN tagging on my r7800 fiber connection

Perhaps you should post your "/etc/config/network" file here...

Re: VLAN tagging on my r7800 fiber connection

eduperez wrote:

Perhaps you should post your "/etc/config/network" file here...

sorry i dont know how to find that may you please show me how to find that?

just installed it for the sqm

4 (edited by mk24 2018-04-16 20:35:16)

Re: VLAN tagging on my r7800 fiber connection

In the GUI go to network -- wan (edit) -- physical settings.  Check which hardware is connected to the wan.
I think the 7800 has DSA switching, which means that there is a separate CPU interface (ethX, with X being a number from 0 to 4) for each port on the back, and there is not a switch configuration page.  In that case in wan physical settings you would see a list of 5 eth's with one selected.   This port number leads to the modem.  Create a new interface ethX.10 and switch to it.   The plain ethX will still exist but you should not attach any network to it.

Re: VLAN tagging on my r7800 fiber connection

mk24 wrote:

In the GUI go to network -- wan (edit) -- physical settings.  Check which hardware is connected to the wan.
I think the 7800 has DSA switching, which means that there is a separate CPU interface (ethX, with X being a number from 0 to 4) for each port on the back, and there is not a switch configuration page.  In that case in wan physical settings you would see a list of 5 eth's with one selected.   This port number leads to the modem.  Create a new interface ethX.10 and switch to it.   The plain ethX will still exist but you should not attach any network to it.

i did all that but cant connect to the internet i think im missing the vlan tag part tried to put wan tagged on vlan 10 but still not working

Re: VLAN tagging on my r7800 fiber connection

i think im doing the vlan tag wrong

Re: VLAN tagging on my r7800 fiber connection

Can you post a screenshot of your switch configuration (Network -> Switch) page?

Re: VLAN tagging on my r7800 fiber connection

i.gyazo.com/d57d93a22c6d950e64eae5e2c8787571.png

Re: VLAN tagging on my r7800 fiber connection

VLAN 10 is "off" on the ETH0 port, the tagged frames on the WAN port cannot reach the CPU.

10 (edited by AAAAlash Yesterday 09:38:53)

Re: VLAN tagging on my r7800 fiber connection

eduperez wrote:

VLAN 10 is "off" on the ETH0 port, the tagged frames on the WAN port cannot reach the CPU.

i.gyazo.com/276651205e37d35671982e3ad9fff4ed.png
is this right ? i tagged them both
i did it but still not working.

Re: VLAN tagging on my r7800 fiber connection

I would delete VLAN 2, if you are not going to use it. If it still does not work, I think you should give us more info: If you do not use your ISPs modem, how do you connect the router to the internet? What type of internet connection do you have? What other devices are involved? Other that using a VLAN, is there anything else your ISP requires to configure?

12 (edited by AAAAlash Yesterday 12:18:56)

Re: VLAN tagging on my r7800 fiber connection

eduperez wrote:

I would delete VLAN 2, if you are not going to use it. If it still does not work, I think you should give us more info: If you do not use your ISPs modem, how do you connect the router to the internet? What type of internet connection do you have? What other devices are involved? Other that using a VLAN, is there anything else your ISP requires to configure?

its fiber connection and how i connect is like this :ont modem hg8245q bridge>r7800 pppoe> pc
i.gyazo.com/0fd5115719af1ca726d39c6713eb5e11.png
i want to get ride of vlan tag though the modem i want it all through the r7800

my isp fiber connection use vlan 10 to use the internet

eduperez wrote:

I would delete VLAN 2, if you are not going to use it

i dont know if im using the vlan 2 or not it came default with the openwrt so i think i can deleted it and i would be ok? because tried missing with those and i couldnt log in to the router

13 (edited by mk24 Yesterday 12:41:29)

Re: VLAN tagging on my r7800 fiber connection

Log in by wifi while you are changing Ethernet settings.

Delete VLAN 2. 

VLAN 10 should be tagged to the external port and untagged to its CPU port.  These two ports must stay off in VLAN 1.

If you tag VLAN 10 to the CPU, you have to go to network - interfaces - wan edit - physical settings and change from eth0 to eth0.10 so that packets leave the CPU tagged.   A configuration where one or both of the CPU ports are tagged makes it possible to have more than two VLANs later.

Re: VLAN tagging on my r7800 fiber connection

mk24 wrote:

Log in by wifi while you are changing Ethernet settings.

Delete VLAN 2. 

VLAN 10 should be tagged to the external port and untagged to its CPU port.  These two ports must stay off in VLAN 1.

If you tag VLAN 10 to the CPU, you have to go to network - interfaces - wan edit - physical settings and change from eth0 to eth0.10 so that packets leave the CPU tagged.   A configuration where one or both of the CPU ports are tagged makes it possible to have more than two VLANs later.


i.gyazo.com/b5683dcf02eabf02863fda24187e7a44.png

i did this and made custom eth0.10 and switch to it but still doesn't connect to the internet.

do i need keep the vlan tag on the modem or should i disable it?

i.gyazo.com/0fd5115719af1ca726d39c6713eb5e11.png

15 (edited by mk24 Yesterday 13:55:22)

Re: VLAN tagging on my r7800 fiber connection

As the configuration you have now sets VLAN 10 UNtagged to the CPU, you need to continue to use the default of eth0 in the wan configuration, not eth0.10.

The whole point is to send tagged packets to the modem, so you always need tagged set on the wan Ethernet physical port.

Have you set the wan to pppoe mode and entered your ISP pppoe username and password?

Do you see non-zero byte counts both in and out of eth0?

If pppoe is trying to connect, you will see pppoe related messages in the system log.  The ISP may reject your connections because of the MAC address.   In that case you need to change the MAC address in the WAN to be the same as your old router, or reset your account with the ISP.

Re: VLAN tagging on my r7800 fiber connection

mk24 wrote:

As the configuration you have now sets VLAN 10 UNtagged to the CPU, you need to continue to use the default of eth0 in the wan configuration, not eth0.10.

The whole point is to send tagged packets to the modem, so you always need tagged set on the wan Ethernet physical port.

Have you set the wan to pppoe mode and entered your ISP pppoe username and password?

Do you see non-zero byte counts both in and out of eth0?

If pppoe is trying to connect, you will see pppoe related messages in the system log.  The ISP may reject your connections because of the MAC address.   In that case you need to change the MAC address in the WAN to be the same as your old router, or reset your account with the ISP.

how i can change my MAC address please i think my isp is locking my modem with the mac address or some other method i always tried changing thier modem but i couldnt even with the same model

17 (edited by mk24 Yesterday 15:14:16)

Re: VLAN tagging on my r7800 fiber connection

First you should examine the log file (Status->System Log) to see if that really could be the problem.  If it is, you will see several steps of pppoe being set up, but then the connection is shut down and it retries.

If you don't see anything other than "Timeout waiting for PADO packet", there is no physical path to the ISP at all and the MAC is not the problem.

You may need to edit the /etc/config/network file to override the MAC address.  I'm not sure where it is in LuCI.  But it is definitely possible.