Topic: TP-Link WDR7500 V6.0

I bought TP-Link WDR7500 V6.0 router with China Firmware.

It is possible to install OpenWRT on it ?

6 antenas - 1750AC, but you see - No USB in ver 6.0,  Ver 5.0 - have 2 USB ports.
h_tt_ps://forum.openwrt.org/viewtopic.php?id=59343


h_tt_p://oi66.tinypic.com/2uzsegy.jpg


QCA9563-AL3A MIPS CPU

h_tt_p://i66.tinypic.com/o70ft1.jpg

QCA9880-BR4A

h_tt_p://i65.tinypic.com/awt8hx.jpg

RTL8367S Gigabit Switch

h_tt_p://i67.tinypic.com/21eb5w6.jpg

One memory chip WinBond
W9751G6KB-25 RAM

h_tt_p://i63.tinypic.com/wvqszb.jpg

Flash Chip
25Q64CSIG (BH1621)
h_tt_p://i65.tinypic.com/9asmqh.jpg

UART J1
h_tt_p://i67.tinypic.com/s1tjlk.jpg

I compare chips and see that it is same as Ubiquiti UniFi AP AC
h_tt_ps://wiki.openwrt.org/toh/ubiquiti/unifiac

So, people  what you thinking about it ?

2 (edited by Max11mus 2016-08-30 19:05:07)

Re: TP-Link WDR7500 V6.0

Openwrt support both QCA9563-AL3A and QCA9880-BR4A chips.

What about realtek RTL8367S Gigabit Switch ?

So i must to build custom firmware and load it via serial ?

Or may be firmware from WDR6500  suitable h_tt_ps://wiki.openwrt.org/toh/tp-link/tp-link_tl-wdr6500_v2

Re: TP-Link WDR7500 V6.0

I also have bought this router on aliexpress and want to install openwrt or english firmware. Please post updates here. I'll write as well if I find a solution.

Re: TP-Link WDR7500 V6.0

I also have bought this router on aliexpress

want to install openwrt or english firmware.


Please post updates here.

5 (edited by Pilot6 2017-05-22 22:12:32)

Re: TP-Link WDR7500 V6.0

The problem is that the device has a 5-port switch and it is unclear how it is connected. Everything else looks similar to v5, except lack of USB.
Only one interface eth0 is used on CPU. Here is the boot log

U-Boot 1.1.4 (Sep 3 2016 - 17:29:14)

rtl8367s - Dragonfly 1.0

DRAM: 64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 145k for U-Boot at: 83fd8000
Reserving 132k for malloc() at: 83fb7000
Reserving 44 Bytes for Board Info at: 83fb6fd4
Reserving 36 Bytes for Global Data at: 83fb6fb0
Reserving 128k for boot params() at: 83f96fb0
Stack Pointer at: 83f96f98
Now running in RAM - U-Boot at: 83fd8000
Flash Manuf Id 0xc8, DeviceId0 0x40, DeviceId1 0x17
flash size 8MB, sector count = 2048
Flash: 8 MB
Using default environment

In: serial
Out: serial
Err: serial
Net: ath_gmac_enet_initialize...
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
athr_mgmt_init : one
Dragonfly ----> S17 PHY *

RTL8367S is ready now!
enable smart speed down
port:0 old:418 new:438
port:1 old:418 new:438
port:2 old:418 new:438
port:3 old:418 new:438
port:4 old:418 new:438
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x80000000 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
eth0
Setting 0x181162c0 to 0x4b962100
Autobooting in 1 seconds
## Booting image at 9f040000 ...
Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80060000) ...
## Giving linux memsize in bytes, 67108864

Starting kernel ...

[ 0.000000] Linux version 3.3.8 (tplink@tplink-0B) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Sat Sep 3 17:42:20 CST 2016
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 00019750 (MIPS 74Kc)
[ 0.000000] SoC: Qualcomm Atheros QCA956X rev 0
[ 0.000000] Clocks: CPU:775.000MHz, DDR:650.000MHz, AHB:258.333MHz, Ref:25.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone PFN ranges:
[ 0.000000] Normal 0x00000000 -> 0x00004000
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] Early memory PFN ranges
[ 0.000000] 0: 0x00000000 -> 0x00004000
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: board=AP152 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 61372k/65536k available (2213k kernel code, 4164k reserved, 566k data, 184k init, 0k highmem)
[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:83
[ 0.000000] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[ 0.060000] pid_max: default: 32768 minimum: 301
[ 0.060000] Mount-cache hash table entries: 512
[ 0.060000] Initialized recycle list for cpu 0.
[ 0.070000] NET: Registered protocol family 16
[ 0.070000] gpiochip_add: registered GPIOs 0 to 22 on device: ath79
[ 0.080000] MIPS: machine is Qualcomm Atheros AP152 reference board
[ 0.080000] registering PCI controller with io_map_base unset
[ 0.090000] bio: create slab <bio-0> at 0
[ 0.100000] PCI host bridge to bus 0000:00
[ 0.100000] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[ 0.110000] pci_bus 0000:00: root bus resource [io 0x0001]
[ 0.110000] pci 0000:00:00.0: invalid calibration data
[ 0.120000] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[ 0.120000] pci 0000:00:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[ 0.130000] pci 0000:00:00.0: using irq 40 for pin 1
[ 0.130000] Switching to clocksource MIPS
[ 0.140000] NET: Registered protocol family 2
[ 0.140000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.140000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.150000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.150000] TCP: Hash tables configured (established 2048 bind 2048)
[ 0.160000] TCP reno registered
[ 0.160000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.170000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.170000] NET: Registered protocol family 1
[ 0.190000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.190000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.200000] msgmni has been set to 119
[ 0.210000] io scheduler noop registered
[ 0.210000] io scheduler deadline registered (default)
[ 0.220000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.240000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[ 0.250000] console [ttyS0] enabled, bootconsole disabled
[ 0.250000] console [ttyS0] enabled, bootconsole disabled
[ 0.260000] m25p80 spi0.0: found gd25q64CSIG, expected m25p80
[ 0.270000] m25p80 spi0.0: gd25q64CSIG (8192 Kbytes)
[ 0.270000] Searching for RedBoot partition table
[ 0.280000] 9 RedBoot partitions found on MTD device spi0.0
[ 0.280000] Creating 9 MTD partitions on "spi0.0":
[ 0.290000] 0x000000000000-0x00000001d800 : "factory_boot"
[ 0.290000] mtd: partition "factory_boot" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.310000] 0x00000001d800-0x00000001e000 : "factory_info"
[ 0.320000] 0x00000001e000-0x000000020000 : "art"
[ 0.320000] 0x000000020000-0x000000030000 : "config"
[ 0.330000] 0x000000030000-0x000000040000 : "normal_boot"
[ 0.330000] 0x000000040000-0x000000140280 : "kernel"
[ 0.340000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.350000] 0x000000140280-0x0000006b0000 : "rootfs"
[ 0.360000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.370000] mtd: partition "rootfs" set to be root filesystem
[ 0.380000] 0x0000006b0000-0x000000800000 : "rootfs_data"
[ 0.390000] 0x000000040000-0x000000800000 : "firmware"
[ 0.390000] Registered character driver slp_flash_chrdev
[ 0.400000] u32 classifier
[ 0.400000] Performance counters on
[ 0.400000] input device check on
[ 0.410000] Actions configured
[ 0.410000] nf_conntrack version 0.5.0 (958 buckets, 3832 max)
[ 0.420000] TCP cubic registered
[ 0.420000] NET: Registered protocol family 17
[ 0.430000] 8021q: 802.1Q VLAN Support v1.8
[ 0.440000] Flash UID signiture check OK.
[ 0.440000] ### of_selftest(): No testcase data in device tree; not running tests
[ 0.450000] VFS: Mounted root (squashfs filesystem) readonly on device 31:6.
[ 0.460000] Freeing unused kernel memory: 184k freed
- preinit -
[ 2.400000] JFFS2 notice: (333) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
switching to jffs2
- init -

Please press Enter to activate this console. Sat Sep 3 09:42:00 UTC 2016
[ 4.730000] ag71xx_mdio: probed
[ 4.740000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[ 5.300000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.0:1d [uid=001cc942, driver=Realtek 8367S]
[ 5.580000] SCSI subsystem initialized
[ 5.730000] NTFS driver 2.1.30 [Flags: R/O MODULE].
[ 5.900000] PPP generic driver version 2.4.2
[ 5.990000] asf: module license 'Proprietary' taints kernel.
[ 5.990000] Disabling lock debugging due to kernel taint
[ 6.340000] ath_hal: 0.9.17.1 (AR5416, AR9380, REGOPS_FUNC, WRITE_EEPROM, TX_DATA_SWAP, RX_DATA_SWAP, 11D)
[ 6.360000] ath_rate_atheros loaded
[ 6.430000] ath_tx99 loaded
[ 6.580000] ath_dev loaded
[ 8.080000] 2G Caldata: 02 02 00 02 03 04 05 06 00 00 00 00 00 00 00 00
[ 8.110000] ath_pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[ 8.110000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[ 9.130000] 5G Caldata: 44 08 50 BC 02 0D 00 03 7F 12 34 56 00 00 1F 00
[ 10.190000] GRE over IPv4 demultiplexor driver
[ 10.210000] GRE over IPv4 tunneling driver
[ 10.240000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 10.440000] xt_time: kernel timezone is -0000
[ 10.520000] NET: Registered protocol family 24
[ 10.810000] PPTP driver version 0.8.5
[ 11.550000] nf_conntrack_rtsp v0.6.21 loading
[ 11.560000] nf_nat_rtsp v0.6.21 loading
[ 11.710000] Registered character driver slp_gpio_chrdev
[ 11.890000] fuse init (API version 7.18)
Command failed: Not found
uci: Entry not found (protocol.wan.macaddr)
[CFG_MAC]user did not configured wan mac, use default.
wifi-freq
Command failed: Not found
[ 15.900000] device eth0 entered promiscuous mode
[ 15.910000] device eth0.1 entered promiscuous mode
[ 16.320000] eth0: link up (1000Mbps/Full duplex)
[ 16.320000] br-lan: port 1(eth0.1) entered forwarding state
[ 16.330000] br-lan: port 1(eth0.1) entered forwarding state
/etc/rc.common: line 1: /lib/network/wan_rate.sh: Permission denied
[ 17.320000] br-lan: port 1(eth0.1) entered disabled state
Invalid command : st_ht_noamsdu
Invalid command : obss_rssi_th
Invalid command : obss_rx_rssi_th
[ 23.960000] 8021q: adding VLAN 0 to HW filter on device ath0
[ 23.960000] device ath0 entered promiscuous mode
[ 23.980000] br-lan: port 2(ath0) entered forwarding state
[ 23.980000] br-lan: port 2(ath0) entered forwarding state
[ 24.050000] device ath2 entered promiscuous mode
[ 24.060000] device wdscli0 entered promiscuous mode
Invalid command : st_ht_noamsdu
Invalid command : obss_rssi_th
Invalid command : obss_rx_rssi_th
[ 25.980000] br-lan: port 2(ath0) entered forwarding state
[ 26.310000] 8021q: adding VLAN 0 to HW filter on device ath1
[ 26.310000] device ath1 entered promiscuous mode
[ 26.320000] br-lan: port 5(ath1) entered forwarding state
[ 26.320000] br-lan: port 5(ath1) entered forwarding state
[ 26.390000] device ath3 entered promiscuous mode
[ 26.400000] device wdscli1 entered promiscuous mode
[ 26.990000] [stat]Lan ip: C0A80101, Lan mask: FFFFFF00
[ 26.990000] [stat]wan dev name: eth0.2
[ 27.270000] ----IGMP init begin------
[ 27.280000] wan_dev_index = 255 lan_dev_name=br-lan wan_dev_name=eth0.2
[ 27.290000] ----IGMP has been loaded------
wlan has already started in etc/init.d/network script.
[ 28.320000] br-lan: port 5(ath1) entered forwarding state
[ 29.010000] ol_vdev_start_resp_ev for vap 0 (832f0000)
[ 29.020000] ol_ath_vap_join: join operation is only for STA/IBSS mode
[ 29.030000] ol_ath_wmm_update:
[ 29.030000] Notification to UMAC VAP layer
Loading redirects
Loading dmz
Loading forbidhost
Loading localmanage
Loading hostctrl
Loading includes
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory
uci: Entry not found (guest_network.@guest_rule_2g[0])
uci: Entry not found (guest_network.@guest_rule_5g[0])
not ap mode, ignored.
not ap mode, ignored.
uci: Entry not found (guest_network.@guest_rule_2g[0])
uci: Entry not found (guest_network.@guest_rule_5g[0])
[ 33.720000] br-lan: port 3(ath2) entered forwarding state
[ 33.730000] br-lan: port 3(ath2) entered forwarding state
[ 33.730000] 8021q: adding VLAN 0 to HW filter on device ath2
[ 33.740000] SFE IPv4 init
[ 33.770000] br-lan: port 3(ath2) entered disabled state
[ 33.900000] SFE Fast-Classifier init
[ 34.240000] ol_vdev_start_resp_ev for vap 2 (832f0000)
[ 34.250000] ol_ath_vap_join: join operation is only for STA/IBSS mode
[ 34.260000] Notification to UMAC VAP layer
[ 34.270000] br-lan: port 6(ath3) entered forwarding state
[ 34.270000] br-lan: port 6(ath3) entered forwarding state
[ 34.280000] 8021q: adding VLAN 0 to HW filter on device ath3
[ 34.320000] br-lan: port 6(ath3) entered disabled state
/sbin/vsftp: eval: line 1: =0: not found
/sbin/vsftp: eval: line 1: =0: not found

Re: TP-Link WDR7500 V6.0

Has anyone tried to flash this router with OpenWRT or LEDE?
I'm considering buying it, but I'd like an assurance it works or doesn't work, for anyone.
Thanks.

Re: TP-Link WDR7500 V6.0

Can anyone install openwrt on TP-Link WDR7500 V6.0?
Which firmware should I install? I know the firmware of TP-Link WDR7500 v3.0 is provided. But the CPU of v6.0 is different from v3.0. So I don't sure that the firmware will work.
I will be very grateful if someone can help me .

Re: TP-Link WDR7500 V6.0

Is it available to install firmware from WDR6500 in WDR7500?
I will be very grateful if you can reply me.

Max11mus wrote:

Openwrt support both QCA9563-AL3A and QCA9880-BR4A chips.

What about realtek RTL8367S Gigabit Switch ?

So i must to build custom firmware and load it via serial ?

Or may be firmware from WDR6500  suitable h_tt_ps://wiki.openwrt.org/toh/tp-link/tp-link_tl-wdr6500_v2