Topic: Asus RT-N56U - ethernet ports issue

I have an asus RT-N56U that is not want to give any comunication through the ethernet ports(on the wireless everyting is ok)....it seems that is manage to give 100 or 1000 link but is not giving any ip(tried manually but is not reaching the gateway). Even in recovey mode is not accessible. Tried to make a PPPOE connection through WAN port and is working; Only the 4 LAN ports is not working, they act only like a switch. I olso tried with multiple firmware but is the same. Could it be the bootloader or the rtl8367 chip is malfunction.
Thanks in advance.



This is the boot log from ttl.


Bootloader version: 1.0.0.6
MAC Address: 08:60:6E:E8:A0:71

GPIOMODE before: 181d
GPIOMODE writing: 181d
GPIOMODE restoring: 181d
## Checking image at bc050000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.49
   Created:      2014-10-01  14:54:43 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1109705 Bytes =  1.1 MB
   Load Address: 80000000
   Entry Point:  80000000
   Verifying Checksum ...
3: System Boot system code via Flash.
## Booting image at bc050000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.49
   Created:      2014-10-01  14:54:43 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1109705 Bytes =  1.1 MB
   Load Address: 80000000
   Entry Point:  80000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 64

Starting kernel ...

[    0.000000] Linux version 3.10.49 (bb@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r42625) ) #3 Wed Oct 1 16:54:20 CEST 2014
[    0.000000] SoC Type: Ralink RT3883 ver:1 eco:5
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001974c (MIPS 74Kc)
[    0.000000] MIPS: machine is Asus RT-N56U
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x07ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x07ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 126484k/131072k available (2394k kernel code, 4588k reserved, 621k data, 184k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 500MHz
[    0.000000] Calibrating delay loop... 249.44 BogoMIPS (lpj=1247232)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.070000] Mount-cache hash table entries: 512
[    0.080000] pinctrl core: initialized pinctrl subsystem
[    0.090000] NET: Registered protocol family 16
[    0.110000] rt3883-pci 10140000.pci: mode: PCIe
[    1.700000] PCI host bridge /pci@10140000/host-bridge ranges:
[    1.710000]  MEM 0x0000000020000000..0x000000002fffffff
[    1.720000]   IO 0x0000000010160000..0x000000001016ffff
[    1.740000] bio: create slab <bio-0> at 0
[    1.750000] rt2880_gpio 10000600.gpio: registering 24 gpios
[    1.760000] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    1.770000] rt2880_gpio 10000638.gpio: registering 16 gpios
[    1.780000] PCI host bridge to bus 0000:00
[    1.790000] pci_bus 0000:00: root bus resource [mem 0x20000000-0x2fffffff]
[    1.800000] pci_bus 0000:00: root bus resource [io  0x10160000-0x1016ffff]
[    1.810000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    1.820000] pci 0000:00:01.0: BAR 8: assigned [mem 0x20000000-0x200fffff]
[    1.830000] pci 0000:00:01.0: BAR 1: assigned [mem 0x20100000-0x2010ffff]
[    1.840000] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x2000ffff]
[    1.850000] pci 0000:00:01.0: PCI bridge to [bus 01]
[    1.850000] pci 0000:00:01.0:   bridge window [mem 0x20000000-0x200fffff]
[    1.860000] pci 0000:00:01.0: unable to get irq map, err=-22
[    1.870000] pci 0000:01:00.0: using irq 40 for pin 1
[    1.880000] Switching to clocksource MIPS
[    1.890000] NET: Registered protocol family 2
[    1.890000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    1.900000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    1.910000] TCP: Hash tables configured (established 1024 bind 1024)
[    1.930000] TCP: reno registered
[    1.930000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    1.950000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    1.960000] NET: Registered protocol family 1
[    1.970000] rt-timer 10000100.timer: maximum frequncy is 10131Hz
[    2.000000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    2.010000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    2.030000] msgmni has been set to 247
[    2.040000] io scheduler noop registered
[    2.050000] io scheduler deadline registered (default)
[    2.060000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    2.080000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20) is a 16550A
[    2.090000] console [ttyS0] enabled, bootconsole disabled
[    2.090000] console [ttyS0] enabled, bootconsole disabled
[    2.120000] 1c000000.nor-flash: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000c2 Chip ID 0x0022cb
[    2.140000] Amd/Fujitsu Extended Query Table at 0x0040
[    2.150000]   Amd/Fujitsu Extended Query version 1.1.
[    2.160000] number of CFI chips: 1
[    2.170000] 4 ofpart partitions found on MTD device 1c000000.nor-flash
[    2.180000] Creating 4 MTD partitions on "1c000000.nor-flash":
[    2.190000] 0x000000000000-0x000000030000 : "u-boot"
[    2.200000] 0x000000030000-0x000000040000 : "u-boot-env"
[    2.210000] 0x000000040000-0x000000050000 : "factory"
[    2.230000] 0x000000050000-0x000000800000 : "firmware"
[    2.240000] 0x00000015ef09-0x000000800000 : "rootfs"
[    2.250000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    2.280000] mtd: device 4 (rootfs) set to be root filesystem
[    2.290000] mtd: partition "rootfs_data" created automatically, ofs=0x380000, len=0x480000
[    2.300000] 0x000000380000-0x000000800000 : "rootfs_data"
[    2.320000] rtl8367 rtl8367.4: using GPIO pins 1 (SDA) and 2 (SCK)
[    2.330000] rtl8367 rtl8367.4: RTL8367M ver. 0 chip found
[    4.280000] libphy: rtl8367.4: probed
[    4.290000] ralink_soc_eth 10100000.ethernet: using fixed link parameters
[    4.300000] (unregistered net_device): link up (1000Mbps/Full duplex)
[    4.310000] eth0: done loading
[    4.320000] rt3xxx-usbphy usbphy.3: loaded
[    4.330000] rt2880_wdt 10000120.watchdog: Initialized
[    4.340000] TCP: cubic registered
[    4.350000] NET: Registered protocol family 17
[    4.360000] Bridge firewalling registered
[    4.370000] 8021q: 802.1Q VLAN Support v1.8
[    4.380000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    4.390000] Freeing unused kernel memory: 184K (802f2000 - 80320000)
procd: Console is alive
procd: - watchdog -
[    6.180000] usbcore: registered new interface driver usbfs
[    6.190000] usbcore: registered new interface driver hub
[    6.200000] usbcore: registered new device driver usb
[    6.220000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    6.230000] ehci-platform: EHCI generic platform driver
[    6.440000] rt3xxx-usbphy usbphy.3: remote usb device wakeup disabled
[    6.460000] rt3xxx-usbphy usbphy.3: UTMI 16bit 30MHz
[    6.470000] ehci-platform 101c0000.ehci: EHCI Host Controller
[    6.480000] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    6.490000] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    6.530000] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    6.540000] hub 1-0:1.0: USB hub found
[    6.550000] hub 1-0:1.0: 2 ports detected
[    6.560000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    6.570000] ohci-platform 101c1000.ohci: Generic Platform OHCI Controller
[    6.580000] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    6.600000] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    6.670000] hub 2-0:1.0: USB hub found
[    6.680000] hub 2-0:1.0: 2 ports detected
[    6.690000] leds-gpio gpio-leds.6: pins are not configured from the driver
procd: - preinit -
[    6.940000] usb 1-2: new high-speed USB device number 2 using ehci-platform
Board is ASUS RT-N56U, replacing uImage header...
[    8.430000] eth0: link up (1000Mbps/Full duplex)
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
jffs2 is ready
jffs2 is ready
[   11.730000] jffs2: notice: (352) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 9 of xref (0 dead, 0 orphan) found.
switching to overlay
[   11.780000] eth0: link down
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[   13.510000] NET: Registered protocol family 10
[   13.530000] nf_conntrack version 0.5.0 (1979 buckets, 7916 max)
[   13.550000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   13.570000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[   13.590000] Backport generated by backports.git backports-20140320-37-g5c33da0
[   13.610000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   13.670000] xt_time: kernel timezone is -0000
[   13.710000] cfg80211: Calling CRDA to update world regulatory domain
[   13.760000] cfg80211: World regulatory domain updated:
[   13.770000] cfg80211:  DFS Master region: unset
[   13.780000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   13.800000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   13.810000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   13.830000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   13.840000] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[   13.860000] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   13.880000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   13.890000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   13.910000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   13.960000] PPP generic driver version 2.4.2
[   13.970000] NET: Registered protocol family 24
[   14.010000] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
[   14.020000] rt2800pci 0000:01:00.0: failed to load eeprom property
[   14.030000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'rt2x00pci_1_0.eeprom'.
[   14.050000] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 3071, rev 021c detected
[   14.070000] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0008 detected
[   14.100000] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 3883, rev 0400 detected
[   14.120000] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 3853 detected
procd: - init complete -
[   22.380000] eth0: link up (1000Mbps/Full duplex)
[   22.390000] device eth0.1 entered promiscuous mode
[   22.400000] device eth0 entered promiscuous mode
[   22.410000] br-lan: port 1(eth0.1) entered forwarding state
[   22.420000] br-lan: port 1(eth0.1) entered forwarding state
[   24.130000] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2860.bin'
[   24.150000] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.34
[   24.380000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   24.390000] device wlan0 entered promiscuous mode
[   24.420000] br-lan: port 1(eth0.1) entered forwarding state
[   24.450000] br-lan: port 2(wlan0) entered forwarding state
[   24.460000] br-lan: port 2(wlan0) entered forwarding state
[   24.470000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   26.460000] br-lan: port 2(wlan0) entered forwarding state

Re: Asus RT-N56U - ethernet ports issue

Show output of command

swconfig dev switch0 show

Re: Asus RT-N56U - ethernet ports issue

I find out what was the problem...(one of the RGMII ports dies), i mean i think that was the problem but now i manage to bricked really well. i did try with a lede firmware and now is giving "Bad Data CRC" and booting directly in rescue mode . The easy way to recover it will be with tftpd, but in my situation i can not use the ethernet ports, so the only solution is with kermit mode loading(i tested with hyperterminal and is working is sending files)....i never done this before so i don't really know how exactly to do. If coult someone help pls.

Thanks.

Re: Asus RT-N56U - ethernet ports issue

============================================
Ralink UBoot Version: 3.5.2.0
--------------------------------------------
ASIC 3883_MP (MAC to VITESSE Mode)
DRAM component: 1024 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 128 MBytes
Flash component: NOR Flash
Date:Jan 12 2011  Time:11:35:36
============================================
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 500 MHZ ####
 estimate memory size =64 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.

You choosed 4
                                                                  0

early Realtek giga Mac support...
GPIOMODE current: 181c
GPIOMODE writing: 181d
GPIOMODE current: 181d
get reg 0x1300: 6088
get reg 0x1300: 6088
get reg 0x1300: 6088
get reg 0x1300: 6088
get reg 0x1300: 6088
rtk_switch_init(): return 0
rtk_port_macForceLinkExt1_set(): return 0
org Ext1 txDelay: 1, rxDelay: 0
new Ext txDelay: 0, rxDelay: 7
rtk_port_rgmiiDelayExt1_set(): return 0
rtk_led_enable_set(LED_GROUP_0...): return 0
rtk_led_enable_set(LED_GROUP_1...): return 0
rtk_led_operation_set(): return 0
rtk_led_groupConfig_set(LED_GROUP_0...): return 0
rtk_led_groupConfig_set(LED_GROUP_1...): return 0
rtl8367m_switch_init_pre() return 0


4: System Enter Boot Command Line Interface.

U-Boot 1.1.3 (Jan 12 2011 - 11:35:36)
RT3883 # ?
?       - alias for 'help'
bootm   - boot application image from memory
cp      - memory copy
erase   - erase FLASH memory
go      - start application at address 'addr'
help    - print online help
loadb   - load binary file over serial line (kermit mode)
md      - memory display
mdio   - Ralink PHY register R/W command !!
mm      - memory modify (auto-incrementing)
mw      - memory write (fill)
nm      - memory modify (constant address)
printenv- print environment variables
protect - enable or disable FLASH write protection
reset   - Perform RESET of the CPU
rf      - read/write rf register
saveenv - save environment variables to persistent storage
setenv  - set environment variables
spicmd  - read/write data from/to eeprom or vtss
tftpboot- boot image via network using TFTP protocol
tftpd    -load the data by tftp protocol
version - print monitor version
RT3883 #

So... if i boot with 7 option "Load Boot Loader code then write to Flash via Serial" is ok to load the .trx firmware through hyperterminal send file with kermit protocol?? or what are the steps for this kind of option. After waiting for about 1:30 hours i manage to send a firmware file with "7" option but i recieved this error "kermit Abort: Bootloader is too big or download aborted!"

Re: Asus RT-N56U - ethernet ports issue

To restore firmware you should do in u-boot command line:
1. Unprotect flash block 5-127 (each block size is 64k)
2. Erase block 5-127.
3. Load firmware at 0x80100000 with loadb command.
4. Copy firmware from memory to flash with command cp.b
All these looks like:

protect off 1:5-127
erase 1:5-127
loadb 80100000
cp.b 80100000 bc050000 $(filesize)

DON'T TOUCH BLOCKS 0-4!!! There exist bootloader and calibraration data.
You can inspect flash data of bootloader/firmware before/after manipulation with memory display command

md bc000000
md bc050000

Don't try If not sure smile

Re: Asus RT-N56U - ethernet ports issue

RT3883 # cp.b 80100000 bc050000 797541
Copy to Flash...
 Copy 7959873 byte to Flash...
 addr = 0xBC0A5D32 ,cnt=7608335
 addr = 0xBC0FBA64 ,cnt=7256797
 addr = 0xBC151796 ,cnt=6905259
 addr = 0xBC1A74C8 ,cnt=6553721
 addr = 0xBC1FD1FA ,cnt=6202183
 addr = 0xBC252F2C ,cnt=5850645
 addr = 0xBC2A8C60 ,cnt=5499105
 addr = 0xBC2FE992 ,cnt=5147567
 addr = 0xBC3546C4 ,cnt=4796029
 addr = 0xBC3AA3F6 ,cnt=4444491
 addr = 0xBC400128 ,cnt=4092953
 addr = 0xBC455E5A ,cnt=3741415
 addr = 0xBC4ABB8C ,cnt=3389877
 addr = 0xBC5018BE ,cnt=3038339
 addr = 0xBC5575F0 ,cnt=2686801
 addr = 0xBC5AD322 ,cnt=2335263
 addr = 0xBC603054 ,cnt=1983725
 addr = 0xBC658D86 ,cnt=1632187
 addr = 0xBC6AEABA ,cnt=1280647
 addr = 0xBC7047EC ,cnt=929109
 addr = 0xBC75A51E ,cnt=577571
 addr = 0xBC7B0250 ,cnt=226033 done
RT3883 # md bc000000
bc000000: 100000ff 00000000 100000fd 00000000    ................
bc000010: 10000268 00000000 10000266 00000000    h.......f.......
bc000020: 10000264 00000000 10000262 00000000    d.......b.......
bc000030: 10000260 00000000 1000025e 00000000    `.......^.......
bc000040: 1000025c 00000000 1000025a 00000000    \.......Z.......
bc000050: 10000258 00000000 10000256 00000000    X.......V.......
bc000060: 10000254 00000000 10000252 00000000    T.......R.......
bc000070: 10000250 00000000 1000024e 00000000    P.......N.......
bc000080: 1000024c 00000000 1000024a 00000000    L.......J.......
bc000090: 10000248 00000000 10000246 00000000    H.......F.......
bc0000a0: 10000244 00000000 10000242 00000000    D.......B.......
bc0000b0: 10000240 00000000 1000023e 00000000    @.......>.......
bc0000c0: 1000023c 00000000 1000023a 00000000    <.......:.......
bc0000d0: 10000238 00000000 10000236 00000000    8.......6.......
bc0000e0: 10000234 00000000 10000232 00000000    4.......2.......
bc0000f0: 10000230 00000000 1000022e 00000000    0...............
RT3883 # md bc050000
bc050000: 56190527 82c10438 e82fe757 01757900    '..V8...W./..yu.
bc050010: 00000080 f0d22b80 0f799643 03020505    .....+..C.y.....
bc050020: 09030403 4e2d5452 00553635 00000000    ....RT-N56U.....
bc050030: 00000000 00000000 00000000 f0801200    ................
bc050040: 0000005d 358bf402 00000000 6f000000    ]......5.......o
bc050050: a3fffffd 3e47ffb7 39721548 92b85161    ......G>H.r9aQ..
bc050060: 86a3e628 e4eef907 2fd3821e 013c3ac5    (........../.:<.
bc050070: c97eb14b 2f4d8a8a 7fd90da3 238ce3a6    K.~...M/.......#
bc050080: 59e05311 8a75c518 86f877e2 0cbcdbf3    .S.Y..u..w......
bc050090: b55be6d6 7fbbdfb3 b963af8c c1c5edec    ..[.......c.....
bc0500a0: 59142764 46aeff4a 514f0222 d6586b03    d'.YJ..F".OQ.kX.
bc0500b0: 575c78dd bb5d04a1 991e350d 2e9b7c50    .x\W..]..5..P|..
bc0500c0: 0d3dbfaf 422a18bf 7db87ac4 ffefa332    ..=...*B.z.}2...
bc0500d0: e0581837 19ef56db 7ea08914 89a9d317    7.X..V.....~....
bc0500e0: 271593fd 78e5f3d1 6335c9ca 719a81d6    ...'...x..5c...q
bc0500f0: 0b1ab6e6 71ad46e7 8a4c0be8 20eb199b    .....F.q..L....
RT3883 # ?

Done..now is dead for sure smile .  is not even boot the bootloader....don't know what i did wrong, but thanks anyway.

Re: Asus RT-N56U - ethernet ports issue

Very strange...It looks correctly.
My rt3883 board sometimes fail to boot after first power on. But after several retries boot ok. And check power supply unit.

8 (edited by anatolpau 2017-12-08 22:56:07)

Re: Asus RT-N56U - ethernet ports issue

When i plugin the power , only the power led is on and is continuous. Nothing is showing through ttl conection. Did try rebooting and checking the power supply and it is ok. Is there a solution to write again the uboot bootloader to the nor flash?...with a nand programmer or it could be written through a jtag port ?

Re: Asus RT-N56U - ethernet ports issue

anatolpau wrote:

Is there a solution to write again the uboot bootloader to the nor flash?

It may help if flash chip is alive.

...with a nand programmer or it could be written through a jtag port ?

Yes to both questions but:
1. New router is cheaper than a nor/nand flash programmer
2. I didn't find jtag port connector on your router PCB.

Re: Asus RT-N56U - ethernet ports issue

You are right regarding the price smile , thanks alot for your support Serge.