OpenWrt Forum Archive

Topic: DODO VDSL WRT1900AC Connection Help

The content of this topic has been archived on 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Model: Linksys WRT1900AC
Openwrt: 17.02 LEDE
ISP: DODO Australia

Loaded the Openwrt firmware ok. Then configured SSL, Wifi, Admin Password.

I am a little confused on how to get it configured for my ISP.

I've edited /etc/config/network to:

config interface 'loopback'                    
        option ifname 'lo'                     
        option proto 'static'                  
        option ipaddr '127.0.0.1'              
        option netmask '255.0.0.0'             
                                               
config globals 'globals'                       
        option ula_prefix 'fd6d:41de:b39f::/48'

config vdsl 'dsl'
        option annex 'b'
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'bv'
        option xfer_mode 'ptm'
                                      
config interface 'lan'                
        option type 'bridge'          
        option ifname 'eth0'          
        option proto 'static'         
        option ipaddr '192.168.1.1'   
        option netmask '255.255.255.0'
        option ip6assign '60'  
                               
config interface 'wan'          
        option ifname 'eth1'    
        option proto 'dhcp'                  
                                               
config interface 'wan6'                        
        option ifname 'eth1'                   
        option proto 'dhcpv6'                  
                                      
config switch                         
        option name 'switch0'         
        option reset '1'              
        option enable_vlan '1'        
                                      
config switch_vlan                    
        option device 'switch0'
        option vlan '1'        
        option ports '0 1 2 3 5'
                                
config switch_vlan              
        option device 'switch0' 
        option vlan '2'         
        option ports '4 6'

But i had a few more questions before i test, i have a PPPoE login/password, where do i put that?

Also does this vdsl.bin firmware come with the standard 17.02 LEDE software or do i need to install it somehow?

Any advice for a noob would be great, i'll post the solution here when found.

(Last edited by BlondeStallman on 23 Sep 2017, 13:35)

Apparently i need to install components for the router:

opkg update
opkg install ppp kmod-pppoe ppp-mod-pppoe

But i can't connect it to the internet without those components. :S

You must have some sort of Internet connectivity, since you are writing here smile

So how about sharing that connection to your router e.g. over Wi-fi, and using that to update the package lists and install necessary components? When facing an issue such as yours, I often share a mobile broadband connection from my mobile phone by setting up a Wi-fi AP on the phone and connecting the router as a client.

You should consult your ISPs tech support for the details of your VDSL connection. What line type, what annex mode, which transfer mode, what encapsulation it uses, what link layer components are necessary and so on and so forth. The more tech specs you can fish out from them, the better off you are. You will need these details in order to configure all the bells and whistles of OpenWRT / LEDE.

BlondeSTallman wrote:

Also does this vdsl.bin firmware come with the standard 17.02 LEDE software or do i need to install it somehow?

Open an SSH connection to your router, and check the contents of '/lib/firmware' folder. Some LEDE images come with a pre-installed firmware file, others load this firmware from a hardcoded address on the flash memory. It all depends on the router, and how the LEDE image was built, and what license conditions cover the firmware file.

You should also check the make and model of your router. Linksys 1900AC does not sound correct. Perhaps you have a Linksys XAC1900 device? The exact make and model are important, because it allows us to determine which ICs your router is using for the DSL connection. This makes a world of a difference.

WRT1900AC sorry. I will talk to my ISP and try and get all the details. /lib/firmware was empty! so it seems i need the vdsl firmware still.

I'll try connecting the router and updating it too.

Update: I can't get it connected to the external internet. Connecting it via LAN to the routers WAN and LAN ports doesn't allow connectivity. Are there any guides on how to connect openwrt as a client via wifi/lan?

(Last edited by BlondeStallman on 23 Sep 2017, 14:07)

If it is a WRT1900AC, it means it does not have the ICs necessary to create a DSL connection. Therefore, you must have another device which acts as a modem. Which device is it? How is it configured? Or is there a mistake or a misunderstanding somewhere now?

If you just want to get your WRT1900AC online, then you should connect its WAN port to the LAN port of the other router that acts as a modem. If the other router has a local network and a DHCP server operating on the LAN ports, then things should work automatically. But if the other router is bridging the ISP's PPPoE link, then you'll need some additional configuration.

EDIT: Is this the setup that you're after?

(Last edited by Antek on 23 Sep 2017, 20:32)

If it is a WRT1900AC, it means it does not have the ICs necessary to create a DSL connection.

#$@! sad i wanted to replace the modem/router my ISP gave me... bugger.

Therefore, you must have another device which acts as a modem. Which device is it? How is it configured? Or is there a mistake or a misunderstanding somewhere now?

A Huwaii HG659 with the standard 192.168.1.1 subnet, i wanted to remove it and replace it with this new router but it seems that's not an option. sad

If you just want to get your WRT1900AC online, then you should connect its WAN port to the LAN port of the other router that acts as a modem. If the other router has a local network and a DHCP server operating on the LAN ports, then things should work automatically.

It does not work automatically, i connected it exactly as you described and can still SSH into it with 192.168.1.1 but the server cannot ping out into the external internet. :S

EDIT: Is this the setup that you're after?

I wanted the original modem/router gone, it's a piece of crap that i couldn't even change the DNS on. Would i get the same speeds if the Huwaii remains and my Linksys acts as a new lower router? tongue

Here is my Openwrt's current config:

# cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd6d:41de:b39f::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config interface 'wan6'
    option ifname 'eth1'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6'

(Last edited by BlondeStallman on 24 Sep 2017, 02:57)

BlondeStallman wrote:

It does not work automatically, i connected it exactly as you described and can still SSH into it with 192.168.1.1 but the server cannot ping out into the external internet. :S

Since the Huawei device is offering a subnet at 192.168.1.0, it sounds like it is acting as a routing gateway between your ISP's network and yours. Maybe the Huawei device is just not configured correctly to operate the PPPoE link?

BlondeStallman wrote:

I wanted the original modem/router gone, it's a piece of crap that i couldn't even change the DNS on. Would i get the same speeds if the Huwaii remains and my Linksys acts as a new lower router? tongue

Possibly. You could perhaps configure the Huawei device to act as a transparent Ethernet bridge, so the PPPoE link provided by your ISP runs through it, and is terminated at the WRT1900AC router. Then the Huawei would only be responsible for operating the DSL link, and Wi-fi & PPPoE would be operated from the WRT1900AC.

BlondeStallman wrote:

Here is my Openwrt's current config:

You will need to get the Huawei's configuration correct first. Once that is done, we can look at the WRT1900AC.

The discussion might have continued from here.