OpenWrt Forum Archive

Topic: Enormous ping time through wifi

The content of this topic has been archived on 23 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have an OpenWrt router I use as wifi access point and which worked perfectly.
However, the wifi network suddenly stopped working. I still can connect my devices to it, but I can't use Internet, or even connect to my router through ssh. I think that the issue is an ernormous ping time to my router : 10 to 15 seconds.
The connection through ethernet is still fine, with a ping time of less than 1 ms.

I have no idea of the cause of the issue. When the problem appeared, I was working on my lan, but not on my router; the only thing I did on it was an "iptables -L".

Do you know the cause of my ping time ? And how to solve the issue ?

Here are some of my config files :

network :

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdc6:a1bd:812c::/48'

config interface 'lan'
    option ifname 'eth1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'
    list dns_search ''

config interface 'wan6'
    option ifname 'eth0'
    option proto 'dhcpv6'

config interface 'vpn0'
    option ifname 'tun0'
    option proto 'none'
    option auto '1'

config 'route' 'br'
    option interface 'wan'
    option target ''
    option netmask '255.255.0.0'
    option gateway ''

wireless:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11a'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
    option distance '20'
    option txpower '20'
    option channel '36'
    option htmode 'VHT20'
    option country 'FR'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid ''
    option encryption 'psk2'
    option key ''
    option disabled '1'

config wifi-device 'radio1'
    option type 'mac80211'
    option hwmode '11g'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option htmode 'HT40'
    option country 'FR'
    option distance '20'
    option txpower '10'
    option channel '6'

config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid ''
    option encryption 'psk2'
    option key ''

firewall :

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    list network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config zone
    option name 'wan'
    list network 'wan'
    list network 'wan6'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config rule
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config zone 'vpn'
    option name 'vpn'
    option network 'vpn0'
    option forward 'REJECT'
    option output 'ACCEPT'
    option masq '1'
    option input 'ACCEPT'

config forwarding 'vpn_forwarding_lan_in'
    option src 'vpn'
    option dest 'lan'

config forwarding 'vpn_forwarding_lan_out'
    option src 'lan'
    option dest 'vpn'

Thank you for your help

You know that the 5GHz channel is disabled, do you?
How is this device connected to the internet? Is there other router?
Perhaps your neighbors use the same channels, have your tried changing to another channel?

Yeah, I disabled the 5Ghz channel, because my actual devices can't use it.
The internet connections is quite complicated (I am on a student network), but I can still acces to the Internet through ethernet, and issues with it should not have impact on my ping time to my router.

I thought about the channels, so I changed them and checked that they are free, but it did not solve the issue.

The discussion might have continued from here.