Topic: [How to] ADSL2+ connection to German Telekom (vlan id 7)

I have a TP-Link TD9980B running OpenWrt Designated Driver 50108 and setting up the DSL connections caused me some trouble. Cos I didn't found a solution on the internet and had to figure it out by myselve, I post this little How to.

Some background information: 2 Months ago the German Telekom changed my internet connecten, without any notice, so my router went offline, off course the hotline couldn't help me. In some forum I read about that the packages on the DSL connection need to be tagged with the VLAN ID 7. I tried it with the original firmaware of the TP-Link and the router went online again, but with poor LAN performance. I could ping websides but not open them in any browser (browsing via WLAN was working fine), since I wanted to fix the LAN performance I flashed the TP-Link with openWrt 2 weeks ago.

Part of my network config (for ADSL2+)(/etc/config/network):

config atm-bridge 'atm'
    option vpi '1'
    option vci '32'
    option encaps 'llc'
    option payload 'bridged'

config dsl 'dsl'
    option annex 'j'
    option xfer_mode 'atm'

config interface 'wan'
    option ifname 'nas0.7'
    option proto 'pppoe'
    option ipv6 '1'
    option username 'xxxxxxxxxxxxxxxxxxxxxxxx#0001@t-online.de'
    option password 'your_password'

config device 'wan_dev'
    option name 'nas0'
    option macaddr 'xx:xx:xx:xx:xx:xx' #your mac address or choose one

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'
    option reqaddress 'none'
    option reqprefix 'auto'

The most important lin in the config is:
option ifname 'nas0.7'
this will tell openWrt to tag the DSL packets with VLAN ID 7, you could use any VLAN ID here as longe your ISP accepts them. If you have a VDSL connection instead of ADSL you wouldn't use the nas0 pseudo adapter, in that case you need to put atm0 or ptm0 with the coresponding VLAN ID port (for Telekom it's again 7 = ptm0.7), obviously you have to change the other DSL settings to fit you setup too.

PS:I've seen network configs with a vlan switch setup (config switch_vlan) to tag the DSL-Port but this doesn't worked for my TP-Link.
PPS: The LAN problems occured with the original firmare are fixed with openWrt and the router ist working fine.