Topic: Asus WL-500gP - unable to configure VLAN ID with VID properly

Hello community,

sorry for bothering but I am already lost. My Asus WL-500gP V1 runs OpenWrt CHAOS CALMER (15.05.1, r48532). I am trying to setup VLAN to receive IPTV from my ISP. The IPTV is running on VLAN ID 949. I wanted IPTV to be attached to physical port 4 of the router.

Here is  my /etc/config/network

config switch 'eth0'
    option name 'eth0'
    option reset '1'
    option enable '1'
    option enable_vlan '1'


config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option dns '178.17.0.11 178.17.0.12'
    option ipaddr '192.168.0.1'
    option gateway '192.168.0.1'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

config interface 'iptv'
    option macaddr '04:8d:38:32:5b:5b'
    option ifname 'eth0.949'
    option proto 'dhcp'
    option metric '10'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '1 2 3 5t'

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0 5t'

config switch_vlan
    option device 'eth0'
    option vlan 3
    option vid 949
    option ports '0t 4 5t'

config globals 'globals'
    option ula_prefix 'fd2f:2794:5464::/48'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

The problem I am having is with VID. Asus does not allow me the set option vlan 949 (15 is the maximum allowed), so I added option vid 949.

Now, my problem is - when I connect STB to port 4 and run tcpdump, I do not see my STB's DHCP requests, I do only see Asus's:

root@OpenWrt:~# tcpdump -n -e -ttt -vv -i eth0 vlan 949
00:00:03.004014 xx:xx:xx:xx:xx:5b > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 346: vlan 949, p 0, ethertype IPv4, (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from xx:xx:xx:xx:xx:5b, length 300, xid 0xf9ce7c3c, secs 1607, Flags [none] (0x0000)
          Client-Ethernet-Address xx:xx:xx:xx:xx:5b
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            MSZ Option 57, length 2: 576
            Parameter-Request Option 55, length 7:
              Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
              Domain-Name, BR, NTP
            Vendor-Class Option 60, length 12: "udhcp 1.23.2"

however, if I dump all the trafic running on eth0, I see my STB requests running on VLAN 3, which I "did not" configured:

root@OpenWrt:~# tcpdump -n -e -ttt -vv -i eth0
00:00:00.037872 xx:xx:xx:xx:xx:ea > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 594: vlan 3, p 0, ethertype IPv4, (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 576)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from xx:xx:xx:xx:xx:ea, length 548, xid 0x5cb10456, secs 3, Flags [none] (0x0000)
          Client-Ethernet-Address XX:XX:XX:XX:XX:ea
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            MSZ Option 57, length 2: 1500
            Parameter-Request Option 55, length 13:
              Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
              Domain-Name, SS, RP, MTU
              BR, YD, NTP, Vendor-Option
              Option 234
            Vendor-Class Option 60, length 16: "Motorola_VIP1003"

But when I run tcpdump command to dump only VLAN 3, I do not see anything.

So, what am I doing wrong? Why there is this confusion of VLAN 3 vs. VID 949?

Thank you very much, it is driving me crazy.