1 (edited by topquant 2017-08-12 08:06:49)

Topic: During hnet-full install ipset dependency fails to install

Installing hnet-full (2015-07-10-ea2bd2bc2d8e617efca4b27fbf1c5c3c8ad09ad9-1) to root...
Failed to start babeld
Configuring mdnsd.
Configuring ip.
Configuring luci-app-hnet.
Configuring babeld.
Configuring ohybridproxy.
Configuring miniupnpd.
Configuring minimalist-pcproxy.
Configuring hnetd-nossl.
Configuring hnet-full.
Installing ipset (6.24-1) to root...
/base/ipset_6.24-1
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.

Warning: Unable to locate ipset utility, disabling ipset support
* Clearing IPv4 filter table
* Clearing IPv4 nat table
* Clearing IPv4 mangle table
* Clearing IPv4 raw table
* Populating IPv4 filter table
   * Zone 'lan'
   * Zone 'wan'
   * Rule 'Allow-DHCP-Renew'
   * Rule 'Allow-Ping'
   * Rule 'Allow-IGMP'
   * Rule #7
   * Rule #8
   * Forward 'lan' -> 'wan'
* Populating IPv4 nat table
   * Zone 'lan'
   * Zone 'wan'
* Populating IPv4 mangle table
   * Zone 'lan'
   * Zone 'wan'
* Populating IPv4 raw table
   * Zone 'lan'
   * Zone 'wan'
* Clearing IPv6 filter table
* Clearing IPv6 mangle table
* Clearing IPv6 raw table
* Populating IPv6 filter table
   * Zone 'lan'
   * Zone 'wan'
   * Rule 'Allow-DHCPv6'
   * Rule 'Allow-MLD'
   * Rule 'Allow-ICMPv6-Input'
   * Rule 'Allow-ICMPv6-Forward'
   * Rule #7
   * Rule #8
   * Forward 'lan' -> 'wan'
* Populating IPv6 mangle table
   * Zone 'lan'
   * Zone 'wan'
* Populating IPv6 raw table
   * Zone 'lan'
   * Zone 'wan'
* Set tcp_ecn to off
* Set tcp_syncookies to on
* Set tcp_window_scaling to on
* Running script '/usr/share/miniupnpd/firewall.include'
sh: 1: unknown operand
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for ipset:
*     kernel (= 3.18.23-1-81be0e40bf30c51dba2c46c84dd50f29) *     kernel (= 3.18.23-1-81be0e40bf30c51dba2c46c84dd50f29) *
* opkg_install_cmd: Cannot install package ipset.

Free space: 91% (18.98 MB)

I am using Linux OpenWrt 3.18.36 is there a version of ipset that runs on this kernel OR if ipset is deprecated in there a new package?

Re: During hnet-full install ipset dependency fails to install

Are you running Designated Driver?

3 (edited by topquant 2017-08-12 23:58:14)

Re: During hnet-full install ipset dependency fails to install

No. I am running the latest stable release Chaos Calmer 15.05.1 (March 2016).  Do I need to run Designated driver to install hnet-full and ipset properly?

As this is for a production application I would prefer to run a stable release.  Ispset is an established stable command-line function.  Is there a different feed for the stable release or a different package?

Re: During hnet-full install ipset dependency fails to install

you shouldn't edit your first post. it is confusing.

Re: During hnet-full install ipset dependency fails to install

No, I would not install DD; I commented because those "Cannot satisfy the following dependencies" messages are mostly caused by running unstable releases.

Re: During hnet-full install ipset dependency fails to install

Thanks for the replies.  I solved the problem by moving to LEDE.  Under LEDE ipset and hnet-full installed immediately without error.