Topic: ZXHN H108NS "You put a wrong file"

Hi lovely people,

I am trying to flash a ZXHN H108NS with openwrt. I reset the router, downloaded the .bin file from the wiki page for the  ZXHN H108N, went to the firmware upgrade page on the router and tried to upload it but it said "you put a wrong file".

There are two options whereby you can state what kind of thing you are uploading - "romfile" or "tclinux.bin". I tried each one, with the same results.

I tried renaming the file to foo.bin in case some character in the filename was causing this but it did not help.

I also re-downloaded the file in case it had not downloaded correctly but again no dice. It is 4.2MB in size so probably not compressed.

Could it be that the file is for the H108N not the H108NS? I could not find one for the exact model.

Any ideas?

Thank you!

Re: ZXHN H108NS "You put a wrong file"

If you rename the file to "tclinux.bin" it lets you upload it, but then it says: "The file is illegal, please to upload again!!".