OpenWrt Forum Archive

Topic: TP-Link 801ND v3

The content of this topic has been archived on 20 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi, i have a 801ND v3 with openwrt up and running. Because of only 4MB flash without luCI sad

The device has only one lan port.

Can someone point me in the right direction how to config multiple vlans on the divuce? because there is no switch in the config i dont know how to do it.

current config (network):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd72:1d77:10fe::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'dhcp'

IFCONFIG:

br-lan    Link encap:Ethernet  HWaddr 18:D6:C7:CB:2D:99
          inet addr:10.18.1.101  Bcast:10.18.1.255  Mask:255.255.255.0
          inet6 addr: fe80::1ad6:c7ff:fecb:2d99/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12824 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3987 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:761845 (743.9 KiB)  TX bytes:316201 (308.7 KiB)

eth1      Link encap:Ethernet  HWaddr 18:D6:C7:CB:2D:99
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14979 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3984 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1877561 (1.7 MiB)  TX bytes:315311 (307.9 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:46 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:3889 (3.7 KiB)  TX bytes:3889 (3.7 KiB)

Does the 'swconfig list' command on the SSH prompt show you any information regarding the switch device?

You can try other 'swconfig' commands as well to probe for more information.

There is a switch0. But the config of switch0 shows it is linked to eth0 - i only have eth1?

Found: switch0 - eth0
root@OpenWrt:~# swconfig dev switch0 show
Global attributes:
        enable_vlan: 0
Port 0:
        pvid: 0
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
Port 1:
        pvid: 0
        link: port:1 link:down
Port 2:
        pvid: 0
        link: port:2 link:down
Port 3:
        pvid: 0
        link: port:3 link:down
Port 4:
        pvid: 0
        link: port:4 link:down
VLAN 0:
        vid: 0
        ports: 0 1 2 3 4
root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 18:D6:C7:CB:2D:99
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::1ad6:c7ff:fecb:2d99/64 Scope:Link
          inet6 addr: fd6e:5ff5:9a2d::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:980 errors:0 dropped:0 overruns:0 frame:0
          TX packets:495 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:69218 (67.5 KiB)  TX bytes:57849 (56.4 KiB)

eth1      Link encap:Ethernet  HWaddr 18:D6:C7:CB:2D:99
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1028 errors:0 dropped:3 overruns:0 frame:0
          TX packets:478 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:89948 (87.8 KiB)  TX bytes:56043 (54.7 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:200 errors:0 dropped:0 overruns:0 frame:0
          TX packets:200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:13712 (13.3 KiB)  TX bytes:13712 (13.3 KiB)

You can use 'switch0' as the device name when writing the switch configuration section to /etc/config/network.

I'm not a driver expert, but regarding the 'eth0' vs 'eth1', I would guess that you might have an independent IC chip inside your router that implements the physical layer of your Ethernet connection. The data pins of this chip are wired internally to one of the ports on the switch, and in turn, the switch's data and control pins are wired to the SoC. In addition to this wiring, the physical layer chip has its own control pins that are connected directly to the SoC.

In this kind of setup, the 'eth0' device object supports both data transmission (through the switch) to the physical layer chip and control transmission to the switch, while the 'eth1' device object supports only control transmission to the physical layer chip.

Anyhow, grab an Ethernet cable and plug it between a PC that is powered on and your router, then run 'swconfig dev switch0 show' again. Which one of the ports changes state? This allows you to know which port you can use in your switch configuration.

Antek wrote:

Anyhow, grab an Ethernet cable and plug it between a PC that is powered on and your router, then run 'swconfig dev switch0 show' again. Which one of the ports changes state? This allows you to know which port you can use in your switch configuration.

This is not possible since the Accesspoint only have one ethernetport. But ill try to use switch0 now smile

i think this config works smile

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'true'
        option proto 'dhcp'
        option hostname 'AP-Test'

config interface 'Guest'
        option type 'bridge'
        option proto 'none'
        option auto '1'
        option delegate '0'
        option _orig_ifname 'eth1'
        option _orig_bridge 'true'
        option ifname 'eth1.222'


config interface 'Intern'
        option type 'bridge'
        option proto 'none'
        option auto '1'
        option delegate '0'
        option _orig_ifname 'eth1'
        option _orig_bridge 'true'
        option ifname 'eth1.221'
mhilgert wrote:

This is not possible since the Accesspoint only have one ethernetport. But ill try to use switch0 now smile

Usually in 'swconfig' output, one port is always shown as connected, and this is the CPU-facing port that is inside the router. Plugging the cable to the external port and querying 'swconfig' again then shows one more port as connected.

I can't say if your config works or not. You are not showing the 'config switch' section, and you haven't outlined any plans on how you intend to use VLANs. In the 'swconfig' output that you showed before, the VLAN functionality was switched off. Based on these, I'd say your VLANs are not working, at least not in any way that I know of, but if you say it works, then I'll take your word for it smile

The discussion might have continued from here.