OpenWrt Forum Archive

Topic: Easybox 904 LTE open source code to be provide soon

The content of this topic has been archived between 1 Apr 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi everyone,

I was trying to flash the fullimage.bin from post #280 to my 904 LTE box via TFTP,
curiously it was accepting the image and starting to erase the flash, only to figure out that something is wrong with the expected image size / offset:

ROM VER: 1.1.4
CFG 06
NAND
NAND Read OK

ROM VER: 1.1.4
CFG 06
NAND
NAND Read OK
nand_read_page - 00000008
DDR autotuning Rev 0.3c
DDR size from 0xa0000000 - 0xa7ffffff
DDR check ok... start booting...



U-Boot 2010.06-Lv2.0.40-A0.3  (Jul 12 2012 - 22:00:12)

CLOCK CPU 500M RAM 250M
DRAM:  128 MiB
NAND:  NAND device: Manufacturer ID: 0xec, Chip ID: 0xdc (Samsung NAND 512MiB 3,
3V 8-bit)
512 MiB
Bad block table found at page 262080, version 0x01
Bad block table found at page 262016, version 0x01
nand_read_bbt: Bad block at 0x0000002e0000
nand_read_bbt: Bad block at 0x00001e680000
In:    serial
Out:   serial
Err:   serial
Net:   Internal phy(GE) firmware version: 0x040b
vr9 Switch

Type "run flash_nfs" to mount root filesystem over NFS

reset button pressed --> 1
reset button pressed --> 2
reset button pressed --> 3
reset button pressed --> 4
reset button pressed --> 5
reset button pressed --> 6
reset button pressed --> 7
enter rescue process ...
Uncompressing LCD bootup images ...............
NAND read: device 0 offset 0x0000000004700000, size 0x0000000000300000
 0x300000 bytes read: OK
Using vr9 Switch device
TFTP from server 192.168.2.100; our IP address is 192.168.2.1
Filename 'fullimage.img'.
Load address: 0x80800000
Loading: T T #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #########################
done
Bytes transferred = 5127544 (4e3d78 hex)
verify firmware validation: loadaddr = 0x80800000, filesize = 5127544
firmware is ok !

NAND erase: device 0 offset 0x0000000004440000, size 0x0000000000100000
Erasing at 0x4520000 -- 100% complete.
OK

NAND erase: device 0 offset 0x0000000002240000, size 0x0000000001e00000
Erasing at 0x4020000 -- 100% complete.
OK

NAND erase: device 0 offset 0x0000000004040000, size 0x0000000000400000
Erasing at 0x4420000 -- 100% complete.
OK
Saving Environment to NAND...
Erasing at 0x4560000 -- 100% complete.
done
Image contains header with name [MIPS LEDE fakeroot]
erasing 0x00040000 size 0x01e00000
Skipping bad block at  0x002e0000
Erasing at 0x1e20000 -- 100% complete. Cleanmarker written at 0x1e20000.
erase OK
writing to 0x00040000 size 0x00000000
 write 0x00000000 bytes: OK
Erasing at 0x4560000 -- 100% complete.
done
Image contains header with name [MIPS LEDE Linux-4.9.14]
Cannot upgrade image f_kernel_addr.
 Error : From start address 0x01e40000, the new size 5127408 is bigger than begi
ning of next image/end of the partition 0x02240000
Can not upgrade the image kernel

Could the stock flash layout be different between xDSL and LTE variants?

Upon power-cycling the box, I assumed the kernel image must have been erased already, but curiously it was still there and trying to boot:

(...)

Hit any key to stop autoboot:  0
Uncompressing LCD bootup images ...............
NAND read: device 0 offset 0x0000000004700000, size 0x0000000000300000
 0x300000 bytes read: OK
1. bootid : 0, bootnum : 0
Erasing at 0x4560000 -- 100% complete.
done
2. bootid : 0, bootnum : 1

NAND read: device 0 offset 0x0000000001e40000, size 0x0000000000400000
 0x400000 bytes read: OK
## Booting kernel from Legacy Image at 80800000 ...
   Image Name:   MIPS LTQCPE Linux-2.6.32.32
   Created:      2014-09-05   4:30:35 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1441728 Bytes = 1.4 MiB
   Load Address: 80002000
   Entry Point:  800061b0
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

Lantiq xDSL CPE VR9
mips_hpt_frequency = 250000000, counter_resolution = 2

I was actually expecting kernel panic (could not mount rootfs) but it was now stuck in a bootloop after "... counter_resolution = 2"

So it seems the bootloop might be due to a suppressed kernel panic when no valid rootfs was found!? (...and there is no console output or system halt, but the manufacturer rather chose to perform a reset immediately...)

The latest LTE stock firmware from the vodafone website was not accepted via tftp recovery...

Bytes transferred = 31383681 (1dee081 hex)
verify firmware validation: loadaddr = 0x80800000, filesize = 31383681
0x81af5040 magic number not found

...flashing the xDSL stock firmware worked but also results in a bootloop.

Has anyone figured out how to enable UART mode for the LTE variant yet? The board layout is quite different from xDSL (the resistor labeled R148 is actually populated on the LTE board, so the naming is definetly not related)

In any case - I will try to build and flash some recovery fullimages tomorrow as described earlier in this thread, maybe I can get back to stock firmware for a while and try getting dropbear access for a start... smile

So I also flashed the 5,1 MB fullimage.img (from #280) to my xDSL Easybox, but the box is getting stuck in a bootloop.

Is there a documentation how to compile the git-source with the vectoring firmware from a fritzbox etc.? To get a VDSL100 Telekom connection working.

(Last edited by biomajuss on 16 Apr 2017, 19:09)

Hi all.
Sorry for delayed response, I just return from vocation and make some additional tests and commit.
My latest results are next:
1. Firmware can be loaded
2. AP starts(only 5G for some reason)
3. I can connect to AP and open LuCi interface in browser.

More detail.
I don't use switch from Lantiq SoC, only rtl8367.
In file path_to_linux_sources/drivers/net/ethernetlantiq_xrx200.c I changed XRX200_MAX_DEV to 3

#ifdef SW_ROUTING
#define XRX200_MAX_DEV        3    
#else
#define XRX200_MAX_DEV        1
#endif

and section eth0 in dts file to have 3 ethernet interfaces

&eth0 {
    lan: interface@0 {
        compatible = "lantiq,xrx200-pdi";
        #address-cells = <1>;
        #size-cells = <0>;
        reg = <0>;                                
        mac-address = [ 84 9C A6 A0 99 9C ];
        ethernet@0 {
            compatible = "lantiq,xrx200-pdi-port";
            reg = <0>;
            phy-mode = "rgmii";
            fixed-link {
                                speed = <1000>;
                                full-duplex;
                        };
        };
    };

    iNIC: interface@1 {
                compatible = "lantiq,xrx200-pdi";
                #address-cells = <1>;
                #size-cells = <0>;
                reg = <1>;
                mac-address = [ 84 9C A6 A0 99 9E ];
                ethernet@5 {
                        compatible = "lantiq,xrx200-pdi-port";
                        reg = <5>;
                        phy-mode = "rgmii";
                        fixed-link {
                                speed = <1000>;
                                full-duplex;
                        };
                }; 
        
    };
    wan1: interface@2 {
                compatible = "lantiq,xrx200-pdi";
                #address-cells = <1>;
                #size-cells = <0>;
                reg = <2>;
                mac-address = [ 84 9C A6 A0 99 9D ];
        ethernet@4 {
            compatible = "lantiq,xrx200-pdi-port";
            reg = <4>;
            phy-mode = "gmii";
            phy-handle = <&phy13>;
        };

        };
};

and run make to build new firmware.
Flash it to router.

Next step - copy original firmware, configs and eeprom files to folder /lib/firmware/iNIC/RT3883/

-rwxr-xr-x    1 root     root        576384 Apr 19 19:48 iNIC_ap.bin                                                                                          
-rwxr-xr-x    1 root     root          2201 Apr 19 19:48 iNIC_ap.dat                                                                                          
-rwxr-xr-x    1 root     root          2129 Apr 19 19:48 iNIC_ap1.dat                                                                                         
-rwxr-xr-x    1 root     root           512 Apr 19 19:49 iNIC_e2p.bin                                                                                         
-rwxr-xr-x    1 root     root           512 Apr 19 19:49 iNIC_e2p1.bin

build kernel module

make CROSS_COMPILE=~/git/Easybox-904-XDSL/staging_dir/toolchain-mips_24kc_gcc-5.4.0_uClibc/bin/mips-openwrt-linux- STAGING_DIR=~/git/Easybox-904-XDSL/build_dir/target-mips_24kc_uClibc/linux-lantiq_xrx200/linux-4.9.20/ ARCH=mips

and copy it to router

scp rt3883_iNIC.ko root@192.168.1.1:/lib/modules/4.9.20/

Now everything ready to load module

ifconfig eth1 192.168.3.1 up 
insmod /lib/module/4.9.20/rt3883_iNIC.ko miimaster=eth1 bridge=1 reset_gpio=483 
mac=84:9C:A6:A0:99:A4 mac2=84:9C:A6:A0:99:A6
ifconfig ra00_0 up
ifconfig ra00_1 up
ifconfig ra01_0 up
ifconfig ra01_1 up

In my case DHCP server doesn't run on eth1 interface, so in client device(Nexus6) I set static IP 192.168.3.100.

Scan for WiFi networks, find INIC_AP_1, and connect to it.
In browser open 192.168.3.1 and you will see LuCi interface.

P.S Continue working on it.

Thanks @kovz. The driver works with some changes. To be honest, now understand somehow what you wrote on github, regarding the dts. Maybe I can drop some changes made by me.
Nevertheless until now, I used my own setup to test the driver. And it works somehow.
I created some packages, to build the lede/openwrt wifi driver adapter and the kernel module. I uploaded all my changes to build the packages to my repositories. (Don't forget to call ./scripts/feeds update before build the image)

When the image is compiled, the driver is built and all additional files will be prepared.
On boot, the driver is loaded via init script and the initial wifi configuration is created.

When migrated from older images, verify that all switch ports are using the same VLAN:

cat /etc/config/network
...
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3 4 5 6t'

config switch_vlan
        option device 'switch1'
        option vlan '1'
        option ports '0 1 2 3 6t'

Attention: No GUI available! Setup is done only via uci- / text- configuration.

root@LEDE:/# cat /etc/config/wireless
# 5 GHz
config wifi-device 'ra00_0'
        option type 'ralink'
        option channel '11'
        option disabled '1'

config wifi-iface 'default_ra00_0'
        option device 'ra00_0'
        option mode 'ap'
        option ssid 'Lede'
        option encryption 'psk2+aes'
        option key 'WiFipassword'

# 2,4 GHz
config wifi-device 'ra01_0'
        option type 'ralink'
        option channel '11'
        option disabled '0'

config wifi-iface 'default_ra01_0'
        option device 'ra01_0'
        option mode 'ap'
        option ssid 'Lede1'
        option encryption 'psk2+aes'
        option key 'WiFipassword'

I also doesn't use a dhcp server at the box itself, but somewhere at the internal network - it works.
PS: Currently it is not possible add one of the interfaces (ra00_0, ra00_1, ...) to the bridge br-lan, it complaints about packets which have the same source and target mac ids (?!) (It is not neccessary, though) -> Open point.

Also no guest network is possible atm (It is not tested.) Guest networks are provided via ra00_1 (5Ghz) and ra01_1 (2.4GHz) interfaces.

Actually the setup doesn't support all available wifi driver options, such as channel auto detection, greenfield mode, etc. - this is a wip module.

Again, thanks kovz for your work !!! smile

(Last edited by QAuge on 2 May 2017, 05:21)

@kovz @QAuge Could you sum up what's current status - what's working, what are the problems? I read whole topic and info is a bit chaotic. And Wiki is outdated completely.

So I have a few questions - from xDSL version PoV.
1. Lantiq/realtek LAN switch - status and usage
Does both of them finally work? If not, with Realtek one, can I access router, or it's connected via one of ports to internal Lantiq switch? Is gigabit connection working? Are vlans and port tagging working (so I can use eg. one port as WAN?)

2. Running from internal flash
Is it possible now, or we are still stuck to using pendrive for rootfs?

3. DHCP
Is there any problem, or it's just a coincidence that you both are using external server? wink

4. DSL connection
Is DSL working? Has anyone tested it with Annex A? On devices like EasyBox 803 it was enough to bypass frequency filter (desolder it and replace with two wires) and load Annex A firmware to get it working.

5. WiFi
So I understand that we have basic functions to run as AP now? What about this bridging issue? - I need to use vlans to have one of ethernet ports used as WAN.

6. LCD and touch keys
I saw progress on getting it to work with LCD4Linux. Is that included now?

I just bought xDSL version (hw r02) for like 10 bucks and wanted it to replace my old EasyBox 803 - all I need now is WiFi + LAN working, and I'm using one of LAN port as WAN.

(Last edited by kitor on 13 May 2017, 16:09)

TODO: SiGe 5005L, markings "SiGe 5005L 301BF"
Datasheet search for :
Skyworks SE5005L

eartquake wrote:

TODO: SiGe 5005L, markings "SiGe 5005L 301BF"
Datasheet search for :
Skyworks SE5005L

Done

And for smartcard reader tda8029HL

A little bit about rt3883 and iNIC config file

Datasheet in Adobe flash viewer(yes, I know that this is strange)  for rtl8370

(Last edited by kovz on 18 May 2017, 10:41)

Hi kitor!

kitor wrote:

@kovz @QAuge Could you sum up what's current status - what's working, what are the problems? I read whole topic and info is a bit chaotic. And Wiki is outdated completely.

Volunteers welcome wink Indeed the wiki has to be updated, there's so much development in the last months.

kitor wrote:

So I have a few questions - from xDSL version PoV.
1. Lantiq/realtek LAN switch - status and usage
Does both of them finally work? If not, with Realtek one, can I access router, or it's connected via one of ports to internal Lantiq switch? Is gigabit connection working? Are vlans and port tagging working (so I can use eg. one port as WAN?)

Yes, this is possible. In the last couple of days I added the patch for FID setting on the lantiq switch.
It is needed to bridge the VLAN interfaces together. This is not needed for WAN, but currently used for WLAN.

kitor wrote:

2. Running from internal flash
Is it possible now, or we are still stuck to using pendrive for rootfs?

The default configuration loads uses the internal flash as UBI device.
(While I'm prefer the pen drive for development to prevent the internal flash from damage.)

kitor wrote:

3. DHCP
Is there any problem, or it's just a coincidence that you both are using external server? wink

Just the private setup. I personally use this device behind a router as "smart" device with switch ports.
The DHCP/DNS configuration should work as expected.

kitor wrote:

4. DSL connection
Is DSL working? Has anyone tested it with Annex A? On devices like EasyBox 803 it was enough to bypass frequency filter (desolder it and replace with two wires) and load Annex A firmware to get it working.

Annex B / Annex J is working here. A introduction is Post 287.

kitor wrote:

5. WiFi
So I understand that we have basic functions to run as AP now? What about this bridging issue? - I need to use vlans to have one of ethernet ports used as WAN.

All fine, currently the WLAN is working as basic AP and sends it traffic VLAN 66 tagged to the interface eth0.66 which is bridged to br-lan. With that, the clients have access to the private network. If you use a special VLAN for the external port of the lantiq switch, it should work. The iNIC control channel is set as eth0.3 to avoid internal traffic on regular interfaces/bridges.

Note that the WLAN has to be configured through the /etc/network/wifi configuration.
If someone has time and would like to extend the configuration, you are welcome.
Also as step for the WLAN driver, I have the feeling we have to convert this to the cfg80211 interface, which is
far better supported by lede/openwrt than the iwext interface.

kitor wrote:

6. LCD and touch keys
I saw progress on getting it to work with LCD4Linux. Is that included now?

It is included now, I had an issue with distorted colors on serdisplib. I reported it and now it is fixed upstream and works as expected. I wrote a small script to enable the lcd4linux/display on touch events and disable it after a while. (It makes no sense for me, to leave the display switched on all the time).
Also here: I really would appreciate updates for the lcd4linux configuration. Maybe things are not perfect.

kitor wrote:

I just bought xDSL version (hw r02) for like 10 bucks and wanted it to replace my old EasyBox 803 - all I need now is WiFi + LAN working, and I'm using one of LAN port as WAN.

If you have no problem with editing your configurations (WIFI) with the use of an text editor, you are fine.

Should I push a current snapshot ?

(Last edited by QAuge on 9 Jun 2017, 09:31)

Hi All,
Can someone let me know what is the correct settings for the O2 sip connection?
I have the O2 (Germany) username, password and the server name.

Username = 49[AreaCode][PhoneNo] eg: 493040700000
Passoword = xxxxxxxxxxxxxxxx
Server = sip.alice-voip.de

On my easybox 904 xDSL ccfg_cli I have the following settings

lineEnable@sip_acc_1=1
userId@sip_acc_1=03040700000
userId_area@sip_acc_1 =
userId_local@sip_acc_1=40700000
displayName@sip_acc_1=03040700000
account_name@sip_acc_1=493040700000
password@sip_acc_1=xxxxxxxxxxxxxxxxx
useAuthId@sip_acc_1=0
authId@sip_acc_1=493040700000
realm@sip_acc_1=sip.alice-voip.de
sipdomain@sip_acc_1=sip.alice-voip.de
registrar@sip_acc_1=sip.alice-voip.de
proxy@sip_acc_1=sip.alice-voip.de
outboundProxy@sip_acc_1=0
useOutboundProxy@sip_acc_1=0
useDNSSRV@sip_acc_1=0
proxyPort@sip_acc_1=5060
obproxyPort@sip_acc_1=5060
registrarPort@sip_acc_1=5060
sipPort@sip_acc_1=5060
ListenVc@sip_acc_1=1
registerExpire@sip_acc_1=3600
dtmfTxMethod@sip_acc_1=1
codec_config@sip_acc_1=1
faxPassthruCodec@sip_acc_1=2
enableRegisterQuery@sip_acc_1=1
codec_s1@sip_acc_1=2
codec_s2@sip_acc_1=4
codec_s3@sip_acc_1=7
codec_s4@sip_acc_1=0
codec_s5@sip_acc_1=0
codec_s6@sip_acc_1=0
codec_s7@sip_acc_1=0
codec_s8@sip_acc_1=0
codec_s9@sip_acc_1=0
codec_s10@sip_acc_1=0
codec_s11@sip_acc_1=0
codec_s12@sip_acc_1=0
codec_a1@sip_acc_1=1
codec_a2@sip_acc_1=3
codec_a3@sip_acc_1=5
codec_a4@sip_acc_1=6
codec_a5@sip_acc_1=8
codec_a6@sip_acc_1=9
codec_a7@sip_acc_1=0
codec_a8@sip_acc_1=0
codec_a9@sip_acc_1=0
codec_a10@sip_acc_1=0
codec_a11@sip_acc_1=0
codec_a12@sip_acc_1=0

If I enter anything else other than my full number including the country code as O2 gave to me as username on account_name@sip_acc_1, I am getting 401 (not authorized) and if enter my full number on it (account_name@sip_acc_1=493040700000), I am getting 403.

I tried all possible combinations but it is not establishing the connection. I don't know how to see the requests going out. Anyone know which module that I should look for? I installed Zoiper on my laptop and it has connected to the O2 without any problems and I can make calls via my laptop.

PS: I have an EasyBox 904 xDSL, it is keep rebooting after I flashed a wrong image. I tried to with the original image from vodafone with no success. Can anyone tell me if I can rescue this box? If not, I am happy to donate this to anyone if they can use it in any way. I will post with in Germany. I need the charger though. 15V 2A pretty generic.

Many Thanks
Anton

(Last edited by antonmdavid on 9 Jun 2017, 10:02)

Hi,
I do not understand the switches:
Is switch0 (vrx288) port 0 ---connected---> switch1 (rtl8367RB)
and the other ports on vrx288 for WAN (4) and WLAN (5) ?

What is the meaning of FID.

I want to separate port 3 (if numbered from 0-3 or the 4th yellow port of my device) of my switch for a second network.
like this:

config switch_vlan
        option device 'switch1'
        option vlan '6'
        option ports '3 6t'
        
config device 'p4lan_dev'              
        option name 'eth0.6'      
        option macaddr '9c:80:df:91:c9:47'
        
config interface 'p4lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.42.1'
        option delegate '0'
        list ifname 'eth0.6'
        

but this wont work, why ?

Plonk34 wrote:

Hi,
I do not understand the switches:
Is switch0 (vrx288) port 0 ---connected---> switch1 (rtl8367RB)
and the other ports on vrx288 for WAN (4) and WLAN (5) ?

What is the meaning of FID.

I want to separate port 3 (if numbered from 0-3 or the 4th yellow port of my device) of my switch for a second network.
like this:

config switch_vlan
        option device 'switch1'
        option vlan '6'
        option ports '3 6t'
        
config device 'p4lan_dev'              
        option name 'eth0.6'      
        option macaddr '9c:80:df:91:c9:47'
        
config interface 'p4lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.42.1'
        option delegate '0'
        list ifname 'eth0.6'
        

but this wont work, why ?

Your config looks good. I made a test and you only missed to setup the lantiq switch.

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option vid '6'
        option fid '6'
        option ports '0t 6t'

With your config, the traffic is "routed" through the switches to the cpu port. Means, you can see dns requests and other broadcasts coming from the connected client on port 3. But the traffic isn't "routed" back. Therefore you need to  prepare the lantiq switch to tag the packets on port 0 on vlan 6 packets. At least in my temporary setup this seems to work as expected.

(Last edited by QAuge on 12 Jun 2017, 12:27)

@ QAuge
Thanks it works.
But what is the meaning of FID ?



I migrade from the O2-Box 6431 to Easybox 904xDSL the reason is i was hoping that i can increase the speed from vdsl<-->eth<-->PC.
But the EB904x is slower than the O2Box.
My problem is that i use montly a new openwrt feature like openvpn, a new VLAN or a new Asterisk application.
I have a 100Mbit VDLS line and the Provider FritzBox 7360 with the same Lantiq Chipset it get speeds like 90-95Mbit (my old PC have only 100Mbit Ethernet adapter).
My O2-Box with a LEDE-no-SMP-firmware gets speeds like:
90-95Mbit in Bridge mode as modem and
80-85Mbit as an normal VDSL-telephon-router.
After i get a lot of ideas what i can do with LEDE i get speeds like: 60-70Mbit
(looking at the webinterface cost 10Mbit)

I was thinking that the reason for low speed are the missed extra chipset of the O2-Box 6431 and the low connection to the Lantiq switch.
The O2Box use the Lantiq switch only with 4 x 100Mbit.

I was hooping that a VR9 router that have a GBit switch and littlebit more RAM like FB-7360 to get the same speed like FB-7360 or min more than 80Mbit.
But it does not, the EB904x get speeds like 50-60Mbit
(For testing i used the modem-firmware from the same FB-7360 model.)

My question is:
Can somebody telling about VDSL-speed on the EB904x or other vr9 devices ?
Why is the FB-7360 so fast ?



The next problem that i have is that only the Telefon U TAE connector are working not the F connector
/etc/asterisk/lantiq.conf:

[interfaces]
channels = 2
per_channel_context = on

[general]
rxgain = 1
txgain = 3
echocancel = nfees
echocancelnlp = on

but i fear it is an electrical problem can everybody confirm that both lines general working ?



Is there a possibility to shut of the screen ?
the Red stripe can be disable via:

echo 1 > /sys/devices/platform/gpio-leds/leds/VGV952CJW33:red:power/brightness

@antonmdavid
Did you have an opened Original FW on the EB-904xDSL or did you use the new QAuge-LEDE Firmware ?
On the last case you have to configure Asterisk.

@Plonk34
I have two EasyBox 904xDSL.
With the first one I put the new Firmware (now I can't remember which one)  and that made that box to restart all the time - I couldn't use it at all.
So bought another box and followed the steps as described here github.com/majuss/easybox904. My 2nd EB904 didn't have any issues worked perfectly. I did the same thing to the first box but it didn't fix the restart problem.

Anyway I am not too much worried about my 1st EasyBox as my 2nd one is doing just fine. If I can fix it I can use it for something else or I am happy to donate to someone if they can make any use of it.


My pressing point is O2 SIP phone connection. I have another line and I am wasting my money on that line. If I can make this O2 sip connection to work I can rid off the 1st connection.

Do you know the correct CCFG_CLI settings for the O2 sip connection?

Please see my original post 309 (forum.openwrt.org/viewtopic.php?pid=360037#p360037) for my current settings.

Many Thanks
Anton

(Last edited by antonmdavid on 14 Jun 2017, 10:40)

Plonk34 wrote:

@ QAuge
Thanks it works.
But what is the meaning of FID ?

I can't explain that in detail. It has to do with the MAC addresses of specific VLANs.
Means, the switch stores the assignment for MAC<->VLAN.
On the current setup I learned that without setting a different FID to the different VLANs
it isn't possible to bridge the different VLAN interfaces together: It results in the same behavior as described in
https://dev.openwrt.org/ticket/8701 : The switch doesn't send packets back to the correct "VLAN" port.

Plonk34 wrote:

My question is:
Can somebody telling about VDSL-speed on the EB904x or other vr9 devices ?
Why is the FB-7360 so fast ?

I tested the box temporary on my 50MBit VDSL.
It reports a line capacity of ~85MBit while the FritzBox 7390 reports only ~75MBit.
Both connects with 50MBit.

Plonk34 wrote:

Is there a possibility to shut of the screen ?
the Red stripe can be disable via:

echo 1 > /sys/devices/platform/gpio-leds/leds/VGV952CJW33:red:power/brightness

It can also disabled via the LuCi web gui, isn't it?

Don't you use the latest image, or at least the one I have posted?
There a lcdcontroller is started, which runs lcd4linux. After some idle time it switches of the display
and later it closed lcd4linux to save cpu power. It is reactivated on touch events.
Have a look at controller.lua.
To switch off the display:

echo '1' >>/sys/class/backlight/fb_ili9341_eb904/bl_power
QAuge wrote:

Should I push a current snapshot ?

First of all, thanks for detailed information!

Yes, current snapshot would be nice, your .config for build system would be nice to have too (I never used OpenWRT/LeDe buildsystem before).

(Last edited by kitor on 15 Jun 2017, 15:17)

@QAuge

Hi,
Do you know how to debug the SIP calls? I am keep getting 403 and trying to find the cause.

Thank you very much for your time.

Regards
Anton

kitor wrote:
QAuge wrote:

Should I push a current snapshot ?

First of all, thanks for detailed information!

Yes, current snapshot would be nice, your .config for build system would be nice to have too (I never used OpenWRT/LeDe buildsystem before).

Here you go:
lede-lantiq-xrx200-VGV952CJW33-E-IR-ubifs-sysupgrade.bin

  • WLAN (LuCi doesn't work the right way)

  • GCC 6.3

  • Package updates 16.06.2017

The used configuration is part of the repository:
vr9_default.config
Just rename it to .config. Have a look at Post 254
To update the repo, don't do a git pull. Perform a

updateGitRepo.sh

.

(Last edited by QAuge on 16 Jun 2017, 21:33)

Thank you again!
After a bit of struggling, I got my 904 xDSL working. I'll try to find some time and update wiki next week.

One more question, CPU has two cores, I noticed in post #271, chipmunk mentioned that:

chipmunk wrote:

I dont need the FSX ports/asterisk. Thats why i enabled SMP again to have a dual core router. :-)

I don't need this either, so I'm going to compile SMP firmware but I wonder whats's the problem with running those ports and SMP?

kitor wrote:

After a bit of struggling, I got my 904 xDSL working. I'll try to find some time and update wiki next week.

That would be really nice. People, which doesn't follow this thread from the beginning might overlook some detail.

kitor wrote:

One more question, CPU has two cores, I noticed in post #271, chipmunk mentioned that:

chipmunk wrote:

I dont need the FSX ports/asterisk. Thats why i enabled SMP again to have a dual core router. :-)

I don't need this either, so I'm going to compile SMP firmware but I wonder whats's the problem with running those ports and SMP?

The wiki has some details about this: Lantiq SoCs/Multithreading
If you want to enable both cores and disable the voip core, then remove the

nosmp

flag.
Latest patches then disables the vpe core on the state of this flag.
Have a look at this commit: lantiq: vr9 fxs support: fixed check of SMP state within vpe-mt.c .
Note, its hard to follow my repository since I use the rebase functionality for applying my patches.
I added a script which performs the update process: updateGitRepo.sh

@QAuge - I combined and a bit updated info from your previous posts. Can you check it before I'll post this to Wiki?
https://pastebin.com/jKPneirr

And about nosmp - i see that it's added in built-in command line and uboot bootargs are ignored there (i always thought they should be appended to built-in one). So the only way to remove it will be by recompiling image, right?

(Last edited by kitor on 21 Jun 2017, 21:31)

@Plonk34
Okay I managed to recover my 1st EasyBox and loaded a new image as QAuge described.

@QAuge
Thanks for the clear instructions to recover my bricked box.

Now I have 2 working boxes smile

Anyway as my original problem remains the same, configuring SIP account sad. I can see the configuration file in /etc/asterisk/sip.conf but I am kind of lost where to configure the ADSL/VDSL. Pardon my ignorance, can you please let me know where the adsl configurations are. Am I missing something? I don't really wanted bridge my two easyboxes in order to use the phone, I am pretty certain I am missing the obvious.

Thanks in advance for the help
Anton

PS: BTW I already checked the web interface and I couldn't see anywhere to configure the adsl connection.

(Last edited by antonmdavid on 22 Jun 2017, 09:17)

kitor wrote:

@QAuge - I combined and a bit updated info from your previous posts. Can you check it before I'll post this to Wiki?
https://pastebin.com/jKPneirr

Thanks! Really helpful. I added some minor things about uboot.
https://pastebin.com/6HjGhdpX

kitor wrote:

And about nosmp - i see that it's added in built-in command line and uboot bootargs are ignored there (i always thought they should be appended to built-in one). So the only way to remove it will be by recompiling image, right?

Yes, currently this is the case. I don't know if it makes sense to release a smp image without asterisk. A build controller would be nice for that wink
Anyway, in case you want switch via boot loader, you have to modify the kernel configuration CONFIG_MIPS_CMDLINE_FROM_BOOTLOADER.
If you don't need to switch via boot loader, just modify the cmd line at the dts and recompile.

First:
On this place i say Thank You to @QAuge and all others that working on this device.
Your LEDE-branch run very well since serveral weeks.
In the moment the FW root-directory loads from USB-stick, the VDSL-Modem is connected, Telephonie via POTS and 5G wlan works well.

I was looking for ISDN sources, but i can not find any source for the stollman.ko
(I think too that the stollman.ko are responsible for ISDN because the company make some ISDN solutions)
but it looks like that there is a Lantiq drv_isdn.ko missed too.
Do everywhere now where the original drv_tapi come from (now it is hosted on the Openwrt sources)
Possible exist on the same place the drv_isdn.
But i have no idea about ISDN (i use old rotary phones) and i have too learn the rudiments first.


An other question what is the meaning of WPS Information: ... is a WPS key activ ?
(my Smartphone say no)

iwpriv wl000 stat get
wl000     stat:
Tx success                      = 84956
Tx retry count                                  = 5520
Tx fail to Rcv ACK after retry  = 17
RTS Success Rcv CTS             = 0
RTS Fail Rcv CTS                = 0
Rx success                      = 95249
Rx with CRC                     = 12929
Rx drop due to out of resource  = 0
Rx duplicate frame              = 45
False CCA (one second)          = 0
RSSI-A                          = -82
RSSI-B (if available)           = -88
RSSI-C (if available)           = -84

WPS Information:
Enrollee PinCode(ra0)           95542522
Enrollee PinCode(ra1)           95542522

Enrollee PinCode(ApCli0)        95542522
Ap Client WPS Profile Count     = 0

Sorry, posts 326 to 325 are missing from our archive.