Topic: Dragino Yun shield with 3G dongle

Hello,
I am looking for some help and I hope here is an appropriate place.
I try to reproduce the setup Yun + dongle 3G to get internet connexion.
I found some tutorial and also video from Dragino :
youtube.com/watch?v=4XK92dmV5Ug

Problem is there is no internet connexion. Here is some log :

root@dragino-16200c:~# dmesg
[    0.000000] Linux version 3.3.8 (dragino@iZ28vl6w7rcZ) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #2 Tue Nov 24 15:51:41 CST 2015
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00004000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00004000
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 80383600, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16256 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  board=Yun console=ttyATH0,250000 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14656k(rootfs),1280k(kernel),64k(nvram),64k(art),15936k@0x50000(firmware) rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 60936k/65536k available (2565k kernel code, 4600k reserved, 649k data, 180k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.090000] gpiochip_add: registered GPIOs 0 to 29 on device: ath79
[    0.100000] MIPS: machine is Arduino Yun
[    0.540000] Setting DogStick2 GPIO
[    0.560000] bio: create slab <bio-0> at 0
[    0.570000] SCSI subsystem initialized
[    0.570000] usbcore: registered new interface driver usbfs
[    0.570000] usbcore: registered new interface driver hub
[    0.580000] usbcore: registered new device driver usb
[    0.580000] Switching to clocksource MIPS
[    0.590000] NET: Registered protocol family 2
[    0.590000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.600000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.600000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.610000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.620000] TCP reno registered
[    0.620000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.630000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.630000] NET: Registered protocol family 1
[    0.660000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.660000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.670000] msgmni has been set to 119
[    0.670000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
[    0.680000] io scheduler noop registered
[    0.680000] io scheduler deadline registered (default)
[    0.690000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.700000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
[    0.710000] console [ttyATH0] enabled, bootconsole disabled
[    0.720000] m25p80 spi0.0: found w25q128, expected m25p80
[    0.720000] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.720000] 7 cmdlinepart partitions found on MTD device spi0.0
[    0.720000] Creating 7 MTD partitions on "spi0.0":
[    0.730000] 0x000000000000-0x000000040000 : "u-boot"
[    0.730000] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.730000] 0x000000050000-0x000000ea0000 : "rootfs"
[    0.740000] mtd: partition "rootfs" set to be root filesystem
[    0.740000] mtd: partition "rootfs_data" created automatically, ofs=910000, len=590000
[    0.740000] 0x000000910000-0x000000ea0000 : "rootfs_data"
[    0.750000] 0x000000ea0000-0x000000fe0000 : "kernel"
[    0.750000] 0x000000fe0000-0x000000ff0000 : "nvram"
[    0.750000] 0x000000ff0000-0x000001000000 : "art"
[    0.760000] 0x000000050000-0x000000fe0000 : "firmware"
[    0.780000] ag71xx_mdio: probed
[    0.780000] eth0: Atheros AG71xx at 0xba000000, irq 5
[    1.340000] eth0: Found an AR7240/AR9330 built-in switch
[    2.370000] eth1: Atheros AG71xx at 0xb9000000, irq 4
[    2.920000] ag71xx ag71xx.0: eth1: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[    2.920000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    2.920000] ehci-platform ehci-platform: Generic Platform EHCI Controller
[    2.930000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    2.960000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    2.980000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    2.980000] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    2.980000] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.980000] usb usb1: Product: Generic Platform EHCI Controller
[    2.990000] usb usb1: Manufacturer: Linux 3.3.8 ehci_hcd
[    2.990000] usb usb1: SerialNumber: ehci-platform
[    2.990000] hub 1-0:1.0: USB hub found
[    2.990000] hub 1-0:1.0: 1 port detected
[    3.000000] Initializing USB Mass Storage driver...
[    3.000000] usbcore: registered new interface driver usb-storage
[    3.000000] USB Mass Storage support registered.
[    3.000000] input: gpio-keys-polled as /devices/platform/gpio-keys-polled/input/input0
[    3.010000] sdhci: Secure Digital Host Controller Interface driver
[    3.010000] sdhci: Copyright(c) Pierre Ossman
[    3.010000] usbcore: registered new interface driver ushc
[    3.010000] TCP cubic registered
[    3.020000] NET: Registered protocol family 17
[    3.020000] Bridge firewalling registered
[    3.020000] 8021q: 802.1Q VLAN Support v1.8
[    3.030000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    3.030000] Freeing unused kernel memory: 180k freed
[    3.340000] usb 1-1: new full-speed USB device number 2 using ehci-platform
[    3.730000] usb 1-1: New USB device found, idVendor=12d1, idProduct=1001
[    3.730000] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.740000] usb 1-1: Product:  HSDPA USB Modem
[    3.740000] usb 1-1: Manufacturer:  HSDPA USB Modem
[    3.740000] usb 1-1: SerialNumber: Data Interface
[    3.990000] scsi4 : usb-storage 1-1:1.4
[    5.000000] scsi 4:0:0:0: CD-ROM            HSDPA    CDROM Storage    2.31 PQ: 0 ANSI: 2
[    5.050000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
[    5.090000] scsi 4:0:0:1: Direct-Access     HSDPA    MMC Storage      2.31 PQ: 0 ANSI: 2
[    6.280000] Registered led device: ds:green:usb
[    6.280000] Registered led device: ds:green:wlan
[    6.750000] eth0: link up (1000Mbps/Full duplex)
[    9.600000] JFFS2 notice: (540) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 12 of xref (0 dead, 2 orphan) found.
[   10.770000] sd 4:0:0:1: [sda] Attached SCSI removable disk
[   31.270000] eth0: link down
[   38.370000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[   38.370000] Backport generated by backports.git backports-20140320-37-g5c33da0
[   38.540000] cfg80211: Calling CRDA to update world regulatory domain
[   38.540000] cfg80211: World regulatory domain updated:
[   38.550000] cfg80211:  DFS Master region: unset
[   38.550000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   38.550000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   38.560000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   38.560000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   38.560000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   38.570000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   38.570000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   39.480000] ath: EEPROM regdomain: 0x0
[   39.490000] ath: EEPROM indicates default country code should be used
[   39.490000] ath: doing EEPROM country->regdmn map search
[   39.490000] ath: country maps to regdmn code: 0x3a
[   39.490000] ath: Country alpha2 being used: US
[   39.490000] ath: Regpair used: 0x3a
[   39.500000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   39.500000] Registered led device: ath9k-phy0
[   39.500000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[   39.510000] cfg80211: Calling CRDA for country: US
[   39.510000] cfg80211: Regulatory domain changed to country: US
[   39.510000] cfg80211:  DFS Master region: FCC
[   39.510000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   39.520000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   39.520000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[   39.520000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[   39.530000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   39.530000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   39.960000] NTFS driver 2.1.30 [Flags: R/O MODULE].
[   40.000000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
[   40.020000] loop: module loaded
[   40.160000] PPP generic driver version 2.4.2
[   40.220000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   40.350000] NET: Registered protocol family 24
[   40.380000] nf_conntrack version 0.5.0 (954 buckets, 3816 max)
[   40.840000] i2c /dev entries driver
[   40.890000] usbcore: registered new interface driver usbserial
[   40.890000] USB Serial support registered for generic
[   40.900000] usbcore: registered new interface driver usbserial_generic
[   40.900000] usbserial: USB Serial Driver core
[   40.930000] Linux video capture interface: v2.00
[   40.990000] USB Serial support registered for GSM modem (1-port)
[   41.000000] option 1-1:1.0: GSM modem (1-port) converter detected
[   41.000000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[   41.000000] option 1-1:1.1: GSM modem (1-port) converter detected
[   41.000000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[   41.010000] option 1-1:1.2: GSM modem (1-port) converter detected
[   41.010000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[   41.010000] option 1-1:1.3: GSM modem (1-port) converter detected
[   41.020000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3
[   41.020000] usbcore: registered new interface driver option
[   41.020000] option: v0.7.2:USB Driver for GSM modems
[   41.140000] fuse init (API version 7.18)
[   48.440000] eth0: link up (1000Mbps/Full duplex)
root@dragino-16200c:~# logread
Apr 21 09:39:35 dragino-16200c user.info sysinit: setting up led wlan
Apr 21 09:39:35 dragino-16200c kern.notice usb-modeswitch: 1-1:1.2: Switching seemingly failed
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: Registering new address record for 172.31.255.254 on eth0.IPv4.
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: Withdrawing address record for 172.31.255.254 on eth0.
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: Registering new address record for 172.31.255.254 on eth0.IPv4.
Apr 21 09:39:35 dragino-16200c user.info sysinit: sh: write error: Device or resource busy
Apr 21 09:39:35 dragino-16200c user.info sysinit: /etc/rc.common: line 85: can't create /sys/class/gpio/gpio24/direction: nonexistent directory
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: Got SIGTERM, quitting.
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.240.1.
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.1.45.
Apr 21 09:39:35 dragino-16200c daemon.info avahi-daemon[1301]: avahi-daemon 0.6.31 exiting.
Apr 21 09:39:36 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Manufacturer=_HSDPA_USB_Modem Product=_HSDPA_USB_Modem Serial=Data_Interface
Apr 21 09:39:36 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Selecting /etc/usb_modeswitch.d/12d1:1001 for mode switching
Apr 21 09:39:36 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Found user 'nobody' (UID 65534) and group 'nogroup' (GID 65534).
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Successfully dropped root privileges.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: avahi-daemon 0.6.31 starting up.
Apr 21 09:39:36 dragino-16200c daemon.warn avahi-daemon[1357]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Loading service file /etc/avahi/services/arduino.service.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Loading service file /etc/avahi/services/ssh.service.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.240.1.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: New relevant interface wlan0.IPv4 for mDNS.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Joining mDNS multicast group on interface eth0.IPv4 with address 172.31.255.254.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: New relevant interface eth0.IPv4 for mDNS.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Network interface enumeration completed.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Registering new address record for 192.168.240.1 on wlan0.IPv4.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Registering new address record for 172.31.255.254 on eth0.IPv4.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Registering new address record for 192.168.1.45 on eth0.IPv4.
Apr 21 09:39:36 dragino-16200c daemon.info avahi-daemon[1357]: Registering HINFO record with values 'MIPS'/'LINUX'.
Apr 21 09:39:37 dragino-16200c daemon.info avahi-daemon[1357]: Server startup complete. Host name is dragino-16200c.local. Local service cookie is 2836814565.
Apr 21 09:39:37 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:39:37 dragino-16200c kern.notice syslog: reset mcu
Apr 21 09:39:37 dragino-16200c daemon.info avahi-daemon[1357]: Service "Secure Shell on dragino-16200c" (/etc/avahi/services/ssh.service) successfully established.
Apr 21 09:39:37 dragino-16200c daemon.info avahi-daemon[1357]: Service "dragino-16200c" (/etc/avahi/services/arduino.service) successfully established.
Apr 21 09:39:38 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:39:39 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:39:40 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:39:41 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:41:03 dragino-16200c kern.notice usb-modeswitch: 1-1:1.3: Switching seemingly failed
Apr 21 09:41:03 dragino-16200c daemon.info pppd[901]: System time change detected.
Apr 21 09:41:04 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Manufacturer=_HSDPA_USB_Modem Product=_HSDPA_USB_Modem Serial=Data_Interface
Apr 21 09:41:05 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Selecting /etc/usb_modeswitch.d/12d1:1001 for mode switching
Apr 21 09:41:05 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:06 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:07 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:08 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:09 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:10 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:11 dragino-16200c kern.notice usb-modeswitch: 1-1:1.4: Switching seemingly failed
Apr 21 09:41:15 dragino-16200c daemon.info hostapd: wlan0: STA 00:22:5f:83:49:ee IEEE 802.11: authenticated
Apr 21 09:41:15 dragino-16200c daemon.info hostapd: wlan0: STA 00:22:5f:83:49:ee IEEE 802.11: associated (aid 1)
Apr 21 09:41:16 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPREQUEST(wlan0) 192.168.1.35 00:22:5f:83:49:ee
Apr 21 09:41:16 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPNAK(wlan0) 192.168.1.35 00:22:5f:83:49:ee wrong network
Apr 21 09:41:20 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPDISCOVER(wlan0) 00:22:5f:83:49:ee
Apr 21 09:41:20 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPOFFER(wlan0) 192.168.240.118 00:22:5f:83:49:ee
Apr 21 09:41:20 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPREQUEST(wlan0) 192.168.240.118 00:22:5f:83:49:ee
Apr 21 09:41:20 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPACK(wlan0) 192.168.240.118 00:22:5f:83:49:ee ELEC-VOSTRO
Apr 21 09:41:22 dragino-16200c daemon.info pppd[901]: No response to 5 echo-requests
Apr 21 09:41:22 dragino-16200c daemon.notice pppd[901]: Serial link appears to be disconnected.
Apr 21 09:41:28 dragino-16200c daemon.notice pppd[901]: Connection terminated.
Apr 21 09:41:29 dragino-16200c daemon.notice pppd[901]: Modem hangup
Apr 21 09:41:29 dragino-16200c daemon.info pppd[901]: Exit.
Apr 21 09:41:30 dragino-16200c daemon.notice netifd: Interface 'HSDPAstick' is now down
Apr 21 09:41:32 dragino-16200c daemon.notice netifd: HSDPAstick (2119): Trying to set mode
Apr 21 09:41:32 dragino-16200c daemon.notice netifd: HSDPAstick (2119): Error setting WWAN mode!
Apr 21 09:41:32 dragino-16200c daemon.notice pppd[2135]: pppd 2.4.5 started by root, uid 0
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: abort on (BUSY)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: abort on (NO CARRIER)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: abort on (ERROR)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: report (CONNECT)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: timeout set to 10 seconds
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: send (AT&F^M)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: expect (OK)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: OK
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]:  -- got it
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: send (ATE1^M)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: expect (OK)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: OK
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]:  -- got it
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: send (AT+CGDCONT=1,"IP","mobiledata"^M)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: timeout set to 30 seconds
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: expect (OK)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: OK
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]:  -- got it
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: send (ATD*99***1#^M)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: expect (CONNECT)
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: ^M
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: CONNECT
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]:  -- got it
Apr 21 09:41:34 dragino-16200c local2.info chat[2140]: send ( ^M)
Apr 21 09:41:34 dragino-16200c daemon.info pppd[2135]: Serial connection established.
Apr 21 09:41:34 dragino-16200c daemon.info pppd[2135]: Using interface 3g-HSDPAstick
Apr 21 09:41:34 dragino-16200c daemon.notice pppd[2135]: Connect: 3g-HSDPAstick <--> /dev/ttyUSB0
Apr 21 09:41:37 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPINFORM(wlan0) 192.168.240.118 00:22:5f:83:49:ee
Apr 21 09:41:37 dragino-16200c daemon.info dnsmasq-dhcp[1295]: DHCPACK(wlan0) 192.168.240.118 00:22:5f:83:49:ee ELEC-VOSTRO
Apr 21 09:42:00 dragino-16200c authpriv.info dropbear[2172]: Child connection from 192.168.240.118:50469
Apr 21 09:42:11 dragino-16200c authpriv.notice dropbear[2172]: Password auth succeeded for 'root' from 192.168.240.118:50469
Apr 21 09:42:11 dragino-16200c daemon.notice pppd[2135]: Modem hangup
Apr 21 09:42:11 dragino-16200c daemon.notice pppd[2135]: Connection terminated.
Apr 21 09:42:12 dragino-16200c daemon.info pppd[2135]: Exit.
Apr 21 09:42:12 dragino-16200c daemon.notice netifd: Interface 'HSDPAstick' is now down
Apr 21 09:42:15 dragino-16200c daemon.notice netifd: HSDPAstick (2196): Trying to set mode
Apr 21 09:42:15 dragino-16200c daemon.notice netifd: HSDPAstick (2196): Error setting WWAN mode!
Apr 21 09:42:15 dragino-16200c daemon.notice pppd[2213]: pppd 2.4.5 started by root, uid 0
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: abort on (BUSY)
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: abort on (NO CARRIER)
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: abort on (ERROR)
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: report (CONNECT)
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: timeout set to 10 seconds
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: send (AT&F^M)
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: expect (OK)
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: OK
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]:  -- got it
Apr 21 09:42:16 dragino-16200c local2.info chat[2217]: send (ATE1^M)
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: expect (OK)
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: OK
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]:  -- got it
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: send (AT+CGDCONT=1,"IP","mobiledata"^M)
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: timeout set to 30 seconds
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: expect (OK)
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: OK
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]:  -- got it
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: send (ATD*99***1#^M)
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: expect (CONNECT)
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: ^M
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: CONNECT
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]:  -- got it
Apr 21 09:42:17 dragino-16200c local2.info chat[2217]: send ( ^M)
Apr 21 09:42:17 dragino-16200c daemon.info pppd[2213]: Serial connection established.
Apr 21 09:42:17 dragino-16200c daemon.info pppd[2213]: Using interface 3g-HSDPAstick
Apr 21 09:42:17 dragino-16200c daemon.notice pppd[2213]: Connect: 3g-HSDPAstick <--> /dev/ttyUSB0
Apr 21 09:42:40 dragino-16200c authpriv.info dropbear[2248]: Child connection from 192.168.240.118:50479
Apr 21 09:42:49 dragino-16200c authpriv.info dropbear[2248]: Exit before auth: Disconnect received
Apr 21 09:42:53 dragino-16200c authpriv.info dropbear[2256]: Child connection from 192.168.240.118:50486
Apr 21 09:42:54 dragino-16200c daemon.notice pppd[2213]: Modem hangup
Apr 21 09:42:54 dragino-16200c daemon.notice pppd[2213]: Connection terminated.
Apr 21 09:42:55 dragino-16200c daemon.info pppd[2213]: Exit.
Apr 21 09:42:55 dragino-16200c daemon.notice netifd: Interface 'HSDPAstick' is now down
Apr 21 09:42:58 dragino-16200c daemon.notice netifd: HSDPAstick (2269): Trying to set mode
Apr 21 09:42:58 dragino-16200c daemon.notice netifd: HSDPAstick (2269): Error setting WWAN mode!
Apr 21 09:42:58 dragino-16200c daemon.notice pppd[2286]: pppd 2.4.5 started by root, uid 0
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: abort on (BUSY)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: abort on (NO CARRIER)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: abort on (ERROR)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: report (CONNECT)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: timeout set to 10 seconds
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: send (AT&F^M)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: expect (OK)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: OK
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]:  -- got it
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: send (ATE1^M)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: expect (OK)
Apr 21 09:42:59 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: OK
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]:  -- got it
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: send (AT+CGDCONT=1,"IP","mobiledata"^M)
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: timeout set to 30 seconds
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: expect (OK)
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: OK
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]:  -- got it
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: send (ATD*99***1#^M)
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: expect (CONNECT)
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: ^M
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: CONNECT
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]:  -- got it
Apr 21 09:43:00 dragino-16200c local2.info chat[2291]: send ( ^M)
Apr 21 09:43:00 dragino-16200c daemon.info pppd[2286]: Serial connection established.
Apr 21 09:43:00 dragino-16200c daemon.info pppd[2286]: Using interface 3g-HSDPAstick
Apr 21 09:43:00 dragino-16200c daemon.notice pppd[2286]: Connect: 3g-HSDPAstick <--> /dev/ttyUSB0
Apr 21 09:43:00 dragino-16200c authpriv.notice dropbear[2256]: Password auth succeeded for 'root' from 192.168.240.118:50486
root@dragino-16200c:~# logread -f
Apr 21 09:43:37 dragino-16200c daemon.notice pppd[2286]: Modem hangup
Apr 21 09:43:37 dragino-16200c daemon.notice pppd[2286]: Connection terminated.
Apr 21 09:43:38 dragino-16200c daemon.info pppd[2286]: Exit.
Apr 21 09:43:38 dragino-16200c daemon.notice netifd: Interface 'HSDPAstick' is now down
Apr 21 09:43:40 dragino-16200c daemon.notice netifd: HSDPAstick (2350): Trying to set mode
Apr 21 09:43:41 dragino-16200c daemon.notice netifd: HSDPAstick (2350): Error setting WWAN mode!
Apr 21 09:43:41 dragino-16200c daemon.notice pppd[2366]: pppd 2.4.5 started by root, uid 0
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: abort on (BUSY)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: abort on (NO CARRIER)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: abort on (ERROR)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: report (CONNECT)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: timeout set to 10 seconds
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: send (AT&F^M)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: expect (OK)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: OK
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]:  -- got it
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: send (ATE1^M)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: expect (OK)
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: OK
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]:  -- got it
Apr 21 09:43:42 dragino-16200c local2.info chat[2371]: send (AT+CGDCONT=1,"IP","mobiledata"^M)
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: timeout set to 30 seconds
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: expect (OK)
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: OK
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]:  -- got it
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: send (ATD*99***1#^M)
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: expect (CONNECT)
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: ^M
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: CONNECT
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]:  -- got it
Apr 21 09:43:43 dragino-16200c local2.info chat[2371]: send ( ^M)
Apr 21 09:43:43 dragino-16200c daemon.info pppd[2366]: Serial connection established.
Apr 21 09:43:43 dragino-16200c daemon.info pppd[2366]: Using interface 3g-HSDPAstick
Apr 21 09:43:43 dragino-16200c daemon.notice pppd[2366]: Connect: 3g-HSDPAstick <--> /dev/ttyUSB0

Is the following trace relevant ?

Apr 21 09:43:40 dragino-16200c daemon.notice netifd: HSDPAstick (2350): Trying to set mode
Apr 21 09:43:41 dragino-16200c daemon.notice netifd: HSDPAstick (2350): Error setting WWAN mode!

Should I change of Yun or of dongle ?
Thanks and regards,
Vincent

Re: Dragino Yun shield with 3G dongle

These messages seem to indicate that you are managing to get a connection:

Apr 21 09:42:17 dragino-16200c daemon.info pppd[2213]: Serial connection established.

However, it does not last long:

Apr 21 09:42:54 dragino-16200c daemon.notice pppd[2213]: Modem hangup
Apr 21 09:42:54 dragino-16200c daemon.notice pppd[2213]: Connection terminated.

I would enable debugging on PPPD and try again.

Re: Dragino Yun shield with 3G dongle

I added "debug" in /etc/ppp/options and this add lot of traces. I am still looking for a problem in it... pastebin.com/4SiM5Wpk

Re: Dragino Yun shield with 3G dongle

Looks like your client and the server are fighting back and forth about the configuration... please, post your config files here.

Re: Dragino Yun shield with 3G dongle

root@dragino-16200c:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.240.1'
        option netmask '255.255.255.0'
        option hostname 'dragino-16200c'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option metric '10'
        option hostname 'dragino-16200c'

config interface 'wan1'
        option ifname 'eth1'
        option proto 'dhcp'
        option metric '10'
        option hostname 'dragino-16200c'

config interface 'HSDPAstick'
        option proto '3g'
        option device '/dev/ttyUSB0'
        option service 'umts_only'
        option apn 'mobiledata'
root@dragino-16200c:~# cat /etc/chatscripts/3g.chat
ABORT   BUSY
ABORT   'NO CARRIER'
ABORT   ERROR
REPORT  CONNECT
TIMEOUT 10
""      "AT&F"
OK      "ATE1"
OK      'AT+CGDCONT=1,"IP","$USE_APN"'
SAY     "Calling UMTS/GPRS"
TIMEOUT 30
OK      "ATD*99***1#"
CONNECT ' '
root@dragino-16200c:~#
root@dragino-16200c:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem
root@dragino-16200c:~# uname -a
Linux dragino-16200c 3.3.8 #2 Tue Nov 24 15:51:41 CST 2015 mips GNU/Linux

Re: Dragino Yun shield with 3G dongle

Try adding this option:

option 'pppd_options' 'noipdefault'

7 (edited by vincenet 2017-04-24 10:09:13)

Re: Dragino Yun shield with 3G dongle

I tried without success and I think this option was already enabled :

root@dragino-16200c:~# cat /etc/ppp/options
debug
logfile /dev/null
noipdefault
noaccomp
nopcomp
nocrtscts
lock
maxfail 0
lcp-echo-failure 5
lcp-echo-interval 1

Do you see here something to change ?

Otherwise, can it be an issue related to poor 3g/2g link ? I could try in better place or buy an other 3g dongle.

Re: Dragino Yun shield with 3G dongle

I would not say it is a case of bad reception, as the client and server keep exchanging messages. There are some messages about not being able to authenticate (sorry, I cannot see the logs right now), I would explore that path now (however, there are further messages stating that an authentication was successful). Try to guess what authentication methods are supported by the server, and play with the "refuse-" / "require-" parameters.