OpenWrt Forum Archive

Topic: SSH no internet access... help!

The content of this topic has been archived on 24 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

(So for the longest time I've put off a problem)
I've configured my owrt tplink archer c7 v2 a year ago and never addressed the problem is until now...


I can access the internet via wifi and wired... however when I ssh into my device, i have no internet access from the session...
I try pinging http://www.google.com

ping: bad address 'google.com' 

I think it's a dns issue (or a incorrect attempt to bridge wan)


I hope you guys can help!
cheers!

(Last edited by opensircut on 21 Mar 2017, 03:55)

Yes, that looks like a DNS problem, but it's quite rare that your devices are not affected.
Please post your network and dhcp config files here.

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5c:6e41:1043::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ip6assign '60'
        option _orig_ifname 'eth1 radio0.network1 wlan1-1'
        option _orig_bridge 'true'
        option ipaddr '10.0.0.9'
        option netmask '255.0.0.0'
        option ifname 'br-wan eth0 eth0.3 eth1'
        option dns '8.8.8.8'

config interface 'wan'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option ifname 'eth0'
        option type 'bridge'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option mirror_source_port '0'
        option mirror_monitor_port '0'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6'        
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '3t'

It is strange config concerning DNS, which DNS is obtained in WAN (cat /tmp/resolv.conf.auto)?

Still not clear how to tackle it down?

What, don't understand?

Do not configure the 8.8.8.8 server on the LAN network but on dnsmask.

Yes, it is exactly the strangeness.

uci add_list dhcp.lan.dhcp_option='6,8.8.8.8,8.8.4.4'

The lan network should only be eth1 and the wifi AP (you should set that in /etc/config/wireless.)

eth0 is usually only for connecting to the modem, on the wan network, which need not be a bridge. 
The default switch setting is
VLAN 1 = ports 0 (eth1), 2,3,4,5
VLAN 2 = ports 6 (eth0), 1
This makes it like eth0 is a dedicated connection to the "WAN" port (1) on the back.  The VLANning is invisible to the user since packets are not tagged on either side.

What are you trying to do with VLAN 3?  It's not doing anything the way it is configured.

Really if you reset to a default configuration and start over, it should Just Work.  Except you may need to change the LAN IP range if the modem gives you 192.168.1.X on the wan.

I should mention that this is behind an xfinity gateway aio from comcast. (these aios are a peice of crap ( and i wanted to create a vpn server and (ssh bittorrent, vpn client) various other services on my router)) (& also I was using luci to configure...)

What i was trying to do was use the wireless as a (client) wan connection for internet and then use the physical wan port as an extra lan port. And also use the 10.x.x.x  for brevity/lazyness.

(Last edited by opensircut on 22 Mar 2017, 02:50)

I remember I had a similar problem when using free proxy servers. When I switched to paid version but has become more stable. Through time, the problem was gone.

Is your router's link to the cable modem by Ethernet, or wireless?  Using wire is generally better.

It looks like the Technicolor modems use 10.0.0.X for the address so you may have a conflict.

(Last edited by mk24 on 22 Mar 2017, 14:52)

OP here
Its wired to the gateway/router/modem/switch all-in-one from my isp. The way it's configured now i can access the nodes across both my openwrt router and the all in one router.
But ssh session has no connection to the internet.

(Last edited by opensircut on 23 Mar 2017, 03:01)

The discussion might have continued from here.