1,551 (edited by hnyman 2017-02-13 10:42:51)

Re: Build for WNDR3700/WNDR3800

LEDE 17.01:  lede1701-r3043-31b0640906-20170130
LEDE 17.01.0-rc1 is being compiled by the buildbot at the moment. This build should match it rather closely.

I am also stopping building for the old CC15.05 branch, as there has been practically no development for ages, not even many package updates.

LEDE 17.01.0-rc2 is being compiled by the buildbot at the moment. This build should match it rather closely.


Re: Build for WNDR3700/WNDR3800

Umm, I seem to have a bit of a problem that I cannot resolve.

I have a wndr3800 which has a copy of Arokh openwrt image that has not been updated in about a year or so. It has laid dormant in a box during that time as part of a move and I am now in the process of resurrecting it. Of course I have no record of what the password was.

  • I can get it to fail-safe mode and telnet into it but I have constant timeouts/retry, until it gives up,  when I try to put a new image with a mode of octet.

  • I can ssh into it but it requests a password (although it is in fail-safe mode), or perhaps a key, and of course I cannot provide either.

  • I can access the login page on the web interface but again I fail without knowledge of the password.

  • I am stumped as I cannot reset the router, it seems, without the old password.

Any suggestions or do I need to give up?

Thanks for any help.

1,553 (edited by hnyman 2017-02-17 15:23:11)

Re: Build for WNDR3700/WNDR3800

MidGe wrote:

I have a wndr3800 ... It has laid dormant ... Of course I have no record of what the password was.

It is very easy to use the Netgear's TFTP recovery mode to flash a new factory image to WNDR3800 and 3700v1 and 3700v2. I have used that a dozen of times during the last 6 years. I usually uses TFTP2 GUI client.

Wiki instructions for the Netgear recovery mode are quite accurate:
https://wiki.openwrt.org/toh/netgear/wn … lsafe_mode

Note that this TFTP recovery mode is separate from Openwrt's own "failsafe mode" and is offered by the original u-boot boot manager by Netgear, so it should be enabled with either an original Netgear firmware, a working Openwrt firmware or a bricked Openwrt firmware.

Note: WNDR3700 may also automatically enter the TFTP recovery mode, if you have flashed a bad firmware image. That is indicated by the power led blinking slowly and steadily, much slower that during a normal Openwrt boot.

For TFTP recovery you need:

*    A TFTP client for your computer. There are both command-line tools and GUI versions available.
*    Your computer must have an IP address from the 192.168.1.x network, as the router failsafe mode defaults to You might need to manually config the address, as some operating systems change the IP to a link-local 196.254.x.x address after a while if there is no DHCP server.
*    A new firmware to flash in. Either an original Netgear firmware or an Openwrt "factory.img" firmware. "Sysupgrade" version will not work.
*    Access to router's reset button

Steps needed in the flashing process:

1    configure and connect PC
2    power on the router
3    press and hold the RESET button as soon as the switch LEDs light up.
4    keep holding RESET until the power LED begins to flash orange and then green.
5    once the power LED is flashing green, release RESET
6    start the TFTP transfer to router at
7    wait a few minutes for the router to complete flash. It should reboot automatically.

Please note that the TFTP transfer is quick, as the file is stored in RAM. However, the flashing process itself will take several minutes, after which the router should reboot automatically.

And Arokh's build may also have a working reset button. Probably resets the router, if you press it over 5 seconds.
(I have removed the time limit from my own build, but 5 seconds is the default). Reset would delete all settings (incl. password) and just leave the defaults provided by Arokh.

The recovery process is found also at Netgear site nowadays:
http://kb.netgear.com/22688/How-to-uplo … using-TFTP


Re: Build for WNDR3700/WNDR3800


Firstly, thank you very much for your very quick reply.

I had read and tried all available documentation already.  I am from the old school that reads the manual first. smile

I did manage to resolve the issue and in so doing I noticed the following.

There are at least three ways to set the router in fail-safe mode. The behavior is different based on what method is used.  I did assume that fail-safe was fail-safe and only tried one method (wait till the power light flash green and then you have two seconds to hot the reset button and that gets you in fail-safe). That method did not work and gave me the issues mentioned in my earlier post. The same happened with hitting and keeping reset pushed in from prior to the power on till it got in fail-safe. That gave me the same problems.  The way out, in my circumstances whatever they were, I don't know exactly what state the router firmware was in, was to hit the reset as soon as the power light first came on after powering on and that finally gave me success with no more timeouts when using tftp.

I hope this note is useful to someone.

Thanks again hnyman as it is your reply that urged me on trying these alternatives.