Topic: OpenWrt on TL-WA860RE

Greetings everyone! Newbie alert! Finally i got hardware which is supported by OpenWrt, got software on it and i got lost a bit. I was trying to configure wireless wan on this, not just as range extender. I can't get it work. Could anyone give me some help about this?

Re: OpenWrt on TL-WA860RE

Have a look to the wiki at https://wiki.openwrt.org/, and see if there is a page related to what you need.

Re: OpenWrt on TL-WA860RE

I read whole beginners tutorial but i still got stuck at creating wifi network. So, i connect to my main router with openwrt device and i have internet only over lan cable. When i create network, device loose connection with main router but then i can see openwrt network with no internet connection.

4 (edited by lujurisic.pt 2017-02-17 11:16:45)

Re: OpenWrt on TL-WA860RE

I'm not so sure about this but i think here's the first problem: one router is already connected to main router over lan and his IP adress is 192.168.1.1. Openwrt device's IP is also 192.168.1.1. Do i have to change this?

I can't understand Network -> Interface
Under Network -> Wifi i have two networks disabled or not associated. Why?
Where should i start? Make wifi network on which will clients connect or connect to the main router first then make network? Also, what does bridging mean?

Re: OpenWrt on TL-WA860RE

lujurisic.pt wrote:

I'm not so sure about this but i think here's the first problem: one router is already connected to main router over lan and his IP adress is 192.168.1.1. Openwrt device's IP is also 192.168.1.1. Do i have to change this?

Yes, definitively.

Re: OpenWrt on TL-WA860RE

Ok i managed the other router so it's adress is now 192.168.2.1 so the 192.168.1.1 is now unused.

I have connected my openwrt device to main router and i have internet connection only over lan cable.
Status of network Openwrt device to main router:
Mode: Client | SSID: lujurisic
BSSID: EC:1D:7F:FB:79:77 | Encryption: WPA2 PSK (CCMP)
Channel: 6 (2.437 GHz) | Tx-Power: 19 dBm
Signal: -61 dBm | Noise: -95 dBm
Bitrate: 86.7 Mbit/s | Country: US

Under general setup here's option called "Network" where i can attach networks to this wireless interface. What is this? i cant find useful information on internet. Please help someone.
Already tried to revert to stock firmware but it says it's unsupported format so i got stuck with this without wifi on my floor. It's quite urgent now..

Re: OpenWrt on TL-WA860RE

Update: i managed to have internet access over access point but speed is poor, ping is way too high and i'm beginning to regret installing openwrt on my device.
I am way too new to linux and advanced wifi properties but willing to learn and i just can't do it myself. Also, everytime i change something in hope to improve speed, i loose link with main router i have to do hard reset. Getting really tired of this. Oh yeah, this stuff made my device refusing to flash oem firmware.
I BEG FOR HELP.