51 (edited by hnyman 2015-04-14 16:07:19)

Re: About "missing" packages in Barrier Breaker and trunk

francus wrote:
hnyman wrote:

your router has "Barrier Breaker", which is not the "trunk" any more. And your version is not even the released Barrier Breaker, as opkg still points to trunk snapshot downloads.

Easiest would be to either update to current trunk or update to released BB14.07.

Many thanks hnyman for your very prompt reply. Is there somewhere a tutorial for the two above steps, particularly the first one that seems simplier?

http://wiki.openwrt.org/doc/howto/generic.sysupgrade

If you have a working Luci http webinterface, easiest is to download the correct firmware from the download repo to your own PC first. And then just select the update from the menu.

If there is only the console, then you probably need to download the firmware via wget.

https://downloads.openwrt.org/

Re: About "missing" packages in Barrier Breaker and trunk

hnyman wrote:

If you have a working Luci http webinterface, easiest is to download the correct firmware from the download repo to your own PC first. And then just select the update from the menu.

https://downloads.openwrt.org/

there are so many options here https://downloads.openwrt.org/barrier_breaker/14.07/
that the chance of me picking the correct one that will not brick my new router is like winning a lottery.

But thanks anyway. I'll try to ask the chinese seller of the router to check if he has an idea, even if I doubt it very much.

Re: About "missing" packages in Barrier Breaker and trunk

And what about mjpg-streamer and BB 17.07 release for BRCM 2708. ?? There are missing in the release .
Is knowing issues?? Kernel usb problrm or what.
Is necessary migrate to AA? What is the thing I must do!  And one more, when I write IMG to SD card openwrt-brcm2708-sdcard-vfat-ext4_128.img, RPI wont  boot . Tsss can I do ever something???
RPI is nice thing and good prize for it is latest wrt release.

Is everybody hear?

Re: About "missing" packages in Barrier Breaker and trunk

This is what the Chineese seller stated:

   

pls change the http link:
    http://downloads.openwrt.org/attitude_a … c/packages
    this link can download opkg

    I replied

Thanks Yang, but are you sure? What is installed in the router is not attitude_adjustment/12.09. It is Barrier Breaker bleeding edge r40698.

He confirmed:

yes
    we had test that ok
    thanks very much!

I am confused!

Re: About "missing" packages in Barrier Breaker and trunk

Hello.

I have seen SEND (RFC3971) in the source codes but not in opkg. I would like to know what package provides SEND.

Thanks!

Re: About "missing" packages in Barrier Breaker and trunk

purifuri maybe i have the same problem with you.How did you add a route for the packets go though gateway ? I am new here hmm

Re: About "missing" packages in Barrier Breaker and trunk

Hello, I couldn't understand very well. So some packages are now out of official tree but on github? How can one find "official" github repos? For example how do I find `util-linux` package? I needed the fallocate binary but can't find a package to contain it.
Also I'd like to know "official" python packages source.

Thank you.

Re: About "missing" packages in Barrier Breaker and trunk

Hello,
there is no any more telnet on new trunk releases.
OK, I am using SSH, but with telnet I finish a lot of work in lan network, remote.
Is it permanent abandon of telnet client in OenWRT?

Re: About "missing" packages in Barrier Breaker and trunk

markom wrote:

there is no any more telnet on new trunk releases.
OK, I am using SSH, but with telnet I finish a lot of work in lan network, remote.
Is it permanent abandon of telnet client in OenWRT?

Looks like the telnet client was disabled at the same time as the server daemon was disabled in Busybox defaults.
https://dev.openwrt.org/changeset/46809

If you need telnet (from busybox), you need to modify busybox settings and re-compile the firmware.

Re: About "missing" packages in Barrier Breaker and trunk

I currently have Chaos Calmer, and i dont understand at all how to install such packages. I want to install hdparm, but because it's not anymore in the repository, I seeked around and found this thread. But now, i dont understand, what i should do.
I dont know how compiling a application myself at all. Has anybody done this yet? Can somebody make maybe a little tutorial?

Re: About "missing" packages in Barrier Breaker and trunk

Edit /etc/opkg.conf and add lines for new repository:

src/gz barrier_breaker_oldpackages https://downloads.openwrt.org/barrier_b … ldpackages

If you don't use ar71xx then change the path...

Re: About "missing" packages in Barrier Breaker and trunk

noobody wrote:

I currently have Chaos Calmer, and i dont understand at all how to install such packages. I want to install hdparm, but because it's not anymore in the repository, I seeked around and found this thread. But now, i dont understand, what i should do.
I dont know how compiling a application myself at all. Has anybody done this yet? Can somebody make maybe a little tutorial?

That's wrong, hdparm is in the repository:
https://github.com/openwrt/packages/tre … ils/hdparm
Example (ar71xx) URL:
https://downloads.openwrt.org/chaos_cal … ar71xx.ipk
You had to break something if it's not available for you.

valentt wrote:

Edit /etc/opkg.conf and add lines for new repository:

src/gz barrier_breaker_oldpackages https://downloads.openwrt.org/barrier_b … ldpackages

It's a pretty bad idea to use 14.07 packages for 15.05 release.

63 (edited by noobody 2015-12-28 09:25:46)

Re: About "missing" packages in Barrier Breaker and trunk

Thanks for your fast answers!

Zajec wrote:

That's wrong, hdparm is in the repository:

Hmm... Could be that I have a wrong configurated openwrt?

root@OpenWrt:~# opkg install hdparm
Unknown package 'hdparm'.
Collected errors:
 * opkg_install_cmd: Cannot install package hdparm.

And that's not all. When I try to install the packages from this (https://wiki.openwrt.org/doc/howto/disk.encryption) instruction, all packages are missing. I am doing anything wrong?
My srcs are 

src/gz chaos_calmer_base http://downloads.openwrt.org/chaos_calmer/15.05/oxnas/generic/packages/base
src/gz chaos_calmer_luci http://downloads.openwrt.org/chaos_calmer/15.05/oxnas/generic/packages/luci
src/gz chaos_calmer_packages http://downloads.openwrt.org/chaos_calmer/15.05/oxnas/generic/packages/packages
src/gz chaos_calmer_routing http://downloads.openwrt.org/chaos_calmer/15.05/oxnas/generic/packages/routing
src/gz chaos_calmer_telephony http://downloads.openwrt.org/chaos_calmer/15.05/oxnas/generic/packages/telephony
src/gz chaos_calmer_management http://downloads.openwrt.org/chaos_calmer/15.05/oxnas/generic/packages/management

and I'm using 15.05 Chaos Calmer. Does it depend on the CPU plattform, on what packages are available?

Re: About "missing" packages in Barrier Breaker and trunk

noobody wrote:

And that's not all. When I try to install the packages ... all packages are missing. I am doing anything wrong?

It sounds like you have not downloaded the actual packages lists... You need to do "opkg update" to get the package lists. Installing packages works only after that.

Re: About "missing" packages in Barrier Breaker and trunk

hnyman wrote:
noobody wrote:

And that's not all. When I try to install the packages ... all packages are missing. I am doing anything wrong?

It sounds like you have not downloaded the actual packages lists... You need to do "opkg update" to get the package lists. Installing packages works only after that.

This is strange, I update my list near everytime

Re: About "missing" packages in Barrier Breaker and trunk

Mine is : BusyBox v1.19.4 (2015-08-28 17:30:02 CST) built-in shell (ash). opkg update failed error message :

root@TuoShi:~# opkg update

-ash: opkg: not found

what am i supposed to do? i wanna use asterisk pbx . please help

Re: About "missing" packages in Barrier Breaker and trunk

It is situated in/openwrt/trunk/xxx and you can utilize it, to make more ... Generally the picture era falls flat with a blunder of a missing bundle

68 (edited by bene7 2016-10-15 18:12:54)

Re: About "missing" packages in Barrier Breaker and trunk

this morning I resetted my router (because I got locked out by my own fault...) and I could opkg update opkg install php5, php-cgi, and other php5-mod's.

But then i got locked out again so i tought: "piece of cake" but now I cannot find the php5 packages anymore (not with Luci, not with PuTTY)

Very strange because I was using my router as a php home server all that time before and I didn't update the OpenWRT version or so.

I still can install luci and zoneinfo-europe but none of the 5 php5* packages i need :-(


details:

Model    TP-Link TL-WR1043N/ND v3
Firmware Version    OpenWrt Designated Driver 49881 / LuCI Master (git-16.288.36935-1e1a706)
Kernel Version    4.4.14


What did I do wrong?
It's strange because I did the same thing and the first 2 times it worked and now suddenly I cannot find the packages anymore:

root@OpenWrt:~# opkg update
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                     /base/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_base.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                        /base/Packages.sig.
Signature check passed.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                       /kernel/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_kernel.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                      /kernel/Packages.sig.
Signature check passed.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                        /telephony/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_telephon                                                                                        y.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                        /telephony/Packages.sig.
Signature check passed.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                       /packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_packages                                                                                        .
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                       /packages/Packages.sig.
Signature check passed.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                        /routing/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_routing.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                       /routing/Packages.sig.
Signature check passed.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                      /luci/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_luci.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                       /luci/Packages.sig.
Signature check passed.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                       /management/Packages.gz.
Updated list of available packages in /var/opkg-lists/designated_driver_manageme                                                                                        nt.
Downloading h ttp://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages                                                                                     /management/Packages.sig.
Signature check passed.
root@OpenWrt:~# opkg install php5
Unknown package 'php5'.
Collected errors:
* opkg_install_cmd: Cannot install package php5.


edit: solved it by removing this line:
option check_signature 1
and adding this line:
src/gz barrier_breaker_oldpackages h ttp://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/oldpackages/

to the file in the router directory /etc/opkg.conf

*note that I deliberately added a "space"  after every "h" of "h ttp" because otherwise i couldn't post this reply because of the 0 allowed links.

69 (edited by bene7 2016-10-16 10:36:38)

Re: About "missing" packages in Barrier Breaker and trunk

edit: removed. Doesn't seem to work
other tread: h ttps://forum.openwrt.org/viewtopic.php?id=68100

Re: About "missing" packages in Barrier Breaker and trunk

bene7 wrote:

this morning I resetted my router (because I got locked out by my own fault...) and I could opkg update opkg install php5, php-cgi, and other php5-mod's.

But then i got locked out again so i tought: "piece of cake" but now I cannot find the php5 packages anymore (not with Luci, not with PuTTY)

Very strange
...

edit: solved it by removing this line:
option check_signature 1
and adding this line:
src/gz barrier_breaker_oldpackages h ttp://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/oldpackages/

Looks like php5 is currently broken for ar71xx in trunk buildbot snapshot compilations: http://buildbot.openwrt.org:8010/broken … es/ar71xx/

That is the reason why you could not find the current DD version of php5.

Seems stragne the the really old BB14.07 version of the package would work with the current DD trunk.