Hello

Looking for some help/advise, my current setup is as follows:

wlan0: mode "ap", network "wan"
wan: ifname "eth0", proto "dhcp", type "bridge"
Basically a straight up bridge between eth0 and wlan0, which is facilitated by the interface "br-wan"

wlan1: mode "ap", network is "lan"
lan: type "bridge"
Standard lan setup, resulting in the interface br-lan, but I have configured iptables masquerades outgoing packets from br-lan and sends them to br-wan (probably will change this at some point as this setup doesn't make sense for what I'm doing, but it works so oh well)

I've just setup a new interface wlan2 in station mode, and this is where I'm looking for some assistance. I'd like to change my setup so instead of having all packets from the wlan interfaces come out on the "wan" interface (eth0) I'd like to use the "wwan" interface (which I'd like to link to wlan2).

So far I've created the interface "wlan2" in the wireless config, set it's mode, provided the ssid and key of the hotspot to connect to, and set the network option to "wwan".  The "wwan" interface has it's proto set to "dhcp", and so far that seems to work, ifconfig shows wlan2 received an IP Address and the device is reachable on the network at that IP Address.

I then tried adding "type 'bridge'" to the "wwan" interface, which did create the interface "br-wwan", but while "br-wan" has DHCP information, "br-wwan" does not and neither does "wlan2" anymore.

So how would I move past this issue so that I can bridge "wlan0" with "wlan2" (assumedly using the "br-wwan" interface) and thus allowing me to change my iptables rules so traffic from "wlan1" is forwarded to "br-wwan"?

Thank you
Aaron

Note that I have the firewall service disabled and am managing iptables rules myself due to the complexity of the rules.

Bellow you'll find extracts from the relevant config files, I've excluded sections and options which are not relevant or should not be shown (ssids and keys for example).

wireless config:

config wifi-iface
    option device 'radio0'
    option ifname 'wlan0'
    option network 'wan'
    option mode 'ap'

config wifi-iface
        option device 'radio0'
        option ifname 'wlan1'
        option network 'lan'
        option mode 'ap'

config wifi-iface
    option device 'radio1'
    option ifname 'wlan2'
    option network 'wwan'
    option mode 'sta'

network config:

config interface 'lan'
    option ifname 'eth1'
    option type 'bridge'
    option proto 'static'

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'
    option type 'bridge'

config interface 'wwan'
    option proto 'dhcp'