OpenWrt Forum Archive

Topic: Need help bricked Hame MPR A2 Router

The content of this topic has been archived between 30 Apr 2018 and 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

With telnet access have you entered "passwd" to provide a password and enable ssh?

Then with ssh enabled, log back in and try again. If it fails, try "ping www.google.com". If that fails, then you have a problem with dhcp--perhaps relating to your gateway or dns setup in /etc/config/network.

ok, have recovered my hame mpr-a2 again to almost full functionality - only web interface is missing, but this buggy luci with lua installation is too cumbersome.
Now I have ethernet, wireless and usb interfaces working, can access via telnet and it's enough for the moment. 4G usb dongle works fine and right now I'm having internet via the device.

Notes
1. I already had OpenWrt flashed some time ago when I had serial connection soldered.
2. This time I didn't have the serial connection and finally didn't need to disassemble the device.
3. MAC addresses are printed on labels on the device
4. The 4G usb dongle is configured for autoconnection and has built-in dhcp.

If it helpful to anybody, below are steps I finally followed to recover:
1. reset the device - using the small reset button (a needle or similar thing is needed). Changed IP on my PC to 192.168.1.2 and logged via telnet to the router with IP 192.168.1.1 (using ethernet interface, wifi by default is disabled after reset)
2. using vi modified the following configuration files in the /etc/config folder
- network
- wireless
- dhcp

Here are the configurations
==== network ====

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.0.70'
        option gateway '192.168.0.250'
        option dns '93.100.1.3'
        option netmask '255.255.255.0'
        option macaddr '9c:41:7c:21:73:08'

config interface 'wan'
        option proto 'dhcp'
        option macaddr '9c:41:7c:21:73:09'
        option type 'bridge'
        option _orig_ifname 'eth0.2 radio0.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1 eth0.2 usb0'

config switch
        option name 'rt305x'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rt305x'
        option vlan '1'
        option ports '0 1 2 3  6t'

config switch_vlan
        option device 'rt305x'
        option vlan '2'
        option ports '4  6t'

config interface 'usbwifi'
        option type 'bridge'
        option proto 'dhcp'
        option _orig_ifname 'usb0'
        option _orig_bridge 'true'
        option ifname 'usb0'

config interface 'wwan'
        option proto 'dhcp'

==== wireless ====
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path '10180000.wmac'
        option htmode 'HT20'
        option channel '10'
        option txpower '20'
        option country '00'

config wifi-iface
        option encryption 'psk2'
        option device 'radio0'
        option ssid 'hamewifi'
        option key 'thesecretkey'
        option mode 'ap'
        option network 'usbwifi wwan'
       

==== dhcp ====
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option enable_tftp '1'
        option tftp_root '/tmp'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'wan6'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'
        option master '1'

about problems with installing luci - my opkg.conf contains:
=== /etc/opkg.conf ===
src/gz barrier_breaker http://downloads.openwrt.org/snapshots/ … ages/base/
#src/gz barrier_breaker http://downloads.openwrt.org/snapshots/ … kages/luci
#src/gz barrier_breaker http://downloads.openwrt.org/snapshots/ … s/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

===

from base I tried to install the following luci dependencies:
opkg install uhttpd uhttpd-mod-ubus lua libuci-lua liblua rpcd libubus-lua  libiwinfo-lua

and the luci itself:
opkg install luci

the result was:
Package uhttpd (2015-11-08-fe01ef3f52adae9da38ef47926cd50974af5d6b7) installed in root is up to date.
Package uhttpd-mod-ubus (2015-11-08-fe01ef3f52adae9da38ef47926cd50974af5d6b7) installed in root is up to date.
Package lua (5.1.5-1) installed in root is up to date.
Package libuci-lua (2015-08-27.1-1) installed in root is up to date.
Package liblua (5.1.5-1) installed in root is up to date.
Package rpcd (2015-01-10-f00890cd6eb47ad9bb5da0fb6c50aedc8406e7c5) installed in root is up to date.
Package libubus-lua (2015-11-19-259450f414d8c9ee41896e8e6d6bc57ec00e2b63) installed in root is up to date.
Package libiwinfo-lua (2015-10-05-813f61e48b9b1a76cb55f3b4a229bf98d3cd53a9) installed in root is up to date.
Unknown package 'luci'.
Configuring liblua.
//usr/lib/opkg/info/liblua.postinst: line 4: default_postinst: not found
Configuring libuci-lua.
//usr/lib/opkg/info/libuci-lua.postinst: line 4: default_postinst: not found
Configuring rpcd.
//usr/lib/opkg/info/rpcd.postinst: line 4: default_postinst: not found
Configuring libubus-lua.
//usr/lib/opkg/info/libubus-lua.postinst: line 4: default_postinst: not found
Configuring libiwinfo-lua.
//usr/lib/opkg/info/libiwinfo-lua.postinst: line 4: default_postinst: not found
Configuring lua.
//usr/lib/opkg/info/lua.postinst: line 4: default_postinst: not found
Configuring uhttpd.
//usr/lib/opkg/info/uhttpd.postinst: line 4: default_postinst: not found
Configuring uhttpd-mod-ubus.
//usr/lib/opkg/info/uhttpd-mod-ubus.postinst: line 4: default_postinst: not found
Collected errors:
* opkg_install_cmd: Cannot install package luci.
* pkg_run_script: package "liblua" postinst script returned status 127.
* opkg_configure: liblua.postinst returned 127.
* pkg_run_script: package "libuci-lua" postinst script returned status 127.
* opkg_configure: libuci-lua.postinst returned 127.
* pkg_run_script: package "rpcd" postinst script returned status 127.
* opkg_configure: rpcd.postinst returned 127.
* pkg_run_script: package "libubus-lua" postinst script returned status 127.
* opkg_configure: libubus-lua.postinst returned 127.
* pkg_run_script: package "libiwinfo-lua" postinst script returned status 127.
* opkg_configure: libiwinfo-lua.postinst returned 127.
* pkg_run_script: package "lua" postinst script returned status 127.
* opkg_configure: lua.postinst returned 127.
* pkg_run_script: package "uhttpd" postinst script returned status 127.
* opkg_configure: uhttpd.postinst returned 127.
* pkg_run_script: package "uhttpd-mod-ubus" postinst script returned status 127.
* opkg_configure: uhttpd-mod-ubus.postinst returned 127.

so far don't know how to fix it.

(Last edited by croooter on 20 Dec 2015, 15:50)

seems to be I have too much free time: I did a very stupid thing - updated busybox package using opkg install busybox.. One should NOT do it unless de-bricking devices is the best thing he/she wants to do.
So I've lost again my hame and had to start from the beginning.
However this time I found in internet the onekeyrecovery tool along with the original firmware file and managed to repair the router and now building openwrt from repository.
So far I don't use any serial connection - with the onekeyrecovery I don't need it.

Can you link me to the original Hame MPR-A2 firmware? I've been also looking for it for a while. All I see are A1 firmwares.

croooter wrote:

seems to be I have too much free time: I did a very stupid thing - updated busybox package using opkg install busybox.. One should NOT do it unless de-bricking devices is the best thing he/she wants to do.
So I've lost again my hame and had to start from the beginning.
However this time I found in internet the onekeyrecovery tool along with the original firmware file and managed to repair the router and now building openwrt from repository.
So far I don't use any serial connection - with the onekeyrecovery I don't need it.

Hello Mil,
Did you get the original HAME MPR-A2 firmaware?
I did the WRT firmware update few month ago but it is too complex for me. Please let me know if you ve got solution.
Stéphane

The discussion might have continued from here.