OpenWrt Forum Archive

Topic: iptv stops after a few seconds

The content of this topic has been archived on 30 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I managed to get both my internet (vlan 35) and iptv (vlan 36) from my FTTH (Bell Fibe) service working on OpenWRT! Yay!

The only prob I have now is after a few seconds of switching tv channels the signal freezes. If I switch channels the same thing occurs after roughly the same amount of time.

I've also noticed at times that everything seems to freeze network wise (can't surf) and that I have to reboot my router to get going again. (flooding?)

It was suggested to me that it must be a multicasting issue, however I can't see what the issue could be.

Any ideas?

/etc/config/igmpproxy (I also noticed there's a /etc/igmpproxy.conf file. Is that file being used for anything?)

config igmpproxy
        option quickleave 1

config phyint wan
        option network iptv
        option direction upstream
        list altnet 0.0.0.0/0

config phyint lan
        option network lan
        option direction downstream
        list altnet 192.168.10.0/24        #same subnet with your LAN subnet

Note: I had tried just putting br-lan instead of lan and it didn't seem to make a difference.

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd1a:50f0:2558::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.10.1'
    option igmp_snooping '1'
    option ifname 'eth1.1'

config interface 'wan'
    option ifname 'eth0.35'
    option proto 'pppoe'
    option username 'xxxxxxx'
    option password 'xxxxxxxx'

config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'eth0.37'
    option reqaddress 'try'
    option reqprefix 'auto'

config interface 'iptv'
    option ifname 'eth0.36 eth1.2'
    option type 'bridge'
    option proto 'dhcp'
    option delegate '0'
    option broadcast '1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0 2 3' #External port 1 and 2 for internet

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'
    option ports '1 6'

config switch_vlan
    option device 'switch0'
    option vlan '35'
    option vid '35'
    option ports '1t 6t'

config switch_vlan
    option device 'switch0'
    option vlan '36'
    option vid '36'
    option ports '1t 4 5 6t' #External port 3 and 4 for IPTV receivers

config switch_vlan
    option device 'switch0'
    option vlan '37'
    option vid '37'
    option ports '1t 6t'

/etc/config/firewall

config rule
    option name 'Allow-DHCP-Renew-iptv'
    option src 'iptv'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping-iptv'
    option src 'iptv'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config zone
    option name 'iptv'
    option output 'ACCEPT'
    option network 'iptv'
    option family 'ipv4'
    option masq '1'
    option log '1'
    option input 'ACCEPT'
    option forward 'ACCEPT'

config rule
    option src 'iptv'
    option proto 'igmp'
    option target 'ACCEPT'

config rule
    option src 'iptv'
    option proto 'udp'
    option dest 'lan'
    option dest_ip '224.0.0.0/4'
    option target 'ACCEPT'

I also added this line to /etc/sysctl.conf

net.ipv4.conf.all.force_igmp_version=2

Ideally I'd like both the computers/wifi/etc and receivers to all be on the same network.. but I think that'll just cause more issues. Right now the receivers hooked up on ports 3 and 4 get 10.x.x.x ips assigned to it by my providers DHCP server (vlan 36). My internet/wifi/etc is on ports 1 and 2.

Thanks

There are many duplicates of this thread, you can delete them by pressing the "Delete topic" button at the bottom right of each post.

Is the consumer grade router's CPU suitable for the traffic?

Max Hopper wrote:

Is the consumer grade router's CPU suitable for the traffic?

I would think so..

I have a TP-LINK Archer C7 V2

Hi Cylac,

Why do you have 2 physicals interfaces map on iptv ?
config interface 'iptv'
    option ifname 'eth0.36 eth1.2'

Eth1.2 is your iptv lan side, right ?

Can you provide a tcpdump log for igmp for wan and lan, when the issue occurs:
tcpdump -i eth0.36 igmp
tcpdump -i eth1.2 igmp

(Last edited by nague on 30 Jun 2016, 17:58)

nague wrote:

Hi Cylac,

Why do you have 2 physicals interfaces map on iptv ?
config interface 'iptv'
    option ifname 'eth0.36 eth1.2'

Eth1.2 is your iptv lan side, right ?

Can you provide a tcpdump log for igmp for wan and lan, when the issue occurs:
tcpdump -i eth0.36 igmp
tcpdump -i eth1.2 igmp

Hi nague,

Yes Eth1.2 is my iptv lan side. I probably bridged the 2 together when I was testing stuff out.

I know that my iptv receivers need both the IPTV signal and internet feed to work properly. This is why I was trying to get these receivers to work on the same lan as my computers/wifi/etc.

I will gather those logs for you and post them later today!

thanks for taking the time to reply and help! wink

Cylac, quick questions:
- Do you have multiple iptv receivers ?
- Is your iptv receivers multi-homed ? (one ip interface for iptv, one for internet/lan access ?)
- eth0.36 get ip address on from you provider (by DHCP) ?

nague wrote:

Can you provide a tcpdump log for igmp for wan and lan, when the issue occurs:
tcpdump -i eth0.36 igmp
tcpdump -i eth1.2 igmp

tcpdump -i eth0.36 igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0.36, link-type EN10MB (Ethernet), capture size 65535 bytes
23:06:39.784332 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
23:08:44.779121 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
23:10:49.762613 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
23:12:54.752803 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2

I got rid of eth1.2. I placed my iptv interface on eth0.36 only.
I placed all my network ports on vlan 1
So my LAN interface is set to eth1.1

I changed my igmpproxy to this:

config igmpproxy
        option quickleave 1

config phyint
        option network iptv
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option direction downstream
        list altnet 192.168.1.0/24
nague wrote:

Cylac, quick questions:
- Do you have multiple iptv receivers ?
- Is your iptv receivers multi-homed ? (one ip interface for iptv, one for internet/lan access ?)
- eth0.36 get ip address on from you provider (by DHCP) ?

Yes I do have multiple receivers. 1 is hooked up via ethernet directly connected to my router and another is wireless.
While testing I'm only using the one connected via ethernet. (the WholeHomePVR receiver)
From what I can tell my receivers get an ip address for my providers dhcp server.
eth0.36 does get a private ip address assigned to it from my provider.

got some better log results this time!

tcpdump -i eth0.36 igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0.36, link-type EN10MB (Ethernet), capture size 65535 bytes
00:23:44.596996 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:25:49.586072 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:26:37.253674 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:26:37.554302 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:26:37.917984 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:26:38.419216 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:27:54.570547 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:29:40.780762 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:29:40.782839 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:29:41.605010 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:29:59.556857 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:32:04.546562 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:32:40.790359 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:32:40.791980 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:32:41.787804 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:34:09.537948 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:35:40.802649 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:35:40.804512 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:35:41.469193 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:36:00.149569 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:36:00.989151 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:36:09.145604 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:36:09.998860 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:36:14.572796 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
00:36:18.889828 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)
00:36:19.507627 IP 10.146.71.97 > igmp.mcast.net: igmp v3 report, 1 group record(s)

so when I switch to a channel.. I get a picture for a few seconds.. then it freezes.. if I switch channels.. it works for a few seconds again.. then freezes... etc etc etc

(Last edited by Cylac on 5 Jul 2016, 05:39)

Hi Cylac,

If you have multiple receivers, you should definitely forget the bridge solution.

Another point, you’ll never manage to send IPTV over wifi, you’ll freeze the radio. Basically, providers who allow STB over wifi are using unicast tunnel encapsulation to avoid broadcasting packets over the air. And most of time, they also switch to TCP to allow retransmission. The udpxy package can do the job (http encapsulation for udp iptv), but your receivers have to be compatible with http streams.

At this time, let’s focus on the wired receiver. In my understanding, you should stay with your current lan interface (eth1.1) for both, internet and iptv.

For the iptv wan interface, you can keep in etc/config/network :

config interface 'iptv'
    option ifname 'eth0.36'
    option proto 'dhcp'
    option defaultroute '0'

and:

config route
        option interface 'iptv'
        option target '224.0.0.0'
        option netmask '240.0.0.0'
        option gateway '0.0.0.0'

In the firewall (/etc/config/firewall), you can use this template:

config zone
        option name             'tv'
        option network          'iptv'
        option input            'REJECT'
        option output           'ACCEPT'
        option forward          'REJECT'
        option masq             '1'

config rule
        option src 'tv'
        option proto 'udp'
        option dest 'lan'
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'

config rule
        option src 'tv'
        option proto 'igmp'
        option target 'ACCEPT'

In case your receivers need unicast routing over iptv wan (this the case here in france with Orange and Bouygues Telecom) :

config forwarding
        option src              lan
        option dest             tv

(if your provider is not using dhcp option 131 to give you routes, you’ll need to specify them in the network configuration)

Regarding the igmpproxy, I can see in the wireshark log igmpv3 reports, and igmpv2 queries from network. I’m not sure igmproxy is comfortable with both igmp version. You should try mcproxy instead. Here the correct configuration:

For /etc/config/mcproxy:

# Use your own MCProxy config file
config mcproxy 'mcproxy_file'
        option disabled '0'
        option respawn '1'
        option file '/etc/mcproxy.conf'

# Use OpenWrt UCI config
config mcproxy 'mcproxy'
        option disabled '1'
        option respawn '1'
        option protocol 'IGMPv2'

For /etc/mcproxy.conf:

######################################
##-- mcproxy configuration script --##
######################################

# Protocol: IGMPv1|IGMPv2|IGMPv3 (IPv4) - MLDv1|MLDv2 (IPv6)
protocol IGMPv3;

###########################################
# Proxy Instance: upstream ==> downstream
pinstance C: "eth0.36" ==> "br-lan";
###########################################

(keep Tables and Instance Behaviour for future usage)

(Last edited by nague on 5 Jul 2016, 17:06)

Hi nague,

Just a few questions before I commit all these changes:

1. for the /etc/config/mcproxy file, do I delete all the lines after the configs you provided? I see there's a bunch of samples listed.
2. How to I make sure mcproxy is being used over igmpproxy? Is there any other configs I have to make? Should I disable igmpproxy?

Here are my config files for verification I configured them properly smile

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdd7:68f9:5948::/48'

config interface 'lan'
    option ifname 'eth1.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option igmp_snooping '1'

config interface 'IPTV'
    option proto 'dhcp'
    option ifname 'eth0.36'
    option defaultroute '0'

config interface 'wan'
    option proto 'pppoe'
    option ifname 'eth0.35'
    option username '***************'
    option password '**************'
    option peerdns '0'
    option dns '208.67.222.222 208.67.220.220 8.8.8.8' #OpenDNS and Google Public DNS

config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'eth0.37'
    option reqaddress 'try'
    option reqprefix 'auto'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'

config switch_vlan
    option device 'switch0'
    option vlan '35'
    option ports '1t 6t'
    option vid '35'

config switch_vlan
    option device 'switch0'
    option vlan '36'
    option vid '36'
    option ports '1t 6t'

config switch_vlan
    option device 'switch0'
    option vlan '37'
    option vid '37'
    option ports '1t 6t'

config route
        option interface 'iptv'
        option target '224.0.0.0'
        option netmask '240.0.0.0'
        option gateway '0.0.0.0'

/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wan6'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config rule
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config zone
        option name             'tv'
        option network          'iptv'
        option input            'REJECT'
        option output           'ACCEPT'
        option forward          'REJECT'
        option masq             '1'

config rule
        option src 'tv'
        option proto 'udp'
        option dest 'lan'
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'

config rule
        option src 'tv'
        option proto 'igmp'
        option target 'ACCEPT'

config forwarding
        option src 'lan'
        option dest 'tv'

/etc/config/mcproxy

# Use your own MCProxy config file
config mcproxy 'mcproxy_file'
    option disabled '0'
    option respawn '1'
    option file '/etc/mcproxy.conf'

# Use OpenWrt UCI config
config mcproxy 'mcproxy'
    option disabled '1'
    option respawn '1'
    option protocol 'IGMPv2'

###########################################

# Simple configuration examples

/etc/mcproxy.conf

######################################
##-- mcproxy configuration script --##
######################################

# Protocol: IGMPv1|IGMPv2|IGMPv3 (IPv4) - MLDv1|MLDv2 (IPv6)
protocol IGMPv3;

###########################################

# Proxy Instance: upstream ==> downstream
pinstance A: ap a1 ==> ap a2;
pinstance B: bp b1 ==> bp b2;
pinstance C: "eth0.36" ==> "br-lan";
###########################################

# Tables

I appreciate the help! big_smile

Hi Cylac,

1.    Basically, the UCI configuration of this file is disabled :

config mcproxy 'mcproxy'
        option disabled '1'

    So, you can keep / remove whatever you want, it will not be read

2.    You should disable it:

/etc/init.d/igmpproxy stop
/etc/init.d/igmpproxy disable

I’ve taken a look at your configuration files, it sounds good, except mcproxy.conf: you should comment the pinstance A and B

# Proxy Instance: upstream ==> downstream
#pinstance A: ap a1 ==> ap a2;
#pinstance B: bp b1 ==> bp b2;
pinstance C: "eth0.36" ==> "br-lan";

Maybe you can reorder the zones / rules in firewall, but I’m not even sure this is important.

Let me know if it's ok.

Thanks nague!

I'll make those changes once I get home!

When I made the other changes you provided I wasn't getting a picture at all anymore. I'd reboot the receiver and it would just sit at the booting splash image. When this happens I can't even access any menu options. I can see however on my openwrt that it's getting an ip assigned to it. So I know it's on the network at least.

I had disabled igmpproxy and had to install mcproxy

I notice this error message when I had to manually restart my firewall:

Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[2] (tv) has no device, network, subnet or extra options

could it be I'm missing something in my firewall settings?

I'll also try to do a tcpdump -v -i eth0.36 to see what I'm getting now once I connect a receiver.
Right now without a receiver I have this going on none stop:

11:55:37.488574 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1360)
    10.2.32.20.47811 > 239.0.56.100.1140: UDP, length 1332
11:55:37.490645 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.32.20.47811 > 239.0.56.100.1140: UDP, length 1328
11:55:37.492691 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.32.20.47811 > 239.0.56.100.1140: UDP, length 1328

Thanks again

Cylac, try IPTV in lowercase:

config interface 'IPTV'
    option proto 'dhcp'
    option ifname 'eth0.36'
    option defaultroute '0'

What is your openwrt release ?

same error after changing IPTV to lowercase.

Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[2] (tv) has no device, network, subnet or extra options

I'm using OpenWRT Chaos Calmer 15.05.1 big_smile

This is all running on a TP-Link Archer C7

(Last edited by Cylac on 6 Jul 2016, 20:02)

tcpdump is stilling showing records flowing like this none-stop! I'm assuming the port is getting flooded?

19:50:13.239829 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1360)
    10.2.128.165.47811 > 239.0.64.150.1163: UDP, length 1332
19:50:13.240015 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.128.165.47811 > 239.0.64.150.1163: UDP, length 1328
19:50:13.240262 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1360)
    10.2.0.18.47811 > 239.0.16.20.1139: UDP, length 1332
19:50:13.241276 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.0.18.47811 > 239.0.16.20.1139: UDP, length 1328
19:50:13.243214 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.0.18.47811 > 239.0.16.20.1139: UDP, length 1328
19:50:13.244869 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.128.165.47811 > 239.0.64.150.1163: UDP, length 1328
19:50:13.245217 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1356)
    10.2.0.18.47811 > 239.0.16.20.1139: UDP, length 1328
19:50:13.246421 IP (tos 0x40, ttl 27, id 0, offset 0, flags [none], proto UDP (17), length 1360)
    10.2.128.165.47811 > 239.0.64.150.1163: UDP, length 1332

I'm also not getting a picture after applying all the setting changes you suggested sad

(Last edited by Cylac on 7 Jul 2016, 00:52)

I have TLWR942v2 with 15.05.1 openwrt. I have issue like you.
when i watch TV channel for 10 minutes the channel auto jump the next chanel (iptv.m3).
i changed igmpproxy to mcproxy, disabe igmp snooping.. but no thing  change.
please advice me what can I do?

Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[2] (tv) has no device, network, subnet or extra options

This error means that the firewall can’t match the network “iptv” for the zone “tv”. Did you reload network / reboot your router after applying changes on /etc/config/network ?

If you still have this error, remove the tv zone and modify the wan zone:

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wan6 iptv'

And of course, rename the src in rules :

config rule
        option src 'wan'
        option proto 'udp'
        option dest 'lan'
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option proto 'igmp'
        option target 'ACCEPT'

And remove:

config forwarding
        option src 'lan'
        option dest 'tv'

Regarding your current tcpdump records, this is absolutely normal: eth0.36 is receiving the multicast group 239.0.64.150 and can’t forward it to the lan interface because firewall rules are not applied.

Hi nague, I must be doing something wrong.. this isn't working for me sad
I'm not even getting a picture at all as I stated in my previous post.
At first I was getting a picture.. but was suffering that picture freeze.

I've uploaded some pictures of my setup under Luci. Maybe you (or someone) can see what I might have configured wrong!

Thanks again

http://s32.postimg.org/70m2cz4nl/screen1.png http://s32.postimg.org/f3k8oap8x/screen3.png

http://s32.postimg.org/71w06e6hd/screen4.png http://s32.postimg.org/6zc4jk2tt/screen5.png

http://s32.postimg.org/frt378nyp/screen6.png

Hi Cylac, sorry for this result, I'm doing my best to help you.

All I can see in your screenshots looks ok... There might be something wrong with mcproxy. Can you porvide me the following log when you request a channel on your receiver:

tcpdump -i br-lan multicast

Then, try to go back with igmpproxy to see if you are still able to get a picture (same config as your original post):

/etc/init.d/mcproxy stop
/etc/init.d/igmpproxy start
nague wrote:

Hi Cylac, sorry for this result, I'm doing my best to help you.

All I can see in your screenshots looks ok... There might be something wrong with mcproxy. Can you porvide me the following log when you request a channel on your receiver:

tcpdump -i br-lan multicast

Then, try to go back with igmpproxy to see if you are still able to get a picture (same config as your original post):

/etc/init.d/mcproxy stop
/etc/init.d/igmpproxy start

Oh man don't get me wrong! I do appreciate your help tremendously! I'm sorry if you took my previous comment the wrong way!

I'll go grab the logs you requested and I'll test igmpproxy again and see what I get!
I'll report back!

Thanks again

Cylac wrote:

I'll go grab the logs you requested and I'll test igmpproxy again and see what I get!
I'll report back!
Thanks again

No problem, email me via forum, if I can help you live...

Thanks nague!

Here's an extract of the command: tcpdump -i br-lan multicast

21:06:21.378230 ARP, Request who-has 192.168.1.38 tell CHAOS.local.lan, length 46
21:06:21.419895 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:22.347228 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46
21:06:22.413041 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:23.413043 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:25.361622 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46
21:06:25.427208 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:26.423040 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:27.335591 IP android-2c350682f0d830a4.local.lan > 239.255.255.250: igmp v2 report 239.255.255.250
21:06:27.423482 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:27.979620 IP 192.168.1.209 > 239.255.255.250: igmp v2 report 239.255.255.250
21:06:28.377596 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46
21:06:28.506370 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:29.503505 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:30.503037 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:30.514177 IP 192.168.1.177 > 224.0.0.251: igmp v2 report 224.0.0.251
21:06:31.044250 IP 192.168.1.177 > 239.255.255.250: igmp v2 report 239.255.255.250
21:06:31.265560 IP android-2c350682f0d830a4.local.lan > 224.0.0.251: igmp v2 report 224.0.0.251
21:06:31.326958 IP CHAOS.local.lan.53070 > 192.168.1.255.32414: UDP, length 21
21:06:31.327085 IP CHAOS.local.lan.53069 > 192.168.1.255.32412: UDP, length 21
21:06:31.394112 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46
21:06:31.619600 IP 192.168.1.209 > 239.255.255.246: igmp v2 report 239.255.255.246
21:06:33.166008 IP Chromecast.local.lan > 239.255.255.250: igmp v2 report 239.255.255.250
21:06:33.455656 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:34.409746 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46
21:06:34.453037 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:35.453036 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:35.628414 IP CHAOS.local.lan.53068 > 239.255.255.250.1900: UDP, length 94
21:06:36.324107 IP CHAOS.local.lan.53069 > 192.168.1.255.32412: UDP, length 21
21:06:36.324213 IP CHAOS.local.lan.53070 > 192.168.1.255.32414: UDP, length 21
21:06:41.316965 IP CHAOS.local.lan.53070 > 192.168.1.255.32414: UDP, length 21
21:06:41.317073 IP CHAOS.local.lan.53069 > 192.168.1.255.32412: UDP, length 21
21:06:41.523046 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:42.523044 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:43.457780 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46
21:06:45.413193 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:46.314091 IP CHAOS.local.lan.53070 > 192.168.1.255.32414: UDP, length 21
21:06:46.314198 IP CHAOS.local.lan.53069 > 192.168.1.255.32412: UDP, length 21
21:06:46.413042 ARP, Request who-has 192.168.1.38 tell GATEKEEPER.local.lan, length 28
21:06:46.470849 ARP, Request who-has GATEKEEPER.local.lan tell 192.168.1.209, length 46

I'll be trying to setup igmpproxy again! I'll report back!

Hi Cylac, on the wireshark log, I can't see your iptv receiver requesting a channel.
You can try this command to avoid arp requests in log:

tcpdump -i br-lan multicast and not arp

(Last edited by nague on 8 Jul 2016, 10:26)

do you have settopbox connect to router? what í vlan 37 work for? do you have IP6
if you do not use them.
try network
Config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdd7:68f9:5948::/48'

config interface 'lan'
    option ifname 'eth1.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
  #  option ip6assign '60'
    option igmp_snooping '1'

config interface 'IPTV'
    option proto 'dhcp'
    option ifname 'eth1.36 eth0.36'
    option defaultroute '0'

config interface 'wan'
    option proto 'pppoe'
    option ifname 'eth0.35'
    option username '***************'
    option password '**************'
    option peerdns '0'
    option dns '208.67.222.222 208.67.220.220 8.8.8.8' #OpenDNS and Google Public DNS

# config interface 'wan6'
  #  option proto 'dhcpv6'
    # option ifname 'eth0.37'
   # option reqaddress 'try'
   # option reqprefix 'auto'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'

config switch_vlan
    option device 'switch0'
    option vlan '35'
    option ports '1 6'
    option vid '35'

config switch_vlan
    option device 'switch0'
    option vlan '36'
    option vid '36'
    option ports '1t 6'

# config switch_vlan
   # option device 'switch0'
    # option vlan '37'
    # option vid '37'
    # option ports '1t 6t'

# config route
   #     option interface 'iptv'
     #   option target '224.0.0.0'
      #  option netmask '240.0.0.0'
       # option gateway '0.0.0.0'

(Last edited by dktn on 8 Jul 2016, 10:25)

The discussion might have continued from here.