OpenWrt Forum Archive

Topic: iptv and multicasting issue

The content of this topic has been archived on 6 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I managed to get both my internet (vlan 35) and iptv (vlan 36) from my FTTH (Bell Fibe) service working on OpenWRT! Yay!

The only prob I have now is after a few seconds of switching tv channels the signal freezes. If I switch channels the same thing occurs after roughly the same amount of time.

I've also noticed at times that everything seems to freeze network wise (can't surf) and that I have to reboot my router to get going again. (flooding?)

It was suggested to me that it must be a multicasting issue, however I can't see what the issue could be.

Any ideas?

/etc/config/igmpproxy (I also noticed there's a /etc/igmpproxy.conf file. Is that file being used for anything?)

config igmpproxy
        option quickleave 1

config phyint wan
        option network iptv
        option direction upstream
        list altnet 0.0.0.0/0

config phyint lan
        option network lan
        option direction downstream
        list altnet 192.168.10.0/24        #same subnet with your LAN subnet

Note: I had tried just putting br-lan instead of lan and it didn't seem to make a difference.

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd1a:50f0:2558::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.10.1'
    option igmp_snooping '1'
    option ifname 'eth1.1'

config interface 'wan'
    option ifname 'eth0.35'
    option proto 'pppoe'
    option username 'xxxxxxx'
    option password 'xxxxxxxx'

config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'eth0.37'
    option reqaddress 'try'
    option reqprefix 'auto'

config interface 'iptv'
    option ifname 'eth0.36 eth1.2'
    option type 'bridge'
    option proto 'dhcp'
    option delegate '0'
    option broadcast '1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0 2 3' #External port 1 and 2 for internet

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'
    option ports '1 6'

config switch_vlan
    option device 'switch0'
    option vlan '35'
    option vid '35'
    option ports '1t 6t'

config switch_vlan
    option device 'switch0'
    option vlan '36'
    option vid '36'
    option ports '1t 4 5 6t' #External port 3 and 4 for IPTV receivers

config switch_vlan
    option device 'switch0'
    option vlan '37'
    option vid '37'
    option ports '1t 6t'

/etc/config/firewall

config rule
    option name 'Allow-DHCP-Renew-iptv'
    option src 'iptv'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping-iptv'
    option src 'iptv'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config zone
    option name 'iptv'
    option output 'ACCEPT'
    option network 'iptv'
    option family 'ipv4'
    option masq '1'
    option log '1'
    option input 'ACCEPT'
    option forward 'ACCEPT'

config rule
    option src 'iptv'
    option proto 'igmp'
    option target 'ACCEPT'

config rule
    option src 'iptv'
    option proto 'udp'
    option dest 'lan'
    option dest_ip '224.0.0.0/4'
    option target 'ACCEPT'

I also added this line to /etc/sysctl.conf

net.ipv4.conf.all.force_igmp_version=2

Ideally I'd like both the computers/wifi/etc and receivers to all be on the same network.. but I think that'll just cause more issues. Right now the receivers hooked up on ports 3 and 4 get 10.x.x.x ips assigned to it by my providers DHCP server (vlan 36). My internet/wifi/etc is on ports 1 and 2.

Thanks for any help anyone can provide!

please? does no one have experience with multi-casting? I'm desprate in ditching my Bell Home Hub 2000!!! tongue
is there anything else I should be looking/checking/test for?

thanks!

anyone?

igmpproxy is multicast forwarding to lan, so basically udp://@ works on lan and can watch iptv on pc, I recommend to use udpxy for that.

igmp version depends on service provider, test whit 1-3 versions

and maybe try different openwrt versions

Driver007 wrote:

igmpproxy is multicast forwarding to lan, so basically udp://@ works on lan and can watch iptv on pc, I recommend to use udpxy for that.

igmp version depends on service provider, test whit 1-3 versions

and maybe try different openwrt versions

Thanks for the quick reply!

I'm using the receivers provided by my provider (Bell Canada).
I don't think I can view iptv from them on my pc too right? or can I?
If I can't, I'm guessing udpxy won't make a diff? (never used/set it up before)

I'll try what you suggested and try other versions of openwrt and see if that makes a difference.
Do I just have to change the value of net.ipv4.conf.all.force_igmp_version=X to the version I want to use?

Thanks

The discussion might have continued from here.