OpenWrt Forum Archive

Topic: 2.4Ghz Wireless Problems on EA3500

The content of this topic has been archived on 1 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Solved in this post.

-----

Running DESIGNATED DRIVER (Bleeding Edge, r49377) on a Linksys EA3500.

The 5GHz radio works fine (radio1), but after enabling the 2.4GHz radio (radio0) it still reads "Wireless is disabled or not associated" in LuCI. Also, all the drop-downs for selecting the frequency options are empty. This is what the edit screen looks like:

http://i.imgur.com/l7tesKd.png

Here is the config for radio0:

# cat /var/run/hostapd-phy0.conf
driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
hw_mode=a
channel=acs_survey

interface=wlan0
ctrl_interface=/var/run/hostapd
ap_isolate=1
disassoc_low_ack=1
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
wpa_passphrase=--redacted--
auth_algs=1
wpa=3
wpa_pairwise=CCMP
ssid=MikeU
bridge=br-lan
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
bssid=20:aa:4b:89:b6:66

The working 5GHz radio1 has an almost identical config.

Here are the radio0 lines in the system logs after a reboot:

# logread | grep radio0
Sat May 21 03:50:25 2016 daemon.notice netifd: radio0 (2030): command failed: Not supported (-95)
Sat May 21 03:50:26 2016 daemon.notice netifd: radio0 (2030): Configuration file: /var/run/hostapd-phy0.conf
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): Hardware does not support configured mode
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): wlan0: IEEE 802.11 Hardware does not support configured mode (2) (hw_mode in hostapd.conf)
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): Could not select hw_mode and channel. (-2)
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): wlan0: interface state UNINITIALIZED->DISABLED
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): wlan0: AP-DISABLED 
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): wlan0: Unable to setup interface.
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): wlan0: interface state DISABLED->DISABLED
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): wlan0: AP-DISABLED 
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): hostapd_free_hapd_data: Interface wlan0 wasn't started
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): Command failed: Invalid argument
Sat May 21 03:50:27 2016 daemon.notice netifd: radio0 (2030): Device setup failed: HOSTAPD_START_FAILED

radio1:

# logread | grep radio1
Sat May 21 03:50:26 2016 daemon.notice netifd: radio1 (2031): command failed: Not supported (-95)
Sat May 21 03:50:26 2016 daemon.notice netifd: radio1 (2031): Configuration file: /var/run/hostapd-phy1.conf
Sat May 21 03:50:27 2016 daemon.notice netifd: radio1 (2031): wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Sat May 21 03:50:27 2016 daemon.notice netifd: radio1 (2031): Using interface wlan1 with hwaddr 20:aa:4b:89:b6:68 and ssid "MikeU"
Sat May 21 03:50:28 2016 daemon.notice netifd: radio1 (2031): wlan1: interface state COUNTRY_UPDATE->ENABLED
Sat May 21 03:50:28 2016 daemon.notice netifd: radio1 (2031): wlan1: AP-ENABLED 

Full system log here.

I don't know what that first "command failed: Not supported (-95)" error is referring to but it appears for the working radio1 as well so I assume this is not the problem. The real issue seems to be "Hardware does not support configured mode ... wlan0: IEEE 802.11 Hardware does not support configured mode (2) (hw_mode in hostapd.conf)".

----- As shown above hw_mode=a ("Access Point"). I don't know much about WiFi so I don't know what the mode should be if it's not "Access Point". Any ideas? -----
Edit:
This is incorrect. hw_mode=a sets the WiFi device's wireless protocol to 802.11a and has nothing to do with the WiFi interface's operation mode ("Access Point").

Thanks,
- Mike

(Last edited by yo1dog on 7 Jun 2016, 16:37)

Bump.

Still experiencing this issue. Anyone got any ideas? Any troubleshooting tips?

can you post your wireless config?

I posted the contents of /var/run/hostapd-phy0.conf in my original post. Is there another related config file? If so can you tell me where it is? I would be happy to post it.

/etc/config/wireless

Posted below. That /etc/config directory is probably a good one to remember.

I posted /var/run/hostapd-phy0.conf before because the system logs explicitly referenced that file in the error (I think?):
"wlan0: IEEE 802.11 Hardware does not support configured mode (2) (hw_mode in hostapd.conf)"

How do these two configuration files relate as they both seem to specify the WiFi device's "mode" (hw_mode and hwmode)? Also, where should I make changes (note that I use the LuCI GUI)?

# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'mbus/mbus:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option hwmode '11a'
        option channel 'auto'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'MikeU'
        option encryption 'psk-mixed'
        option key '--redacted--'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'mbus/mbus:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option channel '48'
        option txpower '20'
        option country '00'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk-mixed'
        option key '--redacted--'
        option ssid 'Mike'

Also, I don't know if this helps but here is what the edit page looks like for the 2.4ghz radio0. Notice that it says the radio is enabled but the status says it is "disabled or not associated". Also all the drop-downs for frequency are empty.

http://i.imgur.com/l7tesKd.png

edit config wifi-device 'radio0' and re-observe 2.4ghz radio.

option hwmode '11g'
option htmode 'HT40'
option txpower '20'
option country '00'

That worked! Thanks!

Would you mind explaining exactly what these changes mean? How did you know to make them?

Could you also answer my questions in my previous post about how /var/run/hostapd-phy0.conf and /etc/config/wireless relate? Both these configuration files seem to specify the WiFi device's wireless protocol (hw_mode and hwmode) and other options. Further, I noticed that after making those changes to /etc/config/wireless and restarting, "hw_mode" in /var/run/hostapd-phy0.conf was updated automatically from"hw_mode=a" to "hw_mode=g". I assume this means that /etc/config/wireless is the authoritative configuration and I should make all changes there.

Here are my final config sections in /etc/config/wireless for radio0:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'mbus/mbus:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option hwmode '11g'
        option htmode 'HT40'
        option txpower '20'
        option country '00'
        option channel '11'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk-mixed'
        option key '--redacted--'
        option network 'lan'
        option ssid 'Mike'

(Last edited by yo1dog on 8 Jun 2016, 00:45)

The hostapd configuration files are created when the interface is brought up. They are generated from the values in /etc/config/wireless, which can be edited directly, modified through the uci tool or through the LuCI GUI.

It's worth noting that /var on OpenWrt is a symlink to /tmp, so nothing there will be saved to flash.

The issue wrtboy spotted was that the 2.4 radio (802.11b/g/n, hence "11g") was configured as a 5ghz radio (802.11a/n, hence "11a").

(Last edited by leitec on 8 Jun 2016, 00:10)

That makes sense. Thanks for the tip about /var.

Actually, I have another quick question. What are these lines for?

option htmode 'HT40'
option txpower '20'

It seems to work fine without them.

(Last edited by yo1dog on 8 Jun 2016, 01:00)

'HT40' sets the channel width (40MHz). 'txpower' is transmitter power, which I'm fairly sure is ignored by the mwl8k driver. Have a look here: https://wiki.openwrt.org/doc/uci/wireless?s[]=ht40

Is there a reason why it is necessary to set the channel width and transmitter power rather than leave them at the default?

Without including those two lines LuCI shows:
Operating frequency Mode: "Legacy"
Transmit Power: "20 dBm"

With those lines LuCI shows:
Operating frequency Mode: "N"
Operating frequency Width: "40 MHz"
Transmit Power: "20 dBm"

Should I make these changes to my 5GHz radio as well?

Edit: I guess my real question is: What does changing the frequency mode/width do?

(Last edited by yo1dog on 8 Jun 2016, 01:26)

Just a quick post to say the problem is also showing up for EA4500, and that the solution in #8 (https://forum.openwrt.org/viewtopic.php … 89#p327489) does indeed work for that router as well.

On a related note, the problem is repeatable. It seems to disable your existing radio when you ADD an interface to an existing radio, like if you want to add a guest network to an existing 2.4 GHz radio.

Oh, and to answer your question about frequency Width, it depends on your radio environment. Increasing your width may give you better reception, at the risk of increased collisions with other routers on neighbouring channels. So if you are in a WiFi congested area (apartment, etc.) it is suggested to stay on the narrow bandwidth (20 MHz). If you have a single home where you can set your router to an un-shared channel, you might get better signal strength from your devices with a wider bandwidth (40 MHz).

When evaluating whether to use 20 or 40, use a WiFi scanner. Don't just test where your router is placed, but also test where your client devices will be located. If other routers are detected using the channel above/below your selected channel, you might encounter collisions with a 40 MHz width.

Of course, YMMV.

Dekker wrote:

Just a quick post to say the problem is also showing up for EA4500, and that the solution in #8 (https://forum.openwrt.org/viewtopic.php … 89#p327489) does indeed work for that router as well.

On a related note, the problem is repeatable. It seems to disable your existing radio when you ADD an interface to an existing radio, like if you want to add a guest network to an existing 2.4 GHz radio.


I just wanted to second what Dekker said, i had this same problem on my EA3500 a few weeks ago after i made a guest network and fixed it in the same way wrtboy did, i didn't think to post about it because i thought i had messed up the config myself somewhere along the way and just not realized it.

(Last edited by mikemccartney on 23 Jun 2016, 20:10)

The discussion might have continued from here.