OpenWrt Forum Archive

Topic: 1900ACS AC radio not working

The content of this topic has been archived on 29 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi OpenWrt,
Any suggestions on investigating the problem below? Did I miss a known issue or is my router broken?

Thanks!

The symptoms are illustrated here:

http://i.imgur.com/NC6ikHi.png

Version CHAOS CALMER (15.05.1, r48532)


The config is nearly the default, AFAIK.

# cat wireless 

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
    option htmode 'VHT80'
    option txpower '20'
    option country '00'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'XXX AC'
    option encryption 'psk2'
    option key 'YYY'

Post your /etc/config/network as well.

Thanks for much for your interest in helping!

# cat network 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdc5:XXXX:feb7::/48'

config interface 'lan'
    option ifname 'eth1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.0.1'

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'
    option hostname 'XXX-apartment-2015'

config interface 'wan6'
    option ifname 'eth0'
    option proto 'dhcpv6'

I probably shouldn't have taken out part of /etc/config/wireless. This is the config for radio 1 at the end of wireless. It's working fine.

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option htmode 'HT20'
    option txpower '20'
    option country '00'

config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'XXX'
    option encryption 'psk2'
    option key 'XXX'

(Last edited by jeffy on 16 May 2016, 18:19)

Your network and wifi configuration looks ok. Check the wireless key and selected auth/encryption mode to see if it matches what your nexthop router expects. Check your firewall to ensure you have allowed dhcp request/renewal. It should be something like this:

        uci -q add firewall rule
        uci -q set firewall.@rule[-1]=rule
        uci -q set firewall.@rule[-1].name='Allow-DHCP-wan'
        uci -q set firewall.@rule[-1].src='wan'
        uci -q set firewall.@rule[-1].proto='udp'
        uci -q set firewall.@rule[-1].dest_port='67-68'
        uci -q set firewall.@rule[-1].target='ACCEPT'
        uci -q set firewall.@rule[-1].family='ipv4'
     
        uci -q add firewall rule
        uci -q set firewall.@rule[-1]=rule
        uci -q set firewall.@rule[-1].name='Allow-DHCP-Lan'
        uci -q set firewall.@rule[-1].src=lan
        uci -q set firewall.@rule[-1].src_port='67-68'
        uci -q set firewall.@rule[-1].dest_port='67-68'
        uci -q set firewall.@rule[-1].proto=udp
        uci -q set firewall.@rule[-1].target=ACCEPT


        uci -q add firewall rule
        uci -q set firewall.@rule[-1]=rule
        uci -q set firewall.@rule[-1].name='Allow-DHCPv6'
        uci -q set firewall.@rule[-1].src='wan'
        uci -q set firewall.@rule[-1].proto='udp'
        uci -q set firewall.@rule[-1].src_ip='fc00::/6'
        uci -q set firewall.@rule[-1].dest_ip='fc00::/6'
        uci -q set firewall.@rule[-1].dest_port='546'
        uci -q set firewall.@rule[-1].family='ipv6'
        uci -q set firewall.@rule[-1].target='ACCEPT'

Hold up, I take my previous comment back. Are you trying to connect to an upstream router, i.e, are you connecting to another router, or you have an ethernet cable connected to your openwrt router from which you plan to get to the internet. If the answer is the former, then your wireless configuration should be sta, like this:

option mode 'sta'

Currently, your configuration looks like you are setup as AP only

nenekofi wrote:

Hold up, I take my previous comment back. Are you trying to connect to an upstream router, i.e, are you connecting to another router, or you have an ethernet cable connected to your openwrt router from which you plan to get to the internet. If the answer is the former, then your wireless configuration should be sta, like this:

option mode 'sta'

Currently, your configuration looks like you are setup as AP only

I don't have another router (or, I want to create a LAN).

I'll try your suggestion when I get back to my apartment.

I'm not terribly hopeful though, because radio 1 is setup as "ap", and clients gets a LAN IP and can connect to the internet... :-/

Unfortunately, setting to mode "sta" didn't have the desired effect. It still says:

Tx-Power: 0 dBm
Signal: 0 dBm
Noise: 0 dBm

In the /etc/config/wireless configuration add "platform" to the path and restart.

option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'

See if that doesn't work.

Is it supposed to show all zeros when there are no clients connected to the radio?

If so, I think the mystery is solved!

Can clients connect?

Also, I noticed the country code is 00. Set it for optimal performance for where you live.

Change it under each wifi > Advanced settings.

(Last edited by davidc502 on 17 May 2016, 04:04)

davidc502 wrote:

Can clients connect?

Also, I noticed the country code is 00. Set it for optimal performance for where you live.

Change it under each wifi > Advanced settings.

Hi David,
I changed my country code as you suggested. I look forward to seeing how it works!

After restarting the router, clients can connect to both radios. However, when I came back to my apartment after a few hours, I couldn't connect to either radio. Unfortunately, the logs were cleared when I restarted, so I didn't catch them.

This sounds less like a hardware problem, and more like a software issue a software issue, which gives me relief. I think there are some open issues on the 1900AC(S) driver being discussed in the forum, so I'll read them over and collect any info that might be useful.

Thanks!

It's working better than ever for me. Thanks!

jeffy wrote:

It's working better than ever for me. Thanks!

Great! Glad it's working now!

The discussion might have continued from here.