OpenWrt Forum Archive

Topic: Archer C7 as switch and AP only?

The content of this topic has been archived on 18 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey all,

I'm trying to setup an Archer C7 (15.05.1) as a bridge and AP only. I'm using a Ubiquiti EdgeRouter Lite as my DHCP/DNS/firewall. I *think* my setup is correct, but I'd like to be able to use my WAN port as part of the switch. Is this correct? Do I only need to add eth0 to the bridge? Do I need a VLAN?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd42:69de:117f::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'dhcp'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 5 6'

EDIT: I've disable the following services:

  • firewall

  • telnet

  • odhcpd

  • dnsmasq

(Last edited by lmm5247 on 19 May 2016, 17:59)

Is that the default config?

I think it is just a case of adding eth0 to ifname under lan and remove interface wan, at least that is what I'd try.

Xotic750 wrote:

Is that the default config?

No, it's a little customized but came pretty much from stock.

Xotic750 wrote:

I think it is just a case of adding eth0 to ifname under lan and remove interface wan, at least that is what I'd try.

I tried this an lost access to the router. Going to try the config below and see.
https://forum.openwrt.org/viewtopic.php … 06#p278806

(Last edited by lmm5247 on 19 May 2016, 18:31)

The discussion might have continued from here.