I have set up my /etc/config/wireless as client

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option macaddr 'ff:ff:ff:ff:ff:ff'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '10'
        option country 'IN'
        option disabled '0'

config wifi-iface
        option network 'wwan'
        option ssid 'SSIDNAME'
        option device 'radio0'
        option key 'PASS'
        option mode 'sta'
        option encryption 'psk2'
        option bssid 'Router MAC ID'

This works for me. I can ping google.com successfully.

To change the wireless into MONITOR mode I change my configuration to

config wifi-iface
        option network 'wwan'
        option ssid 'SSID NAME'
        option device 'radio0'
        option key 'PASS'
        option mode 'monitor'

This works fine. I can airodump-ng in this mode.

/etc/config/network

[quote]config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.150'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'
        list dns '8.8.8.8'

config interface 'wan'
        option proto 'dhcp'

I login to the TP-MR3020 when it is connected to the router via an ethernet cable as follows :

I login from a computer connected to the same router (MY UBUNTU SYSTEM IP : 192.168.1.8 )

ssh root@192.168.1.150

And i get the OPEN WRT ASCII art.

Now What i wish to do is i want to :

ssh root@192.168.1.2

That is remove the ethernet cable, which leaves the TPLINK in the client mode. And i want to ssh to that from my pc or any pc which is connected to the router.

What I Tried :

/etc/config/dropbear


config dropbear
        option PasswordAuth 'on'
        option RootPasswordAuth 'on'
        option Port '22'
        option Interface 'lan'

config dropbear
        option Interface 'wan'
        option Port '2022'
        option PasswordAuth 'on'
        option GatewayPorts 'on'
        option RootPasswordAuth 'on'

when i ARP sudo arp-scan -I eth0 -l it shows this

192.168.1.2    ff:ff:ff:ff:ff:ff # MY TPLINK MAC ADDRESS
192.168.1.150    ff:ff:ff:ff:ff:ff # MY TPLINK MAC ADDRESS

and print the same ascii art tongue

(Last edited by aadi1428 on 17 May 2016, 14:20)