OpenWrt Forum Archive

Topic: 3G wan connection problem

The content of this topic has been archived on 8 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I am working on SOM9331 openwrt Chaos calmer version and installed packages required for 3g data communication as mentioned here:https://wiki.openwrt.org/doc/recipes/3gdongle.

I am using N703 3g modem from Neoway. Currently I have added basic commands to check pin insertion, SIM registration. Here is the chat script:

ABORT   BUSY
ABORT   'NO CARRIER'
ABORT   ERROR
REPORT  CONNECT
TIMEOUT 20
"" "ATI"
TIMEOUT 10
OK      "AT+CPIN?"
TIMEOUT 10
OK      "AT+CREG?"
TIMEOUT 10
OK      "AT+CSQ"
TIMEOUT 10
OK      "AT+XIIC=1"
TIMEOUT 15
OK

Added wan interface in network configuration and upon exection of ifup wan, the chat script is restarting after execution of all commands.
Here is the logread output:

Sat Apr 23 13:50:11 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Apr 23 13:50:13 2016 daemon.notice pppd[5166]: pppd 2.4.7 started by root, uid 0
Sat Apr 23 13:50:13 2016 daemon.notice pppd[5166]: Removed stale lock on ttyUSB2 (pid 4883)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: abort on (BUSY)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: abort on (NO CARRIER)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: abort on (ERROR)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: report (CONNECT)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: timeout set to 20 seconds
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: send (ATI^M)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: timeout set to 10 seconds
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: expect (OK)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ATI^M^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: NEOWAY^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: N703^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: V501^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: OK
Sat Apr 23 13:50:14 2016 local2.info chat[5168]:  -- got it
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: send (AT+CPIN?^M)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: timeout set to 10 seconds
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: expect (OK)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: AT+CPIN?^M^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: +CPIN: READY^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: OK
Sat Apr 23 13:50:14 2016 local2.info chat[5168]:  -- got it
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: send (AT+CREG?^M)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: timeout set to 10 seconds
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: expect (OK)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: AT+CREG?^M^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: +CREG: 0,1^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: OK
Sat Apr 23 13:50:14 2016 local2.info chat[5168]:  -- got it
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: send (AT+CSQ^M)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: timeout set to 10 seconds
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: expect (OK)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: AT+CSQ^M^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: +CSQ: 19,99^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: OK
Sat Apr 23 13:50:14 2016 local2.info chat[5168]:  -- got it
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: send (AT+XIIC=1^M)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: timeout set to 15 seconds
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: expect (OK)
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: ^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: AT+XIIC=1^M^M
Sat Apr 23 13:50:14 2016 local2.info chat[5168]: OK
Sat Apr 23 13:50:14 2016 local2.info chat[5168]:  -- got it
Sat Apr 23 13:50:14 2016 daemon.info pppd[5166]: Serial connection established.
Sat Apr 23 13:50:14 2016 kern.info kernel: [ 1157.630000] 3g-wan: renamed from ppp0
Sat Apr 23 13:50:14 2016 daemon.info pppd[5166]: Using interface 3g-wan
Sat Apr 23 13:50:14 2016 daemon.notice pppd[5166]: Connect: 3g-wan <--> /dev/ttyUSB2
Sat Apr 23 13:50:45 2016 daemon.warn pppd[5166]: LCP: timeout sending Config-Requests
Sat Apr 23 13:50:45 2016 daemon.notice pppd[5166]: Connection terminated.
Sat Apr 23 13:50:45 2016 daemon.warn pppd[5166]: Receive serial link is not 8-bit clean:
Sat Apr 23 13:50:45 2016 daemon.warn pppd[5166]: Problem: all had bit 7 set to 0
Sat Apr 23 13:50:46 2016 daemon.notice pppd[5166]: Modem hangup
Sat Apr 23 13:50:46 2016 daemon.info pppd[5166]: Exit.
Sat Apr 23 13:50:46 2016 daemon.notice netifd: Interface 'wan' is now down
Sat Apr 23 13:50:46 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Apr 23 13:50:48 2016 daemon.notice pppd[5218]: pppd 2.4.7 started by root, uid 0
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: abort on (BUSY)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: abort on (NO CARRIER)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: abort on (ERROR)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: report (CONNECT)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: timeout set to 20 seconds
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: send (ATI^M)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: timeout set to 10 seconds
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: expect (OK)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: ATI^M^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: NEOWAY^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: N703^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: V501^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: OK
Sat Apr 23 13:50:49 2016 local2.info chat[5220]:  -- got it
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: send (AT+CPIN?^M)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: timeout set to 10 seconds
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: expect (OK)
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: AT+CPIN?^M^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: +CPIN: READY^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: OK
Sat Apr 23 13:50:49 2016 local2.info chat[5220]:  -- got it
Sat Apr 23 13:50:49 2016 local2.info chat[5220]: send (AT+CREG?^M)
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: timeout set to 10 seconds
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: expect (OK)
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: AT+CREG?^M^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: +CREG: 0,1^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: OK
Sat Apr 23 13:50:50 2016 local2.info chat[5220]:  -- got it
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: send (AT+CSQ^M)
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: timeout set to 10 seconds
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: expect (OK)
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: AT+CSQ^M^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: +CSQ: 19,99^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: OK
Sat Apr 23 13:50:50 2016 local2.info chat[5220]:  -- got it
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: send (AT+XIIC=1^M)
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: timeout set to 15 seconds
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: expect (OK)
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: ^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: AT+XIIC=1^M^M
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: +CME ERROR
Sat Apr 23 13:50:50 2016 local2.info chat[5220]:  -- failed
Sat Apr 23 13:50:50 2016 local2.info chat[5220]: Failed (ERROR)
Sat Apr 23 13:50:50 2016 daemon.err pppd[5218]: Connect script failed
Sat Apr 23 13:50:51 2016 daemon.info pppd[5218]: Exit.
Sat Apr 23 13:50:51 2016 daemon.notice netifd: Interface 'wan' is now down
Sat Apr 23 13:50:51 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Apr 23 13:50:53 2016 daemon.notice pppd[5240]: pppd 2.4.7 started by root, uid 0

Can anyone help me the cause for the restarting of the chatscript and how to disable it?

Update: Here is the dmesg:

root@OpenWrt:~# dmesg
[    0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 21:55:57 CEST 2015
[    0.000000] MyLoader: sysp=c92abf55, boardp=33d065a3, parts=adccdd4d
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x03ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 8034e2b0, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  board=TL-WR703N  console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 61004K/65536K available (2621K kernel code, 129K rwdata, 344K rodata, 224K init, 194K bss, 4532K reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.090000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.100000] NET: Registered protocol family 16
[    0.100000] MIPS: machine is TP-LINK TL-WR703N v1
[    0.370000] Switched to clocksource MIPS
[    0.370000] NET: Registered protocol family 2
[    0.380000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.380000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.380000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.390000] TCP: reno registered
[    0.390000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.410000] NET: Registered protocol family 1
[    0.410000] PCI: CLS 0 bytes, default 32
[    0.410000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.430000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.430000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.440000] msgmni has been set to 119
[    0.440000] io scheduler noop registered
[    0.450000] io scheduler deadline registered (default)
[    0.450000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.460000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a AR933X UART
[    0.470000] console [ttyATH0] enabled
[    0.480000] bootconsole [early0] disabled
[    0.490000] m25p80 spi0.0: found s25fl064k, expected m25p80
[    0.490000] m25p80 spi0.0: s25fl064k (8192 Kbytes)
[    0.500000] 5 tp-link partitions found on MTD device spi0.0
[    0.500000] Creating 5 MTD partitions on "spi0.0":
[    0.510000] 0x000000000000-0x000000020000 : "u-boot"
[    0.510000] 0x000000020000-0x00000012c4d0 : "kernel"
[    0.520000] 0x00000012c4d0-0x0000007f0000 : "rootfs"
[    0.520000] mtd: device 2 (rootfs) set to be root filesystem
[    0.530000] 1 squashfs-split partitions found on MTD device rootfs
[    0.530000] 0x000000360000-0x0000007f0000 : "rootfs_data"
[    0.540000] 0x0000007f0000-0x000000800000 : "art"
[    0.540000] 0x000000020000-0x0000007f0000 : "firmware"
[    0.580000] libphy: ag71xx_mdio: probed
[    1.180000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[    1.190000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    1.190000] TCP: cubic registered
[    1.190000] NET: Registered protocol family 17
[    1.200000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.210000] Bridge firewalling registered
[    1.210000] 8021q: 802.1Q VLAN Support v1.8
[    1.230000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    1.240000] Freeing unused kernel memory: 224K (80368000 - 803a0000)
[    2.460000] init: Console is alive
[    2.460000] init: - watchdog -
[    3.920000] usbcore: registered new interface driver usbfs
[    3.920000] usbcore: registered new interface driver hub
[    3.930000] usbcore: registered new device driver usb
[    3.940000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.940000] ehci-platform: EHCI generic platform driver
[    3.950000] ehci-platform ehci-platform: EHCI Host Controller
[    3.950000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    3.960000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    3.990000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    3.990000] hub 1-0:1.0: USB hub found
[    3.990000] hub 1-0:1.0: 1 port detected
[    4.320000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[    4.530000] init: - preinit -
[    5.320000] random: procd urandom read with 8 bits of entropy available
[    8.580000] jffs2: notice: (353) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[    8.610000] mount_root: loading kmods from internal overlay
[   10.540000] SGI XFS with security attributes, no debug enabled
[   10.560000] SCSI subsystem initialized
[   10.570000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   10.580000] ohci-platform: OHCI generic platform driver
[   10.580000] uhci_hcd: USB Universal Host Controller Interface driver
[   10.600000] usbcore: registered new interface driver usb-storage
[   10.840000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   10.850000] block: extroot: not configured
[   10.850000] mount_root: switching to jffs2 overlay
[   10.920000] procd: - early -
[   10.920000] procd: - watchdog -
[   11.840000] procd: - ubus -
[   12.860000] procd: - init -
[   15.540000] NET: Registered protocol family 10
[   15.550000] Key type dns_resolver registered
[   15.660000] RPC: Registered named UNIX socket transport module.
[   15.660000] RPC: Registered udp transport module.
[   15.660000] RPC: Registered tcp transport module.
[   15.670000] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   15.700000] ntfs: driver 2.1.31 [Flags: R/O MODULE].
[   15.790000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   15.830000] fuse init (API version 7.23)
[   15.840000] usbcore: registered new interface driver cdc_acm
[   15.850000] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[   15.860000] usbcore: registered new interface driver cdc_wdm
[   15.860000] Loading modules backported from Linux version master-2015-03-09-0-g141f155
[   15.870000] Backport generated by backports.git backports-20150129-0-gdd4a670
[   15.880000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   15.910000] nf_conntrack version 0.5.0 (956 buckets, 3824 max)
[   15.980000] usbcore: registered new interface driver usbserial
[   15.980000] usbcore: registered new interface driver usbserial_generic
[   15.990000] usbserial: USB Serial support registered for generic
[   16.030000] xt_time: kernel timezone is -0000
[   16.070000] cfg80211: Calling CRDA to update world regulatory domain
[   16.090000] cfg80211: World regulatory domain updated:
[   16.090000] cfg80211:  DFS Master region: unset
[   16.090000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   16.100000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   16.110000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   16.120000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   16.130000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   16.140000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   16.150000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   16.150000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   16.160000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   16.280000] PPP generic driver version 2.4.2
[   16.290000] NET: Registered protocol family 24
[   16.300000] usbcore: registered new interface driver qmi_wwan
[   16.400000] usbcore: registered new interface driver option
[   16.410000] usbserial: USB Serial support registered for GSM modem (1-port)
[   16.470000] ath: EEPROM regdomain: 0x0
[   16.470000] ath: EEPROM indicates default country code should be used
[   16.470000] ath: doing EEPROM country->regdmn map search
[   16.470000] ath: country maps to regdmn code: 0x3a
[   16.470000] ath: Country alpha2 being used: US
[   16.470000] ath: Regpair used: 0x3a
[   16.480000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   16.490000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[   16.490000] cfg80211: Calling CRDA for country: US
[   16.520000] cfg80211: Regulatory domain changed to country: US
[   16.520000] cfg80211:  DFS Master region: FCC
[   16.520000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   16.530000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   16.540000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 1700 mBm), (N/A)
[   16.550000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2300 mBm), (0 s)
[   16.560000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   16.570000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   27.290000] device eth0 entered promiscuous mode
[   27.290000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   27.600000] eth0: link up (10Mbps/Full duplex)
[   27.600000] br-lan: port 1(eth0) entered forwarding state
[   27.610000] br-lan: port 1(eth0) entered forwarding state
[   27.640000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   29.610000] br-lan: port 1(eth0) entered forwarding state
[   30.720000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
[   30.730000] device wlan0-1 entered promiscuous mode
[   30.730000] br-lan: port 2(wlan0-1) entered forwarding state
[   30.740000] br-lan: port 2(wlan0-1) entered forwarding state
[   30.830000] br-lan: port 2(wlan0-1) entered disabled state
[   31.450000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   32.910000] wlan0: authenticate with 64:66:b3:47:56:cd
[   32.930000] wlan0: send auth to 64:66:b3:47:56:cd (try 1/3)
[   32.930000] wlan0: authenticated
[   32.950000] wlan0: associate with 64:66:b3:47:56:cd (try 1/3)
[   32.950000] wlan0: RX AssocResp from 64:66:b3:47:56:cd (capab=0x431 status=0 aid=5)
[   32.960000] wlan0: associated
[   32.960000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   35.000000] br-lan: port 2(wlan0-1) entered forwarding state
[   35.000000] br-lan: port 2(wlan0-1) entered forwarding state
[   35.010000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
[   37.000000] br-lan: port 2(wlan0-1) entered forwarding state
[   53.790000] random: nonblocking pool is initialized
[   55.750000] usbserial_generic 1-1:1.0: The "generic" usb-serial driver is only for testing and one-off prototypes.
[   55.760000] usbserial_generic 1-1:1.0: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
[   55.770000] usbserial_generic 1-1:1.0: generic converter detected
[   55.780000] usb 1-1: generic converter now attached to ttyUSB0
[   55.780000] usbserial_generic 1-1:1.1: The "generic" usb-serial driver is only for testing and one-off prototypes.
[   55.790000] usbserial_generic 1-1:1.1: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
[   55.800000] usbserial_generic 1-1:1.1: generic converter detected
[   55.810000] usb 1-1: generic converter now attached to ttyUSB1
[   55.810000] usbserial_generic 1-1:1.2: The "generic" usb-serial driver is only for testing and one-off prototypes.
[   55.820000] usbserial_generic 1-1:1.2: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
[   55.830000] usbserial_generic 1-1:1.2: generic converter detected
[   55.840000] usb 1-1: generic converter now attached to ttyUSB2
[   60.470000] 3g-wan: renamed from ppp0

I am not getting the dmesg:

[426955.836000] option 1-1.2:1.0: GSM modem (1-port) converter detected
[426955.844000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB0
[426955.860000] option 1-1.2:1.1: GSM modem (1-port) converter detected
[426955.868000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB1
[426955.884000] option 1-1.2:1.2: GSM modem (1-port) converter detected
[426955.892000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB2
[426955.908000] option 1-1.2:1.3: GSM modem (1-port) converter detected
[426955.916000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB3
[426955.936000] scsi17 : usb-storage 1-1.2:1.4
[426956.940000] scsi 17:0:0:0: CD-ROM            HSDPA    CDROM Storage    2.31PQ: 0 ANSI: 2
[426956.948000] scsi 17:0:0:0: Attached scsi generic sg0 type 5
[426956.960000] scsi 17:0:0:1: Direct-Access     HSDPA    MMC Storage      2.31PQ: 0 ANSI: 2
[426956.968000] sd 17:0:0:1: Attached scsi generic sg1 type 0
[426956.992000] sd 17:0:0:1: [sda] Attached SCSI removable disk

as mentioned in WIKI page.

This is the usb device file:

root@OpenWrt:~# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.20 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=05c6 ProdID=9002 Rev= 0.00
S:  Manufacturer=Qualcomm, Incorporated
S:  Product=Qualcomm CDMA Technologies MSM
C:* #Ifs= 3 Cfg#= 1 Atr=e0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbserial_generic
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbserial_generic
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbserial_generic
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms

Regards,
Sowmya

(Last edited by sowmyabr on 29 Apr 2016, 14:37)

The script is restarting because the connection is being dropped:

Sat Apr 23 13:50:14 2016 daemon.notice pppd[5166]: Connect: 3g-wan <--> /dev/ttyUSB2
Sat Apr 23 13:50:45 2016 daemon.warn pppd[5166]: LCP: timeout sending Config-Requests
Sat Apr 23 13:50:45 2016 daemon.notice pppd[5166]: Connection terminated.
Sat Apr 23 13:50:45 2016 daemon.warn pppd[5166]: Receive serial link is not 8-bit clean:
Sat Apr 23 13:50:45 2016 daemon.warn pppd[5166]: Problem: all had bit 7 set to 0
Sat Apr 23 13:50:46 2016 daemon.notice pppd[5166]: Modem hangup
Sat Apr 23 13:50:46 2016 daemon.info pppd[5166]: Exit.

I do not know how to resolve the error you are receiving however, sorry.

Hello John,

Thank you for the reply.
Yes I understood the restart is due to the connection issue. If I ping using AT command, I am getting success response.
Right now I am unable to interface the 3G over WAN.

Here is the /etc/config/network file:

config interface 'lan'
        option ifname 'eth0'
        option '_orig_ifname' 'eth0 wlan0'
        option '_orig_bridge' 'true'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto '3g'
        option service 'umts'
        option device '/dev/ttyUSB2'
        option apn 'airtelgprs.com'
        option dialnumber '*99#'
        option type 'bridge'

This is the wireless configuration:

root@OpenWrt:/# cat /etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'platform/ar933x_wmac'
        option htmode   HT20
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        # REMOVE THIS LINE TO ENABLE WIFI:
        option country "US"

config wifi-iface
        option device "radio0"
        option mode "ap"
        option ssid "OpenWRT"
        option encryption "psk2"
        option key "password"
        option network "lan"
        option maxassoc "2"

I do not have the devices in /etc/usb-mode.json which contains message content.
This is the output of lsusb :

Bus 001 Device 002: ID 05c6:9002 Qualcomm, Inc. Gobi Wireless Modem

I added the product and vendor id in rc.local and /etc/usb-mode.json but without message content.
Do I have to add message content for the data connection?

Try it like this;

config interface 'wan'
        option proto '3g'
        option service 'umts'
        option device '/dev/ttyUSB0'
        option apn 'airtelgprs.com'
        option dialnumber '*99#'
        option type 'bridge'

My USB-modem has its' data I/O only at /dev/ttyUSB0, all other /dev/ttyUSBx devices are for control and diagnostics.

(Last edited by booBot on 27 Apr 2016, 17:43)

I changed the USB port to /ttyUSB0 and checked , still the connection is not up. For me, only USB1 and USB2 are working for AT commands transfer.

Update: I checked with gcom command with different USB ports 0/1/2.
USB port 1 and 2 are working bu when I execute with USB0 the result is as below:

root@OpenWrt:/# gcom info -d /dev/ttyUSB0
##### Wireless WAN Modem Configuration #####
Product text:
====

====
Manufacturer:           IMEI and Serial Number: comgt 12:38:02 -> -- Error Report --
comgt 12:38:02 -> ---->                       ^
comgt 12:38:02 -> Error @776, line 45, String is shorter than second argument. (7)

root@OpenWrt:/#

(Last edited by sowmyabr on 28 Apr 2016, 14:16)

sowmyabr, did you try to let it connect with /dev/ttyUSB0?

Yes I tried but getting timeout error for the 1st command which is in chat script. I think I am missing the usbmode data which has to be in /etc/usb-mode.json file.

The output of lsusb is:

root@OpenWrt:/# lsusb
Bus 001 Device 004: ID 05c6:9002 Qualcomm, Inc. Gobi Wireless Modem
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The vendor and product ID of 05c6:9002 device is not listed in usbmode.json file. Can this be the reason to not able to connect?

(Last edited by sowmyabr on 28 Apr 2016, 14:03)

Does you modem support this command?:

at^setport?

You could also look here for an idea of how to pre-configure your modem.

AT^SETPORT

or equivalent AT command is supported in this modem.
I have tested the modem with windows PC and I just configured PDP and dial numner and it is able to connect from PC.

Do we get log message when the usb acts as a MODEM?

Sorry, I do not know.

Hi All,

Sorry to ask out of context question !!

I want to know
1. How to execute AT commands on /dev/ttyUSBx through terminal and c code ( as there is a space crunch in my router and i can't install extra package)
2. How to know which particular /dev/ttyUSBx should be used ( because with different dongle like CDMA and GSM dongle, i have to use different different ttyUSBx).

Thanks in advance smile

The discussion might have continued from here.