OpenWrt Forum Archive

Topic: DGND3700 5Ghz wifi not working

The content of this topic has been archived on 14 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have a Netgear DGND3700 that I have been using Barrier Breaker's generic firmware brcm63xx successfully.  However, when I flashed firmware for Chaos Calmer for a brcm63xx for DGND3700v1 I ran into a problem.  I cannot get the 5Ghz network to switch from 'Wireless is disabled or not associated'.  If anyone could help, I would greatly appreciate it.

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/ssb0:0'
        option txpower '20'
        option country '00'

config wifi-iface
        option device 'radio0'
        option ssid 'AwesomeNetwork2.4'
        option key [REDACTED]
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:02.0/ssb1:0'
        option country '00'
        option txpower '30'
        option hwmode '11a'
        option channel '100'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option encryption 'psk2'
        option key [REDACTED]
        option ssid 'AwesomeNetwork5'
        option network 'lan'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd69:fb4d:9793::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.8.1'
        option _orig_ifname 'eth0.1 wlan0 radio1.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '1 2 3 4 8t'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '0 8t'

I also noticed that the wireless that is working is designated wlan0 and the one that isn't working is radio1.network1.  Not sure if this is a cause or symptom.

It doesn't seem like anyone knows the answer to my question.  Should I submit a bug report and downgrade back to Barrier Breaker?  Any help would be greatly appreciated.

I have also discovered that the 2.4 Ghz wifi has been somewhat unreliable since upgrading to Chaos Calmer.  It tends to intermittently disconnect devices.

Hi, I've made some tests. You're right, for some reason sometimes the 5G wifi radio gets disabled by itself when configuring the interfaces. However after restarting the router, both wifi radios 5G and 2G apparently are enabled and working again (I didn't try to connect stuff to them).

About stability, well the b43 drivers are reverse engenireed code.

The Barrier Breaker firmware posted at the wiki you used previously, uses the propietary wl drivers. There are also some problems with them. You could also test the wl drivers under Chaos Calmer, first remove kmod-b43 and wpad-mini, then install wlc, nas, and kmod-brcm-wl drivers. But don't expect they will work, or work fine.



Edit: more tests reveals that some 5G channels won't work. For example channel 100 doesn't work, channel 36 works.

The wifi config I used for tests:

root@OpenWrt:/# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/ssb0:0'
        option txpower '20'
        option country '00'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'OpenWrt-2G'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:02.0/ssb1:0'
        option hwmode '11a'
        option country '00'
        option txpower '20'
        option channel '36'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'OpenWrt-5G'

Regards.

(Last edited by danitool on 3 Dec 2015, 18:07)

danitool wrote:

Hi, I've made some tests. You're right, for some reason sometimes the 5G wifi radio gets disabled by itself when configuring the interfaces. However after restarting the router, both wifi radios 5G and 2G apparently are enabled and working again (I didn't try to connect stuff to them).

I was able to enable my 5G but could never connect.

danitool wrote:

The Barrier Breaker firmware posted at the wiki you used previously, uses the propietary wl drivers. There are also some problems with them. You could also test the wl drivers under Chaos Calmer, first remove kmod-b43 and wpad-mini, then install wlc, nas, and kmod-brcm-wl drivers. But don't expect they will work, or work fine.

After doing this both work for me, however 5G seems to go awol on uploads from clients. After this luci slows and is almost completely unusable.
The console a little better but still slow.The other 2G interface seems to still be fine at this point so traffic is still flowing through that.
The only way it seems stable is if I set the 5G mode to 'legacy' in luci so I have "option hwmode '11a'" in config/wireless.

The discussion might have continued from here.