1 (edited by souravndp 2015-09-12 23:59:54)

Topic: support for TL-WR841N v10

I am a newbie and noticed that there is a page for my router here(http://wiki.openwrt.org/toh/tp-link/tl-wr841nd).

It has images for  hardware version v3  to v9. In 2015 TP-LINK released v10 and v11.

Can anyone help me to get firmware image for my version?

Thank you.

Re: support for TL-WR841N v10

Did any one found OpenWRT BIN File working for TP Link WR841n V10 or TP Link WR841nd V10 I tried to Upgrade the TP Link Router Firmware to OpenWRT Built for WR841n V9 But, the TP Link Web Interface Gives Below listed error when trying to Upgrade I tried Changing the Name of the OpenWRT BIN File to same as TP Link Firmware File Names But this did not helped and I tried it in both Google Chrome and Internet Explorer and Physically I see their seems to be no difference at all between WR841n v9 and WR841n V10.

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

Re: support for TL-WR841N v10

lohchab1 wrote:

I tried Changing the Name of the OpenWRT BIN File to same as TP Link Firmware File Names But this did not helped

Did you rename it to "wr841nv10_wr841ndv10_en_3_16_9_up_boot(150310).bin" or anything else?

Re: support for TL-WR841N v10

Yes, I tried the same and also tried to Change it to different combinations like Changing the Version Numbers in the Filename. Was you able to Run OpenWRT Firmware on v10 of TP LINK WR841n v9

Re: support for TL-WR841N v10

lohchab1 wrote:

Was you able to Run OpenWRT Firmware on v10 of TP LINK WR841n v9

I have v10 but I didn't try to run it because it is not officially supported. That's why I posted the question here to know if it is possible to use v9 firmware.

Re: support for TL-WR841N v10

ok, Request you to also post the results here if you get any success in running OpenWRT or some other Firmwares on v10

Re: support for TL-WR841N v10

You should also try to Write down the Mail to the OpenWRT Developers at juhosg@openwrt.org,
kaloz@openwrt.org So, They could come up with the Firmware that support v10 and could help the community at large.

Re: support for TL-WR841N v10

lohchab1 wrote:

You should also try to Write down the Mail to the OpenWRT Developers at juhosg@openwrt.org,
kaloz@openwrt.org So, They could come up with the Firmware that support v10 and could help the community at large.

Thank you very much. smile You also let me know if you get any success.

9 (edited by lohchab1 2015-09-18 15:53:37)

Re: support for TL-WR841N v10

Hi,

After lots of Testing full day, I thought to Built the support for the new TP Link Model Myself by Downloading the Sources and Here is the OpenWRT for TP LINK WR841 v10 its fully supported You can download from Below listed Link.

http://www.megafileupload.com/dyhP/OpenWRT-WR841v10.bin

Incase, You face any problem in upgrading try to rename the File Name to tplink.bin or incase there is any issue feel free to post here would be happy to help.

--
Nitin
New Delhi, India

[Sorry as of now you will not be able to Upload the Bin File through the TP LINK Official Firmware Web Interface Refer to my Post Below in this thread to see how you can Upgrade easily through the tFTP Method.]

Re: support for TL-WR841N v10

I have tried to upgrade this version with no succes. Still receiving the Error Message even renaming to tplink.bin. Where are you hosting the source code?

Arturo.

11 (edited by lohchab1 2015-09-18 16:15:50)

Re: support for TL-WR841N v10

The Firmware Image I uploaded contains incorrect Checksum that's why you are unable to Upload the BIN file through the Web Interface of TP LINK Official Firmware.

Follow Below Listed Steps to Upgrade to OpenWRT

1. Change your Computer Ethernet Interface IP Address to "192.168.0.66" (its compulsary else it will not work)
2. Download TFTP Server on your Computer from Here http://tftpd32.jounin.net/download/Tftp … -setup.exe
3. Download OpenWRT Firmware for WR841n v10 from here http://www.megafileupload.com/dyhP/OpenWRT-WR841v10.bin
4. Rename the Downloaded OpenWRT Firmware Filename to "wr841nv10_tp_recovery.bin"
5. In TFTPd32 Software Set your "Current Directory" path to same Folder Location where you have saved "wr841nv10_tp_recovery.bin"
6. Now Plug the CAT5 Cable Connected to Your Computer to Port 1 of TP LINK WR841n v10
7. Now Keep Holding the "WPS/Reset" Button on Back of your Router and at same time Press the Switch ON Button Now wait for 10 Seconds and Release the "WPS/Reset" Button.
8. Your Router is Now being Upgraded to OpenWRT Firmware and in about a Minute when Successfully Upgraded You will see 3 Lights in your Router Power, Port 1 LED & Lock LED.
9. Now change your Computer IP Address to "192.168.1.66" and You can now access the OpenWRT as Usual Open the Command Prompt on Windows and Type "telnet 192.168.1.1" and Now OpenWRT Screen would come up and you can execute any commands as usual and refer to the Official OpenWRT Wiki/Documentation regarding the configurations You can also access the OpenWRT Luci Web Interface at http://192.168.1.1

Hope this helps, This is working perfectly I am using OpenWRT on TL-WR841n v10

Re: support for TL-WR841N v10

Is it possible to correct the checksum?. I am afraid I might brick my router.

Re: support for TL-WR841N v10

@lohchab1,

Many thanks for compiling this version. I used the exact procedure above described and openwrt is working like a charm. I am new to this forum but I think this should be posted in the wr841 page so that if any person has to deal with v10 can receive the right info.

Saludos desde Argentina!

Re: support for TL-WR841N v10

I have also observed that When OpenWRT is Installed on WR841n v10 Only Internal Antenna Seems to be Working External Antennas do not work Due to which It gives very Low Coverage/Range.

Help would be appericiated, if some developers can look into it I have simply Compiled OpenWRT Chaos Calmer built for v9 and Have Simply Changed it to v10 So, Hardware Version do not mismatch which would prevent the upgradation process from TP Link Firmware to OpenWRT everything else seems to be working perfectly in v10 Just Coverage is very low..

I have both v9 and v10 and Have observed v10 has 50% less coverage when OpenWRT is Installed on it.. I have tried to Set TX and RX Antennas in Wireless Configuration of OpenWRT But that Did not helped..

Re: support for TL-WR841N v10

Hello everybody
Any news about the antenna issue in v10?
thanks!

Re: support for TL-WR841N v10

pbelotti wrote:

Hello everybody
Any news about the antenna issue in v10?
thanks!

No, We are still waiting for someone to fix the issue..

Re: support for TL-WR841N v10

I would like to suggest that someone add or edit the ToH for V10.
http://wiki.openwrt.org/toh/start?dataflt[Model*~]=WR841n

It does not need to be supported to be included, but will help other understand and communicate the status.

PC-Engines ALIX 2D13 CC 15.05 RC2 (Router - OpenVPN Server)
HooToo TM02 CC 15.05 (Travel Router - OpenVPN Client)
GLi-AR150 CC15.05/GLi 2.13 (Travel Router - OpenVPN Client)
Kingston MLWG2 CC15.05 (Travel Router - OpenVPN Client, mini-DLNA)

Re: support for TL-WR841N v10

https://forum.openwrt.org/viewtopic.php … 82#p296982

19 (edited by erz 2015-10-22 18:14:46)

Re: support for TL-WR841N v10

What about this ?

https://github.com/freifunk-gluon/gluon … r.-2.patch

Sorry for posting it two times, I started a topic before reading this.

-------------------------------------------

https://forum.openwrt.org/viewtopic.php … 58#p297058

Re: support for TL-WR841N v10

Hello lohchab1, the file http://www.megafileupload.com/dyhP/Open … 41v10.bin, no exists. You can reload ? Thank you.

Re: support for TL-WR841N v10

i need a stable firmware for my tplink v10
fix error with external antenna and wifidog
ty and sorry for my bad english

Re: support for TL-WR841N v10

Double-check that you have entered the desired address (the printenv displays the address). Check that your server is on port 69 (default port). Now load the firmware via TFTP. I've read about this device http://www.routerstop.com/tp-link-n300- … er-review/ but I can't understand why people buy such a "weak" routers...

Re: support for TL-WR841N v10

diemme47 wrote:

i need a stable firmware for my tplink v10
fix error with external antenna and wifidog
ty and sorry for my bad english

if you cant speak english then this might not the place for you.
so far router has defect