OpenWrt Forum Archive

Topic: HELP, I Get IPv6 from ISP: WAN, PC by RADVD, but no IPv6 navigation

The content of this topic has been archived on 22 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey Guys. I need some help regarding IPv6 on Luci.

I have a D-link DSL-2750E and I am receiving IPv6 from my ISP normally. I connect to wifi and I am able to surf on IPv6 websites.

However, I am using a TP-Link TL-WA901ND V3 with LuCI Trunk (0.12+svn-r10530) OpenWrt Barrier Breaker 14.07 as a range extender with a second SSID, where I receive IPv4 and IPv6 from the DSLmodem on wireless WAN, and I have another SSID Wifi on LAN2 (I use lan 1 for cable connection).

I had to configure 2 WANs, one DHCP Client IPv4, and another one with DHCPv6 client. After that, I receive IPv6 from my ISP on both WANs on OpenWRT.  I was able to use the same prefix on RADVD and I am getting IPv6 on my computers.

But this IPv6 is not forwarded to my LANs. I get a different IPv6 based on my Global network options IPv6 ULA-Prefix fd04:xxxx:xxxx::/64 on LAN in OpenWRT and on my computers.

http://s23.postimg.org/4d1k6b80n/Screen_Shot_2015_08_30_at_3_00_14_PM.jpg

IPv6 test shows no IPv6 connectivity, and I don't receive DNSv6 on my devices too.  I would like to have IPv6 since the websites we browse most are already IPv6 Enabled.

I keep receiving this log over and over again

"Sun Aug 30 19:38:39 2015 daemon.warn odhcpd[709]: A default route is present but there is no public prefix on br-lan thus we don't announce a default route!
Sun Aug 30 19:38:39 2015 user.notice firewall: Reloading firewall due to ifupdate of Wan6 (wlan0)"

I have read forums and coding configurations but I would like to do this simply on luci, is it possible to configure this on the web based configuration?

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd04:895b:XXXX::/64'

config interface 'lan'
    option ifname 'eth0'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'lan2'
    option proto 'static'
    option ifname 'lan2'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
    option type 'bridge'
    option ip6assign '64'

config interface 'Wan6'
    option proto 'dhcpv6'
    option reqaddress 'try'
    option reqprefix 'auto'
    option macaddr '2D:CA:3C:21:71:0E'

config interface 'WWAN6'
    option proto 'dhcp'
    option hostname 'Openwrt'




config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option ra 'server'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp
    option start '100'
    option leasetime '12h'
    option limit '150'
    option interface 'lan2'
    option ra 'hybrid'
    option dhcpv6 'hybrid'
    option ra_management '1'


config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan lan2'

config zone
    option name 'wan'
    option output 'ACCEPT'
    option masq '1'
    option mtu_fix '1'
    option input 'ACCEPT'
    option forward 'ACCEPT'
    option network 'wan wan6 wwan WWAN6 Wan6'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'


config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar934x_wmac'
    option disabled '0'
    option channel '6'
    option htmode 'HT40'
    option country 'BR'
    option txpower '20'

config wifi-iface
    option ssid 'WIFI 2750E'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid '70:62:B8:C2:79:11'
    option key 'xxxxXXXX'
    option macaddr '48:08:E8:79:35:29'
    option network 'Wan6 WWAN6'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option network 'lan2'
    option encryption 'psk-mixed'
    option key 'xxxxxxXXxxx'
    option ssid 'WIFI OpenWRT '


I have attached the LAN configuration and Firewall printscrens because I use luci.

http://s6.postimg.org/3qmn7l0il/Screen_Shot_2015_08_30_at_3_26_59_PM.jpg

http://s6.postimg.org/8dsp9cnvh/Screen_Shot_2015_08_30_at_3_27_15_PM.jpg

http://s6.postimg.org/dqhjnhbrx/Screen_Shot_2015_08_30_at_3_27_21_PM.jpg

http://s6.postimg.org/q7o7an6xp/Screen_Shot_2015_08_30_at_3_27_32_PM.jpg

http://s6.postimg.org/9lb8fb3dp/Screen_Shot_2015_08_30_at_3_42_50_PM.jpg

http://s6.postimg.org/3lnhbnil9/Screen_Shot_2015_08_30_at_3_43_08_PM.jpg

(Last edited by pauloavilaneto on 31 Aug 2015, 20:11)

UPDATE: I have installed RADVD for luci already, and it didn't seem to work either.
I have put the values for the Advertised IPv6 prefixes, 2804:D59:A17:900::/64, routes, and RDNSS. AND I GET IPv6 on my computer, a router and a DNS Server v6 as the image shows, Still I don't have IPv6 navigation, since if I deactivate IPV4 I can't access google for exemple, or IPv6 Test does not pass.

http://s6.postimg.org/4yetoebq5/Screen_Shot_2015_08_30_at_8_54_41_PM.jpg

http://s6.postimg.org/4obwismhp/Screen_Shot_2015_08_30_at_8_59_44_PM.jpg

http://s6.postimg.org/xpg8s76xp/Screen_Shot_2015_08_30_at_8_56_36_PM.jpg

config interface
    option AdvSendAdvert '1'
    list client ''
    option ignore '0'
    option interface 'lan2'
    option IgnoreIfMissing '1'
    option AdvSourceLLAddress '1'
    option AdvDefaultPreference 'medium'

config route
    option AdvRoutePreference 'medium'
    option interface 'lan2'
    option ignore '0'
    list prefix '2804:D59:A17:900::/64'

config rdnss
    option ignore '0'
    option interface 'lan2'
    list addr '2804:D59:A17:900::/64'

config dnssl
    list suffix ''
    option interface 'lan2'
    option ignore '1'

config rdnss
    option ignore '1'

config prefix
    option interface 'lan2'
    option AdvOnLink '1'
    option AdvAutonomous '1'
    option ignore '0'
    list prefix '2804:D59:A17:900::/64'

config interface
    option ignore '0'
    option interface 'Wan6'
    option IgnoreIfMissing '1'
    option AdvSendAdvert '1'
    option AdvManagedFlag '1'
    option AdvOtherConfigFlag '1'
    option AdvSourceLLAddress '1'
    option AdvDefaultPreference 'medium'

(Last edited by pauloavilaneto on 31 Aug 2015, 02:13)

Help Anyone?

The discussion might have continued from here.