OpenWrt Forum Archive

Topic: openwrt Barrier Breker 14.07 on TL-WR703n client mode

The content of this topic has been archived on 15 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi

I'm an Italian student of electrical engineering and I hope that my English is enough to ask for help here big_smile

I have a big problem with my router.
I can't configure the router like client mode, I read the openwrt page of this topic and I configure the router like explain in the openwrt wiki page but it doesn't work...it doens't catch my home router that it is connect to internet.
my goal is communicate with my TL-WR703n from all over the world through internet connection

does anyone know how to help me?

thanks

Try set and up it as Client WDS

Please, post your config. files and logs here.

this is my firewall config:

config defaults
    option syn_flood    1
    option input        ACCEPT
    option output        ACCEPT
    option forward        REJECT
# Uncomment this line to disable ipv6 rules
#    option disable_ipv6    1

config zone
    option name        lan
    list   network        'lan'
    option input        ACCEPT
    option output        ACCEPT
    option forward        ACCEPT

config zone
    option name        wan
    list   network        'wan'
    list   network        'wan6'
    option input        REJECT
    option output        ACCEPT
    option forward        REJECT
    option masq        1
    option mtu_fix        1

config forwarding
    option src        lan
    option dest        wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
    option name        Allow-DHCP-Renew
    option src        wan
    option proto        udp
    option dest_port    68
    option target        ACCEPT
    option family        ipv4

# Allow IPv4 ping
config rule
    option name        Allow-Ping
    option src        wan
    option proto        icmp
    option icmp_type    echo-request
    option family        ipv4
    option target        ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
    option name        Allow-DHCPv6
    option src        wan
    option proto        udp
    option src_ip        fe80::/10
    option src_port        547
    option dest_ip        fe80::/10
    option dest_port    546
    option family        ipv6
    option target        ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
    option name        Allow-ICMPv6-Input
    option src        wan
    option proto    icmp
    list icmp_type        echo-request
    list icmp_type        echo-reply
    list icmp_type        destination-unreachable
    list icmp_type        packet-too-big
    list icmp_type        time-exceeded
    list icmp_type        bad-header
    list icmp_type        unknown-header-type
    list icmp_type        router-solicitation
    list icmp_type        neighbour-solicitation
    list icmp_type        router-advertisement
    list icmp_type        neighbour-advertisement
    option limit        1000/sec
    option family        ipv6
    option target        ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
    option name        Allow-ICMPv6-Forward
    option src        wan
    option dest        *
    option proto        icmp
    list icmp_type        echo-request
    list icmp_type        echo-reply
    list icmp_type        destination-unreachable
    list icmp_type        packet-too-big
    list icmp_type        time-exceeded
    list icmp_type        bad-header
    list icmp_type        unknown-header-type
    option limit        1000/sec
    option family        ipv6
    option target        ACCEPT

# include a file with users custom iptables rules
config include
    option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#    option src        lan
#    option src_ip    192.168.45.2
#    option dest        wan
#    option proto    tcp
#    option target    REJECT

# block a specific mac on wan
#config rule
#    option dest        wan
#    option src_mac    00:11:22:33:44:66
#    option target    REJECT

# block incoming ICMP traffic on a zone
#config rule
#    option src        lan
#    option proto    ICMP
#    option target    DROP

# port redirect port coming in on wan to lan
#config redirect
#    option src            wan
#    option src_dport    80
#    option dest            lan
#    option dest_ip        192.168.16.235
#    option dest_port    80
#    option proto        tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#    option src        wan
#    option src_dport    22001
#    option dest        lan
#    option dest_port    22
#    option proto        tcp

# allow IPsec/ESP and ISAKMP passthrough
#config rule
#    option src        wan
#    option dest        lan
#    option protocol        esp
#    option target        ACCEPT

#config rule
#    option src        wan
#    option dest        lan
#    option src_port        500
#    option dest_port    500
#    option proto        udp
#    option target        ACCEPT

### FULL CONFIG SECTIONS
#config rule
#    option src        lan
#    option src_ip    192.168.45.2
#    option src_mac    00:11:22:33:44:55
#    option src_port    80
#    option dest        wan
#    option dest_ip    194.25.2.129
#    option dest_port    120
#    option proto    tcp
#    option target    REJECT

#config redirect
#    option src        lan
#    option src_ip    192.168.45.2
#    option src_mac    00:11:22:33:44:55
#    option src_port        1024
#    option src_dport    80
#    option dest_ip    194.25.2.129
#    option dest_port    120
#    option proto    tcp

this is my network config:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd2b:a4c1:3e80::/48'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option _orig_ifname 'eth0 wlan0'
    option _orig_bridge 'true'
    option proto 'dhcp'

this is my wireless config:

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

and i tried with WDS connection but my AP router not is flashed with openwrt.

mattia952 wrote:

and i tried with WDS connection but my AP router not is flashed with openwrt.

If you have LuCi interface I'll walk you through
If you don't have LuCi and have space, download & install
opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
If you can't read OpenWrt → Community Documentation → Repeater configurations here! Both ways, bridged and simple repeater
https://forum.openwrt.org/viewtopic.php?id=39077

I tried to follow the instructions of LuCI but my router does not connect to the access point

I asked a simple question
Do you have LuCi
And you answered about connecting to AP
Either you never connected via Lan cable to Internet or you don't have space to install LuCi
If you answer I will understand and will be able to help
And if you flashed BB 14.07 as you post you have LuCi web interface, unless you did not download your file from OpenWrt web

(Last edited by danymarc on 18 Aug 2015, 12:44)

Yes, I have LuCI in but flashed router and I connect with the lan to set router

(Last edited by mattia952 on 20 Aug 2015, 10:11)

mattia952 wrote:

Yes, I have LuCI in ma flashed router and I connect with the lan to set router

by default OpenWrt is a router, wifi is disable, enable it, and set password, test your router even if you dont have internet you will be able to connect, once that done, go TO Network tab and Wi-Fi to on the right click Scan it will open a new window, select network click join thena new window will open, on first line there is a ticked box, see screenshot, untick it, ITS IMORTANT as you see in screenshot, nect lne, input password from network you joined, bellow click Submit, next window you can check your setings, nothing to do just SAVE & APPLY, wait about a minute you should have internet wireless and cabled.
http://s9.postimg.org/4etlfbtcf/image.jpg
subir imagenes gratis

(Last edited by danymarc on 3 Sep 2015, 20:02)

Ok but how to set wan and wan6 ?

I follow the instruction to set router in the repeater mode here https://forum.openwrt.org/viewtopic.php?id=39077 ,
because in my project is sufficient this mode but doesn't work!

for my project is sufficient that my router is remotely accessible with the internet connection, if I know the client IP adress

(Last edited by mattia952 on 20 Aug 2015, 10:23)

The discussion might have continued from here.