OpenWrt Forum Archive

Topic: TP-LINK TD-W8980 support ( atheros based )

The content of this topic has been archived between 28 Apr 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Does anyone have a working image for OpenWRT with 2.4GHZ working? if so could you please link me to it. Thank you.

Here is firmware I've build _for myself_ some time ago. I am making this very clear because this firmware contains many packages you probably don't need and there is not so much free space left. Also, it contains updated VDSL drivers and modified connect script to test line parameters auto-detection. It works for me. If it works for you then good, if not then you are unfortunately on your own. I've tested it with DSL firmware 5.7.4.3.0.6-5.7.1.8.0.1 (you can get instructions how to get it from Martin's repository https://xdarklight.github.io/lantiq-xdsl-firmware-info/ ) FW-cutter util is striped from the image so you need to use following command to flash it to firmware partition
tar cvz firmware_file.bin > /dev/mtd4
then you need to make sure that symlink to from /lib/firmware/lantiq/firmware_file.bin to /lib/firmware/vdsl.bin exists

Please note that is not the latest trunk version because for some reason it causes significant issues with wireless for me.
EDIT: this image in longer available. See my post below for updated version.

Please do not ask me for further support as I most likely will not be able to provide it. I am not even using this image anymore.

EDIT: This image is stripped from ATM support (ADSL). It supports PTM (VDSL) only

(Last edited by olewales on 17 Jul 2015, 03:05)

Thank you!

Edit: Just noticed the ATM striped bit. I use ADSL so this won't be any good. Will wait till it becomes supported i guess thanks any how!

(Last edited by hacktrix2006 on 12 Jul 2015, 20:54)

Ok, wifi seems to work fine again so I've build stock version. Only changes I've made to standard config are add LuCI, apply Martin Blumenstingl's patch updating VDSL components to latest version and patch wifi. I did some basic tests on this image but I cannot guarantee anything. It booted on my hardware and wireless seemed to be working fine
Image build from revision 46384.
https://www.dropbox.com/sh/ee2dmzd7jbki … SAAca?dl=0

Thank you olewales.

I tried everything in your previous replies. ADSL managed to sync once and since a reboot will not sync up anymore.

WiFi works and so does lan.

Oh well thanks once again bud will keep on trying to get ADSL to sync up.

Going to reflash your image via TTL again and start clean. i must really be missing something


Update: Ok ADSL Syn's each time, was my fault why it wasn't all i had to do was rename the cpe file to vdsl.bin and boom it will sync.

However my next issue is it will not connect at all to the internet which will be a networking config issue.


Now my current config is

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd5a:6d4f:d48d::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0.1'
    option macaddr 'e8:de:27:41:ee:5e'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 4 5 6t'

config atm-bridge 'atm'
    option payload 'bridged'
    option vci '38'
    option vpi '0'
    option encaps 'vc'
    option atmdev '0'

config interface 'wan'
    option _orig_ifname 'nas0'
    option _orig_bridge 'false'
    option proto 'pppoa'
    option encaps 'vc'
    option atmdev '0'
    option vci '38'
    option vpi '0'
    option username 'xxxxxxxxxxxxxxxxxx'
    option password 'xxxxxxx'
    option ipv6 'auto'
    option mtu '1492'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'atm'

and i am not sure where i am going wrong. WiFi and Lan works and pings but the internet connection doesn't any help would be gratefully received.

(Last edited by hacktrix2006 on 17 Jul 2015, 15:08)

Configuration is highly dependent on your ISP. For a start I'd check system log for any obvious misconfiguration. I use VDSL so my config is quite a bit different and probably wont be much help here. Is your ISP providing you with IPv6 address? If not then you might want to set option ipv6 to '0'

I assume you did basic checks like making sure you are using correct path and channel parameters (VPI, VCI) for your ISP and that it is using pppoa encapsulation

(Last edited by olewales on 17 Jul 2015, 15:57)

Yep VCI and VPI is set to 0/38 which is what DSL in UK is as standard.

Will try at some stage the IPv6 to 0 and see if that helps. Will double and triple check the settings again.

Thanks for the replies though.

hacktrix2006 wrote:

Yep VCI and VPI is set to 0/38 which is what DSL in UK is as standard.

Will try at some stage the IPv6 to 0 and see if that helps. Will double and triple check the settings again.

Thanks for the replies though.

Just a quick sanity check. You said "VCI and VPI is set to 0/38", I believe most UK ISPs have the VPI = 0 and VCI = 38, not the other way around.
An extra check for you.

any chance to get working 5g and increased memory ? Tried to sf  erase up to 0x7b0000 but could not see a change in available memory because loadbalancer with asterisk is not really much space left,... sad

As far as I know 5g support is blocked by 2 separate problems: card not visible not all (something with PCI configuration) and no drivers that works with standard kernel API. I would not expect 5Ghz Wifi support on this device anytime soon (if ever).

What do you mean by increased memory? Could you elaborate on that? There is separate partition in flash dedicated for DSL firmware, but if you are using DSL modem you have to have firmware file somewhere anyway (I am wondering why separate partition model was chosen though, It seems like unnecessary hassle)

Hi,

Before I'll start messing around:
Does any of you tried CC RC3 8970 image ?
Does 2.4GHz radio work out of the box ?
Does striping the firmware file also applies for CC RC3?

Regards

(Last edited by dragongc on 14 Aug 2015, 13:29)

Wifi still needs patching even in trunk so I am afraid it won't work with CC image either.
What do you mean by striping firmware file? You still need to add it manually. License forbids distributing DSL firmware with openwrt.

Thanks for info regarding the WiFi driver.

Forget the firmware part. :-)  I was ranting about the striping U-boot image. But now I can see, I didn't read it correctly (striping from the tp-link image).

One more question - I think I've got TD-W8980_V1_140619 (firmware date 19.06.2014). Does it mean I'm locked ?

Sorry, no experience with that, but wiki article for WD8970 states that you should be fine:

Anyway flashing over serial & bootloader works (tested) with 28.08.2013 version too.

EDIT: I think that devs put that warning on the wiki to keep people on firmware version for which they may eventually support upgrade via http, even though it is not working at the moment.

(Last edited by olewales on 14 Aug 2015, 17:52)

Hello,

Can someone post a description about how to open this device case ?
I'd like to try to connect 2 better antenas for wifi 2.4 but after removing the 4 screws ... it does not seem to be easy to pull up the cover ...

Thank you

It uses the same case as WDR3600/4300/4900 models. Just wedge flat screwdriver where case parts meet on the side and retention clips should let go. On this picture you can see where they are exactly http://content.hwigroup.net/images/prod … dr4300.jpg You don't need to worry about breaking something too much. Plastic used is actually quite durable.
Also, I am sure there are videos on youtube of people doing exactly that

Please post an update if antenna mod improved anything. Since 5Ghz does not work anyway with openWRT I am wondering if swapping 2.4Ghz antenna connections with two of the rear ones would be a good idea.

Thank you. I searched a lot on youtube with a lot of product IDs but not these ones ... and now I found one tutorial.
I will post a return about the results next week I think.
Thanks again.

It's done, the new installation:
https://dl.dropboxusercontent.com/u/328 … GP2454.JPG
https://dl.dropboxusercontent.com/u/328 … GP2455.JPG

There is fan below: this device is so hot even in winter here (rio de janeiro) that i think it will burn in summer ...
Then I used an old broken device: http://www.bewan.fr/produit.php?page=pr … wf-pci300n
I unsoldered the connectors and put them in 2 new holes in the 8980.

About the gain:
- I do have a better signal in the rooms but this may be due to the possibility to orientate the antenas the way I want and have them not so close to the wall.
- I think the internal antenas are not so bad, but just not orientable
- I connected the middle 5GHz 8980 antenna to the middle one of my old device and also gained something.

That's it !

Thank you for your help. Regards.

does anyone has experience on how to bridge modem ( ptm0 ) to lan (eth0.1) or special port I only want to use the device as stupid modem.
My ISP has different vlan for internet and voip and I´m too stupid to get asterisk/pbx running on this device properly,... :-(

Ok finally got it. Working modem-mode for ISP with VLAN for Inet and VOIP wink

Port1 is bridged to modem; Port2/3 is regular lan ; Port4 is configured as wan

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 6t'
    option vid '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'
    option vid '2'

config interface 'Wanlan4'
    option proto 'dhcp'
    option ifname 'eth0.2'

config interface 'wanbrlan1'
    option type 'bridge'
    option proto 'none'
    option ifname 'eth0 ptm0'

config vdsl 'dsl'
    option annex 'b'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'bv'
    option xfer_mode 'ptm'

config atm-bridge
    option atmdev '0'
    option encaps 'llc'
    option payload 'bridged'
    option vci '32'
    option vpi '1'
    option unit '1'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '40'
    option ports '5t 6t'

config interface 'modem'
    option proto 'none'
    option ifname 'ptm0'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option ports '5t 6t'
    option vid '200'

(Last edited by cmoegele on 25 Aug 2015, 00:18)

Hi everyone,
I think I might have bricked my modem. So when I power on the modem all I get is just this in loop:

ROM VER: 1.1.4
CFG 05

ROM VER: 1.1.4
CFG 05

ROM VER: 1.1.4
CFG 05

ROM VER: 1.1.4
CFG 05

I think the issue was I deleted too much (instead of 0x20000 to 0x7a0000, it was 0x7a00000) and unplugged the power cable when it was still deleting.

I have followed bratwurst's guide to unbrick and flashed the image via the uart method, once I power on my modem, the same thing keeps happening.

Did I just broke my bootloader?

Hi all,
i've compiled succesfully an image and flashed my TD-W8980 with ADSL and Wifi (2.4GHz only) working.

I've noticed that the rootfs's size is only 4MB. After installing a pair of packets i've no space left on device.

Flash is 8MB large, but seems to be used only 4MB. Some bug assembling flash image?

Regards

Max

hi all,

could someone pls upload an Image for the TD-W8980 or TD-W9980
THX

(Last edited by b4ngb4ng on 10 Dec 2015, 11:50)

I have 8980B, I need to make it work on Annex A. Is there an easy way to enable it?

Inovator wrote:

I have 8980B, I need to make it work on Annex A. Is there an easy way to enable it?

It depends on your broadband connection. VDSL is (near to?) everywhere Annex B. It works with the Annex A as well as the Annex B version of the 8980.

If your broadband connection is Annex A ADSL, you're out of luck.

I own an Annex A TD-W8980, but I'm living in an Annex B country. I only used the device to add support for the TD-W8980 to OpenWrt
(r47129, r47130)

Depending on shipping costs, it might be an option that to exchange our devices. Please send me a private message if you are interested.