OpenWrt Forum Archive

Topic: Files and install instructions for HooToo HT-TM02 and HT-TM04(RT5350)

The content of this topic has been archived between 29 Mar 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

So I have one of these that i updated to openwrt. Had it set up as a wireless AP, so I can remote between two PC's while working away. Since i set it up, it seems to have suffered some sort of problem. I currently can't get it to boot.
When plugged in it flashes both LED's very briefly, then they both come on steadily forever. I have TFTP'd an upgrade image to it, but it doesn't seem to have helped. Will it auto install or do I have to get in via serial to install it?

Would be great to know, I could do with it working!

So, progress of sorts. If I reboot the router with the reset button held in, it will automatically download an image from a TFTP server at 10.10.10.123, so the uboot bootloader is obviously still in there!

I have a USB-RS232 cable that I have made an adapter for. I can get data out via serial from the unit, but it is all garbage. I have tried all normal baud rates (9600, 19200, 38400, 57600, 115200) but all are garbage. Is this a voltage level thing? I am pretty certain the adapter I have has worked with standard bit bashing serial straight out of a microcontroller in the past.... Any suggestions are welcome!

If it really comes to it I may have to flash the chip once home, what standard is it? I have access to MPLAB ICD's and a JTAG flasher...

Hi all.

I've been working on the HooToo for a few days now. I have a general understanding of networks in general but am having a problem with this device. I tried fiddling around on my own and I feel like I'm very close. All the work I've done is through Luci as I'm terrible at using VI. I'll copy/paste my configs as well to see if that'll help. According to my research, what I wanted done was to do a RoutedAP. I did most of the work on my own without consultation of the Recipes wiki, but it more or less coincides with what's on there. I will probably end up just restarting the config and following the recipe verbatim, just wondering what exactly i'm doing wrong here.

I unbridged the interfaces and made/modified the two interfaces as follows (the two interfaces show up under Network -> Interfaces):
1. Wifi - assigned to the Wireless network I created and is assigned to the LAN firewall zone. Has IP 192.168.25.1 and am able to access web portal over wifi. It is configured as a DHCP server and confirmed it works.

2. WAN - assigned to the eth0 interface and is assigned to the WAN firewall zone. I have it set up as a DHCP client to get an IP from my upstream router. Have confirmed working and can access web portal through hardwire connection.


Under Network -> Firewall I have only 2 zones, WAN & LAN and they correspond to the two interfaces I list above. The two Zone Forwardings I have are:

Lan -> Wan: Input - Accept. Output - Accept. Forward - Reject. Masquerade - 1. MSS clamping 1  (I tried this with nothing checked and all accept as well)
Wan -> LAN: Input - Accept. Output - Accept. Forward - Reject. Masquerade - 0. MSS clamping 0

Under the traffic rules, i kept everything as is, but added two rules:
Name - lan to wan all traffic.
Match - Any traffic From any host in lan to any host in wan
Accept Forward

Name - wan to lan all traffic.
Match - Any traffic From any host in wan to any host in lan
Accept Forward

I'm unable to to get any packet flow upstream or downstream - Can't ping upstream router (192.168.1.1) from wifi client (192.168.25.x). Can't access the internet. Nada. Below are my configs:

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde7:63ca:4ff6::/48'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config interface 'wifi'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.25.1'

config interface 'WAN'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path '10180000.wmac'
        option htmode 'HT20'
        option txpower '20'
        option country '00'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'PortRoute'
        option network 'wifi'
        option encryption 'psk2'
        option key 'Welcome1'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'wifi'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'wifi'

/etc/config/firewall

config rule
        option target 'ACCEPT'
        option src 'lan'
        option dest 'wan'
        option name 'lan to wan all traffic'

config rule
        option target 'ACCEPT'
        option name 'wan to lan all traffic'
        option src 'wan'
        option dest 'lan'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wifi'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option input 'ACCEPT'
        option network 'WAN'
        option forward 'REJECT'

config include
        option path '/etc/firewall.user'

config forwarding
        option dest 'wan'
        option src 'lan'

config forwarding
        option dest 'lan'
        option src 'wan'

For one thing the wan interface needs to be named "wan" not "WAN".

Really you can start from a default configuration.  Configure and enable an AP so you can log into the router via wifi.  Since your wan is 192.168.1.x, set lan IP to 192.168.25.1 like you did.  Log in via wifi and move eth0 from lan to wan.  The wan network and firewall zone should already be set up, there is just no interface attached to it by default on devices with only one ethernet port.

I changed that on the Vi side and had to reapply the zones. After doing that, i was able to ping IPs in the upstream network (192.168.1.x) and even access the HooToo through it's 192.168.1.x address. But I couldn't browse the web or access anything else on the .1.x network from .25.x.

I guess I'll just do what you recommended, though I do feel undefeated and I can't figure out why it was doing that.
Thx for your help.

mk24,
I ended up just doing to reset and reconfiguration and it worked. Sucks I wasn't able to figure out original issue but thanks for help.

Hi everyone, I have a TM05, the 10000 milliamp version, and I'd like to install openWRT on it. I thought that I could use the TM02 image from here, as I found that it uses the same hardware as all the other routers they make. However, when I try to flash the openWRT bin using the factory upgrade, I get the error 'WRONG FILE FORMAT'. Did Hootoo change how updates work on the newer model? I tried renaming the bin to the filename and extension of the hootoo update, but it still didn't accept it. If anyone has played around with it, I'd appreciate the help.

ernvs wrote:

HT-TM03 works with r44945-factory-ws !!!

Install: Don't use an USB-Stick use a micro SD-card instead!

The TM-03 has the same Hardwarebase as TM02 and TM04 and additionally a 3000mAh Lion battery and
a micro SD-card reader.
An USB-stick will be mounted at /data/UsbDisk2/Volume1/ so the Loader will fail.
The micro SD-card will be mounted at /data/USBDisk1/Volume1/ and it works.
I had to manually restart after flashing.

Openwrt works like a charm. LEDs are working right out of the box and I checked lan, wlan-client and wlan-ap.
Thnx very much wingspinner this is now the smallest and smartest mobile router I saw.

Best regards

Your post inspired me to get TM03. I was able to successfully flash the r44945-factory-ws image as well by following your hint of using an empty 4GB micro SD card instead of a USB stick. Thanks! With extroot (note specific Chaos Calmer instructions) enabled on a 128GB micro SD card which I leave permanently installed, I have a pocket sized, very powerful self powered router. With minidlna installed, I can stream my entire music collection with my smartphone or tablet connected to my car's bluetooth. I installed vsftpd to set up an anonymous ftp server to easily share files on the road with my friends. I have other servers and applications installed as well.

Unfortunately, the r4495 kmod package signatures do not match the r44945 kernel signatures so I could not install them. However, the Jun14 build sysupgrade image works fine for me and I downloaded the packages for this build.

Downloading all the packages to a linux machine, installing and running thttpd to serve the packages to your HooToo was easiest way for me to  get all the USB drivers and everything re-installed.

Thanks very much to WingSpinner for the factory images!

"An external antenna is easily installed as it has both a proper impedance matching RF front-end as well as a stripline bandpass filter on the board."

Can you provide any more details on where to tap for an external antenna.  Would really like to try one.

Thanks

How did you open the case of the HT-TM02 ? Where are the "plastic-noses" that have to be clicked: Top, bottom, side ?
I don´t know here to start and I don´t want to break the case.   hmm

By the way: In Germany the HT-TM02 is now sold for 11,-EUR inkl. shipping (~8,-GPB/~12,50USD) here.
(Free shipping seems to be for Germany only, mine took just 2 days to arrive by DHL).

I think I bricked my HT-TM02. Its LEDs are not blinking and I can't telnet on it or ssh. Please help. I'm a newbie on openwrt. TIA

(Last edited by kimboi.neo on 29 Jun 2015, 17:21)

Thank you wingspinner!!

Flashed my TM-02. After a decade of messing around with DD-WRT, playing with OpenWrt on this little device made me feel like a kid.

I performed a sysupgrade and everything is working great, after I installed telnet and fixed the network config to download the packages ... haven't used it in years. I don't get to use telnet at work anymore :0

You're right, this is a great little device. Hard to beat at $15!

(Last edited by s4wrt on 30 Jun 2015, 04:00)

Followed your post to the letter on a TM-02.

Bricked.

Im not new to router hackage so I don't think it's an idiot oversight. I messed around trying to be able to see it via Wireshark and/or send it something(anything) with TFTP to no avail. The dual LED glow at boot shows that some amount of UBoot got on there...the files were indeed copied to my usb drive...

Anywhere I can go from here without a soldering iron?

PS - I am stoked and grateful for your work.  This will likely lead to me buying a soldering iron, however. :/

somehomelessguy

If you hold in the reset button for 30s, or so, while booting you should be able to connect via the ethernet port on ip 198.162.1.1 via telnet if a password was never set, or via ssh if one was.  You will have to set your PC/Laptop ethernet connect to a static ip in the same subnet.

I was able to bridge my ethernet and wireless adapters in my PC to download a sysupdate to the TM02 and load LuCI. Once that was done, I configured it and set it up with the packages I wanted.

(Last edited by s4wrt on 2 Jul 2015, 04:00)

Hi, I have a problem with the change of firmware. Which tool can use to reflash the hootoo. This is the only forum where I found information of this device. Help please!

I appreciate the help @s4wrt but what you said, for clarity' sake for others looking for help, is not accurate.

One, the default login for these devices is in the 10.10.10.* range, not "198.164"

Two, the "sysupgrade" bin that this person made disables the failsafe (holding down button when booting) due to some problems he was having, it states so in the first post - so that's a no-go.

hmm Thank you anyhow, I appreciate the intent

Has anyone tried to update to CC 15.05 RC2, specificaly openwrt-15.05-rc2-ramips-rt305x-ht-tm02-squashfs-sysupgrade.bin? Can you please confirm that LuCi is actualy in the image.  There are some products in RC2 that "misplaced" LuCi (AR71xx and others).

RangerZ

I took some pictures of the HT-TM04 internals.

The flash is a MX25L6406E, the SDRAM is M12L2561616A. There’s a small 8-bit MCU (bottom right corner, Holtek HT66F40) that seems to be handling power management duties; it controls the battery LEDs, power button and most likely hooks into the enable pin(s) of the DCDC converter(s) that power the Realtek SoC.

Unfortunately something is wrong with the SDRAM on my unit, so I haven’t been able to confirm this yet, but I suspect there’s some sort of communication between this MCU and the SoC (I2C maybe?) to report the battery level. Once my new unit gets here, I’ll poke around the factory firmware and see if I can find anything.

I’ve also got a replacement SDRAM on the way to fix the original unit, I’m putting in 512Mbit (64MB) up from the OEM 256Mbit.

Anyway, there’s a lot more pictures of the case, etc. in the gallery, but here’s a few highlights:

http://img.timb.us/HT-TM04/IMG_01.jpg

http://img.timb.us/HT-TM04/IMG_02.jpg

http://img.timb.us/HT-TM04/IMG_14.jpg

http://img.timb.us/HT-TM04/IMG_11.jpg

Forgot to mention, for those interested, I came across the actual manufacturer of these units while deconstructing the HooToo firmware: Power 7 Technology Corp.

http://www.power7tech.com

http://www.globalsources.com/power7.co

So, those might be the people to go after if anyone wants GPL compliance or perhaps specific information on the internals.

I took the plunge and upgraded to CC 15.05 RC2 from CC42649 as I was having issues installing packages.

I was making some screen prints of the process and while I thought I turned off the "keep Settings" flag, I failed.  This in itself may be related to the grief that followed.

The upgrade proceeded and I was able to access the device just as before, except Luci was not installed.  I accessed the console via putty, updated the packages, and installed Luci.  Luci was still not accessible after restart.  The LuCi gui would flash and then I would get a connection error.

I am assuming, but not sure, that as I kept my settings that the old opkg.conf file also remained, and thus called Luci files that did not work correctly.

I removed the trunk files (all that were installed) and the reinstalled LuCi.  Luci came up after restarting the web server.

The following packages are installed during the CC15.05 RC2 sysupgrde and Luci.

Remove    base-files    157-r45918
Remove    busybox    1.23.2-1
Remove    dnsmasq    2.73rc8-1
Remove    dropbear    2015.67-1
Remove    firewall    2015-05-26
Remove    fstools    2015-05-24-09027fc86babc3986027a0e677aca1b6999a9e14
Remove    hostapd-common    2015-03-25-1
Remove    ip6tables    1.4.21-1
Remove    iptables    1.4.21-1
Remove    iw    3.17-1
Remove    jshn    2015-05-08-a8e70c6d361967a23977417fb7d6cf56234f8b81
Remove    jsonfilter    2014-06-19-cdc760c58077f44fc40adbbe41e1556a67c1b9a9
Remove    kernel    3.18.14-1-ced5b5a0a4b7d37ece0f2af5dad52992
Remove    kmod-cfg80211    3.18.14+2015-03-09-3
Remove    kmod-crypto-aes    3.18.14-1
Remove    kmod-crypto-arc4    3.18.14-1
Remove    kmod-crypto-core    3.18.14-1
Remove    kmod-eeprom-93cx6    3.18.14-1
Remove    kmod-gpio-button-hotplug    3.18.14-1
Remove    kmod-ip6tables    3.18.14-1
Remove    kmod-ipt-conntrack    3.18.14-1
Remove    kmod-ipt-core    3.18.14-1
Remove    kmod-ipt-nat    3.18.14-1
Remove    kmod-ipv6    3.18.14-1
Remove    kmod-leds-gpio    3.18.14-1
Remove    kmod-ledtrig-usbdev    3.18.14-1
Remove    kmod-lib-crc-ccitt    3.18.14-1
Remove    kmod-lib-crc-itu-t    3.18.14-1
Remove    kmod-mac80211    3.18.14+2015-03-09-3
Remove    kmod-nf-conntrack    3.18.14-1
Remove    kmod-nf-conntrack6    3.18.14-1
Remove    kmod-nf-ipt    3.18.14-1
Remove    kmod-nf-ipt6    3.18.14-1
Remove    kmod-nf-nat    3.18.14-1
Remove    kmod-nf-nathelper    3.18.14-1
Remove    kmod-nls-base    3.18.14-1
Remove    kmod-ppp    3.18.14-1
Remove    kmod-pppoe    3.18.14-1
Remove    kmod-pppox    3.18.14-1
Remove    kmod-rt2800-lib    3.18.14+2015-03-09-3
Remove    kmod-rt2800-mmio    3.18.14+2015-03-09-3
Remove    kmod-rt2800-soc    3.18.14+2015-03-09-3
Remove    kmod-rt2x00-lib    3.18.14+2015-03-09-3
Remove    kmod-rt2x00-mmio    3.18.14+2015-03-09-3
Remove    kmod-slhc    3.18.14-1
Remove    kmod-usb-core    3.18.14-1
Remove    kmod-usb-ohci    3.18.14-1
Remove    kmod-usb2    3.18.14-1
Remove    libblobmsg-json    2015-05-08-a8e70c6d361967a23977417fb7d6cf56234f8b81
Remove    libc    0.9.33.2-1
Remove    libgcc    4.8-linaro-1
Remove    libip4tc    1.4.21-1
Remove    libip6tc    1.4.21-1
Remove    libiwinfo    2015-06-01-ade8b1b299cbd5748db1acf80dd3e9f567938371
Remove    libiwinfo-lua    2015-06-01-ade8b1b299cbd5748db1acf80dd3e9f567938371
Remove    libjson-c    0.12-1
Remove    libjson-script    2015-05-08-a8e70c6d361967a23977417fb7d6cf56234f8b81
Remove    liblua    5.1.5-1
Remove    libnl-tiny    0.1-4
Remove    libubox    2015-05-08-a8e70c6d361967a23977417fb7d6cf56234f8b81
Remove    libubus    2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
Remove    libubus-lua    2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
Remove    libuci    2015-04-09.1-1
Remove    libuci-lua    2015-04-09.1-1
Remove    libxtables    1.4.21-1
Remove    lua    5.1.5-1
Remove    luci    git-15.146.54948-a497fba-1
Remove    luci-app-firewall    git-15.146.54948-a497fba-1
Remove    luci-base    git-15.146.54948-a497fba-1
Remove    luci-lib-ip    git-15.146.54948-a497fba-1
Remove    luci-lib-nixio    git-15.146.54948-a497fba-1
Remove    luci-mod-admin-full    git-15.146.54948-a497fba-1
Remove    luci-proto-ipv6    git-15.146.54948-a497fba-1
Remove    luci-proto-ppp    git-15.146.54948-a497fba-1
Remove    luci-theme-bootstrap    git-15.146.54948-a497fba-1
Remove    mtd    20
Remove    netifd    2015-05-26-5990d1126fd33665e106508ebcbadfbb2d703d8e
Remove    odhcp6c    2015-05-19-68042ddafe0e1a3498b6c7a57ec8d2d20f25650b
Remove    odhcpd    2015-05-21-2ebf6c8216287983779c8ec6597d30893b914a7c
Remove    opkg    9c97d5ecd795709c8584e972bfdf3aee3a5b846d-7
Remove    ppp    2.4.7-5
Remove    ppp-mod-pppoe    2.4.7-5
Remove    procd    2015-06-03-94e7ea8b88cb01192a6fb1f1f6a68ada1356763f
Remove    rpcd    2015-05-17-3d655417ab44d93aad56a6d4a668daf24b127b84
Remove    swconfig    10
Remove    ubox    2015-05-22-ab5b47397cc143798ba2f367f04579e5b5b82070
Remove    ubus    2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
Remove    ubusd    2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
Remove    uci    2015-04-09.1-1
Remove    uhttpd    2015-05-31-daeea305298197bb50c1e63cdd842ee1d9461d80
Remove    uhttpd-mod-ubus    2015-05-31-daeea305298197bb50c1e63cdd842ee1d9461d80
Remove    usign    2015-05-08-cf8dcdb8a4e874c77f3e9a8e9b643e8c17b19131
Remove    wpad-mini    2015-03-25-1

and the correct opkg.conf file is

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
src/gz chaos_calmer_base http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ramips/rt305x/packages/base
src/gz chaos_calmer_luci http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ramips/rt305x/packages/luci
src/gz chaos_calmer_management http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ramips/rt305x/packages/management
src/gz chaos_calmer_packages http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ramips/rt305x/packages/packages
src/gz chaos_calmer_routing http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ramips/rt305x/packages/routing
src/gz chaos_calmer_telephony http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ramips/rt305x/packages/telephony

RangerZ

(Last edited by RangerZ on 7 Jul 2015, 02:36)

vernonjvs wrote:

Your post inspired me to get TM03. I was able to successfully flash the r44945-factory-ws image as well by following your hint of using an empty 4GB micro SD card instead of a USB stick. Thanks!

...

Thanks very much to WingSpinner for the factory images!

I can also confirm that the discribed way with r44945-factory image and SD-Card works.

After study of OpenWRT Wiki I was able to config my TM03 with luci interface to get the following network configuration:
Internet --> my_router --> wifi_client (TM03) --> wifi_AP (TM03)
                                                                   --> lan (TM03 ethernet socket)

It was very very difficult and not possible with luci interface to a configuration like wan (ethernet-socket) -> wifi_AP.
After extensive search I could find an example, copied the config-files (DHCP, wireless, network, firewall) to my PC, edited this files and copied them back to /etc/config on my TM03. Now this network configuration is like this:
Internet --> my_router --> lan_client (TM03 ethernet socket) -->  wifi_AP (TM03)

Now I have two configuration and be flexibble to load up to my TM03 which of this two I need.
I can post this configs here if it is interessing for somebody.

Regarding the SD and USB I had some problems to get automount this storage. After some research in OpenWRT wiki I found out, that I need to install block-mount modul which is not in the r44945-factory image. I download the block-mount.ipk from the internet manually copied it to the TM03 and installed it with 'opkg install block-mount.ipk' (all by putty ssh connection). After this I could define the mountpoints with luci interface and configurate the share (samba) also with luci.

During my experiments with network configurations I lost the contact to my TM03 and had to hard-reset my TM03 (pushed the ON-button and than pushed and hold the reset-button for more than 30 seconds). After each hard-reset I lost the manually installed block-mount modul and I had to reinstall the block-mount after every hard-reset. My question now is how I can install block-mount permanently so that it survive after such a hard-reset ? Is there any parameter I need to add to the opkg install command ?

(Last edited by goddy99 on 12 Jul 2015, 16:14)

I installed relayd tonight, and while it appears to be working I can no longer get to the GUI or access the device via SCP or putty.  I can not access the USB drive or the client in it's Windows Explorer Network section.  I can see the rest of my LAN on the far side of the HooToo.

I configured the device via Luci and checked the config files against the wiki.  I was not getting to the internet and realized that the local PC that was attached to the HooToo was getting an ip from the LAN side DHCP, so I disabled DHCP, keeping the IP address for LAN (192.168.2.1).  It did not release the IP for the client so I just rebooted the HooToo.  I can now not access it at the 192.168.2.1 or the device my primary router indicates that it has (192.168.1.16)

Any suggestions on how to access the router?

Thanks... RangerZ

I reset the router, reinstalled packages and restored the config.  I back in business.

I am not sure that realyd is what I want.  I understand it supports bi-directional communications (when working properly)

I want to be able to access the resources on the network I am attaching to, but be fire walled from the same network. 

I am configured as a basic router(WWAN/wired LAN).  I can not access any of the resources on the WAN side, but can reach the internet.

RangerZ

I bought an HT-TM01 in bricked condition.
I hooked up my serial cable. I see it stopping at "you have chosen option 3" then it stops with a bad magic number message.
If I try to tftp the factory image it gets to 76% transfer and it timoesout with an error.
If I try to tftp the openwrt image made for it that I downloaded here, it transfers ok but after it programs it still returns the error message.

If it helps I can upload my putty log. Can this thing be fixed?  If not it's ok, I only paid $10 and I can use it as a battery backup.

(Last edited by Malachi on 14 Jul 2015, 20:01)

Since tftp doesnt seem to work using either the openwrt image or the oem image I guess I can try loading the firmware over serial using kermit.
The only thing is is that I am not smart enough to know exactly how to do that.
I know how to start the tranfer, its the erase and cp stuff that my 48 year old brain cant grasp.

Here is the printenv if someone could tell me how to do it

RT5350 # printenv
bootcmd=tftp
bootdelay=5
baudrate=57600
ethaddr="00:AA:BB:CC:DD:10"
ramargs=setenv bootargs root=/dev/ram rw
addip=setenv bootargs $(bootargs) ip=$(ipaddr):$(serverip):$(gatewayip):$(netmask):$(hostname):$(netdev):off
addmisc=setenv bootargs $(bootargs) console=ttyS0,$(baudrate) ethaddr=$(ethaddr) panic=1
flash_self=run ramargs addip addmisc;bootm $(kernel_addr) $(ramdisk_addr)
kernel_addr=BFC40000
u-boot=u-boot.bin
load=tftp 8A100000 $(u-boot)
u_b=protect off 1:0-1;era 1:0-1;cp.b 8A100000 BC400000 $(filesize)
loadfs=tftp 8A100000 root.cramfs
u_fs=era bc540000 bc83ffff;cp.b 8A100000 BC540000 $(filesize)
test_tftp=tftp 8A100000 root.cramfs;run test_tftp
ethact=Eth0 (10/100-M)
filesize=3521b4
fileaddr=80800000
ipaddr=10.10.10.123
serverip=10.10.10.3
autostart=no
bootfile=test.bin
stdin=serial
stdout=serial
stderr=serial

Environment size: 830/4092 bytes
RT5350 #

(Last edited by Malachi on 15 Jul 2015, 22:47)