OpenWrt Forum Archive

Topic: receive and rebroadcast -advice to setup?

The content of this topic has been archived on 15 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey guys

My ISP i currently have uses one of those proprietary piece of crap all in one modem router and
basic 802.11a/b wifi, and does not allow router behind router instances due to (proprietary) software restrictions.
I have a netgear 600 wndr3700v2, with Openwrt installed (obviously, that's why i'm here) with default configuration.

Simply put, i would like to pick up the wifi from that router and rebroadcast it with my wndr3700 as a separate network, just for internet.
Also, for convenience use the 10.0.0.x range. This should be pretty straightforward , however the configuration looks a bit complex to me, especially the vast amount of options in the settings page.


How would i go about acheiving this?

Sidenote: I am looking into other isps without this pathetic childish mandatory crap hardware and spyware they install in your home.



any guidance would be enormously appreciated!!

bump

In a nutshell - you should connect wirelessly to your ISP, create an AP where your home devices will connect and activate NAT on the wan connection.
Edit /etc/config/wireless like this:

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Home'
    option encryption 'psk2'
    option key 'bigsecret'
    option disabled '0'

config wifi-iface
    option device 'radio0'
    option network 'wan'
    option mode 'sta'
    option encryption 'psk2'
    option ssid 'MyISP_Router_SSID'
    option key 'biggersecret'

Edit /etc/config/network:

config interface wan
    option proto dhcp

Reboot or issue the command "/etc/init.d/network restart". You should now be connected to your ISP and have the Home SSID visible.
The last step is to activate NAT (masquerading) for your wan connection. This can be done from Luci (if you use Luci) or by editing /etc/config/firewall

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1

(I think these are the default options, anyway.)
Then

/etc/init.d/firewall enable
/etc/init.d/firewall start

That should be it.

thanks, well see how it goes, need to brush up on my vim skills, not familiar with vim, there aren't any other text editors.
also can I utilize the extra unused wan port?

- I think that it can be done entirely from Luci, but I'm not sure, as I don't use Luci
- you could install nano, which is more user friendly (opkg update; opkg install nano)
- anyway, basic vi is easy to learn, there are only a few combinations to know (i - for editing, ESC:x for saving, ESC:q! for quitting without saving and that's all you need to know to start)
Good luck!

It seems to have worked, kinda
When i say kinda, i mean it establishes a connection with my isps router,
(which verifies the configuration is correct *thank you) but only for a couple seconds until it drops and disconnects
and the bitrate is a horrid 1mbps despite being less than 8 feet away from each-other


any ideas?

just fyi the wndr3700 also has another 5ghz wifi radio labeled 'radio1'  if needed

(Last edited by opensircut on 15 Apr 2015, 09:07)

oh crap wait i typed the password wrong... go figure

however still no response from the internet, and still the horrible 1MB connection

- you should check that both wifi connections are created (iw dev, check that you have 2 interfaces here, one of them type AP and the other type "managed"). Check with logread if something is wrong.
- check if the "managed" interface received IP via DHCP from ISP's router
- ping something from the Internet (e.g. 8.8.8.8) from the router to check connectivity
- if all of the above tests are successful, you can connect to Home SSID and still have no Internet access, you should recheck if NAT (masquerading) is activated for the "outside" wireless interface 
- don't worry about the 1Mbps rate shown (by Luci?). My guess is that when you will have traffic on the link it will be a lot higher

being a complete noob
-In luci my router displays it is connected to my isps router as client (and i checked that it obtained an internal ip via DHCP)
and my router broadcasting its ssid as master, not sure what you mean by managed
-logread?
ping received no response

im lazy (hence use luci) so have a look at my luci config (that i think might help solve this)
http://i.imgur.com/pfKMybZ.png
http://i.imgur.com/0XHY4QX.jpg
http://i.imgur.com/nulbhPP.jpg

other info
192.168.1.115 is my pc im using to connect to it wired
-the time is wrong

Looks good (mostly), except that somehow in your setup lan and wan are bridged.
maybe you should start new and try to make it like this:
WiFi
http://i.imgur.com/GGvqr28.jpg
WAN
http://i.imgur.com/bPlLExG.jpg
LAN
http://i.imgur.com/jrTRAwk.jpg
Firewall looks fine.

Logread is what you see in System log menu.

Good luck!

so i reset to defaults and decided to see how far i got with luci
-moved the wan port to lan
- setup my wifi's (ssid & password for both radios)
- used luci and scanned wifi nearby, (via add new interface) connected to my router as client
       (MUST create new interface "wwan". wouldn't let me just add to current "wan" -weird)
-move new interface to wan (from the wwan it just made)
-delete wwan
so basically using the wan port for an extra lan port, and using wifi as wan
firewall is defaults
but still no internet
so im confused why this is not working

Install WinSCP, connect to the box and edit the files (/etc/config/wireless, /etc/config/network) from Windows. It should be fine...

edit, to what? yes you told me where they are just what do (the stuff before didn't work)
and I don't have windows, the linux stuff works best using openssh

The discussion might have continued from here.