OpenWrt Forum Archive

Topic: Can't get WPS-PBC to work

The content of this topic has been archived on 27 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello everyone

I have three TL-WA901N/ND v3 running r45430 (recompiled some minutes ago). I'm trying to get WPS-PBC running for my Guest-SSID. I've compiled with wpad and hostapd-utils packages, as stated in the documentation. This is the config:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar934x_wmac'
    option htmode 'HT20'
    option channel '11'
    option country 'DE'
    option country_ie '1'
    option require_mode 'g'
    option txpower '20'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'Something'
    option network 'lan'
    option encryption 'psk2+ccmp'
    option key 'xxx'
    option wps_pushbutton '0'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'Guest'
    option network 'guest'
    option encryption 'psk2+ccmp'
    option key 'xxx'
    option wps_pushbutton '1'

Here is the output from hostapd_cli

root@ap3:~# hostapd_cli -i wlan0-1 get_config
bssid=xxx
ssid=Guest
wps_state=configured
passphrase=xxx
psk=xxx
key_mgmt=WPA-PSK 
group_cipher=CCMP
rsn_pairwise_cipher=CCMP

That looks all fine to me up until now, but if I try to launch PBC it failes immediatly:

root@ap3:~# hostapd_cli -i wlan0-1 wps_pbc
FAIL
root@ap3:~#

What am I missing here?

Multiple interfaces with mixed wps_pushbutton settings seem to cause trouble.
I tried configuring two interfaces to my radio1: wps commands fails with mixed wps_pushbutton setting but succeeds if values are identical.

root@OpenWrt:~# ls -l /var/run/hostapd
srwxrwx---    1 root     root             0 Apr 14 16:43 wlan0
srwxrwx---    1 root     root             0 Apr 14 16:43 wlan1
srwxrwx---    1 root     root             0 Apr 14 16:43 wlan1-1
root@OpenWrt:~# grep push /etc/config/wireless
        option wps_pushbutton '1'
        option wps_pushbutton '1'
        option wps_pushbutton '0'
root@OpenWrt:~# hostapd_cli -i wlan0 wps_pbc
OK
root@OpenWrt:~# hostapd_cli -i wlan1 wps_pbc
FAIL
root@OpenWrt:~# hostapd_cli -i wlan1-1 wps_pbc
FAIL

root@OpenWrt:~# nano /etc/config/wireless
root@OpenWrt:~# grep push /etc/config/wireless
        option wps_pushbutton '1'
        option wps_pushbutton '1'
        option wps_pushbutton '1'
root@OpenWrt:~# wifi up
root@OpenWrt:~# hostapd_cli -i wlan0 wps_pbc
OK
root@OpenWrt:~# hostapd_cli -i wlan1 wps_pbc
OK
root@OpenWrt:~# hostapd_cli -i wlan1-1 wps_pbc
OK
root@OpenWrt:~#

Thanks, that's ugly but it works wink I've just opened a ticket: https://dev.openwrt.org/ticket/19485

Is it just me or is Trac really as slow as broken dialup around the globe from a server in North Korea?

Crazyachmed wrote:

Is it just me or is Trac really as slow as broken dialup around the globe from a server in North Korea?

It varies. Apparently there is is database connectivity problem every now and then and some requests go through, some do not. Or something like that.

The discussion might have continued from here.