Topic: Enabling client-bridge mode on a WGT634U

So far it seems the client connectivity works, Just the bridging of the two interfaces ath0 (Wireless Atheros) and eth0 (LAN ports) is causing problems. I realize kamikaze is not supported yet and not much discussion is going on about it. Many users have been playing with this and this is where I am at currently. I have full client mode WPA/WPA2 connectivity to my AP in Master mode.

root@router-bedroom:/etc# cat init.d/S20madwifi

------------------ end of beginning script -----------------------------
#!/bin/sh

wifi_essid=184
wifi_channel=11
wifi_ap_mac=00:13:10:09:5F:A4

iwconfig ath0 essid $wifi_essid channel $wifi_channel ap $wifi_ap_mac
iwpriv ath0 turbo 1
iwpriv ath0 xr 1
iwpriv ath0 burst 1

wpa_supplicant -c /etc/wpa_supplicant.conf -iath0 -B -Dmadwifi

# check status with wpa_cli status
# do not continue until the network is connected

echo "waiting until WPA connection is complete (may take up to a minute)..."

check_wpa_connection() {
        wpa_connection_complete=`wpa_cli status | grep ^wpa_stat | awk -F= 'BEGIN { complete=0; } { if ($2 == "COMPLETED") complete=1; } END { print complete }'`
}

check_wpa_connection

while [ $wpa_connection_complete = 0 ]; do
        echo "still waiting until WPA connection is complete (sleeping for 5 seconds)..."
        sleep 5
        check_wpa_connection
done

iwpriv ath0 wds_add 00:13:10:09:5F:A4
iwpriv ath0 wds 1

brctl addbr br0

# add lan ports and wireless interface to bridge interface
brctl addif br0 eth0
brctl addif br0 ath0

# enable spanning-tree (pvst? or mst)
brctl stp br0 on

------------------ end of init script -----------------------------

root@router-bedroom:/etc#
root@router-bedroom:/etc# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"184"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:13:10:09:5F:A4
          Bit Rate:24 Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:5283-7FB5-5708-89A8-A775-9C84-1FE3-9846   Security mode:restricted
          Power Management:off
          Link Quality=74/94  Signal level=-21 dBm  Noise level=-95 dBm
          Rx invalid nwid:4908  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

br0       no wireless extensions.

--------------------- begin /etc/config/network ----------------------------
root@router-bedroom:/etc# cat /etc/config/network
#### VLAN configuration
vlan0hwname=et0
vlan0ports="0 1 2 3 4 5*"
vlan1hwname=et0
vlan1ports="5"

# I don't need the wan port, because the wgt is only client...
# so I have added the wan port to vlan0

#### LAN configuration
lan_proto="static"
lan_ifname="vlan0"
lan_ifnames="vlan0"
lan_ipaddr="192.168.1.2"
lan_dns="192.168.1.1"
lan_gateway="192.168.1.1"

#### WAN configuration
wan_proto=none
wan_ifname=""
# not using wan
#wan_device="vlan1"
#wan_dns=""
--------------------- end /etc/config/network ----------------------------