OpenWrt Forum Archive

Topic: Quallcomm qca9558/TP-Link WDR7500 support

The content of this topic has been archived between 1 May 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

ranfish wrote:
pepe2k wrote:
wuxeon wrote:

There is QCA9558 uboot(suit to wdr7500,archer c7,i have tested it.) ,it's very useful,u can update uboot,art,firmware with this uboot.
http://www.right.com.cn/forum/thread-136444-1-1.html

And... no sources available? Shame!

Typical way of Chinese doing.

Sure, I know that and I don't have problem with that.

Glad that someone used it and made it better... just don't like when someone grab open sourced project, make some modifications and... close it. Even if the author (I don't know the language, I tried to translate some of his posts) is sure, that he didn't use my sources... he is using U-Boot sources and this project is GPL...

ranfish wrote:

It's generous for them to share a working bin already!

Of course, with some additional "features", like network, password, keys sniffers, etc. wink

For anyone building their own openwrt from source, if you're interested in getting ath10k back to functioning, there is a simple edit of ath10k to get there;

kernel/drivers/net/wireless/ath/ath10k/core.c
At line 564 approximately (depends on the source revision), there is a block of code;

    ret = ath10k_download_and_run_otp(ar);
    if (ret) {
        ath10k_err("failed to run otp: %d\n", ret);
        return ret;
    }

... comment that out.

Also, build yourself a custom board.bin:
dd if=/dev/mtd4 of=/lib/firmware/ath10k/QCA988X/hw2.0/board.bin bs=1 count=2116 skip=20480

And if you want to get fancy, hex edit the board.bin to add your proper MAC address, starting at 0x6 (your custom board.bin will start "4408 c69f 020d 0003 7f00 0000". The part "0003 7f00 0000" is the MAC address. You can see in the current board.bin template that ships with openwrt, that it contains "0003 0712 3456", which is the same as the MAC address being assigned at r40799 and lower.

Also note that you should be able to build just the ath10k driver and replace the ath10k_core.ko in the RC builds.

pepe2k wrote:
ranfish wrote:
pepe2k wrote:

And... no sources available? Shame!

Typical way of Chinese doing.

Sure, I know that and I don't have problem with that.

Glad that someone used it and made it better... just don't like when someone grab open sourced project, make some modifications and... close it. Even if the author (I don't know the language, I tried to translate some of his posts) is sure, that he didn't use my sources... he is using U-Boot sources and this project is GPL...

ranfish wrote:

It's generous for them to share a working bin already!

Of course, with some additional "features", like network, password, keys sniffers, etc. wink

Openwrt means Money in China now.
They even host a conference about  openwrt development in Shenzhen.Nothing profitable will be opensourced,you know,just hypes and promotions.
http://www.right.com.cn/Forum/forum.php … 1#lastpost
You can google translate this.

definesinsanity wrote:

For anyone building their own openwrt from source, if you're interested in getting ath10k back to functioning, there is a simple edit of ath10k to get there;

kernel/drivers/net/wireless/ath/ath10k/core.c
At line 564 approximately (depends on the source revision), there is a block of code;

    ret = ath10k_download_and_run_otp(ar);
    if (ret) {
        ath10k_err("failed to run otp: %d\n", ret);
        return ret;
    }

... comment that out.

Also, build yourself a custom board.bin:
dd if=/dev/mtd4 of=/lib/firmware/ath10k/QCA988X/hw2.0/board.bin bs=1 count=2116 skip=20480

And if you want to get fancy, hex edit the board.bin to add your proper MAC address, starting at 0x6 (your custom board.bin will start "4408 c69f 020d 0003 7f00 0000". The part "0003 7f00 0000" is the MAC address. You can see in the current board.bin template that ships with openwrt, that it contains "0003 0712 3456", which is the same as the MAC address being assigned at r40799 and lower.

Also note that you should be able to build just the ath10k driver and replace the ath10k_core.ko in the RC builds.

I've tried the three steps you said.2.4g is ok but 5g still not working

[   12.500000] cfg80211: Calling CRDA to update world regulatory domain
[   12.500000] cfg80211: World regulatory domain updated:
[   12.510000] cfg80211:  DFS Master region: unset
[   12.510000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   12.520000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   12.530000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   12.540000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   12.550000] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[   12.550000] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   12.560000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   12.570000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   12.580000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   12.620000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
[   12.640000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
[   12.660000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
[   12.680000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
[   12.700000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   12.760000] xt_time: kernel timezone is -0000
[   12.770000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
[   12.790000] PPP generic driver version 2.4.2
[   12.800000] NET: Registered protocol family 24
[   12.810000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
[   12.850000] cfg80211: Calling CRDA for country: US
[   12.860000] cfg80211: Regulatory domain changed to country: US
[   12.860000] cfg80211:  DFS Master region: FCC
[   12.870000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   12.880000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   12.880000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[   12.890000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[   12.900000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   12.910000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   12.920000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
[   12.930000] ath10k_core: Unknown symbol mac80211_ieee80211_rx (err 0)
procd: - init complete -

And accompany by occasionally crash.

[  221.160000] ath10k: [20]: 0x0000FFFF 0x00000000 0x0042E84C 0x00000000
[  221.170000] ath10k: [24]: 0x809A0978 0x0040AD94 0x00439304 0x0D63D8EE
[  221.170000] ath10k: [28]: 0x809AD1A2 0x0040ADE4 0x00439304 0x0043F68C
[  221.180000] ath10k: [32]: 0x809B01DA 0x00000000 0x00410110 0x0041939C
[  221.190000] ath10k: [36]: 0x00000000 0x00000000 0x00000000 0x00000000
[  221.190000] ath10k: [40]: 0x00000000 0x00000000 0x00000000 0x00412700
[  221.200000] ath10k: [44]: 0x00439BB8 0x00000000 0x00000000 0x00400000
[  221.210000] ath10k: [48]: 0x809AE0B4 0x0040AE04 0x00400000 0x0043F68C
[  221.210000] ath10k: [52]: 0x00000001 0x00000000 0x004231F0 0x00400000
[  221.220000] ath10k: [56]: 0x809AE17E 0x0040AE44 0x0040FE6C 0x0040D310
[  225.110000] ath10k: failed to synchronise setup for vdev 0: -145
[  228.110000] ath10k: failed to set erp slot for vdev 0: -11
[  231.110000] ath10k: failed to set preamble for vdev 0: -11
[  231.110000] ath10k: device successfully recovered
[  231.120000] br-lan: port 2(wlan0) entered forwarding state
[  231.120000] br-lan: port 2(wlan0) entered forwarding state
[  231.130000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  233.120000] br-lan: port 2(wlan0) entered forwarding state
[  234.120000] ath10k: failed to put down monitor vdev 1: -11
[  237.120000] ath10k: failed to to request monitor vdev 1 stop: -11
[  242.120000] ath10k: failed to synchronise monitor vdev 1: -145
[  242.120000] ath10k: failed to stop monitor vdev: -145
[  245.130000] ath10k: failed to request wmi monitor vdev 1 removal: -11
[  245.130000] ath10k: failed to delete monitor vdev: -11
[  245.660000] ieee80211 phy0: Hardware restart was requested
[  245.660000] ath10k: failed to request monitor vdev 2 creation: -143
[  245.670000] ath10k: failed to create monitor vdev: -143
[  245.670000] ath10k: failed to start monitor (promisc): -143
[  245.680000] ath10k: failed to recalculate rts/cts prot for vdev 0: -143
[  245.690000] ath10k: failed to set erp slot for vdev 0: -143
[  245.690000] ath10k: failed to set preamble for vdev 0: -143
[  245.710000] ath10k: failed to request monitor vdev 2 creation: -143
[  245.710000] ath10k: failed to create monitor vdev: -143
[  248.130000] ath10k: firmware crashed!
[  248.130000] ath10k: hardware name qca988x hw2.0 version 0x4100016c
[  248.140000] ath10k: firmware version: 999.999.0.636
[  248.140000] ath10k: target register Dump Location: 0x0040AC14
[  248.150000] ath10k: target Register Dump
[  248.150000] ath10k: [00]: 0x4100016C 0x00000000 0x009C4521 0x00000000
[  248.160000] ath10k: [04]: 0x009C4521 0x00060330 0x00000019 0x00955A00
[  248.170000] ath10k: [08]: 0x0003C00B 0x00000000 0x0040CC94 0x00000020
[  248.170000] ath10k: [12]: 0x00000000 0x00000000 0x00958360 0x0095836B
[  248.180000] ath10k: [16]: 0x809A0978 0x0040AD94 0x00439304 0x0040D074
[  248.190000] ath10k: [20]: 0x0000FFFF 0x00000000 0x0042EC24 0x00000000
[  248.190000] ath10k: [24]: 0x809A0978 0x0040AD94 0x00439304 0x0F002E56
[  248.200000] ath10k: [28]: 0x809AD1A2 0x0040ADE4 0x00439304 0x0043F68C
[  248.210000] ath10k: [32]: 0x809B01DA 0x00000000 0x00410110 0x0041939C
[  248.210000] ath10k: [36]: 0x00000000 0x00000000 0x00000000 0x00000000
[  248.220000] ath10k: [40]: 0x00000000 0x00000000 0x00000000 0x00412700
[  248.230000] ath10k: [44]: 0x00439BB8 0x00000000 0x00000000 0x00400000
[  248.230000] ath10k: [48]: 0x809AE0B4 0x0040AE04 0x00400000 0x0043F68C
[  248.240000] ath10k: [52]: 0x00000001 0x00000000 0x004231F0 0x00400000
[  248.250000] ath10k: [56]: 0x809AE17E 0x0040AE44 0x0040FE6C 0x0040D310
[  252.130000] net_ratelimit: 1 callbacks suppressed
[  252.130000] ath10k: failed to synchronise setup for vdev 0: -145
[  255.140000] ath10k: failed to set erp slot for vdev 0: -11

(Last edited by ranfish on 18 Jul 2014, 02:25)

Anyone got original  WDR75000 V3 firmware dump?

bumped

Some interesting development: https://dev.openwrt.org/ticket/16589#comment:38

5 GHz should work as of r41757, but I can't tell from the changes whether it is now calibrated or back to the state it was in r40799. It would be interesting to hear some Wi-Fi performance reports (I don't have one myself, I'd check if I could).

makro wrote:

Some interesting development: https://dev.openwrt.org/ticket/16589#comment:38

5 GHz should work as of r41757, but I can't tell from the changes whether it is now calibrated or back to the state it was in r40799. It would be interesting to hear some Wi-Fi performance reports (I don't have one myself, I'd check if I could).

Take a look at the two patches...

The first, 41756, is a local hack to *not bail* on the otp failure. That one, all by itself, will put it back to where it was *before* the otp failure problem started happening.

The second, 41757, generates a custom board.bin from the contents of the art partition PLUS the device's mac address. Basically, this one actually sets up the calibrations for the device as defined by tplink.

pepe2k wrote:
wuxeon wrote:

There is QCA9558 uboot(suit to wdr7500,archer c7,i have tested it.) ,it's very useful,u can update uboot,art,firmware with this uboot.
http://www.right.com.cn/forum/thread-136444-1-1.html

It looks like very deep modification/fork of my project (just checked that).
And... no sources available? Shame!

The author said he would opensource , once the codes become stable.
And how come he was using your "mod" project?

(Last edited by PowerRC on 22 Jul 2014, 04:56)

ranfish wrote:
pepe2k wrote:
wuxeon wrote:

There is QCA9558 uboot(suit to wdr7500,archer c7,i have tested it.) ,it's very useful,u can update uboot,art,firmware with this uboot.
http://www.right.com.cn/forum/thread-136444-1-1.html

And... no sources available? Shame!

Typical way of Chinese doing.It's generous for them to share a working bin already!

This is totally racism.

PowerRC wrote:

The author said he would opensource , once the codes become stable.

Sure, of course, but... he should do that BEFORE releasing any binaries.

PowerRC wrote:

And how come he was using your "mod" project?

It doesn't matter. I'm not hiding my code, he is. I released binaries AND source code at the same time.

Even if he isn't using my code directly (I mean copy&paste), he is using code from QCA/Atheros, TP-Link (and maybe some another manufacturers), uIP and of course, U-Boot sources. I'm 100% sure that he wouldn't make it without the above sources and some knowledge taken from there (I suppose that he doesn't have signed NDA with QCA/A).

Do you know why, just for example, TP-Link releases their firmware sources in their GPL Code Center? Try to guess.

PowerRC wrote:
ranfish wrote:
pepe2k wrote:

And... no sources available? Shame!

Typical way of Chinese doing.It's generous for them to share a working bin already!

This is totally racism.

No! It's true, based on a long-term practical experience smile

PowerRC wrote:
ranfish wrote:
pepe2k wrote:

And... no sources available? Shame!

Typical way of Chinese doing.It's generous for them to share a working bin already!

This is totally racism.

Chinese is not a race, thus not a racist remark. Bigot YES, racist NO! Also, anyone who has dealt with chinese businesses and/or businessmen know this is very much the case. I have as pepe2k first hand experience with this, do you? Lastly, their total lack of respect for copyright is what lies behind you being able to purchase cheap products...if you think this is a good thing or not is up to you, but please don't jump up on the PC-bandwagon before give it an own thought first.

I'm sooo tired of this "racists" mantra that people spit out more and more! There is something called trust and credibility, which applies to anything we are supposed to take action based upon. The more people misuse the trust and credibility associated with cry-outs like racism (and others), the less the REAL victims get the attention they deserve. If you get lied to enough many times you eventually stop trusting people in the same setting...

/ end rant

(Last edited by Lennong on 22 Jul 2014, 13:21)

Could someone upstream the codes so to have trunk builds for WDR7500v3?

BTW, the current ath10k driver/firmware doesn't support virtual interfaces?

Thanks in advance.

(Last edited by loyukfai on 26 Jul 2014, 11:17)

Hi,

I'm running an archer c7 v2 behind a router. I disabled stuff on the archer (wan, wan6, nat/firewall, dnsmasq, ipv6-prefix, vlan2), added switch ports 1 and 6 to vlan1, and set a static address for the br-lan. It seems to work well, but I would like confirmation or clarification on some things.

First, does that setup sound sane? I've been trying to find information on such a configuration. The openwrt "dumb AP" article seems close, but doesn't quite match the archer setup.

Using swconfig, I can map switch port 1 to 5 to the physical RJ-45 jacks. Are the other two ports the two wireless radios?

Based on the last question, what are the original two vlans for? One radio plus the lan ports for vlan1? The other radio and the wan port for vlan2?

I think eth1 is the switch. What is eth0?


bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.e894f690xxxx       no              eth1
                                                        wlan0
                                                        wlan1
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.1.1.2'
        option netmask '255.255.255.0'
        option gateway '10.1.1.1'
        option dns '10.1.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
#       option ports '0 2 3 4 5'
        option ports '0 1 2 3 4 5 6'

#config switch_vlan
#       option device 'switch0'
#       option vlan '2'
#       option ports '1 6'
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether e8:94:f6:90:xx:xx brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP group default qlen 1000
    link/ether e8:94:f6:90:xx:xx brd ff:ff:ff:ff:ff:ff
4: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 32
    link/ether 16:1b:5f:0e:xx:xx brd ff:ff:ff:ff:ff:ff
5: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 32
    link/ether 42:14:2c:33:xx:xx brd ff:ff:ff:ff:ff:ff
14: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether e8:94:f6:90:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 10.1.1.2/24 brd 10.1.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fe80::ea94:f6ff:fe90:xxxx/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP group default qlen 1000
    link/ether 00:03:07:12:xx:xx brd ff:ff:ff:ff:ff:ff
    inet6 fe80::203:7ff:fe12:xxxx/64 scope link 
       valid_lft forever preferred_lft forever
16: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP group default qlen 1000
    link/ether e8:94:f6:90:xx:xx brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea94:f6ff:fe90:xxxx/64 scope link 
       valid_lft forever preferred_lft forever

Archer C5 uses same card. It is now listed in trunk list. Any one tested 5G performance on AC5 yet?

I compile with latest trunk.2.4g is ok.But 5G is not working.
http://s16.postimg.org/yvulipngx/5g_not_working.jpg
Seen these errors of drivers
[ 27.560000] ath10k: firmware crashed!
[ 27.560000] ath10k: hardware name qca988x hw2.0 version 0x4100016c
[ 27.570000] ath10k: firmware version: 999.999.0.636
[ 27.580000] ath10k: target register Dump Location: 0x0040AC14
[ 27.580000] ath10k: target Register Dump
[ 27.590000] ath10k: [00]: 0x4100016C 0x00000000 0x009C4521 0x00000000
[ 27.590000] ath10k: [04]: 0x009C4521 0x00060330 0x00000019 0xFFFFFFFD
[ 27.600000] ath10k: [08]: 0x00007CCB 0x00000000 0x0040CC94 0x00000020
[ 27.610000] ath10k: [12]: 0x00000000 0x00000000 0x00958360 0x0095836B
[ 27.610000] ath10k: [16]: 0x809A0978 0x0040AD94 0x00439304 0x0040D074
[ 27.620000] ath10k: [20]: 0x00000000 0x00000000 0x000249F0 0x00000001
[ 27.630000] ath10k: [24]: 0x809A0978 0x0040AD94 0x00439304 0x01F32E9D
[ 27.630000] ath10k: [28]: 0x809AD1A2 0x0040ADE4 0x00439304 0x0043F68C
[ 27.640000] ath10k: [32]: 0x809B5DA3 0x00000000 0x000000FE 0x004440FC
[ 27.650000] ath10k: [36]: 0x00000000 0x00000000 0x00000000 0x00000000
[ 27.650000] ath10k: [40]: 0x00000000 0x00000000 0x00443C54 0x00000004
[ 27.660000] ath10k: [44]: 0x00439BB8 0x00000000 0x00000000 0x00400000
[ 27.670000] ath10k: [48]: 0x809AE0B4 0x0040AE04 0x00400000 0x0043F68C
[ 27.670000] ath10k: [52]: 0x00000001 0x00000000 0x004231F0 0x00400000
[ 27.680000] ath10k: [56]: 0x809AE17E 0x0040AE44 0x0040FE6C 0x0040D310
[ 28.630000] br-lan: port 3(wlan1) entered forwarding state
[ 30.690000] ath10k: failed to to request monitor vdev 1 stop: -11
[ 35.690000] ath10k: failed to synchronise monitor vdev 1: -145
[ 35.690000] ath10k: failed to stop monitor vdev: -145
[ 38.700000] ath10k: failed to request wmi monitor vdev 1 removal: -11
[ 38.700000] ath10k: failed to delete monitor vdev: -11
[ 39.230000] ieee80211 phy0: Hardware restart was requested
[ 39.670000] ath10k: otp stream is empty, using board.bin contents
[ 40.780000] ath10k: device successfully recovered
[ 41.790000] ath10k: firmware crashed!
[ 41.790000] ath10k: hardware name qca988x hw2.0 version 0x4100016c
[ 41.800000] ath10k: firmware version: 999.999.0.636
[ 41.800000] ath10k: target register Dump Location: 0x0040AC14
[ 41.810000] ath10k: target Register Dump
[ 41.810000] ath10k: [00]: 0x4100016C 0x00000000 0x009C4521 0x00000000
[ 41.820000] ath10k: [04]: 0x009C4521 0x00060330 0x00000019 0x0040F948
[ 41.830000] ath10k: [08]: 0x0000B30E 0x00000000 0x0040CC94 0x00000020
[ 41.830000] ath10k: [12]: 0x00000000 0x00000000 0x00958360 0x0095836B
[ 41.840000] ath10k: [16]: 0x809A0978 0x0040AD94 0x00439304 0x0040D074
[ 41.850000] ath10k: [20]: 0x00412EB0 0x121134F0 0x0000001C 0x0043E8D4
[ 41.850000] ath10k: [24]: 0x809A0978 0x0040AD94 0x00439304 0x02CC38CC
[ 41.860000] ath10k: [28]: 0x809AD1A2 0x0040ADE4 0x00439304 0x0043F6FC
[ 41.870000] ath10k: [32]: 0x809B01DA 0x00000001 0x00410110 0x0041937C
[ 41.870000] ath10k: [36]: 0x00000000 0x00000000 0x00000000 0x00000000
[ 41.880000] ath10k: [40]: 0x00000000 0x00000000 0x0040AE38 0x00412718
[ 41.890000] ath10k: [44]: 0x00439C00 0x00000000 0x00000000 0x00400000
[ 41.890000] ath10k: [48]: 0x809AE0B4 0x0040AE04 0x00400000 0x0043F6FC
[ 41.900000] ath10k: [52]: 0x00000001 0x00000000 0x004231F0 0x00400000
[ 41.900000] ath10k: [56]: 0x809AE17E 0x0040AE44 0x0040FE6C 0x0040D310

(Last edited by ranfish on 27 Jul 2014, 12:17)

Installed build 41846 from trunk on my Archer C7 v2 and it needed a little fiddling to get things right.

Firstly, for some reason kmod-ath10k is not in the image, I had to install it via opkg.
Secondly, patch 41757 is not working or not included as I was still getting the wrong MAC address and the board.bin was clearly the default one from the package.  I just copy/pasted the code from patch 41757 into a script and ran it as follows:

#!/bin/sh
. /lib/functions.sh
. /lib/functions/system.sh

dd if=/dev/mtdblock2 bs=1 skip=20480 count=2116 of=/tmp/ath10k-board.bin
local mac
mac=$(macaddr_add $(cat /sys/class/net/eth1/address) -2)

dd if=/dev/mtdblock4 bs=1 skip=20480 count=6 of=/tmp/ath10k-board.bin
macaddr_2bin $mac >> /tmp/ath10k-board.bin
dd if=/dev/mtdblock4 bs=1 skip=20492 count=2104 >> /tmp/ath10k-board.bin

[ -f /tmp/ath10k-board.bin ] || {
       return
}
cmp -s /tmp/ath10k-board.bin /lib/firmware/ath10k/QCA988X/hw2.0/board.bin || {
        cp /tmp/ath10k-board.bin /lib/firmware/ath10k/QCA988X/hw2.0/board.bin
        rm /tmp/ath10k-board.bin
}

Fortunately patch 41756 does seem to be applied so once I rebooted it ignored the missing otp, pulled in the now correct board.bin and so far appears to have perfectly functional VHT80 for the first time on OpenWRT for me.

[NOTE]
Delete /etc/config/wireless after rebooting and then run "wifi-detect >/etc/config/wireless".  This will make sure both WiFi adapters are assigned correctly.  Also, luci does not support 802.11ac yet so its best to manually edit this file instead.

I only have a Galaxy Note 3 to test on but I am getting over 200Mbit throughput in both directions according to iperf.  It does seem to fluctuate by around 30-60Mbit compared to the stock firmware but its still a good speed.  Its hard to test much beyond iperf as Android is not exactly optimised for these kinds of speed.

There does seem to be a bug in ath10k though, it is not reporting the link speeds properly.  In fact the link speed is not changing at all in the UI or station dump, it was saying 6Mbit tx bitrate even when I got 237Mbit throughput to my phone.

I'm about to install the C7 (v1) version of this router on my network, and I'll be using the method in post 63. Just wanted to confirm a couple things. Since I'm already using the C7 hardware, i shouldnt need to remap the ports, right?
should I use the main trunk or the one posted in this thread?

I believe trunk should work fine for everything except 5Ghz WiFi which is not supported on the v1 in ANY build, unless you swap out the PCIe card.

As for the v2:

Been using it as my main WiFi both 2.4Ghz and 5Ghz now for 24 hours and so far its perfectly stable.  In fact, I haven't had the Galaxy Note 3 WiFi fail yet which it ALWAYS does on 5Ghz sooner or later.

[UPDATE]

Another couple of days use and I have only seen the Note 3 drop WiFi once and it ACTUALLY dropped, rather than what it used to do which was stop all data transfer and me have to manually force it to disconnect/reconnect.

Also done some further iperf testing after mounting the C7 on the wall and the speed I am getting now is near enough identical to the stock firmware, so very pleased there.  If only I had a three stream device to test I would be REALLY curious what speeds I could get.

Interestingly even my 2.4Ghz signal seems improved compared to the Buffalo WHR-HP-G300NH.   I haven't heard any complaints from my mum (who is stuck on 2.4Ghz) since the swap as the Buffalo had been crashing the WiFi lately, I think it may be failing due to the recent heatwave.

I am using the following version:
CHAOS CALMER (Bleeding Edge, r41945)

Is this a good version to use for Archer C7 V2? Anyone notice a drop in signal strength from previous?

I installed the ath10k driver and regenerated my wireless file. I have each band setup with PSK2 encryption. I can connect to 2Ghz but not 5Ghz unless unencrypted.

Any ideas? Here's my wireless config:

wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.channel=36
wireless.radio0.hwmode=11a
wireless.radio0.path=pci0000:01/0000:01:00.0
wireless.radio0.htmode=VHT80
wireless.radio0.disabled=0
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=radio0
wireless.@wifi-iface[0].network=lan
wireless.@wifi-iface[0].mode=ap
wireless.@wifi-iface[0].ssid=MillerNet 5Ghz
wireless.@wifi-iface[0].encryption=psk2
wireless.@wifi-iface[0].key=foofoofoo
wireless.radio1=wifi-device
wireless.radio1.type=mac80211
wireless.radio1.channel=11
wireless.radio1.hwmode=11g
wireless.radio1.path=platform/qca955x_wmac
wireless.radio1.htmode=HT20
wireless.radio1.disabled=0
wireless.@wifi-iface[1]=wifi-iface
wireless.@wifi-iface[1].device=radio1
wireless.@wifi-iface[1].network=lan
wireless.@wifi-iface[1].mode=ap
wireless.@wifi-iface[1].ssid=MillerNet
wireless.@wifi-iface[1].encryption=psk2
wireless.@wifi-iface[1].key=*******

@kamiller42: Have you tried VHT40, for me at lease 'iw reg get' doesn't list any 80Mhz channels, which I think would cause the interface to not come up.
If that doesn't work, then the below settings are working for me;

wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.channel=40
wireless.radio0.path=pci0000:01/0000:01:00.0
wireless.radio0.ht_capab=LDPC SHORT-GI-20 SHORT-GI-40 TX-STBC RX-STBC1 DSSS_CCK-40
wireless.radio0.vht_capab=MAX-MPDU-11454 RXLDPC SHORT-GI-80 TX-STBC-2BY1 RX-STBC-1 MAX-A-MPDU-LEN-EXP7 RX-ANTENNA-PATTERN TX-ANTENNA-PATTERN
wireless.radio0.country=GB
wireless.radio0.country_ie=1
wireless.radio0.distance=20
wireless.radio0.txpower=17
wireless.radio0.hwmode=11nac
wireless.radio0.htmode=VHT40
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=radio0
wireless.@wifi-iface[0].network=lan
wireless.@wifi-iface[0].mode=ap
wireless.@wifi-iface[0].encryption=psk2
wireless.@wifi-iface[0].key=<key>
wireless.@wifi-iface[0].ssid=<ssid>
wireless.@wifi-iface[0].short_preamble=1
wireless.@wifi-iface[0].uapsd=1

Strange thing is it works with VHT80, and it did before my last upgrade, but not with encryption. What happens is the PC reaches the router, prompts for password, I enter it and know it's right, and I get prompted again for a password. It's refusing to accept my password. I'll try VHT40, but I hate downgrading the router capabilities.

UPDATE: Just tried VHT40. I am still getting prompted for password repeatedly.

(Last edited by kamiller42 on 3 Aug 2014, 17:27)

Is it safe to downgrade a few versions using the steps outlined in Terminal Upgrade Process here...?
http://wiki.openwrt.org/doc/howto/generic.sysupgrade

I'm thinking of trying 14.07 RC2. Anyone have positive or negative experiences with it?

Was anything useful logged to indicate why it's failing, I remember having issues with a Mac on 5Ghz previously as it was trying to connect using the old a rather than the an N client, which failed because of something I'd disabled. This was on an older Tp-Link device, so probably not your issue, but the logs may explain what's going on

I don't think 14.07 RC2 is going to help, it seems to be based on r41580, 5Ghz was broken between r40800 and r41755 for our devices, it's only been working for the last 2 weeks so I'd not be surprised if there are a few more bugs to fix

Bought myself a C7 now that AC is working, got a v1.1 with a QCA9880-AR1A. Thought the v1s were all sold out by now, but no. Now to find something else to have fun with. sad

Sorry, posts 501 to 500 are missing from our archive.