OpenWrt Forum Archive

Topic: WDR4300 Wifi repeater

The content of this topic has been archived on 17 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello!

I just got my new TP-Link WDR4300 Dual band. As the router has dual band it can operate both at 2.4Ghz and 5Ghz wifi. I already have an Asus router connecting to the internet with BT modem (UK). The reason I bought the tp-link is to set it up as a wifi repeater. I flashed the openwrt and now trying to configure it. What I want to do is to set the tp-link to connect to the Asus wifi on 5Ghz band and accept as Access point on the 2.4Ghz. Is this possible?
Any idea / information would be awesome!

Thanks

hello,

You can try my config below. I use the same setup, connect to my main router using the 5 gHz channel.
main router: 192.168.1.1
SSID - 2.4 gHz : white
SSID - 5 gHz : yellow

secondary router : 192.168.1.3
Extend SSID - 2.4 gHz : white
connect to primary via 5 gHz

get the relayd installed on secondary router.


/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option dns '8.8.8.8'
    option ifname 'eth0.1'
    option ipaddr '192.168.1.3'
    option gateway '192.168.1.1'
    option broadcast '192.168.1.255'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 1 2 3 4 5'
    option vid '1'

config interface 'stabridge'
    option proto 'relay'
    list network 'lan'
    list network 'wwan'
    option ipaddr '192.168.1.5'

config interface 'wwan'
    option proto 'static'

/etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '90:f6:xx:xx:xx:xx'
    option hwmode '11ng'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option channel '11'
    option txpower '27'
    option htmode 'HT40-'
    option country 'US'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option macaddr '90:f6:xx:xx:xx:xx'
    option hwmode '11na'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '17'
    option htmode 'HT40+'
    option country 'US'
    option distance '50'

config wifi-iface
    option device 'radio1'
    option encryption 'psk2+ccmp'
    option key 'xxxxxxxx'
    option mode 'sta'
    option ssid 'Yellow'
    option network 'wwan'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'White'
    option encryption 'psk2+ccmp'
    option key 'xxxxxxxx'
    option network 'lan'

disable firewall

/etc/init.d/firewall stop
/etc/init.d/firewall disable 

All clients can access internet and can see and talk to each other. Link is very stable as well.

The only problem with this setup primary and secondary router can't talk to each other. Secondary router, from console, cant access the internet.

It sufficient for repeater, just abit annoyed with the disconnect between router primary and secondary. Would be good if someone can improve it.

The discussion might have continued from here.