OpenWrt Forum Archive

Topic: Seek help: HG553 Firmware direct support VLAN

The content of this topic has been archived on 14 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Dear friends,

I'm compile openwrt to hg553, there is a problem, I WAN port is not working properly.
I want to modify the default network configuration file "/etc/config/network"
I modify what files should be inside source "Attitude Adjustment" in order to achieve the division of VLAN?
Firmware direct support VLAN.
------------------------------------------------------------------------------------
The default network configuration:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127 .0.0.1 '
option netmask '255 .0.0.0 '

config interface 'lan'
option ifname 'eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192 .168.1.1 '
option netmask '255 .255.255.0 '

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

--------------------------------------------------------------------------------------
Corrected network configuration:

config switch 'eth1'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth1'
    option vlan '1'
    option ports '0 1 2 5t'

config switch_vlan
    option device 'eth1'
    option vlan '2'
    option ports '3 5t'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option nat '1'

config interface 'wan'
    option ifname 'eth1.2'
    option _orig_ifname 'eth1.2'
    option _orig_bridge 'false'
    option proto 'dhcp'


Looking forward to your reply.
Best regards!

tony

(Last edited by hxzhyx on 15 Mar 2013, 17:06)

replace "5*" with "5t"

dear jow,

I modify the network configuration in the following path, but unfortunately, compiled firmware is still the default configuration:
attitude_adjustment/target/linux/brcm63xx/base-files/etc/config/network
attitude_adjustment / package / base-files / files / etc / config / network

Can you see what I mean, what, the relatively poor level of English.

Thank you for your help.

Don't edit these files, they're not always used, some architectures generated them on the first boot instead.
To properly embed a custom network config into a firmware image, create a folder "files/etc/config/" in your buildroot toplevel directory (where you execute "make" in) and put your network config there.

dear jow, thanks again for your help, I hope you have a wonderful weekend.

tony

I need Firmware direct support VLAN help.

integrated management system

(Last edited by Samir151595 on 7 Apr 2013, 18:29)

The discussion might have continued from here.