Topic: My WR2543 got bricked by latest trunk build

I premise I've been running OpenWRT on a number of devices since 3 years now. I wouldn't describe myself as a newbie.
I've donwloaded trunk r33270 (25.aug.2012) in order to upgrade from r33212 (21.aug.2012).
As soon as I flashed the firmware I got my box bricked: only the power led is on.
As soon as I power cycle the box  I have all leds flashing for a moment. Then the power led stays on with a short flash of "internet" led.
Then only the power led is on.
Of course it's not working with either the default cfg (192.168.0.1) nor with my custom one (I've requested to keep the settings).
The wiki is not useful and both the reset and the qss buttons seems to be uneffective.
Should I open the box, solder the serial pad and go the hard way, or is there another non intrusive option?
Thanks in advance.

Sent as ripples into the electromagnetic field. No single photon has been harmed in the process.

Re: My WR2543 got bricked by latest trunk build

hi uqbar,

it's "funny" (hope u got the irony), i have the same problem with my WR1043ND and the current trunk build (https://forum.openwrt.org/viewtopic.php?id=38943). What i can say is, that access via serial console isnt working (used it several times before THIS brick, the last days). So before you open the box i suggest u wait until the pros hopefully come up with a solution. But i fear that somehow the bootloader got fucked up so that we need to unsolder the flash chip and reflash it (i wont do that though) sad

Re: My WR2543 got bricked by latest trunk build

mexyn wrote:

hi uqbar,

it's "funny" (hope u got the irony)

irony is saving my life these days ...
My dealer is offering a 2 year warranty. So I'll bring the box back saying it's not working anymore. :-P

Sent as ripples into the electromagnetic field. No single photon has been harmed in the process.

4 (edited by nebbia88 2012-08-29 06:13:21)

Re: My WR2543 got bricked by latest trunk build

omg, does this mean that lastest trunk is THAT dangerous for these and maybe other devices????

Re: My WR2543 got bricked by latest trunk build

nebbia88 wrote:

omg, does this mean that lastest trunk is THAT dangerous for these and maybe other devices????

This is a known issue.
Officially there is no warranty with trunk builds (and actually there's no warranty on any build).
As soon as you start uploading a non official formware into a device, your warranty gets voided.
You (as well as me) are the only one to blame in cases like this.

Sent as ripples into the electromagnetic field. No single photon has been harmed in the process.

Re: My WR2543 got bricked by latest trunk build

yes but usually you can recover with serial!! i don't think anyone will flash a trunk image if there's the possibility to have a permanent brick -.-

Re: My WR2543 got bricked by latest trunk build

nebbia88 wrote:

i don't think anyone will flash a trunk image if there's the possibility to have a permanent brick -.-

Well, I was not expecting a trunk build to brick my router.
I can expect new or experimental features to be broken. I understand there's no warranty (at all), but in the past 12+ trunk releases I never got any show-stopping issue.
Wishful thinking...

Sent as ripples into the electromagnetic field. No single photon has been harmed in the process.

Re: My WR2543 got bricked by latest trunk build

I got hit by this as well. For over a year, I've been using sysupgrade to upgrade my routers, and if something went wrong, failsafe worked.

What a shame...

I've updated the wiki so others are warned:

http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd?do=diff

Re: My WR2543 got bricked by latest trunk build

The issue got fixed with r33272 & r33274, latest snapshot iteration is at r33288 and should work fine, so the wiki notice is most likely outdated already.

10 (edited by Tuttle 2012-09-07 22:09:26)

Re: My WR2543 got bricked by latest trunk build

I was able to debrick my router with serial connection, so it's worth a try.

This was fixed https://lists.openwrt.org/pipermail/openwrt-devel/2012-August/016523.html

Re: My WR2543 got bricked by latest trunk build

I can confirm this. Coincidentally, Mirko was visiting Hong Kong and the problem was fixed quickly using serial and TFTP. Caveat: Find a proper ground connection if you see garbage on serial.

Re: My WR2543 got bricked by latest trunk build

I can also confirm that current trunk bricks 1043nd.
I've been building my own trunk for a couple years now, had a few problems along the way, but nothing that wasn't sorted out by a failsafe, I was always able to recover.
The tplink always seemed much more resilient than other hardware I'd used. But that was then, and this is now.
Just upgraded trunk to 33444 this morning. Built the image and flashed it. Now I have a brand new doorstop sad  I guess I shouldn't have been so complacent, should have re-read the page that actually says this will brick the unit.
Anyways, for what its worth, while I was flashing the unit I saw something that I hadn't seen before while flashing.
It said that my jffs partition needed to be fixed and it was going to fix it for me.
I wish it asked if I wanted it fixed sad
I am able to get the led's to flash quickly, just as you would expect from failsafe, but I have no access to the unit.

So, I'm off to the store to buy another unit. Just wanting some clarity, which version is safe?

Re: My WR2543 got bricked by latest trunk build

It turns out I need to modify my earlier statement. My router is not bricked.

I noticed that my cell phone had a wireless connection to the unit still. Upon checking it out I find that the unit is fine, I am able to log into it via ssh over wifi without any issues at all. Almost everything is as it was except for WAN.
Not sure what exactly has changed, but the wan led is not lighting up nor do I actually have a working wan.

All my custom files are still intact, all the software I put on the unit is still there. Even the custom configs are still operating as they always have, I just have no wan.

Would anyone know any commands I could issue to perhaps bring up the wan port?

Re: My WR2543 got bricked by latest trunk build

Hi

just wanted to know if the problem still exists. Can i safely upgrade my 1043nd to current trunk? Status page reports it as a "TP-Link TL-WR1043N/ND v1". Is this v1.0?

Re: My WR2543 got bricked by latest trunk build

atbs wrote:

Hi

just wanted to know if the problem still exists. Can i safely upgrade my 1043nd to current trunk? Status page reports it as a "TP-Link TL-WR1043N/ND v1". Is this v1.0?

Most definitely not! I also believed mine was 1.0 on my previous 1043 and got it bricked. To find out the correct hardware revision of the unit, you should never trust the webadmin page, but either use manufacturer's site or remove the housing of the device and find the appropriate sticker.