801 (edited by johan666 2012-08-12 19:01:55)

Re: Tp-link Tl-wr703n

giubari wrote:

Hi Guys, I'm having some problems with my openwrt installation.

I've got a wr703n chinese clone called "Fast FWR171-3G" managed to install open Wrt on it (tl-wr703n version) but I can't actually get any web interface.

I can connect via Telnet first then set passwd and connect via SSH (with putty) but I can't really do anything more.

At first I had wireless working but after an Hard Reset it's disappeared, I can't obviously connect it to internet and install luci.

If I try to go in folders like etc/config/dhcp or network or wifi i see them from ls but i cannot access them or even launch commands like config...
I get this "-ash: config: not found"

These are my specs:

Linux version 3.2.5 (openwrt@OpenWRTBuild) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Wed Feb 29 09:06:46 MST 2012

Can you help me.

"Config" !?
There is NO command called "config"
You should use build-in text editor to EDIT the "config files"
And, openwrt does NOT come with webui (web interface), you can only install it after you config your router to have internet connection.

something like that:

root@703N:/# ping ipv6.google.com
PING ipv6.google.com (2404:6800:8005::68): 56 data bytes
ping: can't create raw socket: Address family not supported by protocol
root@703N:/# ping goo.gl -w6
PING goo.gl (74.125.71.101): 56 data bytes
64 bytes from 74.125.71.101: seq=0 ttl=54 time=7.884 ms
64 bytes from 74.125.71.101: seq=1 ttl=54 time=5.284 ms
64 bytes from 74.125.71.101: seq=2 ttl=54 time=7.257 ms
64 bytes from 74.125.71.101: seq=3 ttl=54 time=7.253 ms
64 bytes from 74.125.71.101: seq=4 ttl=54 time=5.691 ms
64 bytes from 74.125.71.101: seq=5 ttl=54 time=6.091 ms

--- goo.gl ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 5.284/6.576/7.884 ms
root@703N:/#

Study the openwrt-wiki is a must for your guys.

Re: Tp-link Tl-wr703n

johan666 wrote:

......
Study the openwrt-wiki is a must for your guys.

Agreed.

Re: Tp-link Tl-wr703n

RyoSaeba wrote:

I'm sorry I must be missing something here... I got as far as changing the password and SSH into the device but that's as far as I got. This is where I'm stuck at:

2. Configure /etc/config/network with an IP address, gateway and DNS servers that allow the device to access the Internet. Either reboot the device or run "/etc/init.d/network restart" to apply the settings.

There's no "Configure" command. Another guide said "Edit /etc/config/netw...." but there's no edit command either.

When I try to type in "/etc/config/network" and hit enter, it gives me a "Permission Denied. "

Here's a screen shot:

http://img215.imageshack.us/img215/2388/permissiondenied.jpg

I tried running a opkg command but as you can see, it can't access the web...  what am I doing wrong?  How do I actually edit my IP?  A guide with a "Now type 'some command I actually type' " would be nice...

Sorry for being so noobish but any help would be greatly appreciated.

EDIT:  Ok I figure out how to edit files (no one mentioned vi but after hours of searching, I got it) and got the web interface installed, or it suppose it did. A bunch of stuff was downloaded and installed when I ran "opkg update" and "opkg install luci".

I try to access the router using a web browser but I get a "The connection was reset".... what did I do wrong now?

EDIT2: Ok, I finally got the router working by enabling radio0. I can even connect to it by wifi and use it as a router.  But still no web interface... every time I try to connect, I get a "The connection was reset."  Any idea guys?

can you explain me your edit2 ? how to get working

root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
wget: bad address 'downloads.openwrt.org'
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

804

Re: Tp-link Tl-wr703n

vi is the text editor which come with the 703n flash.  If you're not familiar with it, search the web for "vi cheat sheet".

Do you have internet access for your 703n?  For instance, what do you get if you do "ping www.google.com"?

Have you changed the default ip address on the 703n?   If not, do you have another 192.168.1.1 on your network?  Is your network in the 192.168.1 range?

If you haven't been able to edit your /etc/config files, then you won't have wireless active--you need to edit /etc/config/wireless to turn it on (and perhaps to set it up properly).  You should at least be familiar with the contents and significance of /etc/config/network and of /etc/config/wireless.  Consult the wiki for information.

What is your intended use?

805 (edited by fpopic 2012-08-13 18:38:48)

Re: Tp-link Tl-wr703n

I followed this instructions :
1. Connect your PC to the WR703N and configure it with a static IP of 192.168.1.2
2. Visit http://192.168.1.1/userRpm/SoftwareUpgradeRpm.htm
3. Upload the latest OpenWrt snapshot for the TL-WR703N (http://downloads.openwrt.org/snapshots/ … actory.bin)
4. Wait 4-5 minutes for the firmware to upload and the device to reboot. The blue LED will be lit solid when it's finished.
5. You should be able to telnet to the device on 192.168.1.1 and receive an OpenWrt prompt (no password required)
6. Set a password on the device (use the "passwd" command). Note: once you've done this you will need to SSH to the device, telnet will be disabled.
7. Configure /etc/config/network with an IP address, gateway and DNS servers that allow the device to access the Internet. Either reboot the device or run "/etc/init.d/network restart" to apply the settings.
8. Run "opkg update" and "opkg install luci" to install the web interface

I just want to install LUCI so i can go to router with web browser
I use ADSL network with adsl-router (192.168.1.254)

https://lh6.googleusercontent.com/-pFLWdgH-ALQ/UCkbU8BJjdI/AAAAAAAAAUQ/cdubQp-4ekc/s1600/sss.png

(wr703n is connected in one of it's lan ports)
192.168.1.100 is in range of 64-253 so puted .100

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'

Run "opkg update" and "opkg install luci" to install the web interface it says no connection :

Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
wget: bad address 'downloads.openwrt.org'
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
/etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  ec:17:2f:6b:e3:38
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-20
        list ht_capab   SHORT-GI-40
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        
config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none
TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

You need to add a line in the lan section:
option dns 'xxx.xxx.xxx.xxx', where the ip address of dns server can be either your gateway address or, as I usually do, using some public domain dns servers, e.g., '208.67.222.222' which is an opendns server.  Good luck.

807 (edited by fpopic 2012-08-13 19:16:10)

Re: Tp-link Tl-wr703n

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'
        option dns '192.168.1.254'

Thank you very much big_smile

for all other noobs as me nice video for PUTTY - VI EDITOR
http://www.youtube.com/watch?v=Kewk_ZxRejY


i putted this also for a full LuCI installation with HTTPS support enter

opkg install luci-ssl

Enable (so that it will be started at every boot) and start uHTTPd:

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

fpopic wrote:

Thank you very much big_smile

for all other noobs as me nice video for PUTTY - VI EDITOR
http://www.youtube.com/watch?v=Kewk_ZxRejY

Or use UCI CLI:

uci set network.lan.dns=192.168.1.254
uci commit network
ifup lan

809 (edited by twinclouds 2012-08-13 20:38:05)

Re: Tp-link Tl-wr703n

fpopic wrote:

........
i putted this also for a full LuCI installation with HTTPS support enter

opkg install luci-ssl

.......

If you use the original 4M flash without extroot, have you checked how much ROM still left?  Do a df you will know.  If not much left, be careful when you install other packages.

810 (edited by fpopic 2012-08-16 22:08:17)

Re: Tp-link Tl-wr703n

twinclouds wrote:

If you use the original 4M flash without extroot, have you checked how much ROM still left?  Do a df you will know.  If not much left, be careful when you install other packages.

next few days i will replace 8Mb Flash + add extroot and upgrade ram to 64mb


EDIT : i replaced 8mb today big_smile

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

fpopic wrote:
twinclouds wrote:

If you use the original 4M flash without extroot, have you checked how much ROM still left?  Do a df you will know.  If not much left, be careful when you install other packages.

next few days i will replace 8Mb Flash + add extroot and upgrade ram to 64mb

Replace the 8MB flash is easy, but if you use extroot, why you need that?  I have not done the 64 MB ram yet.  Looks like a difficult task.

Re: Tp-link Tl-wr703n

Hi! I'm newbie on this forum, newbie in using OpenWrt (or even linux) and this device! So, I have some question!
1) Can I use this device as client and AP at the same time? If YES, can you help me with settings?
2) Can I connect usbflash (for use extroot) and uvc webcam via usbhub to this device at the same time?
Thnx!

Re: Tp-link Tl-wr703n

AxelWind wrote:

Hi! I'm newbie on this forum, newbie in using OpenWrt (or even linux) and this device! So, I have some question!
1) Can I use this device as client and AP at the same time? If YES, can you help me with settings?
2) Can I connect usbflash (for use extroot) and uvc webcam via usbhub to this device at the same time?
Thnx!

I think the answers for both are yes and yes.  The first one is a little tricky if you want the 703n on the same subnet as the host but will be much easier if on different subnet.  I did this but don't have much experience so maybe others can help.
As for question 2, there's no problem.  I did this many times.
Good luck.

Re: Tp-link Tl-wr703n

twinclouds wrote:

I think the answers for both are yes and yes.  The first one is a little tricky if you want the 703n on the same subnet as the host but will be much easier if on different subnet.  I did this but don't have much experience so maybe others can help.
As for question 2, there's no problem.  I did this many times.
Good luck.

Great news! smile I will try! smile

815

Re: Tp-link Tl-wr703n

Hi I am also new to openwrt. I used before dd-wrt
Can somebody tell me step by step  best way to mount usb flash drive for installation of packages ?
I understand I need to install what packages to be able to mount external usb drive ?
Where will they be installed  ?
I guess they must go on 4MB flash, is there enough space left ?
How to  reset openwrt in case something goes wrong, can I use this command : mtd -r erase nvram
?

Re: Tp-link Tl-wr703n

etan wrote:

Hi I am also new to openwrt. I used before dd-wrt
Can somebody tell me step by step  best way to mount usb flash drive for installation of packages ?
I understand I need to install what packages to be able to mount external usb drive ?
Where will they be installed  ?
I guess they must go on 4MB flash, is there enough space left ?
How to  reset openwrt in case something goes wrong, can I use this command : mtd -r erase nvram
?

You can take a look of this: http://wiki.openwrt.org/doc/howto/extroot.  4MB will be sufficient but you'd better install extroot first (with needed packages) before install anything else.
When I did this, I compiled openwrt myself but it is out of date.  Let me see if I can find some more information before get back to you.

817 (edited by etan 2012-08-16 07:40:10)

Re: Tp-link Tl-wr703n

twinclouds wrote:
etan wrote:

Hi I am also new to openwrt. I used before dd-wrt
Can somebody tell me step by step  best way to mount usb flash drive for installation of packages ?
I understand I need to install what packages to be able to mount external usb drive ?
Where will they be installed  ?
I guess they must go on 4MB flash, is there enough space left ?
How to  reset openwrt in case something goes wrong, can I use this command : mtd -r erase nvram
?

You can take a look of this: http://wiki.openwrt.org/doc/howto/extroot.  4MB will be sufficient but you'd better install extroot first (with needed packages) before install anything else.
When I did this, I compiled openwrt myself but it is out of date.  Let me see if I can find some more information before get back to you.

Thank you but I would need more reading to compile opewrt and seems risky for me.
With recent "snapshot" firmware df -h shows some 1MB free space and lsmod shows usbcore and ehci is already in firmware.
Now when I read extroot howto it mentions another howto usb.essentials
My concern I will end up with duplicate packages when I follow extroot howto.
Hence my question about mtd -r erase nvram
Is it safe to reset openwrt that way ?
Or can I reflash squashfs-factory.bin to reset it  ?

818 (edited by twinclouds 2012-08-18 07:04:03)

Re: Tp-link Tl-wr703n

etan wrote:

......
Thank you but I would need more reading to compile opewrt and seems risky for me.
With recent "snapshot" firmware df -h shows some 1MB free space and lsmod shows usbcore and ehci is already in firmware.
Now when I read extroot howto it mentions another howto usb.essentials
My concern I will end up with duplicate packages when I follow extroot howto.
Hence my question about mtd -r erase nvram
Is it safe to reset openwrt that way ?
Or can I reflash squashfs-factory.bin to reset it  ?

You don't need to recompile.  Just follow the how-to.
You will never install any package twice.  It will ignore the request if the package is already installed.
I don't think you need to do mtd -r nvram.  I don't think I ever did.
The only confusion part is to make sure "/etc/config/fstab" match you openwrt version.  You can always try a couple options.  It is pretty safe.
Good luck.

Re: Tp-link Tl-wr703n

Hello

Any one have working config with relayd pseudobridge (repeater) working in leatest trunk? I'm following http://wiki.openwrt.org/doc/recipes/relayclient and it doesn't work. Also opened ticket (https://dev.openwrt.org/ticket/12063) but no solution yet.

820 (edited by fpopic 2012-08-31 15:46:39)

Re: Tp-link Tl-wr703n

hello, i googled some chinese sites about this router and i found nice POE thread for it.
Use Google Chrome (always translate chinese to english) + you have to register to see attachments and pictures

http://www.openwrt.org.cn/bbs/forum.php?mod=viewthread&tid=7046&extra=&page=1

so they made a power supply over ethernet cable without need of microUSB power charger, can somebody please tell me what things should i buy cause i have poe adapters but they don't fit in box so it is better to use that kind of direct poe from rj45 to board

http://i48.tinypic.com/2vmizcx.jpg

translated text under
POE powered through the network cable principle . standard UTP cable with four twisted pairs, but in l0M BASE-T and 100M BASE-T uses only one of the two pairs,
i.e. the crystal head 1/3 , 2/6 feet. POE remote power supply, the application is idle foot 4/5 and 7/8 foot DC power supply to the remote device.
2. cable fine, relatively high resistivity, so generally the higher voltage transmission (typically 12-48V ), to reduce line losses.
3. distal generally require the voltage drop back to normal voltage suitable for the route used.


poe :
http://www.eidusa.com/Electronics_Kits_PoE_injector.htm

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

szymon_zy wrote:

Hello

Any one have working config with relayd pseudobridge (repeater) working in leatest trunk? I'm following http://wiki.openwrt.org/doc/recipes/relayclient and it doesn't work. Also opened ticket (https://dev.openwrt.org/ticket/12063) but no solution yet.

It work for me with no encryption, 100% speed. 

Wr703n plug into laptop ethernet,
Using wep, webpage random stop loading, get about 300-500Kbps
Using wpa2, my speedtest is half, 3Mbps instead of 6Mbps from my wifi.

Re: Tp-link Tl-wr703n

fpopic wrote:

hello, i googled some chinese sites about this router and i found nice POE thread for it.
Use Google Chrome (always translate chinese to english) + you have to register to see attachments and pictures

http://www.openwrt.org.cn/bbs/forum.php?mod=viewthread&tid=7046&extra=&page=1

so they made a power supply over ethernet cable without need of microUSB power charger, can somebody please tell me what things should i buy cause i have poe adapters but they don't fit in box so it is better to use that kind of direct poe from rj45 to board

translated text under
POE powered through the network cable principle . standard UTP cable with four twisted pairs, but in l0M BASE-T and 100M BASE-T uses only one of the two pairs,
i.e. the crystal head 1/3 , 2/6 feet. POE remote power supply, the application is idle foot 4/5 and 7/8 foot DC power supply to the remote device.
2. cable fine, relatively high resistivity, so generally the higher voltage transmission (typically 12-48V ), to reduce line losses.
3. distal generally require the voltage drop back to normal voltage suitable for the route used.


poe :
http://www.eidusa.com/Electronics_Kits_PoE_injector.htm

The power supply fitted inside the WR703N is an MP2307-based DC-DC step-down power supply "KIS-3R33s" module with 4.75-23V 3A input and 95% efficiency. Just search for "KISS-3R33" on eBay, you can find some < $2 with free shipping.

Then basically, it says that usually only wires 1,2,3 and 6 are used in an RJ45 10/100 BASE-T Ethernet cable, so you can use the available 4,5,7 and 8 wires to carry power, but as these wires have high resistivity, you should power with at least 12V-48V to minimize losses.

However, it looks like they count on some voltage drop, as the KIS3R33 only withstand up to 23V.

You better have some spare WR703N to experiment smile

2x TP-Link TL-MR3020, 2x TP-Link TL-WR703N, 1x TP-Link TL-MR11U, 1x Hame MPR-L8

Re: Tp-link Tl-wr703n

ok did anybody tried that with normal power supply ?

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

fpopic wrote:

ok did anybody tried that with normal power supply ?

If by "normal" you mean a certified PoE load point supply, no.

But I don't see any reason why this shouldn't work with it.

They basically use some free pairs on the UTP cable and feed 5V to the GND/VUSB pins of the microUSB connector.

Now the problem is to find a good power supply that fits into the WR703N case!

2x TP-Link TL-MR3020, 2x TP-Link TL-WR703N, 1x TP-Link TL-MR11U, 1x Hame MPR-L8

825 (edited by fpopic 2012-09-01 22:22:35)

Re: Tp-link Tl-wr703n

ok i will give a try big_smile and suggestions beside kis3r33

any of those (use google chrome for translation) ?
http://leivin.taobao.com/?spm=2013.1.1000126.3

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)