Re: TP-Link TL-MR3020 Support

Thanks Nilfred for the info. Here is something else strange, now the 3G is stable but wifi became unstable:

Jun 15 03:24:55 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: authenticated
Jun 15 03:24:55 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: Station tried to associate before authentication (aid=-1 flags=0x0)
Jun 15 03:24:55 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: Station tried to associate before authentication (aid=-1 flags=0x0)
Jun 15 03:24:55 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: Station tried to associate before authentication (aid=-1 flags=0x0)

But very obviously, it's been authenticated, but the followed message still says: tried to associated before authentication....

Jun 15 03:28:17 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: authenticated
Jun 15 03:28:17 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: associated (aid 2)
Jun 15 03:28:17 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:aa:e8 IEEE 802.11: disassociated


why it keep authenticating?

Jun 15 04:12:22 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated
Jun 15 04:12:24 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: disassociated
Jun 15 04:12:28 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated
Jun 15 04:12:28 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated
Jun 15 04:12:34 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated
Jun 15 04:12:34 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: Station tried to associate before authentication (aid=-1 flags=0x0)
Jun 15 04:12:37 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: authenticated
Jun 15 04:12:37 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: associated (aid 1)
Jun 15 04:12:37 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 WPA: pairwise key handshake completed (RSN)
Jun 15 04:12:39 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated
Jun 15 04:12:41 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: Station tried to associate before authentication (aid=-1 flags=0x0)
Jun 15 04:12:44 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated
Jun 15 04:12:44 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: authenticated
Jun 15 04:12:44 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 IEEE 802.11: associated (aid 1)
Jun 15 04:12:44 OpenWrt daemon.info hostapd: wlan0: STA 10:0b:a9:5f:aa:e8 WPA: pairwise key handshake completed (RSN)
Jun 15 04:12:45 OpenWrt daemon.info hostapd: wlan0: STA 90:c1:15:cc:dd:a3 IEEE 802.11: authenticated

Re: TP-Link TL-MR3020 Support

luneng8183 wrote:

now the 3G is stable

Which was the root cause?

Netgear WNR854T (ARM Marvell Orion CPU 500MHz, Marvell 88W8361P mini-PCI STA only, 8/32MB) - trunk r17427 since 09/09/09 to 06-06-12 GLOD
TP-LINK TL-WR741ND v1.9 (Atheros AR7240 CPU 350MHz, Atheros AR9285 Chipset, 4/32MB) - trunk r23281 since 10/10/10
TP-LINK TL-MR3420 v1.1, TL-MR3220 v1.2 - trunk r25302 since 11/11/11
TP-LINK TL-WR842ND v1.0, TL-WR1043ND v1.8 - 12.09-rc1 since 12/12/12

Re: TP-Link TL-MR3020 Support

I wanted to know if there is any possibility where this router could work with a self-powered usb hub, and support various usb devices including a 3g modem, e.g, flash disk, external hard drive, printer etc. ?  If the hardware does, would OpenWRT be able to support something like this?   It would be great if one could also use this router for network printing, network storage, etc.

Re: TP-Link TL-MR3020 Support

sorry, I changed from Huawei E169 to Huawei E1782 then it became stable... but wifi start to drop...

Nilfred wrote:
luneng8183 wrote:

now the 3G is stable

Which was the root cause?

I kinda suspect the wifi and 3G conflict each other in this router using dd-wrt/openwrt...

Using LAN cable, I flashed this router then installed all essential ipk for 3G, start 3G, without enable wifi, everything works perfect.. then I enable wifi, 3G start to drop (with E169), change to E1782, wifi start to drop....

I really hope there is somebody who has successfully configured this router using same 3G modems HELP ME.

Now I flash back to original firmware and wait...

180

Re: TP-Link TL-MR3020 Support

I believe it is a matter of a too weak power supply. It would probably already help to tune down the wifi instead of letting it sendign with max power.

Re: TP-Link TL-MR3020 Support

jow wrote:

I believe it is a matter of a too weak power supply. It would probably already help to tune down the wifi instead of letting it sendign with max power.

how to tune down the wifi power? I didn't install luci, all were manually configured by editing config files.

Thanks.

Re: TP-Link TL-MR3020 Support

I state that I am a newbie to linux.
The latest snapshot works quite well on tp-link-mr3020.
The 3G internet key works fine.
But the dial on demand does not work, when not on active 3g connects.
I have tested with version openwrt x86 installed on vmware and I have the same problem.
Is there a solution?

Sorry for the grammar of this message that I made ??with the translator of google.

Thanks to those who I know to help.

Re: TP-Link TL-MR3020 Support

you use wifi LAN? or cable LAN?

ziomax66 wrote:

I state that I am a newbie to linux.
The latest snapshot works quite well on tp-link-mr3020.
The 3G internet key works fine.
But the dial on demand does not work, when not on active 3g connects.
I have tested with version openwrt x86 installed on vmware and I have the same problem.
Is there a solution?

Sorry for the grammar of this message that I made ??with the translator of google.

Thanks to those who I know to help.

Re: TP-Link TL-MR3020 Support

luneng8183 : you use wifi LAN? or cable LAN?

The Internet is a key olicard 200 and properly setting usbserial connects fine.

I use wifi with WPA2 security and country "IT" power level 100 mW (the wifi has a small bug on speed instead of 150 Mbps applications wifi scanner I report it as 74 Mbps).

It also works well if you use the ethernet port.

The connection on demand when I should use the wifi.

Re: TP-Link TL-MR3020 Support

hi, how to use MR3020's serial port /dev/ttyATH0 for my own purpose (send to or receive from some device)? in this case, i use digitemp to read temperature sensor yields error "Error 24: Failed to initialize system resources", but when i use usb to serial which connected at /dev/ttyUSB0 it works! My hunch is /dev/ttyATH0 locked to system console or something. I prefer NOT to recompile image, is there any other way?

Re: TP-Link TL-MR3020 Support

Wanna learn from you how to configure the power level to 100mW?

Really appreciate if you can paste your /etc/config/wireless here.

I have problem using Huawei USB 3G modem together with wifi enabled, some people said it could due to power consumption problem.

ziomax66 wrote:

luneng8183 : you use wifi LAN? or cable LAN?

The Internet is a key olicard 200 and properly setting usbserial connects fine.

I use wifi with WPA2 security and country "IT" power level 100 mW (the wifi has a small bug on speed instead of 150 Mbps applications wifi scanner I report it as 74 Mbps).

It also works well if you use the ethernet port.

The connection on demand when I should use the wifi.

Re: TP-Link TL-MR3020 Support

luneng8183 wrote:

Wanna learn from you how to configure the power level to 100mW?

Really appreciate if you can paste your /etc/config/wireless here.

I have problem using Huawei USB 3G modem together with wifi enabled, some people said it could due to power consumption problem.

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option macaddr '90:f6:52:20:bf:62'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country 'IT'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'psk-mixed'
    option key 'miapassword'

root@OpenWrt:~#

Re: TP-Link TL-MR3020 Support

Thx for the info. I tried "option txpower 20", later I also changed to 17, 14...

whatever I changed, using "iw phy0 info", I can see the txpower still show "20dBm"... seems there is no effect at all.

anyway, now wif+3G works perfectly with Huawei E-1782, but 3G will always drop after 2-5 minutes with Huawei E-169... I give up E-169 with openwrt (use it with tp-link origin fw).

ziomax66 wrote:
luneng8183 wrote:

Wanna learn from you how to configure the power level to 100mW?

Really appreciate if you can paste your /etc/config/wireless here.

I have problem using Huawei USB 3G modem together with wifi enabled, some people said it could due to power consumption problem.

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option macaddr '90:f6:52:20:bf:62'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country 'IT'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'psk-mixed'
    option key 'miapassword'

root@OpenWrt:~#

Re: TP-Link TL-MR3020 Support

to:luneng8183

But the original 5V power adapter from the router 1 A. or via the two USB ports (500 +500 mA.) on your computer?

Re: TP-Link TL-MR3020 Support

Hi!

"For this to work, you want to have 1 ap mode, 1 client mode entry and a 3G wan in /etc/config/network."

This is a bit cryptic for me ! Should I add 3 config interface lines on /etc/config/network?

Thanks!

Re: TP-Link TL-MR3020 Support

use power adapter.


ziomax66 wrote:

to:luneng8183

But the original 5V power adapter from the router 1 A. or via the two USB ports (500 +500 mA.) on your computer?

Re: TP-Link TL-MR3020 Support

luisfmoreira wrote:

Hi!

"For this to work, you want to have 1 ap mode, 1 client mode entry and a 3G wan in /etc/config/network."

This is a bit cryptic for me ! Should I add 3 config interface lines on /etc/config/network?

Thanks!

buddy, what you have to do is telnet/ssh into mr3020 and vi /etc/config/network... you will see that if you need 3g works, you have to add 1 entry wan for 3g only.

Re: TP-Link TL-MR3020 Support

Thanks!

I was referring to the button switch on the side (3g wisp ap), i want to use it but I wasn't understanding that part of the instructions!
What I was asking is do I need to add anything specific to make the switch work.

I was trying to use it to make 3 configs:

1 Bridge
2 AP and STA masquerade
3 Share my iphone connection (but I'm having trouble installing the iphone on openwrt)

Do you reckon it is possible?

Re: TP-Link TL-MR3020 Support

Hello,

I don't know if this is the right place to ask, but I've been planning on buying a TL-MR3020 and was wondering if it was possible to use transmission on it since it only has a 4mb flash and 32mb of ram. Is it possible to install transmission on an external drive (the drive that it will download the files on?)  I was also planning on installing other programs on it (PirateBox) and don't know if it will be able to do all that simultaneously with such low specs. Can anyone shed some light on this issue?

Thanks in advance!

195

Re: TP-Link TL-MR3020 Support

Hi Nvirjskly,
have a look at this page http://wiki.openwrt.org/doc/recipes/install.packages.on.usb-stick

Good luck smile

Matthias

Re: TP-Link TL-MR3020 Support

You should read all the wiki.openwrt

root@MR3020:/# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  885.3M     16.5M    824.3M   2% /
/dev/root                 2.3M      2.3M         0 100% /rom
tmpfs                    14.0M    176.0K     13.9M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
overlayfs:/overlay      885.3M     16.5M    824.3M   2% /

197 (edited by ElectricSheep 2012-07-02 16:58:55)

Re: TP-Link TL-MR3020 Support

Nvirjskly wrote:

Hello,

I don't know if this is the right place to ask, but I've been planning on buying a TL-MR3020 and was wondering if it was possible to use transmission on it since it only has a 4mb flash and 32mb of ram. Is it possible to install transmission on an external drive (the drive that it will download the files on?)  I was also planning on installing other programs on it (PirateBox) and don't know if it will be able to do all that simultaneously with such low specs. Can anyone shed some light on this issue?

Thanks in advance!

MaStr wrote:

Hi Nvirjskly,
have a look at this page http://wiki.openwrt.org/doc/recipes/install.packages.on.usb-stick

Good luck smile

Matthias

I tried installing the packages required for external support a few days ago, but it wouldn't let me due to the older kernel installed. So i went about upgrading the version, went to the repository, downloaded the latest version and updated via the luci interface. But i ended up bricking it. doh. It just cycles on and off.

Re: TP-Link TL-MR3020 Support

I reinstalled the latest version of trunk to mr3020 but the dial on demand on 'interface 3G' still does not work.

If I enable this feature the internet key never connects.

Someone help me to operate dial on demand?

You could see if it works for you and open a ticket to developers?

199 (edited by languagegame 2012-07-12 06:54:16)

Re: TP-Link TL-MR3020 Support

wurststulle wrote:
st3n wrote:

Hi,

On my MR3020, I try to manage the position of my sliding switch  (3 positions managed by BTN_0 and BTN_1 values)

However, the script /etc/hotplug.d/button/00-button can only manage one button at a time. I would need to know both values (bt0 and bt1) to take the correct action.
I can't use "echo xxx > /sys/class/gpio/export", it said that the pin is busy.

Any hints to manage the 3G/WISP/AP switch ?

Thanks

any news on this?

Try the following in /etc/hotplug.d/button/00-button.  Then replace the logger lines with whatever code you want to run.

#!/bin/sh

if [ $ACTION == "released" ] ; then
if [ $BUTTON == "BTN_1" ] ; then
logger "Slider 3G"
elif [ $BUTTON == "BTN_0" ] ; then
logger "Slider WISP"
fi
elif [ $BUTTON == "BTN_0" ] || [ $BUTTON == "BTN_1" ] ; then
if grep -qe "sw1.*in  hi" /sys/kernel/debug/gpio ; then
if grep -qe "sw2.*in  hi" /sys/kernel/debug/gpio ; then
logger "Slider AP"
fi
fi
fi

Re: TP-Link TL-MR3020 Support

luisfmoreira wrote:

Thanks!

I was referring to the button switch on the side (3g wisp ap), i want to use it but I wasn't understanding that part of the instructions!
What I was asking is do I need to add anything specific to make the switch work.

I was trying to use it to make 3 configs:

1 Bridge
2 AP and STA masquerade
3 Share my iphone connection (but I'm having trouble installing the iphone on openwrt)

Do you reckon it is possible?

I setup a script to run on boot that reads the position of the switch and sets the configuration accordingly.

Run the following:

touch /etc/init.d/slider
chmod 777 /etc/init.d/slider

Then paste something like the following into /etc/init.d/slider.  You'll need to insert uci commands to configure the networking and wireless configuration according to the position of the slider switch.

#!/bin/sh /etc/rc.common

START=19
boot() {
if grep -qe "sw2.*in  hi" /sys/kernel/debug/gpio ; then
if grep -qe "sw1.*in  hi" /sys/kernel/debug/gpio ; then
# AP
logger "Configure AP"
# PUT UCI STATEMENTS HERE TO CONFIGURE AP MODE
uci commit
else
# WISP
logger "Configure WISP"
# PUT UCI STATEMENTS HERE TO CONFIGURE WISP MODE
uci commit
fi
else
# 3G
logger "Configure 3G"
# PUT UCI STATEMENTS HERE TO CONFIGURE 3G MODE
uci commit
fi
}

Finally, enable the script to run on boot. 

/etc/init.d/slider enable

It will read the position of the switch early in the boot process, and update the network configuration prior to networking being activated.