Topic: TP-Link TL-MR3420 v1.2

I have flashed a firmware "OpenWrt Backfire 10.03.1 final". When I set WDS function then reboot, only "SYS" led light is slowly flashing (no any respond).
I want to know how to get "Fail Safe" mode with reset firstboot.

I tried to test many method for failsafe mode but unsuccessful. How can help me ?  Thanks!

2 (edited by Dioptimizer 2011-12-25 05:35:45)

Re: TP-Link TL-MR3420 v1.2

Try this.
You need set static IP addres for this router.

Re: TP-Link TL-MR3420 v1.2

Thanks for your help but unsuccessful. I followed this procedure... I press and hold 'QSS' button above 2 minutes which 'SYS' led is still slowly flashing.
How long is hold 'QSS' button ?

Resetting of the Safe Mode
• Turn off the router
• Prescribe in the settings of your network card a static IP in the range of 192.168.1.2 and 192.168 .254 (make sure your computer is connected to the first LAN port of router)
• Turn on the router
• Once the flashing 'SYS' LED (signaling system boot), press and hold the button on the front panel 'QSS' until the LED 'SYS' flashes very quickly.
• You can then open a telnet console at 192.168.1.1. Without requiring a username and password.

Re: TP-Link TL-MR3420 v1.2

Try the same procedure except use 'Reset' button instead of 'QSS'

Re: TP-Link TL-MR3420 v1.2

Hi,
  I am having the same problem. i also tried reset button instead.
  Any luck on on your router?

Thanks

6 (edited by franco127 2012-01-03 00:05:03)

Re: TP-Link TL-MR3420 v1.2

try this trick:
Power up the router and press the button many times (keep toggling) very fast.
The SYS LED  on your  Tl-mr3420  starts to change the blinking frequency from slow to fast if it worked.
after that use telnet 192.168.1.1   and try a reset command!after that if are all ok  you returned in old situation after
bricked state!

Re: TP-Link TL-MR3420 v1.2

Backfire 10.03.1 final R295xx 21 dec 2011 Can not reset by QSS button (for MR3420),
you can debricking with serial cable

Tl-MR3220

Re: TP-Link TL-MR3420 v1.2

Watch out! If you need to use the serial port, you need to have a pull-up resistor between TX and VCC. I managed to get something over serial, but my message was a bit garbled (with every keytroke double text coming back, half readable, other half gibberish). I guess it was because of that. So I did not believe in the correctness of the soldering and started forcing. Now I do not have any text coming from the serial line...

Re: TP-Link TL-MR3420 v1.2

3420 v1.2 may not require pull-up resistors as confirmed for 3220 v1.2

Netgear WNR854T (ARM Marvell Orion CPU 500MHz, Marvell 88W8361P mini-PCI STA only, 8/32MB) - trunk r17427 since 09/09/09 to 06-06-12 GLOD
TP-LINK TL-WR741ND v1.9 (Atheros AR7240 CPU 350MHz, Atheros AR9285 Chipset, 4/32MB) - trunk r23281 since 10/10/10
TP-LINK TL-MR3420 v1.1, TL-MR3220 v1.2 - trunk r25302 since 11/11/11
TP-LINK TL-WR842ND v1.0, TL-WR1043ND v1.8 - 12.09-rc1 since 12/12/12

Re: TP-Link TL-MR3420 v1.2

Nilfred wrote:

3420 v1.2 may not require pull-up resistors

I have the Model 3420 v1.2,  pull-up 10K resistor is required ......... and I am not alone ...... wink

Re: TP-Link TL-MR3420 v1.2

I have load the trunk file without web interface and now i can't collegate my router,TP-Link MR 3420,but the pc recognize it,ip 192.168.1.1 but I cant speak with him,any solution?I never use telnet or ssh,thanks

12 (edited by garynych 2012-06-18 18:44:45)

Re: TP-Link TL-MR3420 v1.2

telnet 192.168.1.1

http://wiki.openwrt.org/doc/howto/firstlogin   set password

very convenient to edit via winSCP (but only after you set the password for root)

http://s019.radikal.ru/i616/1206/25/4edaa7a96889.png
http://s019.radikal.ru/i616/1206/15/25cfda9b6ccd.jpg

http://wiki.openwrt.org/doc/howto/internet.connection  config network

http://wiki.openwrt.org/doc/howto/luci.essentials  install luci

Re: TP-Link TL-MR3420 v1.2

I do it,and now how can I install Luci gui or wher can I find a package to put in tmp,I'm not able to have internet connection

14 (edited by garynych 2012-06-18 20:33:11)

Re: TP-Link TL-MR3420 v1.2

Svensimilla wrote:

I do it,and now how can I install Luci gui or wher can I find a package to put in tmp,I'm not able to have internet connection

garynych wrote:

telnet 192.168.1.1

http://wiki.openwrt.org/doc/howto/luci.essentials  install luci

if install from tmp

download package

http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/

put in /tmp and in putty type  opkg install /tmp/you_packages.ipk

only I'm not sure that it will come out ... most likely there are dependent packages (when installation is that the automatic install) check yourself ...

Re: TP-Link TL-MR3420 v1.2

I not understand tonight,tomorrow  is another day.

Re: TP-Link TL-MR3420 v1.2

Today I'm not able to collegate winscp with router,psw error,but in putty the psw is correct,why this?

Re: TP-Link TL-MR3420 v1.2

protocol set SCP, like my screen?

Re: TP-Link TL-MR3420 v1.2

Ok I solved with winscp,but I can't install Luci Gui,internet connection is down.I have another router with ADSL but I can't download,
i write with putty
opkg update
Downloading ftp hmm/192.168.1.100/Package/Packages.gz
wget:Can't connect to remote host (192.168.1.100):Connection refused or no route to host

My Lan Ip of Mr3240 is 192.168.1.1
My Wan Ip of Mr3420 is 192.168.1.4
my Netgear Ip is 192.168.1.2
my pc Ip is 192.168.1.3


Yesterday I have put the packages.gz in tmp,but the web interface is K.O

19 (edited by Svensimilla 2012-06-19 14:57:31)

Re: TP-Link TL-MR3420 v1.2

I have install all this packages,version is 3.3.8,but no web interface
    nano_2.2.6-1_ar71xx.ipk
    terminfo_5.7-5_ar71xx.ipk
    libncurses_5.7-5_ar71xx.ipk

    chat_2.4.5-4_ar71xx.ipk
    comgt_0.32-9_ar71xx.ipk
    kmod-usb-serial_2.6.39.4-1_ar71xx.ipk
    kmod-usb-serial-option_2.6.39.4-1_ar71xx.ipk
    kmod-usb-serial-wwan_2.6.39.4-1_ar71xx.ipk
    libusb_0.1.12-2_ar71xx.ipk
    usb-modeswitch_1.2.0-2_ar71xx.ipk
    usb-modeswitch-data_20111023-1_ar71xx.ipk
    luci-i18n-italian_trunk+svn8702-1_ar71xx.ipk

    kmod-usb2_2.6.39.4-1_ar71xx.ipk
    kmod-usb-core_2.6.39.4-1_ar71xx.ipk
    kmod-usb-ohci_2.6.39.4-1_ar71xx.ipk
what I have forget?

20 (edited by garynych 2012-06-19 15:15:20)

Re: TP-Link TL-MR3420 v1.2

1. opkg update
2. opkg install luci
3. /etc/init.d/uhttpd enable
4. /etc/init.d/uhttpd start

and go web http://192.168.1.1

21 (edited by Svensimilla 2012-06-19 15:35:56)

Re: TP-Link TL-MR3420 v1.2

opkg update?I haven't internet connection,or better I have internet but i can't collegate the 2 routers

Re: TP-Link TL-MR3420 v1.2

Ok now its ko,i have changed the internet config file to activate y 3g key,and now no answer from router

Re: TP-Link TL-MR3420 v1.2

it`s my network from /etc/config

wan it`s 3g

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option dns '8.8.8.8'

config interface 'wan'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'
    option proto '3g'
    option device '/dev/ttyUSB0'
    option service 'umts'
    option apn 'internet'
    option mtu '1400'
    option maxwait '20'
    option username 'gdata'
    option password 'gdata'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0 1 2 3 4'

home lan (dhcp)

Re: TP-Link TL-MR3420 v1.2

if you not connect to router use failsafe mode to reset all

Re: TP-Link TL-MR3420 v1.2

ok,you have help me another time,now i speak with my router,i have installed a lot of files ipk,but the luci web interface don't starts,ok tomorrow is anothet day.