1 (edited by soopersonic 2012-05-01 11:26:41)

Topic: TP-Link TL-WR1043ND LAN <> WAN throughput

I'm using the TP-Link TL-WR1043ND with Backfire 10.03.1, flashed directly from the original firmware. My connection is establed using PPPoE.

I bought the WR1043ND because, according to this chart and this site, it's able to put through the full 100mbit/s my ISP provides me with.

But in tests (for example speedtest.net) I'm unable to get more than 60 - 70 mbit/s downstream. The upstream is absolutely fine (50 mbit/s). Also, when I connect my computer directly to WAN, I get what I should: 95 mbit/s downstream.

Is there anything I could do to improve OpenWrt's throughput?


Further information:
* I'm using luci-app-qos, but disabled it in the admin interface
* I also tried it without having OpenVPN listening
* top while testing:

Mem: 21172K used, 8256K free, 0K shrd, 1912K buff, 9224K cached
CPU:   0% usr   0% sys   0% nic 100% idle   0% io   0% irq   0% sirq
Load average: 0.07 0.02 0.00 1/38 6953
  PID  PPID USER     STAT   VSZ %MEM %CPU COMMAND
 3964     1 root     S     3064  10%   0% /usr/sbin/openvpn --syslog openvpn(la
 4512     1 root     S     1624   6%   0% /usr/sbin/pppd plugin rp-pppoe.so mtu
  909     1 root     S     1496   5%   0% hostapd -P /var/run/wifi-phy0.pid -B
 6618     1 root     S     1468   5%   0% /bin/sh /usr/lib/ddns/dynamic_dns_upd
 1512     1 root     S     1388   5%   0% crond -c /etc/crontabs -l 8
  315     1 root     S     1388   5%   0% syslogd -C16
    1     0 root     S     1384   5%   0% init
 6948  6947 root     S     1384   5%   0% -ash
  295     1 root     S     1384   5%   0% init
 1649     1 root     S     1380   5%   0% watchdog -t 5 /dev/watchdog
 1653     1 root     S     1380   5%   0% /usr/sbin/ntpd -n -p 0.openwrt.pool.n
 6953  6948 root     R     1376   5%   0% top
  317     1 root     S     1372   5%   0% klogd
 6946  6618 root     S     1368   5%   0% sleep 600
 6947  1529 root     S     1204   4%   0% /usr/sbin/dropbear -P /var/run/dropbe
 1529     1 root     S     1132   4%   0% /usr/sbin/dropbear -P /var/run/dropbe
 1610     1 root     S     1016   3%   0% /usr/sbin/uhttpd -f -h /www -r Router
 1635     1 nobody   S      928   3%   0% /usr/sbin/dnsmasq -K -D -y -Z -b -E -
  331     1 root     S      784   3%   0% /sbin/hotplug2 --override --persisten
   91     2 root     SW       0   0%   0% [ar71xx-spi]

Re: TP-Link TL-WR1043ND LAN <> WAN throughput

opkg remove --autoremove luci-app-qos

And all is good. Shouldn't be this way (or at least be documented) but I guess it's somehow logical, as qos is nothing that's "running" but a set of configuration values.

Re: TP-Link TL-WR1043ND LAN <> WAN throughput

https://forum.openwrt.org/viewtopic.php?id=30110

duplicate?

nice finding about the qos thing..

Re: TP-Link TL-WR1043ND LAN <> WAN throughput

Probably. Didn't want to revive a too old thread. Some hate it when people do that in forums. Never really understood why, though smile

Re: TP-Link TL-WR1043ND LAN <> WAN throughput

Did you try
/etc/init.d/qos stop
/etc/init.dqos disable

6 (edited by soopersonic 2012-05-01 12:43:07)

Re: TP-Link TL-WR1043ND LAN <> WAN throughput

I stopped qos, but I didn't disable it and also didn't reboot.

Anyway: If enabling QOS means my max. downstream bandwidth goes down to 60mbit/s, I don't need it installed smile