2,826

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Where can I run this command?

2,827

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Through SSH or telnet

2,828

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

I did that and nothing happens. When i press enter after than line I get new command line waiting for me to end the command somehow.

2,829

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Jow forgot that before the closing brace you need a semicolon too

...    ; } |

2,830

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

OK I finnaly got it working and this is the response.


    0     0 ACCEPT     tcp  --  *      *       192.168.1.0/24       192.168.1.10                                             0       tcp dpt:3389
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            192.168.1.10                                             0       tcp dpt:3389
    0     0 DNAT       tcp  --  *      *       192.168.1.0/24       92.37.121.20                                             9       tcp dpt:3389 to:192.168.1.100:3389
    0     0 SNAT       tcp  --  *      *       192.168.1.0/24       192.168.1.10                                             0       tcp dpt:3389 to:192.168.1.1
    0     0 DNAT       tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                        tcp dpt:3389 to:192.168.1.100:3389

2,831

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Well??? Can someone please help me? Why my RDC does not work? Where lies the issue?

2,832

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Your rules where never reached, that hints at the fact that your isp filters those ports.
Try to use an high external port, like 12345 and see if you can connect to that.

2,833

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

I checked with my ISP and they do not filter ANY ports. The problems is with OpenWRT build installed on my router. The way I see it, the port forwarding weather DOES NOT work as it should OR I don't know how to configure it properly (very posible).

Can someone PLEASE post the PROPER way to forward port in LUCI?

The strange this is that I do have open port for uTorrent but I cannot connect over RDC and also I cannot access my webserver that is on the same compurer.

HELP!!!!

2,834 (edited by johan81 2012-04-20 16:48:51)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Drop this:

config redirect
    option src 'wan'
    option src_dport '3389'
    option dest 'lan'
    option dest_ip '192.168.1.10'
    option dest_port '3389'
    option proto 'tcp'
    option name 'RDP'

in your /etc/config/firewall file and restart firewall (sometimes you need to do a reboot). Then it should be fine.

In this rule I assume the PC you use RDP with, has a reserved IP address of 192.168.1.10 in your DHCP config. Also, you have to make sure that your Windows firewall has the proper rules as well!

2,835

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

johan81, that will result in exactly the same rules he already has.
At this point I suspect that either
a) something from the outside is filtering RDP requests
b) the destination host does not actually listen on the RDP port (though the rules grepped above should have nonzero counters then)
c) a non-redirect rule is actually filtering traffic away destined for the redirect. At some point the order of rules and redirects was changed in trunk to allow rules to overrule redirects

2,836

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Jow can u please post the pictures of all your settings under firewall section in Luci?

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Oh good its not just me! I feel a little better about that.

I have a thread over here that has the exact same issue!

I'm not sure which build I have exactly, as I'm at work and I changed it so many times to try to get it working.

2,838 (edited by doctor78 2012-04-20 23:57:26)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Try putting the following

iptables -t nat -A POSTROUTING -j MASQUERADE

under firewalls custom commands and reboot router. Let me know if it helped.

EDIT: This alone does not solve the problem. However I solved my problem. For some reason my server did not get a proper IP. Even thou I did checked this many times I guess a chain of stupid events prevented me from configuring my settings properly ALL TOGETHER. I have different mistakes at different times. So now I finnaly got them all right. I actualy feel pretty ashamed cause I am not some rookie in this things and I really thought I have all thing configured properly. I guess I was wrong.

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

doctor78 wrote:

Try putting the following

iptables -t nat -A POSTROUTING -j MASQUERADE

under firewalls custom commands and reboot router. Let me know if it helped.

EDIT: This alone does not solve the problem. However I solved my problem. For some reason my server did not get a proper IP. Even thou I did checked this many times I guess a chain of stupid events prevented me from configuring my settings properly ALL TOGETHER. I have different mistakes at different times. So now I finnaly got them all right. I actualy feel pretty ashamed cause I am not some rookie in this things and I really thought I have all thing configured properly. I guess I was wrong.

Thanks for the hint, but it didn't do anything.

I know my server has the proper IP and the proper gateway, and its listening on the correct port , because I verified that I can connect to that server on that IP with that port. It fact, I didn't change anything except the router from the old Netgear which worked fine- so it also isn't my ISP.

Jow posted a list of steps in the other thread that I'm going to try later tonight. I really did nothing except set up DHCP, and set up port forwarding. So something has to be going on.

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

I finally got it to work, and I think your hint did help.

2,841 (edited by SRG 2012-04-22 13:18:32)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

I've just installed the openwrt-ar71xx-generic-wndr3700-squashfs-factory.img on a WNDR3700v1 the r31219 (was running for a long time the last official firmware), and it's just unusable : the whole router is incredibly slow.
I just can't browse the LuCI interface (one or two pages show up normally, then it just hang).
Most of the pages then just gave an error. If i open a new tab and i log in again, i can then navigate again on one or two pages then it just slows down / hangs again.
Internet connection was automatically detected but seems damn slow too.

What can be the cause of this problem ?

I haven't configured yet a single thing (but it's quite impossible for me to configure anything as the whole interface is just unusable / too slow)
Last time i tried this build or openwrt directly, i too had a lot of issues, is this openwrt firmware supposed to be stable now on a WNDR3700v1 ?

edit : i think the fact that the router becomes awefully slow is caused to a linux server attached on the network with a torrent client and a few torrents (running Vuze). Indeed, if i unplug that network cable, the openwrt router behaves normally, if i put it back, it becomes slows again nearly immediately. The point is that everything works very well with the official firmware (that i've just restored)

2,842

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

apple4ever wrote:
doctor78 wrote:

Try putting the following

iptables -t nat -A POSTROUTING -j MASQUERADE

under firewalls custom commands and reboot router. Let me know if it helped.

EDIT: This alone does not solve the problem. However I solved my problem. For some reason my server did not get a proper IP. Even thou I did checked this many times I guess a chain of stupid events prevented me from configuring my settings properly ALL TOGETHER. I have different mistakes at different times. So now I finnaly got them all right. I actualy feel pretty ashamed cause I am not some rookie in this things and I really thought I have all thing configured properly. I guess I was wrong.

Thanks for the hint, but it didn't do anything.

I know my server has the proper IP and the proper gateway, and its listening on the correct port , because I verified that I can connect to that server on that IP with that port. It fact, I didn't change anything except the router from the old Netgear which worked fine- so it also isn't my ISP.

Jow posted a list of steps in the other thread that I'm going to try later tonight. I really did nothing except set up DHCP, and set up port forwarding. So something has to be going on.

I am glad you got it to work. To be honest I am not sure what was the problem with my configuration. I don't think it was realy wrong IP. But after triple reinstall of OpenWRT, one DD-WRT and official Netgear FW I got it to work. So I dunno what fixed my problem.

2,843 (edited by Desert 2012-04-23 21:12:48)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Hi Guys,

today i tried to get a IPv6 (6in4) Tunnel (tunnelbroker.com) to work, but no Luck with the latest arokh build (r31216).

With the Standard-Backfire Release the Tunnel works really well, but then my LAN is slow, because of the Lack of Support for Jumboframes.

The Configuration works well but after a Reboot i cant start the "henet" Interface: "Cannot find device "6in4-henet""

I use these How-Tos and Wiki-Entries:
https://forum.openwrt.org/viewtopic.php?pid=159878
https://forum.openwrt.org/viewtopic.php?id=27541
http://wiki.openwrt.org/doc/howto/ipv6

Is there some difference in Configuration of the Tunnel between the Standard Backfire Release and the arokh Build?

Edit:
I'am sorry to waste your Time. Tried it again and now it works like a Charme, dont know what happend.... yikes

2,844

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Is the first post its feature list complete? Has been a while since it has been updated while I see that the latest build is from 08-04-2012. Are the sources also available via git/svn? I could only find the trunk of openwrt but not this specific branch.

It seems that r31219 is the latest version:

http://enduser.subsignal.org/~trondah/latest-release-is-r31219/


I currently have OpenWrt Backfire 10.03.1 running on my WNDR3700v1, my guess is that I need the following update, Is that correct?

openwrt-ar71xx-generic-wndr3700-squashfs-sysupgrade.bin



Do I need to back-up my previous changes? I have configure some firewall rules and setup PPTPD.


The reason that I want to upgrade is that in 10.03.1 Jumbo Frames are disabled and the first post of this thread says that this is now enabled.

2,845 (edited by Desert 2012-04-23 22:36:46)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

The IPv6 Tunnel Problem ist gone now, but i have a new one. neutral radvd fills my Log up with these Entries, i found a Ticket about this Problem but its over 3 Moths ago that someone had closed this Ticket. Is there something that i can do about this?

Apr 23 23:46:45 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:45 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:49 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:49 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:49 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:49 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:49 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:50 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:46:50 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:46:50 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:14 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: resuming normal operation
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: attempting to reread config file
Apr 23 23:47:18 Cube daemon.debug radvd[2314]: resuming normal operation

@exyll
Yes Jumboframesupport are in and its working well. PPTP is already configured, you need to setup a Username and a Password in /etc/ppp/chap-secrets, like arokh said on Page 1. I think making a Backup is always a good Idea. wink If its "only" a few Firewall-Rules and some kind of simple PPTPD Configuration, i would srew them and do a fresh setup of the Router, but thats just me. wink

2,846

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Desert, see if you have some radvd handler somewhere in /etc/hotplug.d/ - if you find one delete it. Recent radvd versions will figure out changes themselves.

2,847 (edited by Desert 2012-04-24 15:01:41)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

I found one in /etc/hotplug.d/iface, deleted it, but still the Log fills up. No Change in the Log Entries. The radvd Version is 1.8.3.

2,848

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

Usually debug messages should get supressed. Did you change the log message levels in the system config?

2,849 (edited by Desert 2012-04-24 16:52:55)

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

They were set to Debug, i changed them to Warning (don't know why and when yikes) and now back to Debug, looking good so far, i keep an Eye on it. Thank You! smile

Edit:
Damn, that didnt work. hmm

Re: Fully featured OpenWrt build for the WNDR3700 (NO LONGER MAINTAINED)

doctor78 wrote:

I am glad you got it to work. To be honest I am not sure what was the problem with my configuration. I don't think it was realy wrong IP. But after triple reinstall of OpenWRT, one DD-WRT and official Netgear FW I got it to work. So I dunno what fixed my problem.

Yeah I'm in the same boat- I really don't know what I did to get it fixed, which is annoying. I don't think it was the IP either, because I was wrong- it never changed. But I think your hint did help.