1 (edited by castocolina 2012-04-06 14:00:41)

Topic: fstab fail mount

Hello,

I trying to mount swap partition and get error "swapon: /etc/fstab: No such file or directory". The problem is the fstab file is on /etc/config and not simple /etc dir.

Another issue is in luci, navigate to System->Mount Points and enable SWAP to my device, perfom reboot, navigate to CLI and type 'free' command, and 'df', but the device is not mounted as SWAP. I have another device 30GB stick, try mounted by CLI and first time df command show the mount point, reboot exec df but the device is not visible, it's OK because to automount externals devices those must be include in fstab file, but try this option by luci config GUI and not work, the device is not visible with df  command. The last option was copy /etc/config/fstab to /etc/fstab reboot and check again, nothing with this, the df option no show the devices.

I have enable autostart of fstab

What wrong here?

I have
Router Model NETGEAR WNDR3700v2 (WNDR3800 hardware)
Firmware Version OpenWrt Backfire 10.03.1 /
LuCI 0.10.0 Release (0.10.0)
Kernel Version2.6.32.27

Belkin USB 2.0 4-Port Hub
Corsair 32GB Flash Voyager Mini USB 2.0 Flash Drive CMFUSBMINI-32GB
Sony 2GB M2 Stick with SankDisk USB adapter

Please let me know.

Re: fstab fail mount

After install block-hotplug my EXT4 drive is automounted in /mnt/sda1/ but my SWAP drive is not loaded :-/